source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 9603

Revision 9603, 26.0 KB checked in by iwamoto, 9 years ago (diff)

openssl: update to 1.0.1o with security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1o
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.1-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19Patch5: openssl-1.0.1m-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# security fix
23# nothing ;-)
24
25License: BSDish
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31Requires: mktemp
32Requires: ca-certificates
33
34Packager: daisuke
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
39
40%description
41The OpenSSL certificate management tool and the shared libraries that
42provide various cryptographic algorithms and protocols.
43
44%package devel
45Summary: OpenSSL libraries and development headers.
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48Requires: krb5-devel
49
50%description devel
51The static libraries and include files needed to compile apps
52with support for various the cryptographic algorithms and protocols
53supported by OpenSSL.
54
55Patches for many networking apps can be found at:
56ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
57
58%package static
59Summary:  Libraries for static linking of applications which will use OpenSSL
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64OpenSSL is a toolkit for supporting cryptography. The openssl-static
65package contains static libraries needed for static linking of
66applications which support various cryptographic algorithms and
67protocols.
68
69%package perl
70Summary: OpenSSL scripts which require Perl.
71Group: Applications/Internet
72Requires: perl
73Requires: %{name} = %{version}-%{release}
74
75%description perl
76Perl scripts provided with OpenSSL for converting certificates and keys
77from other formats to those used by OpenSSL.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: Secure Sockets Layer Toolkit
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84%description -n compat32-%{name}
85The OpenSSL certificate management tool and the shared libraries that
86provide various cryptographic algorithms and protocols.
87
88%package -n compat32-%{name}-devel
89Summary: OpenSSL libraries and development headers.
90Group: Development/Libraries
91Requires: compat32-%{name} = %{version}-%{release}
92Requires: compat32-krb5-devel
93%description -n compat32-%{name}-devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98%prep
99%setup -q -n openssl-%{version}
100%patch0 -p1 -b .soversion
101%patch2 -p1 -b .rpm_opt
102%patch4 -p1 -b .enginesdir
103%patch5 -p1 -b .version-add-engines
104%patch8 -p1 -b .perlfind
105
106# security fix
107# nothing ;-)
108
109chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
110chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
111chmod 644 doc/openssl_button.html doc/openssl_button.gif
112chmod 644 doc/ssleay.txt
113
114# Link the configuration header to the one we're going to make.
115ln -sf ../../crypto/opensslconf.h include/openssl/
116
117%build
118PATH=${PATH}:${PWD}/bin
119TOPDIR=${PWD}
120LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
121
122# Modify the various perl scripts to reference perl in the right location.
123perl util/perlpath.pl `dirname %{__perl}`
124
125# Generate a table with the compile settings for my perusal.
126touch Makefile
127make TABLE PERL=%{__perl}
128
129# Figure out which flags we want to use.
130# default
131sslarch=%{_os}-%{_target_cpu}
132#
133%ifarch %ix86
134sslarch=linux-elf
135if ! echo %{_target} | grep -q i686 ; then
136   sslflags="no-asm 386"
137fi
138%endif
139%ifarch sparcv9
140sslarch=linux-sparcv9
141sslflags=no-asm
142%endif
143%ifarch sparc64
144sslarch=linux64-sparcv9
145sslflags=no-asm
146%endif
147%ifarch alpha alphaev56 alphaev6 alphaev67
148sslarch=linux-alpha-gcc
149%endif
150%ifarch s390 sh3eb sh4eb
151sslarch="linux-generic32 -DB_ENDIAN"
152%endif
153%ifarch s390x
154sslarch="linux64-s390x"
155%endif
156%ifarch %{arm} sh3 sh4
157sslarch=linux-generic32
158%endif
159# ia64/x86_64/ppc\ppc64 are OK by default.
160
161# Configure the build tree.  Override OpenSSL defaults with known-good defaults
162# usable on all platforms.  The Configure script already knows to use -fPIC and
163# RPM_OPT_FLAGS, so we can skip specifiying them here.
164./Configure  \
165         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
166         zlib-dynamic enable-camellia enable-seed enable-tlsext \
167         enable-rfc3779 enable-cms enable-md2 \
168         --enginesdir=%{_libdir}/openssl/engines \
169         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
170         shared ${sslarch}
171
172# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
173# marked as not requiring an executable stack.
174RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
175make depend
176make all build-shared
177
178# Generate hashes for the included certs.
179LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
180export LD_LIBRARY_PATH
181make rehash build-shared
182
183# Verify that what was compiled actually works.
184make -C test apps tests
185
186# Relink the main binary to get it dynamically linked.
187rm apps/openssl
188make all build-shared
189
190%install
191[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
192# Install OpenSSL.
193install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
194make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
195install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
196# added for lib64
197# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
198mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
199# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
200mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
201mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
202rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
203rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
204for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
205        chmod 755 ${lib}
206        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
207        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
208done
209# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
210
211# Install a makefile for generating keys and self-signed certs, and a script
212# for generating them on the fly.
213mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
214install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
215install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
216install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
217
218# Make sure we actually include the headers we built against.
219for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
220        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
221                install -m644 include/openssl/`basename ${header}` ${header}
222        fi
223done
224
225# Rename man pages so that they don't conflict with system man pages.  We used
226# to change the file extensions, but that only prevents file conflicts.  The
227# man viewer still can't select either of the two unless we physically change
228# the directory.
229for section in 1 2 3 4 5 6 7 8 ; do
230        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
231                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
232                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
233        fi
234done
235
236# Pick a CA script.
237pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
238mv CA.sh CA
239popd
240
241mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
242mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
245mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
246
247# Ensure the openssl.cnf timestamp is identical across builds to avoid
248# mulitlib conflicts and unnecessary renames on upgrade
249touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
250
251%clean
252[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
253
254%files
255%defattr(-,root,root)
256%doc FAQ LICENSE CHANGES NEWS INSTALL README
257%doc doc/README doc/c-indentation.el doc/openssl.txt
258%doc doc/openssl_button.html doc/openssl_button.gif
259%doc doc/ssleay.txt
260
261%{_sysconfdir}/pki/tls/certs/make-dummy-cert
262%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
263%{_sysconfdir}/pki/tls/certs/Makefile
264%{_sysconfdir}/pki/tls/misc/CA
265%dir %{_sysconfdir}/pki/CA
266%dir %{_sysconfdir}/pki/CA/private
267%dir %{_sysconfdir}/pki/CA/certs
268%dir %{_sysconfdir}/pki/CA/crl
269%dir %{_sysconfdir}/pki/CA/newcerts
270%{_sysconfdir}/pki/tls/misc/c_*
271%dir %{_sysconfdir}/pki/tls
272%dir %{_sysconfdir}/pki/tls/certs
273%dir %{_sysconfdir}/pki/tls/misc
274%dir %{_sysconfdir}/pki/tls/private
275%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
276
277%attr(0755,root,root) %{_bindir}/openssl
278%attr(0755,root,root) /%{_lib}/*.so.*
279%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
280%attr(0755,root,root) %dir %{_mandir}/man1*
281%attr(0644,root,root) %{_mandir}/man1*/*
282%attr(0755,root,root) %dir %{_mandir}/man5*
283%attr(0644,root,root) %{_mandir}/man5*/*
284%attr(0755,root,root) %dir %{_mandir}/man7*
285%attr(0644,root,root) %{_mandir}/man7*/*
286
287%files devel
288%defattr(-,root,root)
289%{_prefix}/include/openssl
290%exclude %{_libdir}/lib*.a
291%attr(0755,root,root) %{_libdir}/*.so
292%attr(0755,root,root) %dir %{_mandir}/man3*
293%attr(0644,root,root) %{_mandir}/man3*/*
294%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
295
296%files static
297%defattr(-,root,root)
298%attr(0644,root,root) %{_libdir}/*.a
299
300%files perl
301%defattr(-,root,root)
302%attr(0755,root,root) %{_bindir}/c_rehash
303%attr(0755,root,root) %dir %{_mandir}/man1*
304%attr(0644,root,root) %{_mandir}/man1*/*.pl*
305%{_sysconfdir}/pki/tls/misc/*.pl
306#%{_sysconfdir}/pki/tls/misc/tsget
307%doc apps/tsget
308
309## to build compat32 for x86_64 architecture support
310%if %{build_compat32}
311%files -n compat32-%{name}
312%defattr(-,root,root)
313%attr(0755,root,root) /%{_lib}/*.so.*
314
315%files -n compat32-%{name}-devel
316%defattr(-,root,root)
317%exclude %{_libdir}/lib*.a
318%attr(0755,root,root) %{_libdir}/*.so
319%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
320%endif
321
322%post -p /sbin/ldconfig
323
324%postun -p /sbin/ldconfig
325
326%post -n compat32-%{name} -p /sbin/ldconfig
327
328%postun -n compat32-%{name} -p /sbin/ldconfig
329
330%changelog
331* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
332- new upstream release with security fixes 
333
334* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
335- new upstream release with security fixes 
336- update Patch2,5
337
338* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-1
339- rebuild for VineLinux 6.x
340
341* Sun Feb  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-0.1
342- test package for VineLinux 6.x
343
344* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0p-1
345- new upstream release with security fixes 
346
347* Sun Oct 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0o-1
348- new upstream release with security fixes (CVE-2014-3566,3567,3568)
349
350* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0n-1
351- new upstream release with security fixes
352
353* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
354- new upstream release with security fixes
355- drop patch10-12 (are included in new release)
356
357* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
358- add patch12 CVE-2014-0198
359
360* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
361- add patch11 for fix CVE-2010-0098
362
363* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
364- add patch10 for fix CVE-2014-0076
365
366* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
367- new upstream release with security fix (CVE-2013-6450)
368
369* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
370- move root CA bundle to ca-certificates package
371
372* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
373- new upstream release with security fix (CVE-2013-0166, 0169)
374
375* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
376- new upstream release with security fix (CVE-2012-2333) 
377
378* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
379- new upstream release with security fix (CVE-2012-2110)
380
381* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
382- new upstream release with security fix (CVE-2012-0884)
383
384* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
385- new upstream release with security fix (CVE-2012-0050)
386
387* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
388- new upstream release with security fix
389  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
390
391* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
392- new upstream release with security fix (CVE-2011-3207, 3210)
393
394* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
395- rebuild with krb5-libs 1.8
396
397* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
398- new upstream release with security fix
399
400* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
401- use upstream openssl.pc instead of vine original one (SOURCE6)
402
403* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
404- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
405
406* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
407- add R: krb5-devel into devel pkg
408- add R: compat32-krb5-devel into compat32-devel pkg
409
410* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
411- new upstream release 1.0.0x
412- separate static libs into static package
413- change configure options
414- change so version 10
415- add tsget into perl package
416- update all patches
417
418* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
419- fix changelog typo...
420
421* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
422- new upstream release with security fix (CVE-2010-4180)
423
424* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
425- new upstream release with security fix (CVE-2010-3864)
426- drop patches included in new release
427- update patch4
428
429* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
430- add patch12 for fix CVE-2009-3555 (renegotiation)
431
432* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
433- add patch11 for fix CVE-2009-4355 (memory leak)
434
435* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
436- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
437
438* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
439- removed unnecessary %%if %{build_compat32} statements
440- removed lib*.a from devel package
441
442* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
443- new upstream release with security fix (CVE-2000-0590,0591,0789)
444
445* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
446- new upstream release with security fix (CVE-2008-5077)
447
448* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
449- new upstream release
450
451* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
452- new upstream release
453- new versioning policy
454
455* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
456- new upstream release
457- drop patch10,20 which is merged in upstream
458
459* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
460- add security patch in advance for CVE-2007-5135
461  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
462  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
463
464* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
465- add security patch for CVE-2007-3108
466  (http://openssl.org/news/patch-CVE-2007-3108.txt)
467
468* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
469- new upstream release
470
471* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
472- update (fix) openssl.pc <BTS:437>
473
474* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
475- new upstream release (with security fix)
476
477* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
478- new upstream release
479- add patch2 to use RPM_OPT macro
480
481* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
482- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
483
484* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
485- added compat32-* packages for x86_64 architecture support
486- added openssl-0.9.7i.Configure-compat32.patch
487- changed '/lib' to '/%{_lib}'
488
489* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
490- new upstream release
491
492* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
493- rebuild on VineSeed
494
495* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
496- added a security patch from Gentoo.
497  - Patch1: openssl-0.9.7c-tempfile.patch
498
499* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
500- sslarch for ppc was missing... added.
501
502* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
503- use sslarch=linux-alpha-gcc instead of alpha-gcc
504
505* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
506- new upstream version
507- clean up of spec file
508        -- removed old patches
509
510* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
511- new upstream release
512- SECURITY fix.
513  - http://www.openssl.org/news/secadv_20040317.txt
514
515* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
516- new upstream release
517- [Security fix]
518  - Vulnerabilities in ASN.1 parsing
519    http://www.openssl.org/news/secadv_20030930.txt
520- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
521
522* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
523- add openssl.pc for pkgconfig
524
525* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
526- New upstream version
527- dropped patch10, 11
528        -- merged upstream version
529
530* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
531- rebuild for VineSeed
532
533* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
534- [Security Fix]
535  - Timing-based attacks on RSA keys
536    http://www.openssl.org/news/secadv_20030317.txt
537  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
538    http://www.openssl.org/news/secadv_20030317.txt
539
540* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
541- new upstream release 0.9.6i
542- [Security Fix]
543- build for Vine Linux 2.6 errata
544
545* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
546- new upstream release 0.9.6h
547
548* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
549- new upstream release 0.9.6g
550
551* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
552- SECURITY: CAN-2002-0659 fixed
553  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
554    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
555    - update asn patch to fix accidental reversal of a logic check
556    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
557    - update asn patch to reduce chance that compiler optimization will remove
558      one of the added tests
559    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
560    - rebuild
561    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
562    - add patch to fix ASN.1 vulnerabilities
563
564* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
565- rename spec file name
566- SECURITY: CA-2002-23 fixed
567  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
568    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
569    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
570
571* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
572- added ${PATH} in LD_LIBRARY_PATH
573- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
574 
575* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
576- remove --no-<cipher>
577
578* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
579- add Patch10 for mipsel shared ( Configure )
580
581* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
582- build for Vine Linux
583- use openssl-engine-0.9.6b.tar.gz
584
585* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
586- update to 0.9.6b
587
588* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
589- move .so symlinks back to %%{_libdir}
590
591* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
592- move shared libraries to /lib (#38410)
593
594* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
595- switch to engine code base
596
597* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
598- add a script for creating dummy certificates
599- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
600
601* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
602- add s390x support
603
604* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
605- change two memcpy() calls to memmove()
606- don't define L_ENDIAN on alpha
607
608* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
609- make subpackages depend on the main package
610
611* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
612- adjust the hobble script to not disturb symlinks in include/ (fix from
613  Joe Orton)
614
615* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
616- drop the m2crypo patch we weren't using
617
618* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
619- configure using "shared" as well
620
621* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
622- update to 0.9.6a
623- use the build-shared target to build shared libraries
624- bump the soversion to 2 because we're no longer compatible with
625  our 0.9.5a packages or our 0.9.6 packages
626- drop the patch for making rsatest a no-op when rsa null support is used
627- put all man pages into <section>ssl instead of <section>
628- break the m2crypto modules into a separate package
629
630* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
631- use BN_LLONG on s390
632
633* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
634- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
635
636* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
637- move c_rehash to the perl subpackage, because it's a perl script now
638
639* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
640- update to 0.9.6
641- enable MD2
642- use the libcrypto.so and libssl.so targets to build shared libs with
643- bump the soversion to 1 because we're no longer compatible with any of
644  the various 0.9.5a packages circulating around, which provide lib*.so.0
645
646* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
647- change hobble-openssl for disabling MD2 again
648
649* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
650- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
651  bytes or so, causing EVP_DigestInit() to zero out stack variables in
652  apps built against a version of the library without it
653
654* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
655- disable some inline assembly, which on x86 is Pentium-specific
656- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
657
658* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
659- fix s390 patch
660
661* Fri Dec 8 2000 Than Ngo <than@redhat.com>
662- added support s390
663
664* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
665- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
666- add the CA.pl man page to the perl subpackage
667
668* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
669- always build with -mcpu=ev5 on alpha
670
671* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
672- add a symlink from cert.pem to ca-bundle.crt
673
674* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
675- add a ca-bundle file for packages like Samba to reference for CA certificates
676
677* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
678- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
679
680* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
681- add unzip as a buildprereq (#17662)
682- update m2crypto to 0.05-snap4
683
684* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
685- fix some issues in building when it's not installed
686
687* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
688- make sure the headers we include are the ones we built with (aaaaarrgh!)
689
690* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
691- add Richard Henderson's patch for BN on ia64
692- clean up the changelog
693
694* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
695- fix the building of python modules without openssl-devel already installed
696
697* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
698- byte-compile python extensions without the build-root
699- adjust the makefile to not remove temporary files (like .key files when
700  building .csr files) by marking them as .PRECIOUS
701
702* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
703- break out python extensions into a subpackage
704
705* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
706- tweak the makefile some more
707
708* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
709- disable MD2 support
710
711* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
712- disable MDC2 support
713
714* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
715- tweak the disabling of RC5, IDEA support
716- tweak the makefile
717
718* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
719- strip binaries and libraries
720- rework certificate makefile to have the right parts for Apache
721
722* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
723- use %%{_perl} instead of /usr/bin/perl
724- disable alpha until it passes its own test suite
725
726* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
727- move the passwd.1 man page out of the passwd package's way
728
729* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
730- update to 0.9.5a, modified for U.S.
731- add perl as a build-time requirement
732- move certificate makefile to another package
733- disable RC5, IDEA, RSA support
734- remove optimizations for now
735
736* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
737- Bero told me to move the Makefile into this package
738
739* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
740- add lib*.so symlinks to link dynamically against shared libs
741
742* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
743- update to 0.9.5
744- run ldconfig directly in post/postun
745- add FAQ
746
747* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
748- Fix build on non-x86 platforms
749
750* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
751- move /usr/share/ssl/* from -devel to main package
752
753* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
754- inital packaging
755- changes from base:
756  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
757  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.