source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 8325

Revision 8325, 24.9 KB checked in by iwamoto, 10 years ago (diff)

openssl: fix CVE-2014-0076

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0l
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.0-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19
20# security fix
21Patch10: openssl-1.0.0_CVE-2014-0076.patch
22
23License: OpenSSL
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl, sed
28BuildRequires: zlib-devel, krb5-devel
29Requires: mktemp
30Requires: ca-certificates
31
32Packager: daisuke
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
37
38%description
39The OpenSSL certificate management tool and the shared libraries that
40provide various cryptographic algorithms and protocols.
41
42%package devel
43Summary: OpenSSL libraries and development headers.
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Requires: krb5-devel
47
48%description devel
49The static libraries and include files needed to compile apps
50with support for various the cryptographic algorithms and protocols
51supported by OpenSSL.
52
53Patches for many networking apps can be found at:
54ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
55
56%package static
57Summary:  Libraries for static linking of applications which will use OpenSSL
58Group: Development/Libraries
59Requires: %{name}-devel = %{version}-%{release}
60
61%description static
62OpenSSL is a toolkit for supporting cryptography. The openssl-static
63package contains static libraries needed for static linking of
64applications which support various cryptographic algorithms and
65protocols.
66
67%package perl
68Summary: OpenSSL scripts which require Perl.
69Group: Applications/Internet
70Requires: perl
71Requires: %{name} = %{version}-%{release}
72
73%description perl
74Perl scripts provided with OpenSSL for converting certificates and keys
75from other formats to those used by OpenSSL.
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: Secure Sockets Layer Toolkit
80Group: System Environment/Libraries
81Requires: %{name} = %{version}-%{release}
82%description -n compat32-%{name}
83The OpenSSL certificate management tool and the shared libraries that
84provide various cryptographic algorithms and protocols.
85
86%package -n compat32-%{name}-devel
87Summary: OpenSSL libraries and development headers.
88Group: Development/Libraries
89Requires: compat32-%{name} = %{version}-%{release}
90Requires: compat32-krb5-devel
91%description -n compat32-%{name}-devel
92The static libraries and include files needed to compile apps
93with support for various the cryptographic algorithms and protocols
94supported by OpenSSL.
95
96%prep
97%setup -q -n openssl-%{version}
98%patch0 -p1 -b .soversion
99%patch2 -p1 -b .rpm_opt
100%patch4 -p1 -b .enginesdir
101
102# security fix
103%patch10 -p1 -b .CVE-2014-0076
104
105chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
106chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
107chmod 644 doc/openssl_button.html doc/openssl_button.gif
108chmod 644 doc/ssleay.txt
109
110# Link the configuration header to the one we're going to make.
111ln -sf ../../crypto/opensslconf.h include/openssl/
112
113%build
114PATH=${PATH}:${PWD}/bin
115TOPDIR=${PWD}
116LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
117
118# Figure out which flags we want to use.  Can't use assembler because it's
119# not lowest-common-denominator in most cases.
120perl util/perlpath.pl `dirname %{__perl}`
121%ifarch %ix86
122sslarch=linux-elf
123sslflags="no-asm 386"
124%endif
125%ifarch ppc
126sslarch=linux-ppc
127sslflags=no-asm
128%endif
129%ifarch sparc
130sslarch=linux-sparcv9
131sslflags=no-asm
132%endif
133%ifarch ia64
134sslarch=linux-ia64
135sslflags=no-asm
136%endif
137%ifarch alpha
138sslarch=linux-alpha-gcc
139sslflags=no-asm
140%endif
141%ifarch s390
142sslarch=linux-s390
143%endif
144%ifarch s390x
145sslarch=linux-s390x
146%endif
147%ifarch mipsel
148sslarch=linux-mips
149sslflags=no-asm
150%endif
151## to build for x86_64 architecture support
152%ifarch x86_64
153sslarch=linux-x86_64
154sslflags=no-asm
155%endif
156
157# Configure the build tree.  Override OpenSSL defaults with known-good defaults
158# usable on all platforms.  The Configure script already knows to use -fPIC and
159# RPM_OPT_FLAGS, so we can skip specifiying them here.
160./Configure  \
161         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
162         zlib-dynamic enable-rfc3779 \
163         --enginesdir=%{_libdir}/openssl/engines \
164        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
165         shared ${sslarch}
166
167# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
168# marked as not requiring an executable stack.
169RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
170make depend
171make all build-shared
172
173# Generate hashes for the included certs.
174LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
175export LD_LIBRARY_PATH
176make rehash build-shared
177
178# Verify that what was compiled actually works.
179make -C test apps tests
180
181# Relink the main binary to get it dynamically linked.
182rm apps/openssl
183make all build-shared
184
185%install
186[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
187# Install OpenSSL.
188install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
189make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
190install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
191# added for lib64
192# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
193mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
194# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
195mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
196mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
197rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
198rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
199for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
200        chmod 755 ${lib}
201        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
202        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
203done
204# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
205
206# Install a makefile for generating keys and self-signed certs, and a script
207# for generating them on the fly.
208mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
209install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
210install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
211install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
212
213# Make sure we actually include the headers we built against.
214for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
215        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
216                install -m644 include/openssl/`basename ${header}` ${header}
217        fi
218done
219
220# Rename man pages so that they don't conflict with system man pages.  We used
221# to change the file extensions, but that only prevents file conflicts.  The
222# man viewer still can't select either of the two unless we physically change
223# the directory.
224for section in 1 2 3 4 5 6 7 8 ; do
225        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
226                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
227                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
228        fi
229done
230
231# Pick a CA script.
232pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
233mv CA.sh CA
234popd
235
236mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
237mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
238mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
239mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
241
242# Ensure the openssl.cnf timestamp is identical across builds to avoid
243# mulitlib conflicts and unnecessary renames on upgrade
244touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
245
246# Fix libdir.
247#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
248# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
249#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
250#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
251# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
252#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
253# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
254
255%clean
256[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
257
258%files
259%defattr(-,root,root)
260%doc FAQ LICENSE CHANGES NEWS INSTALL README
261%doc doc/README doc/c-indentation.el doc/openssl.txt
262%doc doc/openssl_button.html doc/openssl_button.gif
263%doc doc/ssleay.txt
264
265%{_sysconfdir}/pki/tls/certs/make-dummy-cert
266%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
267%{_sysconfdir}/pki/tls/certs/Makefile
268%{_sysconfdir}/pki/tls/misc/CA
269%dir %{_sysconfdir}/pki/CA
270%dir %{_sysconfdir}/pki/CA/private
271%dir %{_sysconfdir}/pki/CA/certs
272%dir %{_sysconfdir}/pki/CA/crl
273%dir %{_sysconfdir}/pki/CA/newcerts
274%{_sysconfdir}/pki/tls/misc/c_*
275%dir %{_sysconfdir}/pki/tls
276%dir %{_sysconfdir}/pki/tls/certs
277%dir %{_sysconfdir}/pki/tls/misc
278%dir %{_sysconfdir}/pki/tls/private
279
280%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
281
282%attr(0755,root,root) %{_bindir}/openssl
283%attr(0755,root,root) /%{_lib}/*.so.*
284%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
285%attr(0755,root,root) %dir %{_mandir}/man1*
286%attr(0644,root,root) %{_mandir}/man1*/*
287%attr(0755,root,root) %dir %{_mandir}/man5*
288%attr(0644,root,root) %{_mandir}/man5*/*
289%attr(0755,root,root) %dir %{_mandir}/man7*
290%attr(0644,root,root) %{_mandir}/man7*/*
291
292%files devel
293%defattr(-,root,root)
294%{_prefix}/include/openssl
295%exclude %{_libdir}/lib*.a
296%attr(0755,root,root) %{_libdir}/*.so
297%attr(0755,root,root) %dir %{_mandir}/man3*
298%attr(0644,root,root) %{_mandir}/man3*/*
299%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
300
301%files static
302%defattr(-,root,root)
303%attr(0644,root,root) %{_libdir}/*.a
304
305%files perl
306%defattr(-,root,root)
307%attr(0755,root,root) %{_bindir}/c_rehash
308%attr(0755,root,root) %dir %{_mandir}/man1*
309%attr(0644,root,root) %{_mandir}/man1*/*.pl*
310%{_sysconfdir}/pki/tls/misc/*.pl
311#%{_sysconfdir}/pki/tls/misc/tsget
312%doc apps/tsget
313
314## to build compat32 for x86_64 architecture support
315%if %{build_compat32}
316%files -n compat32-%{name}
317%defattr(-,root,root)
318%attr(0755,root,root) /%{_lib}/*.so.*
319
320%files -n compat32-%{name}-devel
321%defattr(-,root,root)
322%exclude %{_libdir}/lib*.a
323%attr(0755,root,root) %{_libdir}/*.so
324%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
325%endif
326
327%post -p /sbin/ldconfig
328
329%postun -p /sbin/ldconfig
330
331%post -n compat32-%{name} -p /sbin/ldconfig
332
333%postun -n compat32-%{name} -p /sbin/ldconfig
334
335%changelog
336* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
337- add patch10 for fix CVE-2014-0076
338
339* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
340- new upstream release with security fix (CVE-2013-6450)
341
342* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
343- move root CA bundle to ca-certificates package
344
345* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
346- new upstream release with security fix (CVE-2013-0166, 0169)
347
348* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
349- new upstream release with security fix (CVE-2012-2333) 
350
351* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
352- new upstream release with security fix (CVE-2012-2110)
353
354* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
355- new upstream release with security fix (CVE-2012-0884)
356
357* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
358- new upstream release with security fix (CVE-2012-0050)
359
360* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
361- new upstream release with security fix
362  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
363
364* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
365- new upstream release with security fix (CVE-2011-3207, 3210)
366
367* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
368- rebuild with krb5-libs 1.8
369
370* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
371- new upstream release with security fix
372
373* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
374- use upstream openssl.pc instead of vine original one (SOURCE6)
375
376* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
377- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
378
379* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
380- add R: krb5-devel into devel pkg
381- add R: compat32-krb5-devel into compat32-devel pkg
382
383* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
384- new upstream release 1.0.0x
385- separate static libs into static package
386- change configure options
387- change so version 10
388- add tsget into perl package
389- update all patches
390
391* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
392- fix changelog typo...
393
394* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
395- new upstream release with security fix (CVE-2010-4180)
396
397* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
398- new upstream release with security fix (CVE-2010-3864)
399- drop patches included in new release
400- update patch4
401
402* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
403- add patch12 for fix CVE-2009-3555 (renegotiation)
404
405* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
406- add patch11 for fix CVE-2009-4355 (memory leak)
407
408* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
409- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
410
411* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
412- removed unnecessary %%if %{build_compat32} statements
413- removed lib*.a from devel package
414
415* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
416- new upstream release with security fix (CVE-2000-0590,0591,0789)
417
418* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
419- new upstream release with security fix (CVE-2008-5077)
420
421* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
422- new upstream release
423
424* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
425- new upstream release
426- new versioning policy
427
428* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
429- new upstream release
430- drop patch10,20 which is merged in upstream
431
432* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
433- add security patch in advance for CVE-2007-5135
434  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
435  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
436
437* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
438- add security patch for CVE-2007-3108
439  (http://openssl.org/news/patch-CVE-2007-3108.txt)
440
441* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
442- new upstream release
443
444* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
445- update (fix) openssl.pc <BTS:437>
446
447* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
448- new upstream release (with security fix)
449
450* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
451- new upstream release
452- add patch2 to use RPM_OPT macro
453
454* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
455- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
456
457* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
458- added compat32-* packages for x86_64 architecture support
459- added openssl-0.9.7i.Configure-compat32.patch
460- changed '/lib' to '/%{_lib}'
461
462* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
463- new upstream release
464
465* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
466- rebuild on VineSeed
467
468* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
469- added a security patch from Gentoo.
470  - Patch1: openssl-0.9.7c-tempfile.patch
471
472* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
473- sslarch for ppc was missing... added.
474
475* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
476- use sslarch=linux-alpha-gcc instead of alpha-gcc
477
478* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
479- new upstream version
480- clean up of spec file
481        -- removed old patches
482
483* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
484- new upstream release
485- SECURITY fix.
486  - http://www.openssl.org/news/secadv_20040317.txt
487
488* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
489- new upstream release
490- [Security fix]
491  - Vulnerabilities in ASN.1 parsing
492    http://www.openssl.org/news/secadv_20030930.txt
493- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
494
495* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
496- add openssl.pc for pkgconfig
497
498* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
499- New upstream version
500- dropped patch10, 11
501        -- merged upstream version
502
503* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
504- rebuild for VineSeed
505
506* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
507- [Security Fix]
508  - Timing-based attacks on RSA keys
509    http://www.openssl.org/news/secadv_20030317.txt
510  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
511    http://www.openssl.org/news/secadv_20030317.txt
512
513* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
514- new upstream release 0.9.6i
515- [Security Fix]
516- build for Vine Linux 2.6 errata
517
518* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
519- new upstream release 0.9.6h
520
521* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
522- new upstream release 0.9.6g
523
524* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
525- SECURITY: CAN-2002-0659 fixed
526  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
527    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
528    - update asn patch to fix accidental reversal of a logic check
529    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
530    - update asn patch to reduce chance that compiler optimization will remove
531      one of the added tests
532    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
533    - rebuild
534    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
535    - add patch to fix ASN.1 vulnerabilities
536
537* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
538- rename spec file name
539- SECURITY: CA-2002-23 fixed
540  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
541    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
542    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
543
544* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
545- added ${PATH} in LD_LIBRARY_PATH
546- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
547 
548* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
549- remove --no-<cipher>
550
551* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
552- add Patch10 for mipsel shared ( Configure )
553
554* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
555- build for Vine Linux
556- use openssl-engine-0.9.6b.tar.gz
557
558* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
559- update to 0.9.6b
560
561* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
562- move .so symlinks back to %%{_libdir}
563
564* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
565- move shared libraries to /lib (#38410)
566
567* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
568- switch to engine code base
569
570* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
571- add a script for creating dummy certificates
572- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
573
574* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
575- add s390x support
576
577* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
578- change two memcpy() calls to memmove()
579- don't define L_ENDIAN on alpha
580
581* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
582- make subpackages depend on the main package
583
584* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
585- adjust the hobble script to not disturb symlinks in include/ (fix from
586  Joe Orton)
587
588* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
589- drop the m2crypo patch we weren't using
590
591* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
592- configure using "shared" as well
593
594* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
595- update to 0.9.6a
596- use the build-shared target to build shared libraries
597- bump the soversion to 2 because we're no longer compatible with
598  our 0.9.5a packages or our 0.9.6 packages
599- drop the patch for making rsatest a no-op when rsa null support is used
600- put all man pages into <section>ssl instead of <section>
601- break the m2crypto modules into a separate package
602
603* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
604- use BN_LLONG on s390
605
606* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
607- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
608
609* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
610- move c_rehash to the perl subpackage, because it's a perl script now
611
612* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
613- update to 0.9.6
614- enable MD2
615- use the libcrypto.so and libssl.so targets to build shared libs with
616- bump the soversion to 1 because we're no longer compatible with any of
617  the various 0.9.5a packages circulating around, which provide lib*.so.0
618
619* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
620- change hobble-openssl for disabling MD2 again
621
622* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
623- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
624  bytes or so, causing EVP_DigestInit() to zero out stack variables in
625  apps built against a version of the library without it
626
627* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
628- disable some inline assembly, which on x86 is Pentium-specific
629- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
630
631* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
632- fix s390 patch
633
634* Fri Dec 8 2000 Than Ngo <than@redhat.com>
635- added support s390
636
637* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
638- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
639- add the CA.pl man page to the perl subpackage
640
641* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
642- always build with -mcpu=ev5 on alpha
643
644* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
645- add a symlink from cert.pem to ca-bundle.crt
646
647* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
648- add a ca-bundle file for packages like Samba to reference for CA certificates
649
650* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
651- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
652
653* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
654- add unzip as a buildprereq (#17662)
655- update m2crypto to 0.05-snap4
656
657* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
658- fix some issues in building when it's not installed
659
660* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
661- make sure the headers we include are the ones we built with (aaaaarrgh!)
662
663* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
664- add Richard Henderson's patch for BN on ia64
665- clean up the changelog
666
667* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
668- fix the building of python modules without openssl-devel already installed
669
670* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
671- byte-compile python extensions without the build-root
672- adjust the makefile to not remove temporary files (like .key files when
673  building .csr files) by marking them as .PRECIOUS
674
675* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
676- break out python extensions into a subpackage
677
678* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
679- tweak the makefile some more
680
681* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
682- disable MD2 support
683
684* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
685- disable MDC2 support
686
687* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
688- tweak the disabling of RC5, IDEA support
689- tweak the makefile
690
691* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
692- strip binaries and libraries
693- rework certificate makefile to have the right parts for Apache
694
695* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
696- use %%{_perl} instead of /usr/bin/perl
697- disable alpha until it passes its own test suite
698
699* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
700- move the passwd.1 man page out of the passwd package's way
701
702* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
703- update to 0.9.5a, modified for U.S.
704- add perl as a build-time requirement
705- move certificate makefile to another package
706- disable RC5, IDEA, RSA support
707- remove optimizations for now
708
709* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
710- Bero told me to move the Makefile into this package
711
712* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
713- add lib*.so symlinks to link dynamically against shared libs
714
715* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
716- update to 0.9.5
717- run ldconfig directly in post/postun
718- add FAQ
719
720* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
721- Fix build on non-x86 platforms
722
723* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
724- move /usr/share/ssl/* from -devel to main package
725
726* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
727- inital packaging
728- changes from base:
729  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
730  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.