source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 6038

Revision 6038, 23.6 KB checked in by iwamoto, 12 years ago (diff)

openssl: new upstream release with security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.0i
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27BuildRequires: zlib-devel, krb5-devel
28Requires: mktemp
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
34
35%description
36The OpenSSL certificate management tool and the shared libraries that
37provide various cryptographic algorithms and protocols.
38
39%package devel
40Summary: OpenSSL libraries and development headers.
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: krb5-devel
44
45%description devel
46The static libraries and include files needed to compile apps
47with support for various the cryptographic algorithms and protocols
48supported by OpenSSL.
49
50Patches for many networking apps can be found at:
51ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
52
53%package static
54Summary:  Libraries for static linking of applications which will use OpenSSL
55Group: Development/Libraries
56Requires: %{name}-devel = %{version}-%{release}
57
58%description static
59OpenSSL is a toolkit for supporting cryptography. The openssl-static
60package contains static libraries needed for static linking of
61applications which support various cryptographic algorithms and
62protocols.
63
64%package perl
65Summary: OpenSSL scripts which require Perl.
66Group: Applications/Internet
67Requires: perl
68Requires: %{name} = %{version}-%{release}
69
70%description perl
71Perl scripts provided with OpenSSL for converting certificates and keys
72from other formats to those used by OpenSSL.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: Secure Sockets Layer Toolkit
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79%description -n compat32-%{name}
80The OpenSSL certificate management tool and the shared libraries that
81provide various cryptographic algorithms and protocols.
82
83%package -n compat32-%{name}-devel
84Summary: OpenSSL libraries and development headers.
85Group: Development/Libraries
86Requires: compat32-%{name} = %{version}-%{release}
87Requires: compat32-krb5-devel
88%description -n compat32-%{name}-devel
89The static libraries and include files needed to compile apps
90with support for various the cryptographic algorithms and protocols
91supported by OpenSSL.
92
93%prep
94%setup -q -n openssl-%{version}
95%patch0 -p1 -b .soversion
96%patch2 -p1 -b .rpm_opt
97%patch4 -p1 -b .enginesdir
98
99# security fix
100# nothing ;-)
101
102chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
103chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
104chmod 644 doc/openssl_button.html doc/openssl_button.gif
105chmod 644 doc/ssleay.txt
106
107# Link the configuration header to the one we're going to make.
108ln -sf ../../crypto/opensslconf.h include/openssl/
109
110%build
111PATH=${PATH}:${PWD}/bin
112TOPDIR=${PWD}
113LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
114
115# Figure out which flags we want to use.  Can't use assembler because it's
116# not lowest-common-denominator in most cases.
117perl util/perlpath.pl `dirname %{__perl}`
118%ifarch %ix86
119sslarch=linux-elf
120sslflags="no-asm 386"
121%endif
122%ifarch ppc
123sslarch=linux-ppc
124sslflags=no-asm
125%endif
126%ifarch sparc
127sslarch=linux-sparcv9
128sslflags=no-asm
129%endif
130%ifarch ia64
131sslarch=linux-ia64
132sslflags=no-asm
133%endif
134%ifarch alpha
135sslarch=linux-alpha-gcc
136sslflags=no-asm
137%endif
138%ifarch s390
139sslarch=linux-s390
140%endif
141%ifarch s390x
142sslarch=linux-s390x
143%endif
144%ifarch mipsel
145sslarch=linux-mips
146sslflags=no-asm
147%endif
148## to build for x86_64 architecture support
149%ifarch x86_64
150sslarch=linux-x86_64
151sslflags=no-asm
152%endif
153
154# Configure the build tree.  Override OpenSSL defaults with known-good defaults
155# usable on all platforms.  The Configure script already knows to use -fPIC and
156# RPM_OPT_FLAGS, so we can skip specifiying them here.
157./Configure  \
158         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
159         zlib-dynamic enable-rfc3779 \
160         --enginesdir=%{_libdir}/openssl/engines \
161        --with-krb5-flavor=MIT  --with-krb5-dir=/usr \
162         shared ${sslarch}
163
164# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
165# marked as not requiring an executable stack.
166RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
167make depend
168make all build-shared
169
170# Generate hashes for the included certs.
171LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
172export LD_LIBRARY_PATH
173make rehash build-shared
174
175# Verify that what was compiled actually works.
176make -C test apps tests
177
178# Relink the main binary to get it dynamically linked.
179rm apps/openssl
180make all build-shared
181
182%install
183[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
184# Install OpenSSL.
185install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
186make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
187install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
188# added for lib64
189# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
190mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
191# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
192mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
193mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
194rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
195rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
196for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
197        chmod 755 ${lib}
198        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
199        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
200done
201# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
202
203# Install a makefile for generating keys and self-signed certs, and a script
204# for generating them on the fly.
205mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
206install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
207install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
208
209# Make sure we actually include the headers we built against.
210for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
211        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
212                install -m644 include/openssl/`basename ${header}` ${header}
213        fi
214done
215
216# Rename man pages so that they don't conflict with system man pages.  We used
217# to change the file extensions, but that only prevents file conflicts.  The
218# man viewer still can't select either of the two unless we physically change
219# the directory.
220for section in 1 2 3 4 5 6 7 8 ; do
221        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
222                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
223                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
224        fi
225done
226
227# Pick a CA script.
228pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
229mv CA.sh CA
230popd
231
232# Install root CA stuffs.
233cat %{SOURCE3} > ca-bundle.crt
234install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
235ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
236
237# Fix libdir.
238#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
239# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
240#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
241#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
242# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
243#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
244# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
245
246%clean
247[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
248
249%files
250%defattr(-,root,root)
251%doc FAQ LICENSE CHANGES NEWS INSTALL README
252%doc doc/README doc/c-indentation.el doc/openssl.txt
253%doc doc/openssl_button.html doc/openssl_button.gif
254%doc doc/ssleay.txt
255%dir %{_datadir}/ssl
256%{_datadir}/ssl/certs
257%{_datadir}/ssl/cert.pem
258%{_datadir}/ssl/misc/CA
259%{_datadir}/ssl/misc/c_*
260%{_datadir}/ssl/private
261
262%config(noreplace) %{_datadir}/ssl/openssl.cnf
263
264%attr(0755,root,root) %{_bindir}/openssl
265%attr(0755,root,root) /%{_lib}/*.so.*
266%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
267%attr(0755,root,root) %dir %{_mandir}/man1*
268%attr(0644,root,root) %{_mandir}/man1*/*
269%attr(0755,root,root) %dir %{_mandir}/man5*
270%attr(0644,root,root) %{_mandir}/man5*/*
271%attr(0755,root,root) %dir %{_mandir}/man7*
272%attr(0644,root,root) %{_mandir}/man7*/*
273
274%files devel
275%defattr(-,root,root)
276%{_prefix}/include/openssl
277%exclude %{_libdir}/lib*.a
278%attr(0755,root,root) %{_libdir}/*.so
279%attr(0755,root,root) %dir %{_mandir}/man3*
280%attr(0644,root,root) %{_mandir}/man3*/*
281%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
282
283%files static
284%defattr(-,root,root)
285%attr(0644,root,root) %{_libdir}/*.a
286
287%files perl
288%defattr(-,root,root)
289%attr(0755,root,root) %{_bindir}/c_rehash
290%attr(0755,root,root) %dir %{_mandir}/man1*
291%attr(0644,root,root) %{_mandir}/man1*/*.pl*
292%{_datadir}/ssl/misc/*.pl
293# %{_datadir}/ssl/misc/tsget
294%doc apps/tsget
295
296## to build compat32 for x86_64 architecture support
297%if %{build_compat32}
298%files -n compat32-%{name}
299%defattr(-,root,root)
300%attr(0755,root,root) /%{_lib}/*.so.*
301
302%files -n compat32-%{name}-devel
303%defattr(-,root,root)
304%exclude %{_libdir}/lib*.a
305%attr(0755,root,root) %{_libdir}/*.so
306%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
307%endif
308
309%post -p /sbin/ldconfig
310
311%postun -p /sbin/ldconfig
312
313%post -n compat32-%{name} -p /sbin/ldconfig
314
315%postun -n compat32-%{name} -p /sbin/ldconfig
316
317%changelog
318* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
319- new upstream release with security fix (CVE-2012-2110)
320
321* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
322- new upstream release with security fix (CVE-2012-0884)
323
324* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
325- new upstream release with security fix (CVE-2012-0050)
326
327* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
328- new upstream release with security fix
329  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
330
331* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
332- new upstream release with security fix (CVE-2011-3207, 3210)
333
334* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
335- rebuild with krb5-libs 1.8
336
337* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
338- new upstream release with security fix
339
340* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
341- use upstream openssl.pc instead of vine original one (SOURCE6)
342
343* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
344- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
345
346* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
347- add R: krb5-devel into devel pkg
348- add R: compat32-krb5-devel into compat32-devel pkg
349
350* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
351- new upstream release 1.0.0x
352- separate static libs into static package
353- change configure options
354- change so version 10
355- add tsget into perl package
356- update all patches
357
358* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
359- fix changelog typo...
360
361* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
362- new upstream release with security fix (CVE-2010-4180)
363
364* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
365- new upstream release with security fix (CVE-2010-3864)
366- drop patches included in new release
367- update patch4
368
369* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
370- add patch12 for fix CVE-2009-3555 (renegotiation)
371
372* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
373- add patch11 for fix CVE-2009-4355 (memory leak)
374
375* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
376- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
377
378* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
379- removed unnecessary %%if %{build_compat32} statements
380- removed lib*.a from devel package
381
382* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
383- new upstream release with security fix (CVE-2000-0590,0591,0789)
384
385* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
386- new upstream release with security fix (CVE-2008-5077)
387
388* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
389- new upstream release
390
391* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
392- new upstream release
393- new versioning policy
394
395* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
396- new upstream release
397- drop patch10,20 which is merged in upstream
398
399* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
400- add security patch in advance for CVE-2007-5135
401  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
402  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
403
404* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
405- add security patch for CVE-2007-3108
406  (http://openssl.org/news/patch-CVE-2007-3108.txt)
407
408* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
409- new upstream release
410
411* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
412- update (fix) openssl.pc <BTS:437>
413
414* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
415- new upstream release (with security fix)
416
417* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
418- new upstream release
419- add patch2 to use RPM_OPT macro
420
421* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
422- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
423
424* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
425- added compat32-* packages for x86_64 architecture support
426- added openssl-0.9.7i.Configure-compat32.patch
427- changed '/lib' to '/%{_lib}'
428
429* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
430- new upstream release
431
432* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
433- rebuild on VineSeed
434
435* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
436- added a security patch from Gentoo.
437  - Patch1: openssl-0.9.7c-tempfile.patch
438
439* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
440- sslarch for ppc was missing... added.
441
442* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
443- use sslarch=linux-alpha-gcc instead of alpha-gcc
444
445* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
446- new upstream version
447- clean up of spec file
448        -- removed old patches
449
450* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
451- new upstream release
452- SECURITY fix.
453  - http://www.openssl.org/news/secadv_20040317.txt
454
455* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
456- new upstream release
457- [Security fix]
458  - Vulnerabilities in ASN.1 parsing
459    http://www.openssl.org/news/secadv_20030930.txt
460- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
461
462* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
463- add openssl.pc for pkgconfig
464
465* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
466- New upstream version
467- dropped patch10, 11
468        -- merged upstream version
469
470* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
471- rebuild for VineSeed
472
473* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
474- [Security Fix]
475  - Timing-based attacks on RSA keys
476    http://www.openssl.org/news/secadv_20030317.txt
477  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
478    http://www.openssl.org/news/secadv_20030317.txt
479
480* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
481- new upstream release 0.9.6i
482- [Security Fix]
483- build for Vine Linux 2.6 errata
484
485* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
486- new upstream release 0.9.6h
487
488* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
489- new upstream release 0.9.6g
490
491* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
492- SECURITY: CAN-2002-0659 fixed
493  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
494    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
495    - update asn patch to fix accidental reversal of a logic check
496    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
497    - update asn patch to reduce chance that compiler optimization will remove
498      one of the added tests
499    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
500    - rebuild
501    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
502    - add patch to fix ASN.1 vulnerabilities
503
504* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
505- rename spec file name
506- SECURITY: CA-2002-23 fixed
507  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
508    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
509    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
510
511* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
512- added ${PATH} in LD_LIBRARY_PATH
513- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
514 
515* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
516- remove --no-<cipher>
517
518* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
519- add Patch10 for mipsel shared ( Configure )
520
521* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
522- build for Vine Linux
523- use openssl-engine-0.9.6b.tar.gz
524
525* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
526- update to 0.9.6b
527
528* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
529- move .so symlinks back to %%{_libdir}
530
531* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
532- move shared libraries to /lib (#38410)
533
534* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
535- switch to engine code base
536
537* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
538- add a script for creating dummy certificates
539- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
540
541* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
542- add s390x support
543
544* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
545- change two memcpy() calls to memmove()
546- don't define L_ENDIAN on alpha
547
548* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
549- make subpackages depend on the main package
550
551* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
552- adjust the hobble script to not disturb symlinks in include/ (fix from
553  Joe Orton)
554
555* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
556- drop the m2crypo patch we weren't using
557
558* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
559- configure using "shared" as well
560
561* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
562- update to 0.9.6a
563- use the build-shared target to build shared libraries
564- bump the soversion to 2 because we're no longer compatible with
565  our 0.9.5a packages or our 0.9.6 packages
566- drop the patch for making rsatest a no-op when rsa null support is used
567- put all man pages into <section>ssl instead of <section>
568- break the m2crypto modules into a separate package
569
570* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
571- use BN_LLONG on s390
572
573* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
574- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
575
576* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
577- move c_rehash to the perl subpackage, because it's a perl script now
578
579* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
580- update to 0.9.6
581- enable MD2
582- use the libcrypto.so and libssl.so targets to build shared libs with
583- bump the soversion to 1 because we're no longer compatible with any of
584  the various 0.9.5a packages circulating around, which provide lib*.so.0
585
586* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
587- change hobble-openssl for disabling MD2 again
588
589* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
590- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
591  bytes or so, causing EVP_DigestInit() to zero out stack variables in
592  apps built against a version of the library without it
593
594* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
595- disable some inline assembly, which on x86 is Pentium-specific
596- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
597
598* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
599- fix s390 patch
600
601* Fri Dec 8 2000 Than Ngo <than@redhat.com>
602- added support s390
603
604* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
605- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
606- add the CA.pl man page to the perl subpackage
607
608* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
609- always build with -mcpu=ev5 on alpha
610
611* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
612- add a symlink from cert.pem to ca-bundle.crt
613
614* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
615- add a ca-bundle file for packages like Samba to reference for CA certificates
616
617* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
618- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
619
620* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
621- add unzip as a buildprereq (#17662)
622- update m2crypto to 0.05-snap4
623
624* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
625- fix some issues in building when it's not installed
626
627* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
628- make sure the headers we include are the ones we built with (aaaaarrgh!)
629
630* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
631- add Richard Henderson's patch for BN on ia64
632- clean up the changelog
633
634* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
635- fix the building of python modules without openssl-devel already installed
636
637* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
638- byte-compile python extensions without the build-root
639- adjust the makefile to not remove temporary files (like .key files when
640  building .csr files) by marking them as .PRECIOUS
641
642* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
643- break out python extensions into a subpackage
644
645* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
646- tweak the makefile some more
647
648* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
649- disable MD2 support
650
651* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
652- disable MDC2 support
653
654* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
655- tweak the disabling of RC5, IDEA support
656- tweak the makefile
657
658* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
659- strip binaries and libraries
660- rework certificate makefile to have the right parts for Apache
661
662* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
663- use %%{_perl} instead of /usr/bin/perl
664- disable alpha until it passes its own test suite
665
666* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
667- move the passwd.1 man page out of the passwd package's way
668
669* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
670- update to 0.9.5a, modified for U.S.
671- add perl as a build-time requirement
672- move certificate makefile to another package
673- disable RC5, IDEA, RSA support
674- remove optimizations for now
675
676* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
677- Bero told me to move the Makefile into this package
678
679* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
680- add lib*.so symlinks to link dynamically against shared libs
681
682* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
683- update to 0.9.5
684- run ldconfig directly in post/postun
685- add FAQ
686
687* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
688- Fix build on non-x86 platforms
689
690* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
691- move /usr/share/ssl/* from -devel to main package
692
693* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
694- inital packaging
695- changes from base:
696  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
697  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.