source: projects/specs/branches/6/o/openssl/openssl-vl.spec @ 10783

Revision 10783, 27.4 KB checked in by iwamoto, 8 years ago (diff)

openssl: update to 1.0.1u with security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1u
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10
11Source: openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16Patch0: openssl-1.0.0-soversion.patch
17Patch2: openssl-1.0.1-rpm_opt.patch
18Patch4: openssl-1.0.0-enginesdir.patch
19Patch5: openssl-1.0.1m-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# woakaround against the time bomb
23# Patch500: update-expired-smime-test-certs.patch
24
25# security fix
26# Patch1000: CVE-2016-2177.patch
27# Patch1001: CVE-2016-2178-1.patch
28# Patch1002: CVE-2016-2178-2.patch
29# Patch1003: CVE-2016-2180.patch
30
31License: BSDish
32Group: System Environment/Libraries
33URL: http://www.openssl.org/
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: perl, sed
36BuildRequires: zlib-devel, krb5-devel
37Requires: mktemp
38Requires: ca-certificates
39
40Packager: daisuke
41Vendor: Project Vine
42Distribution: Vine Linux
43
44%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
45
46%description
47The OpenSSL certificate management tool and the shared libraries that
48provide various cryptographic algorithms and protocols.
49
50%package devel
51Summary: OpenSSL libraries and development headers.
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54Requires: krb5-devel
55
56%description devel
57The static libraries and include files needed to compile apps
58with support for various the cryptographic algorithms and protocols
59supported by OpenSSL.
60
61Patches for many networking apps can be found at:
62ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
63
64%package static
65Summary:  Libraries for static linking of applications which will use OpenSSL
66Group: Development/Libraries
67Requires: %{name}-devel = %{version}-%{release}
68
69%description static
70OpenSSL is a toolkit for supporting cryptography. The openssl-static
71package contains static libraries needed for static linking of
72applications which support various cryptographic algorithms and
73protocols.
74
75%package perl
76Summary: OpenSSL scripts which require Perl.
77Group: Applications/Internet
78Requires: perl
79Requires: %{name} = %{version}-%{release}
80
81%description perl
82Perl scripts provided with OpenSSL for converting certificates and keys
83from other formats to those used by OpenSSL.
84
85## to build compat32 for x86_64 architecture support
86%package -n compat32-%{name}
87Summary: Secure Sockets Layer Toolkit
88Group: System Environment/Libraries
89Requires: %{name} = %{version}-%{release}
90%description -n compat32-%{name}
91The OpenSSL certificate management tool and the shared libraries that
92provide various cryptographic algorithms and protocols.
93
94%package -n compat32-%{name}-devel
95Summary: OpenSSL libraries and development headers.
96Group: Development/Libraries
97Requires: compat32-%{name} = %{version}-%{release}
98Requires: compat32-krb5-devel
99%description -n compat32-%{name}-devel
100The static libraries and include files needed to compile apps
101with support for various the cryptographic algorithms and protocols
102supported by OpenSSL.
103
104%prep
105%setup -q -n openssl-%{version}
106%patch0 -p1 -b .soversion
107%patch2 -p1 -b .rpm_opt
108%patch4 -p1 -b .enginesdir
109%patch5 -p1 -b .version-add-engines
110%patch8 -p1 -b .perlfind
111
112# %patch500 -p1 -b .expired-certificates
113
114# security fix
115# %patch1000 -p1 -b .CVE-2016-2177
116# %patch1001 -p1 -b .CVE-2016-2178-1
117# %patch1002 -p1 -b .CVE-2016-2178-2
118# %patch1003 -p1 -b .CVE-2016-2180
119
120chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
121chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
122chmod 644 doc/openssl_button.html doc/openssl_button.gif
123chmod 644 doc/ssleay.txt
124
125# Link the configuration header to the one we're going to make.
126# ln -sf ../../crypto/opensslconf.h include/openssl/
127
128%build
129PATH=${PATH}:${PWD}/bin
130TOPDIR=${PWD}
131LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
132
133# Modify the various perl scripts to reference perl in the right location.
134perl util/perlpath.pl `dirname %{__perl}`
135
136# Generate a table with the compile settings for my perusal.
137touch Makefile
138make TABLE PERL=%{__perl}
139
140# Figure out which flags we want to use.
141# default
142sslarch=%{_os}-%{_target_cpu}
143#
144%ifarch %ix86
145sslarch=linux-elf
146if ! echo %{_target} | grep -q i686 ; then
147   sslflags="no-asm 386"
148fi
149%endif
150%ifarch sparcv9
151sslarch=linux-sparcv9
152sslflags=no-asm
153%endif
154%ifarch sparc64
155sslarch=linux64-sparcv9
156sslflags=no-asm
157%endif
158%ifarch alpha alphaev56 alphaev6 alphaev67
159sslarch=linux-alpha-gcc
160%endif
161%ifarch s390 sh3eb sh4eb
162sslarch="linux-generic32 -DB_ENDIAN"
163%endif
164%ifarch s390x
165sslarch="linux64-s390x"
166%endif
167%ifarch %{arm} sh3 sh4
168sslarch=linux-generic32
169%endif
170# ia64/x86_64/ppc\ppc64 are OK by default.
171
172# Configure the build tree.  Override OpenSSL defaults with known-good defaults
173# usable on all platforms.  The Configure script already knows to use -fPIC and
174# RPM_OPT_FLAGS, so we can skip specifiying them here.
175./Configure  \
176         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
177         zlib-dynamic enable-camellia enable-seed enable-tlsext \
178         enable-rfc3779 enable-cms enable-md2 \
179         --enginesdir=%{_libdir}/openssl/engines \
180         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
181         shared ${sslarch}
182
183# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
184# marked as not requiring an executable stack.
185RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
186make depend
187make all build-shared
188
189# Generate hashes for the included certs.
190LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
191export LD_LIBRARY_PATH
192make rehash build-shared
193
194# Verify that what was compiled actually works.
195make -C test apps tests
196
197# Relink the main binary to get it dynamically linked.
198rm apps/openssl
199make all build-shared
200
201%install
202[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
203# Install OpenSSL.
204install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
205make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
206install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
207# added for lib64
208# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
209mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
210# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
211mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
212mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
213rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
214rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
215for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
216        chmod 755 ${lib}
217        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
218        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
219done
220# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
221
222# Install a makefile for generating keys and self-signed certs, and a script
223# for generating them on the fly.
224mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
225install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
226install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
227install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
228
229# Make sure we actually include the headers we built against.
230for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
231        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
232                install -m644 include/openssl/`basename ${header}` ${header}
233        fi
234done
235
236# Rename man pages so that they don't conflict with system man pages.  We used
237# to change the file extensions, but that only prevents file conflicts.  The
238# man viewer still can't select either of the two unless we physically change
239# the directory.
240for section in 1 2 3 4 5 6 7 8 ; do
241        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
242                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
243                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
244        fi
245done
246
247# Pick a CA script.
248pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
249mv CA.sh CA
250popd
251
252mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
253mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
254mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
255mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
256mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
257
258# Ensure the openssl.cnf timestamp is identical across builds to avoid
259# mulitlib conflicts and unnecessary renames on upgrade
260touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
261
262%clean
263[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
264
265%files
266%defattr(-,root,root)
267%doc FAQ LICENSE CHANGES NEWS INSTALL README
268%doc doc/README doc/c-indentation.el doc/openssl.txt
269%doc doc/openssl_button.html doc/openssl_button.gif
270%doc doc/ssleay.txt
271
272%{_sysconfdir}/pki/tls/certs/make-dummy-cert
273%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
274%{_sysconfdir}/pki/tls/certs/Makefile
275%{_sysconfdir}/pki/tls/misc/CA
276%dir %{_sysconfdir}/pki/CA
277%dir %{_sysconfdir}/pki/CA/private
278%dir %{_sysconfdir}/pki/CA/certs
279%dir %{_sysconfdir}/pki/CA/crl
280%dir %{_sysconfdir}/pki/CA/newcerts
281%{_sysconfdir}/pki/tls/misc/c_*
282%dir %{_sysconfdir}/pki/tls
283%dir %{_sysconfdir}/pki/tls/certs
284%dir %{_sysconfdir}/pki/tls/misc
285%dir %{_sysconfdir}/pki/tls/private
286%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
287
288%attr(0755,root,root) %{_bindir}/openssl
289%attr(0755,root,root) /%{_lib}/*.so.*
290%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
291%attr(0755,root,root) %dir %{_mandir}/man1*
292%attr(0644,root,root) %{_mandir}/man1*/*
293%attr(0755,root,root) %dir %{_mandir}/man5*
294%attr(0644,root,root) %{_mandir}/man5*/*
295%attr(0755,root,root) %dir %{_mandir}/man7*
296%attr(0644,root,root) %{_mandir}/man7*/*
297
298%files devel
299%defattr(-,root,root)
300%{_prefix}/include/openssl
301%exclude %{_libdir}/lib*.a
302%attr(0755,root,root) %{_libdir}/*.so
303%attr(0755,root,root) %dir %{_mandir}/man3*
304%attr(0644,root,root) %{_mandir}/man3*/*
305%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
306
307%files static
308%defattr(-,root,root)
309%attr(0644,root,root) %{_libdir}/*.a
310
311%files perl
312%defattr(-,root,root)
313%attr(0755,root,root) %{_bindir}/c_rehash
314%attr(0755,root,root) %dir %{_mandir}/man1*
315%attr(0644,root,root) %{_mandir}/man1*/*.pl*
316%{_sysconfdir}/pki/tls/misc/*.pl
317#%{_sysconfdir}/pki/tls/misc/tsget
318%doc apps/tsget
319
320## to build compat32 for x86_64 architecture support
321%if %{build_compat32}
322%files -n compat32-%{name}
323%defattr(-,root,root)
324%attr(0755,root,root) /%{_lib}/*.so.*
325
326%files -n compat32-%{name}-devel
327%defattr(-,root,root)
328%exclude %{_libdir}/lib*.a
329%attr(0755,root,root) %{_libdir}/*.so
330%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
331%endif
332
333%post -p /sbin/ldconfig
334
335%postun -p /sbin/ldconfig
336
337%post -n compat32-%{name} -p /sbin/ldconfig
338
339%postun -n compat32-%{name} -p /sbin/ldconfig
340
341%changelog
342* Sun Sep 25 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1u-1
343- new upstream release with security fixes
344- drop Patch500, Patch1000-1003 (are included in new release)
345
346* Mon Aug  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1t-3
347- added Patch1003 to fix CVE-2016-2180.
348
349* Sun Jul 31 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1t-2
350- added Patch500 to renew the expired certificates for test.
351- added Patch1000-1002 to fix vulnerabilities.
352  - CVE-2016-2177
353  - CVE-2016-2178
354
355* Wed May  4 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1t-1
356- new upstream release with security fixes
357
358* Wed Mar  2 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1s-1
359- new upstream release with security fixes
360
361* Fri Jan 29 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1r-1
362- new upstream release with security fixes 
363
364* Fri Dec  4 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
365- new upstream release with security fixes
366
367* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
368- new upstream release with security fixes
369
370* Mon Jun 15 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
371- new upstream release with security fixes 
372
373* Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
374- new upstream release with security fixes 
375- update Patch2,5
376
377* Wed Feb 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-1
378- rebuild for VineLinux 6.x
379
380* Sun Feb  8 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1l-0.1
381- test package for VineLinux 6.x
382
383* Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0p-1
384- new upstream release with security fixes 
385
386* Sun Oct 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0o-1
387- new upstream release with security fixes (CVE-2014-3566,3567,3568)
388
389* Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0n-1
390- new upstream release with security fixes
391
392* Thu Jun  5 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0m-1
393- new upstream release with security fixes
394- drop patch10-12 (are included in new release)
395
396* Mon May 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-4
397- add patch12 CVE-2014-0198
398
399* Mon Apr 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-3
400- add patch11 for fix CVE-2010-0098
401
402* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-2
403- add patch10 for fix CVE-2014-0076
404
405* Tue Jan  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0l-1
406- new upstream release with security fix (CVE-2013-6450)
407
408* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0k-2
409- move root CA bundle to ca-certificates package
410
411* Wed Feb  6 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0k-1
412- new upstream release with security fix (CVE-2013-0166, 0169)
413
414* Sat May 12 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0j-1
415- new upstream release with security fix (CVE-2012-2333) 
416
417* Fri Apr 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0i-1
418- new upstream release with security fix (CVE-2012-2110)
419
420* Sat Mar 31 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0h-1
421- new upstream release with security fix (CVE-2012-0884)
422
423* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
424- new upstream release with security fix (CVE-2012-0050)
425
426* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
427- new upstream release with security fix
428  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
429
430* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
431- new upstream release with security fix (CVE-2011-3207, 3210)
432
433* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
434- rebuild with krb5-libs 1.8
435
436* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
437- new upstream release with security fix
438
439* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
440- use upstream openssl.pc instead of vine original one (SOURCE6)
441
442* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
443- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
444
445* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
446- add R: krb5-devel into devel pkg
447- add R: compat32-krb5-devel into compat32-devel pkg
448
449* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
450- new upstream release 1.0.0x
451- separate static libs into static package
452- change configure options
453- change so version 10
454- add tsget into perl package
455- update all patches
456
457* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
458- fix changelog typo...
459
460* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
461- new upstream release with security fix (CVE-2010-4180)
462
463* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
464- new upstream release with security fix (CVE-2010-3864)
465- drop patches included in new release
466- update patch4
467
468* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
469- add patch12 for fix CVE-2009-3555 (renegotiation)
470
471* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
472- add patch11 for fix CVE-2009-4355 (memory leak)
473
474* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
475- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
476
477* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
478- removed unnecessary %%if %{build_compat32} statements
479- removed lib*.a from devel package
480
481* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
482- new upstream release with security fix (CVE-2000-0590,0591,0789)
483
484* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
485- new upstream release with security fix (CVE-2008-5077)
486
487* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
488- new upstream release
489
490* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
491- new upstream release
492- new versioning policy
493
494* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
495- new upstream release
496- drop patch10,20 which is merged in upstream
497
498* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
499- add security patch in advance for CVE-2007-5135
500  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
501  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
502
503* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
504- add security patch for CVE-2007-3108
505  (http://openssl.org/news/patch-CVE-2007-3108.txt)
506
507* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
508- new upstream release
509
510* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
511- update (fix) openssl.pc <BTS:437>
512
513* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
514- new upstream release (with security fix)
515
516* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
517- new upstream release
518- add patch2 to use RPM_OPT macro
519
520* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
521- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
522
523* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
524- added compat32-* packages for x86_64 architecture support
525- added openssl-0.9.7i.Configure-compat32.patch
526- changed '/lib' to '/%{_lib}'
527
528* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
529- new upstream release
530
531* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
532- rebuild on VineSeed
533
534* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
535- added a security patch from Gentoo.
536  - Patch1: openssl-0.9.7c-tempfile.patch
537
538* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
539- sslarch for ppc was missing... added.
540
541* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
542- use sslarch=linux-alpha-gcc instead of alpha-gcc
543
544* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
545- new upstream version
546- clean up of spec file
547        -- removed old patches
548
549* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
550- new upstream release
551- SECURITY fix.
552  - http://www.openssl.org/news/secadv_20040317.txt
553
554* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
555- new upstream release
556- [Security fix]
557  - Vulnerabilities in ASN.1 parsing
558    http://www.openssl.org/news/secadv_20030930.txt
559- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
560
561* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
562- add openssl.pc for pkgconfig
563
564* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
565- New upstream version
566- dropped patch10, 11
567        -- merged upstream version
568
569* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
570- rebuild for VineSeed
571
572* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
573- [Security Fix]
574  - Timing-based attacks on RSA keys
575    http://www.openssl.org/news/secadv_20030317.txt
576  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
577    http://www.openssl.org/news/secadv_20030317.txt
578
579* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
580- new upstream release 0.9.6i
581- [Security Fix]
582- build for Vine Linux 2.6 errata
583
584* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
585- new upstream release 0.9.6h
586
587* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
588- new upstream release 0.9.6g
589
590* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
591- SECURITY: CAN-2002-0659 fixed
592  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
593    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
594    - update asn patch to fix accidental reversal of a logic check
595    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
596    - update asn patch to reduce chance that compiler optimization will remove
597      one of the added tests
598    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
599    - rebuild
600    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
601    - add patch to fix ASN.1 vulnerabilities
602
603* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
604- rename spec file name
605- SECURITY: CA-2002-23 fixed
606  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
607    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
608    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
609
610* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
611- added ${PATH} in LD_LIBRARY_PATH
612- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
613 
614* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
615- remove --no-<cipher>
616
617* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
618- add Patch10 for mipsel shared ( Configure )
619
620* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
621- build for Vine Linux
622- use openssl-engine-0.9.6b.tar.gz
623
624* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
625- update to 0.9.6b
626
627* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
628- move .so symlinks back to %%{_libdir}
629
630* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
631- move shared libraries to /lib (#38410)
632
633* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
634- switch to engine code base
635
636* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
637- add a script for creating dummy certificates
638- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
639
640* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
641- add s390x support
642
643* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
644- change two memcpy() calls to memmove()
645- don't define L_ENDIAN on alpha
646
647* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
648- make subpackages depend on the main package
649
650* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
651- adjust the hobble script to not disturb symlinks in include/ (fix from
652  Joe Orton)
653
654* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
655- drop the m2crypo patch we weren't using
656
657* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
658- configure using "shared" as well
659
660* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
661- update to 0.9.6a
662- use the build-shared target to build shared libraries
663- bump the soversion to 2 because we're no longer compatible with
664  our 0.9.5a packages or our 0.9.6 packages
665- drop the patch for making rsatest a no-op when rsa null support is used
666- put all man pages into <section>ssl instead of <section>
667- break the m2crypto modules into a separate package
668
669* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
670- use BN_LLONG on s390
671
672* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
673- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
674
675* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
676- move c_rehash to the perl subpackage, because it's a perl script now
677
678* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
679- update to 0.9.6
680- enable MD2
681- use the libcrypto.so and libssl.so targets to build shared libs with
682- bump the soversion to 1 because we're no longer compatible with any of
683  the various 0.9.5a packages circulating around, which provide lib*.so.0
684
685* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
686- change hobble-openssl for disabling MD2 again
687
688* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
689- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
690  bytes or so, causing EVP_DigestInit() to zero out stack variables in
691  apps built against a version of the library without it
692
693* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
694- disable some inline assembly, which on x86 is Pentium-specific
695- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
696
697* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
698- fix s390 patch
699
700* Fri Dec 8 2000 Than Ngo <than@redhat.com>
701- added support s390
702
703* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
704- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
705- add the CA.pl man page to the perl subpackage
706
707* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
708- always build with -mcpu=ev5 on alpha
709
710* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
711- add a symlink from cert.pem to ca-bundle.crt
712
713* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
714- add a ca-bundle file for packages like Samba to reference for CA certificates
715
716* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
717- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
718
719* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
720- add unzip as a buildprereq (#17662)
721- update m2crypto to 0.05-snap4
722
723* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
724- fix some issues in building when it's not installed
725
726* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
727- make sure the headers we include are the ones we built with (aaaaarrgh!)
728
729* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
730- add Richard Henderson's patch for BN on ia64
731- clean up the changelog
732
733* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
734- fix the building of python modules without openssl-devel already installed
735
736* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
737- byte-compile python extensions without the build-root
738- adjust the makefile to not remove temporary files (like .key files when
739  building .csr files) by marking them as .PRECIOUS
740
741* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
742- break out python extensions into a subpackage
743
744* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
745- tweak the makefile some more
746
747* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
748- disable MD2 support
749
750* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
751- disable MDC2 support
752
753* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
754- tweak the disabling of RC5, IDEA support
755- tweak the makefile
756
757* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
758- strip binaries and libraries
759- rework certificate makefile to have the right parts for Apache
760
761* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
762- use %%{_perl} instead of /usr/bin/perl
763- disable alpha until it passes its own test suite
764
765* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
766- move the passwd.1 man page out of the passwd package's way
767
768* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
769- update to 0.9.5a, modified for U.S.
770- add perl as a build-time requirement
771- move certificate makefile to another package
772- disable RC5, IDEA, RSA support
773- remove optimizations for now
774
775* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
776- Bero told me to move the Makefile into this package
777
778* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
779- add lib*.so symlinks to link dynamically against shared libs
780
781* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
782- update to 0.9.5
783- run ldconfig directly in post/postun
784- add FAQ
785
786* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
787- Fix build on non-x86 platforms
788
789* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
790- move /usr/share/ssl/* from -devel to main package
791
792* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
793- inital packaging
794- changes from base:
795  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
796  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.