source: projects/specs/branches/6/o/openssh/openssh-vl.spec @ 7547

Revision 7547, 25.6 KB checked in by iwamoto, 11 years ago (diff)

openssh: vl6 update

Line 
1%define ver 5.8p2
2%define rel 2%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init
83Source110: sshd.sysconfig
84
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87
88# security patches
89Patch1000: openssh-5.8p2_CVE-2010-5107.patch
90
91License: BSD
92Group: Applications/Internet
93BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
94
95Obsoletes: ssh
96
97BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
98BuildRequires: util-linux
99BuildRequires: db4-devel
100BuildRequires: pam-devel
101BuildRequires: zlib-devel
102%if ! %{no_gnome_askpass}
103BuildRequires: libX11-devel
104BuildRequires: gtk2-devel
105%endif
106BuildRequires: xorg-x11-xauth
107BuildRequires: groff
108BuildRequires: libedit-devel
109
110Vendor: Project Vine
111Distribution: Vine Linux
112Packager: daisuke
113
114%package clients
115Summary: OpenSSH clients.
116Summary(ja): OpenSSH Secure Shell プロトコルクライアント
117Requires: openssh = %{version}-%{release}
118Group: Applications/Internet
119Obsoletes: ssh-clients
120Obsoletes: openssh-contrib
121
122%package server
123Summary: The OpenSSH server daemon.
124Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
125Group: System Environment/Daemons
126Obsoletes: ssh-server
127Requires(post): openssh = %{version}-%{release}
128Requires(post): chkconfig
129Requires(pre): shadow-utils
130Requires(post): initscripts >= 5.20
131Requires: pam
132
133%package askpass-gnome
134Summary: A passphrase dialog for OpenSSH, X, and GNOME.
135Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
136Group: Applications/Internet
137Requires: openssh = %{version}-%{release}
138Obsoletes: ssh-extras
139Obsoletes: openssh-askpass < 5.5p1-3vl6
140Provides: openssh-askpass = %{version}-%{release}
141
142%description
143SSH (Secure SHell) is a program for logging into and executing
144commands on a remote machine. SSH is intended to replace rlogin and
145rsh, and to provide secure encrypted communications between two
146untrusted hosts over an insecure network. X11 connections and
147arbitrary TCP/IP ports can also be forwarded over the secure channel.
148
149OpenSSH is OpenBSD's version of the last free version of SSH, bringing
150it up to date in terms of security and features, as well as removing
151all patented algorithms to separate libraries.
152
153This package includes the core files necessary for both the OpenSSH
154client and server. To make this package useful, you should also
155install openssh-clients, openssh-server, or both.
156
157#'
158%description -l ja
159OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
160Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
161するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
162ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
163可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
164な通信路の中を通すことができます。
165
166OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
167最新のセキュリティと機能を提供しています。またすべての特許がからむ
168アルゴリズムは分割したライブラリにわかれています。
169
170このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
171コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
172openssh-clients および/または openssh-server が必要です。
173
174%description clients
175OpenSSH is a free version of SSH (Secure SHell), a program for logging
176into and executing commands on a remote machine. This package includes
177the clients necessary to make encrypted connections to SSH servers.
178You'll also need to install the openssh package on OpenSSH clients.
179
180#'
181%description -l ja clients
182OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
183Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
184するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
185ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
186可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
187な通信路の中を通すことができます。
188
189OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
190最新のセキュリティと機能を提供しています。またすべての特許がからむ
191アルゴリズムは分割したライブラリにわかれています。
192
193このパッケージは OpenSSH をクライアントとして使用する場合に
194必要なものを含んでいます。
195
196
197%description server
198OpenSSH is a free version of SSH (Secure SHell), a program for logging
199into and executing commands on a remote machine. This package contains
200the secure shell daemon (sshd). The sshd daemon allows SSH clients to
201securely connect to your SSH server. You also need to have the openssh
202package installed.
203
204%description -l ja server
205OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
206Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
207するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
208ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
209可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
210な通信路の中を通すことができます。
211
212OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
213最新のセキュリティと機能を提供しています。またすべての特許がからむ
214アルゴリズムは分割したライブラリにわかれています。
215
216このパッケージは OpenSSH をサーバとして使用する場合に必要な
217デーモンなどを含んでいます。
218
219%description askpass-gnome
220OpenSSH is a free version of SSH (Secure SHell), a program for logging
221into and executing commands on a remote machine. This package contains
222an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
223environment.
224
225%description -l ja askpass-gnome
226OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
227Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
228するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
229ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
230可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
231な通信路の中を通すことができます。
232
233OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
234最新のセキュリティと機能を提供しています。またすべての特許がからむ
235アルゴリズムは分割したライブラリにわかれています。
236
237このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
238
239%prep
240
241%setup -q
242%patch0 -p1 -b .vine
243%patch4 -p1 -b .vendor
244
245%if %{WITH_SELINUX}
246#SELinux
247%patch12 -p1 -b .selinux
248%endif
249
250%patch21 -p1 -b .safe-stop
251%patch24 -p1 -b .fromto-remote
252%patch26 -p1 -b .stack
253%patch27 -p1 -b .log-chroot
254%patch30 -p1 -b .exit-deadlock
255%patch35 -p1 -b .progress
256
257%patch100 -p1 -b .norootlogin
258
259%patch1000 -p1 -b .CVE-2010-5107
260
261autoreconf
262
263
264%build
265CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
266%if %{rescue}
267CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
268%endif
269%if %{pie}
270%ifarch s390 s390x sparc sparc64
271CFLAGS="$CFLAGS -fPIE"
272%else
273CFLAGS="$CFLAGS -fpie"
274%endif
275export CFLAGS
276LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
277%endif
278
279%configure \
280        --sysconfdir=%{_sysconfdir}/ssh \
281        --libexecdir=%{_libexecdir}/openssh \
282        --datadir=%{_datadir}/openssh \
283        --with-tcp-wrappers \
284        --with-default-path=/usr/local/bin:/bin:/usr/bin \
285        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
286        --with-privsep-path=%{_var}/empty/sshd \
287        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
288        --with-libedit \
289%if %{scard}
290        --with-smartcard \
291%endif
292%if %{noip6}
293        --with-ipv4-default \
294%endif
295%if %{rescue}
296        --without-pam --with-md5-passwords
297%else
298        --with-pam
299%endif
300
301%if %{static_libcrypto}
302perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
303%endif
304
305make
306
307%if %{gtk2}
308        gtk2=yes
309%else
310        gtk2=no
311%endif
312
313%if ! %{no_gnome_askpass}
314pushd contrib
315if [ $gtk2 = yes ]; then
316        make gnome-ssh-askpass2
317        mv gnome-ssh-askpass2 gnome-ssh-askpass
318else
319        make gnome-ssh-askpass1
320        mv gnome-ssh-askpass1 gnome-ssh-askpass
321fi
322popd
323%endif
324
325%install
326rm -rf $RPM_BUILD_ROOT
327mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
328mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
329mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
330mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
331
332make install DESTDIR=$RPM_BUILD_ROOT
333
334touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
335install -d $RPM_BUILD_ROOT/etc/pam.d/
336install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
337install -d $RPM_BUILD_ROOT/etc/sysconfig/
338install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
339install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
340install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
341install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
342
343%if ! %{scard}
344        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
345%endif
346
347%if ! %{no_gnome_askpass}
348install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
349install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
350install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
351%endif
352
353%if %{no_gnome_askpass}
354rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
355%endif
356
357# for contrib package
358install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
359install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
360mv contrib/README contrib/README.contrib
361
362perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
363
364%clean
365rm -rf $RPM_BUILD_ROOT
366
367%triggerun server -- ssh-server
368if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
369        touch /var/run/sshd.restart
370fi
371
372%triggerun server -- openssh-server < 2.5.0p1
373# Count the number of HostKey and HostDsaKey statements we have.
374gawk    'BEGIN {IGNORECASE=1}
375         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
376         END {exit sawhostkey}' /etc/ssh/sshd_config
377# And if we only found one, we know the client was relying on the old default
378# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
379# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
380# one nullifies the default, which would have loaded both.
381if [ $? -eq 1 ] ; then
382        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
383        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
384fi
385
386%triggerpostun server -- ssh-server
387if [ "$1" != 0 ] ; then
388        /sbin/chkconfig --add sshd
389        if test -f /var/run/sshd.restart ; then
390                rm -f /var/run/sshd.restart
391                # /sbin/service sshd start > /dev/null 2>&1 || :
392                /sbin/service sshd start
393        fi
394fi
395
396%pre server
397%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
398%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
399        -g sshd -M -r sshd 2>/dev/null || :
400
401%post server
402/sbin/chkconfig --add sshd
403
404%postun server
405# /sbin/service sshd condrestart > /dev/null 2>&1 || :
406/sbin/service sshd condrestart
407exit 0
408
409%preun server
410if [ "$1" = 0 ]
411then
412        /sbin/service sshd stop > /dev/null 2>&1 || :
413        /sbin/chkconfig --del sshd
414fi
415
416%files
417%defattr(-,root,root)
418%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
419%attr(0755,root,root) %{_bindir}/scp
420%attr(0644,root,root) %{_mandir}/man1/scp.1*
421%attr(0755,root,root) %dir %{_sysconfdir}/ssh
422%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
423%attr(644,root,root) %{_mandir}/man5/moduli.5*
424%if ! %{rescue}
425%attr(0755,root,root) %{_bindir}/ssh-keygen
426%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
427%attr(0755,root,root) %dir %{_libexecdir}/openssh
428%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
429%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
430%endif
431%if %{scard}
432%attr(0755,root,root) %dir %{_datadir}/openssh
433%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
434%endif
435
436%files clients
437%defattr(-,root,root)
438%attr(0755,root,root) %{_bindir}/ssh
439%attr(0644,root,root) %{_mandir}/man1/ssh.1*
440%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
441%attr(0644,root,root) %{_mandir}/man1/slogin.1*
442%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
443%attr(-,root,root) %{_bindir}/slogin
444%if ! %{rescue}
445%attr(0755,root,root) %{_bindir}/ssh-agent
446%attr(0755,root,root) %{_bindir}/ssh-add
447%attr(0755,root,root) %{_bindir}/ssh-keyscan
448%attr(0755,root,root) %{_bindir}/sftp
449%attr(0755,root,root) %{_bindir}/ssh-copy-id
450%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
451%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
452%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
453%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
454%attr(0644,root,root) %{_mandir}/man1/sftp.1*
455%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
456%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
457%endif
458
459%if ! %{rescue}
460%files server
461%defattr(-,root,root)
462%dir %attr(0711,root,root) %{_var}/empty/sshd
463%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
464%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
465%attr(0755,root,root) %{_sbindir}/sshd
466%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
467%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
468%attr(0644,root,root) %{_mandir}/man8/sshd.8*
469%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
470%attr(0755,root,root) %dir %{_sysconfdir}/ssh
471%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
472%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
473%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
474%attr(0755,root,root) %config /etc/sysconfig/sshd
475%endif
476
477%if ! %{no_gnome_askpass}
478%files askpass-gnome
479%defattr(-,root,root)
480%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
481%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
482%endif
483
484
485%changelog
486* Wed Mar 13 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-2
487- add patch1000 for fix CVE-2010-5107 (login interval)
488
489* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
490- new upstream release
491
492* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
493- add our own sshd.init based on fedora's sshd.init
494  - generate ECDSA host key.
495
496* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
497- new upstream release
498
499* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
500- new upstream release
501
502* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
503- new upstream release
504- obsolete contrib subpackage, move ssh-copy-id to client subpackage
505
506* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
507- rebuilt with openssl 1.0.0c
508
509* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
510- drop x11-askpass, add Obsoletes: openssh-askpass
511- add BR: groff
512- enable --with-libedit option, add BR: libedit-devel
513- remove unrecognized option '--with-rsh'
514
515* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
516- add BR: xorg-x11-xauth for X11 forwarding support
517
518* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
519- new upstream release
520- update patch0,2
521- drop patch3,22
522
523* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
524- new upstream release
525
526* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
527- new upstream release
528
529* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
530- rebuild with xorg-x11-7.3
531
532* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
533- new upstream release with security fix (CVE-2008-1483)
534- drop patch31 which is included in new release (This was for CVE-2008-1483)
535
536* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
537- new upstream release with security fix ("ForceCommand" Directive)
538- turn on daemon restart message
539- new versioning policy
540
541* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
542- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
543
544* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
545- new upstream release
546
547* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
548- build with -fpie/-pie by default.
549- enable ipv6 by default.
550
551* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
552- new upstream release
553
554* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
555- new upstream release
556
557* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
558- new upstream release
559
560* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
561- new upstream release
562
563* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
564- new upstream release
565- remove build6x stuff
566- remove libgnome-devel from BuildRequires
567- cleanup BuildRequires
568- drop Patch200, it is merged in upstream.
569- import patches(25-35) from FC-devel
570
571* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
572- SECURITY FIX: CVE-2006-0225
573  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
574- update BuildPreReq: s/XFree86-devel/XOrg-devel/
575- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
576  - When GNOME2 is used, using libgnome-devel
577  - add BuildPreReq: gtk2-devel for GNOME2
578
579* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
580- rebuild with gtk+-2.8 final
581
582* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
583- new upstream release
584- build with gtk+-2.7
585
586* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
587- new upstream release
588
589* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
590- cleanup obsolete patches and added patches from fedora
591
592* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
593- new upstream release
594
595* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
596- new upstream release
597
598* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
599- new upstream release
600
601* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
602- rebuild with openssl-0.9.7d
603
604* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
605- new upstream release
606
607* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
608- create contrib package
609
610* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
611- new upstream release
612- fix security issue: http://www.openssh.com/txt/sshpam.adv
613
614* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
615- new upstream release
616- fix security issue: http://www.openssh.com/txt/buffer.adv
617
618* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
619- new upstream release
620
621* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
622- rebuild with gtk2
623
624* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
625- new upstream release
626
627* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
628- rebuild with new tool chain
629
630* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
631- new upstream release
632- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
633
634* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
635- change some defines in spec files
636
637* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
638- add patch110 ( 3.4p1 does not include mmap-fallback patch )
639
640* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
641- new upstream release
642  - security fix
643- drop patch10
644
645* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
646- add patch from Solar Designer to make privsep work with a 2.2 kernel.
647
648* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
649- new upstream release
650- add {sshd,ssh}_config.5 manpages
651- add ssh-keysign
652
653* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
654- new upstream release
655
656* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
657- new upstream release
658- drop patch1
659
660* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
661- new upstream release
662- merged with rawhide release.
663- drop Patch101 (merged in upstream)
664
665* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
666- seurity patch for off-by-one bug
667
668* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
669- merged with Rawhide 3.0.2p1-2
670
671* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
672- updated to 3.0.2p1
673
674* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
675- updated to 3.0.1p1
676
677* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
678- updated to 3.0p1
679
680* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
681- add japanese summery and descriptions.
682- update x11-askpass 1.2.5
683
684* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
685- update to openssh-2.9.9p2
686
687* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
688- rebuilt with openssl-0.9.6b
689
690* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
691- do not Permit RootLogin
692
693* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
694- update to openssh-2.5.2p2
695
696* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
697- update to openssh-2.5.2p1
698
699* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
700- update to openssh-2.5.1p2
701
702* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
703- update to openssh-2.5.1p1
704
705* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
706- update to openssh-2.5.1p1
707
708* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
709- remove suid bit from ssh
710
711* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
712- moved man dir to /usr/share/man
713
714* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
715- fixed askpass's link in ssh-add
716- partially used rpmmacros
717
718* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
719- update to 2.3.0p1
720- update x11-askpass 1.0.3
721
722* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
723- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
724  Redhat 7.0 spec file
725
726* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
727- rebuild for Vine Linux
728
729* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
730- Use RPM configure macro
731* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
732- Some surgery to sshd.init (generate keys at runtime)
733- Cleanup of groups and removal of keygen calls
734* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
735- Make building of X11-askpass and gnome-askpass optional
736* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
737- Glob manpages to catch compressed files
738* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
739- Updated for new location
740- Updated for new gnome-ssh-askpass build
741* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
742- Added Jim Knoble's <jmknoble@pobox.com> askpass
743* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
744- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
745* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
746- Added 'Obsoletes' directives
747* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
748- Use make install
749- Subpackages
750* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
751- Added links for slogin
752- Fixed perms on manpages
753* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
754- Renamed init script
755* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
756- Back to old binary names
757* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
758- Use autoconf
759- New binary names
760* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
761- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
762
Note: See TracBrowser for help on using the repository browser.