source: projects/specs/branches/6/o/openbox/openbox-vl.spec @ 4105

Revision 4105, 12.4 KB checked in by kudoh, 13 years ago (diff)
Line 
1Name:           openbox
2Version:        3.4.11.2
3Release:        3%{?_dist_release}
4Summary:        A highly configurable and standards-compliant X11 window manager
5Summary(ja):    高度に設定可能な標準準拠の X11 ウィンドウマネージャ
6
7Group:          User Interface/Desktops
8License:        GPLv2+
9URL:            http://openbox.org/
10Source0:        http://openbox.org/releases/%{name}-%{version}.tar.gz
11Source1:        http://icculus.org/openbox/tools/setlayout.c
12Source2:        xdg-menu
13Source3:        menu.xml
14Source4:        openbox.desktop
15
16Patch0:         openbox-3.4.9-autostartdir.patch
17#Patch1:                openbox-3.4.8-gdm.patch
18#Patch3:                openbox-3.4.7.2-autostartid.patch
19Patch7:         openbox-3.4.7.2-24bit.patch
20Patch9:         openbox-3.4.10-obxpropman.patch
21Patch10:        openbox-3.4.11-Xau.patch
22Patch11:        06_fix_swap_byte_order.patch
23
24BuildRoot:      %{_tmppath}/%{name}-%{version}-root
25
26Requires:       %{name}-libs = %{version}-%{release}
27
28BuildRequires:  gettext
29BuildRequires:  glib2-devel >= 2.14.0
30BuildRequires:  desktop-file-utils
31BuildRequires:  pango-devel
32BuildRequires:  startup-notification-devel
33BuildRequires:  libxml2-devel >= 2.6.0
34BuildRequires:  libSM-devel
35BuildRequires:  libXau-devel
36BuildRequires:  libXcursor-devel
37BuildRequires:  libXfixes-devel
38BuildRequires:  libXt-devel
39BuildRequires:  libXrandr-devel
40BuildRequires:  libXinerama-devel
41
42# The xdg-menu dynamic pipe menu requires the gmenu Python module
43Requires:       gnome-menus
44Requires:       pyxdg
45
46%description
47Openbox is a window manager designed explicity for standards-compliance and
48speed. It is fast, lightweight, and heavily configurable (using XML for its
49configuration data). It has many features that make it unique among window
50managers: window resistance, chainable key bindings, customizable mouse
51actions, multi-head/Xinerama support, and dynamically generated "pipe menus."
52
53For a full list of the FreeDesktop.org standards with which it is compliant,
54please see the COMPLIANCE file in the included documentation of this package.
55For a graphical configuration editor, you'll need to install the obconf
56package. For a graphical menu editor, you'll need to install the obmenu
57package.
58
59
60%package        devel
61Summary:        Development files for %{name}
62Summary(ja):    %{name} の開発ファイル
63Group:          Development/Libraries
64Requires:       %{name}-libs = %{version}-%{release}
65Requires:       pkgconfig
66Requires:       pango-devel
67Requires:       libxml2-devel
68Requires:       glib2-devel
69
70%description    devel
71The %{name}-devel package contains libraries and header files for
72developing applications that use %{name}.
73
74
75%package        libs
76Summary:        Shared libraries for %{name}
77Summary:        %{name} の共有ライブラリ
78Group:          System Environment/Libraries
79
80%description    libs
81The %{name}-libs package contains shared libraries used by %{name}.
82
83
84%prep
85%setup -q
86%patch0 -p1 -b .autostartdir
87#%patch1 -p1 -b .gdm
88#%patch3 -p1 -b .autostartid
89%patch7 -p1 -b .24bit
90%patch9 -p1 -b .obxpropman
91%patch10 -p1 -b .Xau
92%patch11 -p1 -b .color
93
94
95%build
96%configure \
97        --disable-static
98## Fix RPATH hardcoding.
99sed -ie 's|^hardcode_libdir_flag_spec=.*$|hardcode_libdir_flag_spec=""|g' libtool
100sed -ie 's|^runpath_var=LD_RUN_PATH$|runpath_var=DIE_RPATH_DIE|g' libtool
101make %{?_smp_mflags}
102
103gcc %{optflags} -o setlayout %{SOURCE1} -lX11
104
105%install
106rm -rf %{buildroot}
107make install DESTDIR=%{buildroot}
108
109install setlayout %{buildroot}%{_bindir}
110install -p %{SOURCE2} %{buildroot}%{_datadir}/%{name}/xdg-menu
111sed 's|_XDGMENU_|%{_datadir}/%{name}/xdg-menu|g' < %{SOURCE3} \
112        > %{buildroot}%{_sysconfdir}/xdg/%{name}/menu.xml
113
114desktop-file-install --vendor="" \
115        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
116        %{SOURCE4}
117
118%find_lang %{name}
119rm -f %{buildroot}%{_libdir}/*.la
120rm -rf %{buildroot}%{_datadir}/doc/%{name}
121
122
123%clean
124rm -rf %{buildroot}
125
126
127%files -f %{name}.lang
128%defattr(-,root,root,-)
129%doc AUTHORS CHANGELOG COMPLIANCE COPYING README
130%doc data/*.xsd data/menu.xml doc/rc-mouse-focus.xml
131%dir %{_sysconfdir}/xdg/%{name}/
132%config(noreplace) %{_sysconfdir}/xdg/%{name}/*
133%{_bindir}/gnome-panel-control
134%{_bindir}/gdm-control
135%{_bindir}/%{name}*
136%{_bindir}/obxprop
137%{_bindir}/setlayout
138%{_datadir}/applications/*%{name}.desktop
139%{_datadir}/%{name}
140%{_datadir}/themes/*/
141%{_datadir}/pixmaps/%{name}.png
142%{_datadir}/gnome/wm-properties/
143%{_datadir}/xsessions/%{name}*.desktop
144%{_mandir}/man1/*
145
146%files  libs
147%{_libdir}/libobrender.so.*
148%{_libdir}/libobparser.so.*
149
150%files  devel
151%{_includedir}/%{name}/
152%{_libdir}/libobrender.so
153%{_libdir}/libobparser.so
154%{_libdir}/pkgconfig/*.pc
155
156
157%post libs -p /sbin/ldconfig
158
159
160%postun libs -p /sbin/ldconfig
161
162
163%changelog
164* Fri Jun 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-3
165- dropt Patch1,3
166- added patch11 from Debian
167
168* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-2
169- rebuilt with rpm-4.8.1 for pkg-config
170- BuildRequires: libXau-devel
171
172* Tue May 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.2-1
173- new upstream release
174- added Requires: pyxdg
175
176* Fri May 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11.1-1
177- new upstream release
178- changed URL and Source0
179- dropt Patch6
180- added BuildRequires: libXfixes-devel, libSM-devel
181- changed BuildRequires: glib2-devel >= 2.14.0, libxml2-devel >= 2.6.0
182
183* Thu Feb 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.11-1
184- new upstream release
185- added Patch10 from Fedora
186- added summary(ja) in -devel and -libs
187
188* Sun Jan 10 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.10-1
189- new upstream release
190- dropt Patch8
191- Patch9 from Fedora
192
193* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.9-1
194- new upstream release
195  - dropt patch2
196  - replaced and renamed Patch0 from Fedora
197
198* Tue Dec 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.8-1
199- new upstream release
200  - dropt patch4,5
201  - added Patch8 from Fedora
202- added Requires: gnome-menus
203
204* Tue Oct 20 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-4
205- improved Source3
206  - enabled administration menu (disabled preference menu because included)
207- added Patch6 from Mandriva
208- added Patch7 from Fedora
209- replaced Source1 from Fedora
210
211* Sun Sep 27 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-3
212- updated Source4
213- added Patch4,5 from Debian
214
215* Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-2vl5
216- changed openbox-libs Group: System Environment/Libraries
217- spec in UTF-8
218
219* Fri Mar 6 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.4.7.2-1vl5
220- initial build for VineSeed
221
222* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.4.7.2-8
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
224
225* Tue Dec 09 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-7
226- Restore gnome session script (#474143)
227- Use DESKTOP_AUTOSTART_ID to avoid gnome-session registration timeout
228
229* Thu Oct 02 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-6
230- Drop gnome session script (gnome-session no longer supports $WINDOW_MANAGER)
231- Add application desktop file to allow starting openbox in gnome-session
232  when configured in gconf
233
234* Thu Sep 04 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-5
235- Don't use --choose-session option in gnome session script
236
237* Fri Aug 01 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-4
238- Remove field codes from commands in xdg-menu (#452403)
239- Add support for launching applications in xterm to xdg-menu
240
241* Tue Jun 10 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-3
242- Clean up properties after gdm in session scripts (#444135)
243- Add license to xdg-menu script
244
245* Tue May 20 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-2
246- Drop numdesks patch (#444135)
247
248* Wed May 14 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.2-1
249- Update to 3.4.7.2
250- Use gnome menus by default (Luke Macken) (#443548)
251- Force setting number of desktops (#444135)
252
253* Thu Apr 17 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.7.1-1
254- Update to 3.4.7.1
255- Don't require /usr/share/themes
256
257* Wed Feb 06 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6.1-1
258- Update to 3.4.6.1
259
260* Sun Feb 03 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.6-1
261- Update to 3.4.6
262
263* Mon Jan 07 2008 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.5-1
264- Update to 3.4.5
265
266* Wed Aug 22 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-2
267- Rebuild
268
269* Sun Aug 05 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.4-1
270- Update to 3.4.4
271- Update license tag
272
273* Mon Jul 23 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.3-1
274- Update to 3.4.3
275- Package setlayout tool
276
277* Wed Jun 13 2007 Miroslav Lichvar <mlichvar@redhat.com> - 3.4.2-1
278- Update to 3.4.2
279
280* Mon Jun 04 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-7
281- Own %%{_datadir}/gnome/wm-properties instead of depending on gnome-session
282  in order to reduce dependency bloat. (Resolves bug 242339; thanks to Miroslav
283  Lichvar for the bug report.)
284
285* Tue Mar 27 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-6
286- Split shared libraries into a -libs subpackage to properly handle multilib
287  setups. (This precludes the further need to %%ghost the byte-compiled
288  themeupdate scripts which was introduced in the previous release.)
289- Fix handling of the startup_notification build conditional. It will actually
290  work properly now. :)
291- Remove the hardcoded RPATH using some sed invocations from the packaging
292  guidelines.
293
294* Mon Feb 12 2007 Peter Gordon <peter@thecodergeek.com> - 3.3.1-5
295- %%ghost the byte-compiled themeupdate scripts to fix multilib conflict
296  (bug #228379).
297
298* Thu Nov 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-4
299- Don't own %%{_datadir}/gnome/wm-properties anymore, as that's now owned
300  by gnome-session in Rawhide and we should not have ownership conflicts with
301  Core packages.
302
303* Mon Oct 02 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-3
304- Rebuild to pick up unwind info generation fixes in new GCC
305
306* Wed Sep 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-2
307- Allow building with startup-notification as an rpmbuild option (though it is
308  disabled by default as recommended by upstream).
309
310* Sun Sep 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3.1-1
311- Update to new 3.3.1 from upstream
312
313* Sun Aug 27 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-3
314- Mass FC6 rebuild
315
316* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-2
317- Bump release to fix sources tagging issue
318
319* Sat Aug 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-1
320- Update to 3.3 final release from upstream
321- Remove the slew of versioning macros, as it's overkill for this and just adds
322  unneeded complexity to the spec.
323
324* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2.1
325- Add missing BuildRequires: libXxf86vm-devel
326
327* Wed Jun 28 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.8.rc2
328- Unconditionalize the BuildRequires for modular X.org, since it's branched
329  for a specific Fedora release.
330
331* Mon Jun 26 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.7.rc2
332- Own the %%{_datadir}/gnome/wm-properties directory (#195292)
333
334* Fri Jun 23 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.6.rc2
335- Add %%{_datadir}/themes to Requires (#195292)
336
337* Tue Jun 20 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.5.rc2
338- Own all created theme directories (#195292)
339- Fix previous review bug IDs in this %%changelog to point to the recreated
340  review bug (due to recent bugzilla outage)
341
342* Sun Jun 18 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.4.rc2
343- Don't default to an executable xsession script (#195292)
344
345* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.3.rc2
346- Fix versioning to conform to the Extras packaging guidelines
347
348* Mon Jun 12 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.2
349- Add %%{_datadir}/xsessions .desktop file for easy selection of Openbox at
350  login screen (#195292)
351
352* Fri Jun 09 2006 Peter Gordon <peter@thecodergeek.com> - 3.3-0.rc2.1
353- Unorphan, rewriting nearly all of the spec file
354- Update to upstream 3.3 RC2
355
356* Sun Jul 27 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.5
357- Need to own /etc/X11/gdm/Sessions && /etc/X11/gdm (#440)
358- Need to conflict with fluxbox (#422 / #440)
359
360* Tue Jul 22 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.4
361- Need to own /usr/share/apps/switchdesk (#422)
362
363* Mon Jul 21 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.3
364- More spec revisions (#422); change make and preserve timestamps
365
366* Sun Jul 20 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.2
367- Minor spec revisions (#422); add epoch and versions to changelogs
368
369* Sun Jul 06 2003 Chris Ricker <kaboom@gatech.edu> 0:2.3.1-0.fdr.1
370- Add switchdesk support
371- Add display manager support
372- Fix NLS build on Cambridge
373- Fedora'ize the spec
374
375* Sun Jun 29 2003 Chris Ricker <kaboom@gatech.edu>
376- Rev to 2.3.1 release
377- Make go with GCC 3.3
378
379* Tue Mar 18 2003 Chris Ricker <kaboom@gatech.edu>
380- Package of 2.3.0 release
Note: See TracBrowser for help on using the repository browser.