source: projects/specs/branches/6/nonfree/self-build-mplayer/mplayer-vl.spec @ 7875

Revision 7875, 18.1 KB checked in by munepi, 11 years ago (diff)

updated to 1.1.1 based on 1.1.1-1vl7

Line 
1%global with_faac 1
2#% global with_vaapi 1
3#% global with_libvpx 1
4
5#% global with_ffmpeg 1
6%global ffmpegver 0.11.4
7
8%define codecdir   %{_libdir}/codecs
9
10%global ttfontdir   %{_datadir}/fonts
11%global ttfontlist  TrueType-vlgothic/VL-PGothic-Regular \\\
12                    TrueType-sazanami-gothic/sazanami-gothic
13
14Summary:        The Movie Player
15Summary(ja):    動画プレイヤー
16Name:           mplayer
17Version:        1.1.1
18Release:        1%{?svndate:.%svndate}%{?_dist_release}
19Source0:        http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}.tar.xz
20#Source0:       mplayer-export-%{svndate}.tar.xz
21Source1:        http://ffmpeg.org/releases/ffmpeg-%{ffmpegver}.tar.bz2
22
23Source10:       mplayer-snapshot-vine.sh
24
25Source11:       http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
26Source12:       http://www.mplayerhq.hu/MPlayer/skins/Blue-small-1.5.tar.bz2
27Source13:       http://www.mplayerhq.hu/MPlayer/skins/standard-1.9.tar.bz2
28Source14:       http://www.mplayerhq.hu/MPlayer/skins/OSX-Mod-1.1.tar.bz2
29
30# set defaults for Vine Linux
31#Patch2:         %{name}-config.patch
32#Patch2:         %{name}-config-20120525-vine.patch
33Patch2:         %{name}-1.1.1-config-vine.patch
34# use roff include statements instead of symlinks
35Patch8:         %{name}-1.1.1-manlinks.patch
36# erase any trace of libdvdcss
37Patch14:        %{name}-1.1.1-nodvdcss.patch
38# use system FFmpeg libraries
39Patch18:        %{name}-1.1.1-ffmpeg.patch
40
41## Vine
42
43
44%if 0%{!?_without_amr:1}
45License:        GPLv3+
46%else
47License:        GPLv2+
48%endif
49Group:          Applications/Multimedia
50URL:            http://www.mplayerhq.hu/
51
52BuildRequires: xz
53BuildRequires:  SDL-devel
54BuildRequires:  aalib-devel
55BuildRequires:  alsa-lib-devel
56BuildRequires:  cdparanoia-devel
57BuildRequires:  desktop-file-utils
58##!!BuildRequires:  em8300-devel
59BuildRequires:  libdvdnav-devel
60BuildRequires:  enca-devel
61BuildRequires:  fontconfig-devel
62BuildRequires:  freetype2-devel >= 2.0.9
63BuildRequires:  fribidi-devel
64BuildRequires:  giflib-devel
65BuildRequires:  gtk2-devel
66BuildRequires:  mesa-libGL-devel
67BuildRequires:  libXinerama-devel
68BuildRequires:  libXScrnSaver-devel
69BuildRequires:  libXv-devel
70BuildRequires:  libXvMC-devel
71BuildRequires:  libXxf86dga-devel
72BuildRequires:  libXxf86vm-devel
73BuildRequires:  libass-devel
74BuildRequires:  libpng-devel
75BuildRequires:  libjpeg-devel
76BuildRequires:  libdvdread
77BuildRequires:  libmpcdec-devel >= 1.2.1
78BuildRequires:  librtmp-devel >= 2.3
79BuildRequires:  speex-devel >= 1.1
80%{?with_vaapi:BuildRequires:libva-devel}
81BuildRequires:  libvdpau-devel
82BuildRequires:  libvorbis-devel
83%{?with_libvpx:BuildRequires:  libvpx-devel >= 0.9.6}
84BuildRequires:  lzo-devel >= 2
85BuildRequires:  pulseaudio-lib-devel
86BuildRequires:  speex-devel >= 1.1
87BuildRequires:  twolame-devel
88BuildRequires:  xorg-x11-devel
89BuildRequires:  yasm
90BuildRequires:  zlib-devel
91
92# *-devel packages provided by other self-build-* should only be listed
93# in self-build-%{name}.spec as PreReq.
94##Requires:     self-build-mplayer-codecs
95##BuildRequires:        self-build-libdvdcss
96##BuildRequires:  self-build-lame
97##BuildRequires:  self-build-libdca
98##BuildRequires:  self-build-x264 >= 0.129
99##BuildRequires:  self-build-xvidcore >= 0.9.2
100##BuildRequires:  self-build-faad2 >= 2.6.1
101##BuildRequires:  self-build-libmpeg2
102
103Requires:       TrueType-vlgothic
104Requires:       mesa-libGL
105
106BuildRoot:      %{_tmppath}/%{name}-%{version}-root
107
108Obsoletes:      mplayer < %{version}-%{release}
109
110%description
111MPlayer can play most standard video formats out of the box and almost
112all others with the help of external codecs.
113MPlayer currently works best from the command line, but visual feedback
114for many functions is available from its onscreen status display (OSD),
115which is also used for displaying subtitles.
116MPlayer also has a GUI with skin support and several unofficial alternative
117graphical frontends are available.
118
119MEncoder is a command line video encoder for advanced users that can
120be built from the MPlayer source tree. Unofficial graphical frontends
121exist but arenot included.
122
123MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
124support for some newer codecs are not yet inpmlemented.
125You should install mplayer-codecs package if you want to play videos
126using those new codecs.
127
128%description -l ja
129MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
130またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
131で再生できます。
132現在の MPlayer はコマンドラインから使うのが一番便利ですが、
133多くの操作は字幕と同様に、
134オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
135MPlayer には スキンを変更できる GUI も用意されていますし、
136また複数の非公式なフロントエンドも利用できます。
137
138MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
139非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
140
141MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
142を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
143いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
144をインストールする必要があります。
145
146
147%prep
148#% setup -q -n mplayer-export-%{svndate}
149%setup -q -n MPlayer-%{version}
150%__rm -rf ffmpeg && %__tar xf %{SOURCE1} && mv ffmpeg-%{ffmpegver} ffmpeg || exit 1
151
152%patch2 -p1 -b .vine
153%patch8 -p1 -b .manlinks
154%patch14 -p1 -b .nodvdcss
155%{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
156
157%build
158./configure \
159    --prefix=%{_prefix} \
160    --bindir=%{_bindir} \
161    --datadir=%{_datadir}/mplayer \
162    --mandir=%{_mandir} \
163    --confdir=%{_sysconfdir}/mplayer \
164    --libdir=%{_libdir} \
165    --codecsdir=%{codecdir} \
166    \
167    --extra-cflags="$RPM_OPT_FLAGS" \
168    --language=ja,en \
169    --enable-joystick \
170    --enable-gui --enable-menu \
171    --enable-radio --enable-radio-capture \
172    --enable-runtime-cpudetection \
173    --enable-unrarexec \
174    \
175    --disable-dvdread-internal \
176    --disable-libdvdcss-internal \
177    --disable-nemesi \
178    \
179    %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
180    %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
181    %{!?with_faac:--disable-faac} \
182    --disable-libmpeg2-internal \
183    --disable-libopenjpeg \
184    \
185    --disable-bitmap-font \
186    --disable-dga1 --disable-dga2 \
187    --disable-directfb \
188    --disable-svga \
189    --disable-termcap \
190    --enable-xvmc \
191    --with-xvmclib=XvMCW \
192    \
193    --disable-arts --disable-esd --disable-jack --disable-openal \
194    --disable-live \
195    ;
196
197%{__make} V=1 %{?_smp_mflags}
198
199%install
200%{__rm} -rf ${RPM_BUILD_ROOT}
201%{__make} install INSTALLSTRIP= \
202    prefix=${RPM_BUILD_ROOT}%{_prefix} \
203    BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
204    DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
205    CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
206    LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
207    MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
208    ;
209
210## install some default config files
211%{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
212%{__install} -pm 644 etc/example.conf \
213    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
214%{__install} -pm 644 etc/{input,menu,codecs}.conf \
215    ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
216
217# # Icons
218# for iconsize in 16x16 22x22 24x24 32x32 48x48 256x256; do
219#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps
220#     install -pm 644 etc/mplayer$iconsize.png \
221#         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/$iconsize/apps/mplayer.png
222# done
223
224# install skins and set the default skin
225%{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
226pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
227  for x in %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14}; do
228    %__tar xf ${x} || exit 1
229  done
230  %__ln_s Blue default || exit 1
231popd
232
233# make sybolic link to ttf font for subtitle
234for i in %{ttfontlist}; do
235    if [ -e %{ttfontdir}/$i.ttf ];then
236        %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
237        break;
238    fi;
239done
240
241## install TOOLS
242for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
243%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
244done
245
246for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
247%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
248done
249
250for file in vobshift.py ; do
251%__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
252done
253
254%__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
255%__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
256
257
258%clean
259%{__rm} -rf ${RPM_BUILD_ROOT}
260
261%post
262touch --no-create %{_datadir}/icons/hicolor
263if [ -x %{_bindir}/gtk-update-icon-cache ]; then
264  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
265fi
266%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
267
268%postun
269%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
270touch --no-create %{_datadir}/icons/hicolor
271if [ -x %{_bindir}/gtk-update-icon-cache ]; then
272  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
273fi || :
274
275
276%files
277%defattr(-,root,root)
278#%doc AUTHORS Changelog Copyright LICENSE README
279%config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
280%config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
281%config(noreplace) %{_sysconfdir}/mplayer/input.conf
282%config(noreplace) %{_sysconfdir}/mplayer/menu.conf
283%{_bindir}/mplayer
284%{_bindir}/gmplayer
285%{_bindir}/mencoder
286%{_datadir}/mplayer/skins/default
287%{_datadir}/mplayer/skins/Blue
288%{_datadir}/mplayer/skins/Blue-small
289%{_datadir}/mplayer/skins/OSX-Mod
290%{_datadir}/mplayer/skins/standard
291%{_datadir}/mplayer/subfont.ttf
292%{_datadir}/applications/mplayer.desktop
293%{_datadir}/icons/hicolor/*/apps/mplayer.png
294%{_mandir}/man1/mplayer.1*
295%{_mandir}/man1/mencoder.1*
296## TOOLS
297%{_bindir}/aconvert
298%{_bindir}/calcbpp
299%{_bindir}/countquant
300%{_bindir}/divx2svcd
301%{_bindir}/dvd2divxscript
302%{_bindir}/mencvcd
303%{_bindir}/midentify
304%{_bindir}/mpconsole
305%{_bindir}/qepdvcd
306%{_bindir}/subsearch
307%{_bindir}/vobshift
308%{_datadir}/mplayer/*.fp
309
310
311%changelog
312* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.1-1
313- updated to 1.1.1 based on 1.1.1-1vl7
314
315* Tue Jul  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.rc4
316- dropped BuildRequires: self-build-libdvdcss
317
318* Wed Nov  2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
319- s/self-build-libdvdnav/libdvdnav/
320
321* Fri Oct  7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
322- updated %%SOURCE1
323  - update to 1.8
324
325* Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
326- dropped BuildRequires: esound-devel
327
328* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
329- new upstream release
330  - ready for Vine Linux 6
331  - revived support for Vine Linux 5
332- added BuildRequires:
333  - libass-devel
334  - librtmp-devel >= 2.3
335  - speex-devel >= 1.1
336
337* Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
338- added BuildRequires:
339  - aalib-devel
340  - enca-devel
341  - lzo-devel
342  - speex-devel
343
344* Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
345- updated fixed %{name}-config.patch
346  - applied %{name}-config-20100709-vine.patch
347
348* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
349- change release to sync with self-build-mplayer
350
351* Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
352- updated source snapshot 20100709
353- renamed %%Source10 to mplayer-snapshot-vine.sh
354- applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
355- added BuildRequires: libvpx-devel >= 0.9.1
356
357* Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
358- updated source snapshot 20100621
359
360* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
361- updated source snapshot 20100615
362- added BuildRequires: libXinerama-devel
363- dropped vl4 support
364
365* Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
366- updated source snapshot 20100410
367
368* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
369- updated source snapshot 20100401
370
371* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
372- updated source snapshot 20100326
373
374* Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
375- updated source snapshot 20100317
376
377* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
378- updated source snapshot 20100216
379- moved scripts from TOOLS
380- added --disable-libopenjpeg in configure options
381
382* Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
383- updated source snapshot 20100201
384- dropped obsolete patches
385- added BuildRequires:
386  - libvdpau-devel
387  - libXScrnSaver-devel
388
389* Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
390- update mplayer-config-20091215-vine.patch
391- update mplayer-20091215-x86_32-compile.patch
392- added --enable-runtime-cpudetection in configure options
393
394* Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
395- source snapshot 20091031
396  - updated mplayer-20091031-x86_32-compile.patch
397
398* Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
399- source snapshot 20091003
400
401* Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
402- change release to sync with self-build-mplayer
403
404* Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
405- source snapshot 20090905
406- added settings for vl6
407
408* Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
409- source snapshot 20090821
410- replaced BR: libungif-devel with BR: giflib-devel
411
412* Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
413- source snapshot 20090722
414
415* Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
416- source snapshot 20090702
417
418* Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
419- source snapshot 20090611
420
421* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
422- added Requires: TrueType-vlgothic
423
424* Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
425- source snapshot 20090522
426  - build with x264 >= 0.0.0-9.20090522
427  - updated mplayer-20090522-nodvdcss.patch
428
429* Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
430- change release to sync with self-build-mplayer
431
432* Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
433- source snapshot 20090502
434- updated mplayer-20090503-x86_32-compile.patch
435- updated mplayer-20090502-nodvdcss.patch
436
437* Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
438- applied mplayer-config-vine.patch
439
440* Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
441- source snapshot 20090327
442- updated mplayer-20090327-x86_32-compile.patch
443- updated mplayer-20090325-nodvdcss.patch
444- dropped gmplayer-about-vine.patch
445- install some default config files
446- added configure options:
447  - --disable-termcap
448  - --enable-xvmc
449  - --with-xvmclib=XvMCW
450- archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
451- fixed %%files for *.conf
452
453* Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
454- source snapshot 20090305
455
456* Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
457- source snapshot 20090227
458
459* Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
460- source snapshot 20090216
461
462* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
463- source snapshot 20090206
464- dropped mplayer-man-zh_CN.patch
465- updated mplayer-20090206-nodvdcss.patch
466- changed to PreReq:  self-build-faad2 from faad2-devel
467- added PreReq:  self-build-libmad
468
469* Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
470- source snapshot 20090131
471
472* Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
473- change release to sync with self-build-mplayer
474
475* Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
476- source snapshot
477- update mplayer-20090122-nodvdcss.patch
478- added BuildRequires:
479  - faad2-devel
480  - libmpcdec-devel
481  - twolame-devel
482  - yasm
483  - faac-devel (as PreReq in self-build-%{name})
484  - lame-devel (as PreReq in self-build-%{name})
485  - libdca-devel (as PreReq in self-build-%{name})
486  - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
487  - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
488
489* Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
490- source snapshot
491- added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
492  --disable-faad-internal in configure options
493- dropped gmplayer-add-flv-extension.patch
494
495* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
496- source snapshot
497- fixed License
498- added some patches from RPM Fusion
499- updated gmplayer-about-vine.patch for 20081001 snapshot
500- added BuildRequires:  libdvdread
501- added BuildRequires:  self-build-libdvdcss self-build-libdvdnav
502- added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
503  in configure options
504#- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
505
506* Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
507- fixed License
508- added some devel packages to support OpenGL
509
510* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
511- spec in utf8
512- fix sybolic link of subfont for vl5
513
514* Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
515- add "Patch105: CVE-2008-1558.patch".
516
517* Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
518- build with new versioning policy.
519- fix Source[01] URLs.
520- add "Patch200: gmplayer-about-vine.patch".
521- add "Patch201: gmplayer-add-flv-extension.patch".
522
523* Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
524- add four official security patches (CVE-2008-0485, CVE-2008-0486,
525  CVE-2008-0629, CVE-2008-0630)
526- add mplayer-1.0rc2-20080211-stream_cddb.patch
527
528* Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
529- change source download URL. <BTS:VineLinux:603>
530
531* Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
532- fix CONFDIR for make install. <BTS:wishes:33>
533
534* Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
535- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.