source: projects/specs/branches/6/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl6.spec @ 5338

Revision 5338, 11.4 KB checked in by munepi, 12 years ago (diff)

updated self-build-ffmpeg

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define pkgname ffmpeg
8%define name    self-build-%{pkgname}
9%define version 0.6.4
10#% define svndate       20110326
11%define release 1%{?svndate:.%svndate}%{?_dist_release}
12
13%define sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
14
15## available for v0.6 or lower
16%define with_libfaad 1
17
18%define with_faac 1
19
20%define with_vaapi 1
21%define with_libvpx 1
22
23Summary:        Package to automatically build %{pkgname} rpm package
24Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
25Name:           %{name}
26Version:        %{version}
27Release:        %{release}
28Source0:        %{pkgname}-vl6.spec
29#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
30Source2:        %{pkgname}-snapshot.sh
31Source90:       ffmpeg.1.gz
32Source91:       ffplay.1.gz
33Source92:       ffserver.1.gz
34Source93:       ffprobe.1.gz
35
36License:        GPLv2+
37Group:          Restricted Software
38
39Requires(post):         self-build-setup >= 0.9.9
40#Requires(post):                subversion
41
42# (build)requies of target package.
43Requires(post):  bzip2-devel
44Requires(post): gsm-devel
45Requires(post): imlib2-devel
46Requires(post): libdc1394-devel
47Requires(post): libraw1394-devel
48Requires(post): librtmp-devel >= 2.3
49Requires(post): libtheora-devel
50%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
51Requires(post):  libvdpau-devel
52Requires(post): libvorbis-devel
53%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
54%{?_with_opencore_amr:Requires(post):  opencore-amr-devel}
55##Requires(post):  openjpeg-devel
56##Requires(post):  schroedinger-devel
57Requires(post): SDL-devel
58Requires(post):  speex-devel
59##Requires(post):       texi2html
60Requires(post): zlib-devel
61Requires(post): libogg-devel
62Requires(post):         yasm
63Requires(post):         self-build-a52dec
64Requires(post):         self-build-faac
65Requires(post):         self-build-faad2
66Requires(post):         self-build-lame
67Requires(post):         self-build-libdca
68Requires(post):         self-build-x264 >= 0.0.0-15.20110322
69Requires(post):         self-build-xvidcore
70
71BuildRoot:      %{_tmppath}/%{name}-%{version}-root
72
73BuildArch:      noarch
74Packager:       munepi
75
76%description
77FFMpeg is a complete and free Internet live audio and video
78broadcasting solution for Linux/Unix. It also includes a
79digital VCR. It can encode in real time in many formats
80including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
81real, mjpeg, and flash.
82
83If you install this package, it automaticaly downloads source
84code ,compile it, and create rpm packages of %{pkgname}-%{version}.
85And the created rpm packages are automatically installed
86if installation is executed by apt-get command or synaptic
87package manager.
88
89[Note]
90This package requires many other packages to compile
91target software. So it consume more disk space than usual.
92Also installation takes longer time because of compilation.
93(This will take a few minutes to quarter or half of an hour,
94depends on building environment)
95
96[About self-build package]
97For some kind of software, distributing of binary package
98may viorate the patent or law. Therefore we chose self-build
99packge, create binary package on your machine, for such kind
100of softwares instead of distributing binary package.
101
102Please obey the national law when you use the created binary
103packages. And if you want to use the softwares using patented
104thechnology, it may be required to get a permission, make an
105agreement or purchas a license. Please consider it with your
106purpose or way of use and take appropriate action.
107
108%description -l ja
109FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
110ブオーティオ・ビデオブロードキャスティングソリューションです.
111またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
112MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
113多様なフォーマットをリアルタイムにエンコードすることができます.
114
115このパッケージをインストールすると、自動的にソースコードを
116ダウンロードしてコンパイルし、%{pkgname}-%{version}
117の rpm パッケージを作成します。
118また apt-get コマンドや synaptic パッケージマネージャから実行
119した場合は、作成された rpm パッケージのインストールも自動的に
120行います。
121
122[注意]
123コンパイルに必要な多くの関連パッケージを要求するので通常より
124ディスクの領域を多く消費します。
125またインストール時にコンパイルを行うため、通常より時間がかか
126る場合があります。(環境にもよりますが数分から数十分程度)
127
128[self-build パッケージについて]
129ソフトウェアによってはバイナリパッケージの配布が特許や法律に
130違反する可能性があるものがあります。その為、このような問題が
131懸念されるソフトウェアについてはバイナリパッケージを直接配布
132せずに、ユーザの環境でバイナリを作成する self-build パッケー
133ジという方法を採っています。
134
135作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
136アのライセンス、および利用する国の各種法令に従ってください。
137また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
138センスの購入などが必要となる場合がありますので、利用する目的
139や形態に応じて各自で判断し適切な対応を取ってください。
140
141%prep
142[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
143
144%install
145%{__rm} -rf ${RPM_BUILD_ROOT}
146%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
147%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
148#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
149#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
150%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
151    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
152
153%clean
154%{__rm} -rf ${RPM_BUILD_ROOT}
155
156%posttrans
157#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
158/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl6.spec "%{sourceurl0}" 77000
159/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
160                                 %{pkgname}-libs-%{version}-%{release} \
161                                 %{pkgname}-devel-%{version}-%{release}
162
163## Rebuild gpac with ffmpeg-devel
164# set locale
165case $LANG in
166    ja*)LOCALE=ja ;;
167    *) LOCALE=C ;;
168esac
169
170Rebuild_gpac_C(){
171    echo -n "     "
172    echo "Rebuild gpac with ffmpeg-devel"
173}
174
175Rebuild_gpac_ja(){
176    echo -n "     "
177    echo "ffmpeg-devel で gpac をリビルドします。"
178}
179
180Rebuild_gpac_$LOCALE
181%{gpac_postinstall}
182
183
184%files
185%defattr(-,root,root)
186%{_datadir}/%{name}
187
188%changelog
189* Tue Dec 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.4-1
190- new upstream release
191
192* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
193- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
194  from git.videolan.org
195
196* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
197- added BuildArch: noarch
198
199* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
200- new upstream release
201
202* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
203- new upstream release
204
205* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
206- required latest x264 build
207- added BuildRequires: librtmp-devel >= 2.3
208
209* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
210- new upstream release
211
212* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
213- unpacked source archives
214
215* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
216- fixed some dependencies
217  - Requires(post): libva-devel
218  - Requires(post): libvpx-devel >= 0.9.1
219
220* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
221- new upstream release
222
223* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
224- bumped version to pre-0.6
225- updated source snapshot 20100410
226
227* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
228- fixed self-build log size
229
230* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
231- added ffprobe.1.gz
232
233* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
234- updated source snapshot 20100401
235
236* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
237- renamed %%{Source0} to ffmpeg-vl.spec
238
239* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
240- updated source snapshot 20100216
241  - rebuild with recent x264-devel
242- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
243- added BuildRequires:  libvdpau-devel
244
245* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
246- dropped BuildArch: noarch
247- added ffmpeg.1, ffplay.1, ffserver.1
248
249* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
250- avoided to execute self-build-rpm.sh on RPM transaction
251  - moved %%post actions to %%posttrans
252
253* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
254- added BuildArch: noarch
255- added ffmpeg-0.5-disable-texi2html.patch
256  - dropped PreReq: texi2html
257
258* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
259- added %%{gpac_postinstall} in %%post
260
261* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
262- corrected release number
263
264* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
265- new upstream release
266- added PreReq:
267  - speex-devel
268  - bzip2-devel
269
270* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
271- change release to sync with ffmpeg
272
273* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
274- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
275
276* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
277- 20090202 snapshot
278
279* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
280- 20090110 snapshot
281- dropped some patches
282
283* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
284- source updated (r15488)
285- fixed License: GPLv2+
286- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
287- added BuildRequires: yasm (only %%ix86)
288- applied ffmpeg-cpu.patch (merged from RPM Fusion)
289
290* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
291- spec in utf8
292
293* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
294- run pre-allocate-rpm.sh in %%post
295- set PreReq: self-build-setup >= 0.8
296- change release number
297
298* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
299- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
300  include Source1 in the binary package.
301- drop "Source100: ffmpeg-vine.patch".
302- drop "PreReq: subversion".
303
304* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
305- build with new versioning policy
306- change to use svn export from svn checkout on post install
307- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
308
309* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
310- For all pre-required package that is provied by self-build, 
311  changed to its self-build package
312 
313* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
314- initial build for Vine Linux 4.2
315- snapshot 2008/01/28 + some Rev.11662 2008/01/29
316
317### end of file
Note: See TracBrowser for help on using the repository browser.