source: projects/specs/branches/6/nonfree/self-build-ffmpeg/self-build-ffmpeg-vl6.spec @ 7904

Revision 7904, 12.3 KB checked in by munepi, 11 years ago (diff)

added ffmpeg-0.6.7-gcc-check-cflags.patch

Line 
1%define gpac_postinstall     \
2    gpac_postinstall_sh=$(mktemp) && \
3    rpm -q --scripts self-build-gpac | \
4    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${gpac_postinstall_sh} && \
5    /bin/bash ${gpac_postinstall_sh} && /bin/rm -f ${gpac_postinstall_sh}
6
7%define x264_postinstall     \
8    x264_postinstall_sh=$(mktemp) && \
9    rpm -q --scripts self-build-x264 | \
10    /bin/sed -e 's|posttrans[[:blank:]].*|\#!/bin/bash|' > ${x264_postinstall_sh} && \
11    /bin/bash ${x264_postinstall_sh} && /bin/rm -f ${x264_postinstall_sh}
12
13
14%define pkgname ffmpeg
15%define name    self-build-%{pkgname}
16%define version 0.6.7
17#% define svndate       20110326
18%define release 2%{?svndate:.%svndate}%{?_dist_release}
19
20%define sourceurl0      http://ffmpeg.org/releases/%{pkgname}-%{version}.tar.bz2
21
22## available for v0.6 or lower
23%define with_libfaad 1
24
25%define with_faac 1
26
27%define with_vaapi 1
28%define with_libvpx 1
29
30Summary:        Package to automatically build %{pkgname} rpm package
31Summary(ja):    %{pkgname} の rpm パッケージを自動作成するパッケージ
32Name:           %{name}
33Version:        %{version}
34Release:        %{release}
35Source0:        %{pkgname}-vl6.spec
36#Source1:       %{pkgname}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
37Source2:        %{pkgname}-snapshot.sh
38Source90:       ffmpeg.1.gz
39Source91:       ffplay.1.gz
40Source92:       ffserver.1.gz
41Source93:       ffprobe.1.gz
42
43Source100:      ffmpeg-0.6.7-gcc-check-cflags.patch
44
45License:        GPLv2+
46Group:          Restricted Software
47
48Requires(post):         self-build-setup >= 0.9.9
49#Requires(post):                subversion
50
51# (build)requies of target package.
52Requires(post):  bzip2-devel
53Requires(post): gsm-devel
54Requires(post): imlib2-devel
55Requires(post): libdc1394-devel
56Requires(post): libraw1394-devel
57Requires(post): librtmp-devel >= 2.3
58Requires(post): libtheora-devel
59%{?with_vaapi:Requires(post):   libva-devel >= 0.31.0}
60Requires(post):  libvdpau-devel
61Requires(post): libvorbis-devel
62%{?with_libvpx:Requires(post):  libvpx-devel >= 0.9.1}
63%{?_with_opencore_amr:Requires(post):  opencore-amr-devel}
64##Requires(post):  openjpeg-devel
65##Requires(post):  schroedinger-devel
66Requires(post): SDL-devel
67Requires(post):  speex-devel
68##Requires(post):       texi2html
69Requires(post): zlib-devel
70Requires(post): libogg-devel
71Requires(post):         yasm
72Requires(post):         self-build-a52dec
73Requires(post):         self-build-faac
74Requires(post):         self-build-faad2
75Requires(post):         self-build-lame
76Requires(post):         self-build-libdca
77Requires(post):         self-build-x264 >= 0.0.0-15.20110322
78Requires(post):         self-build-xvidcore
79
80BuildRoot:      %{_tmppath}/%{name}-%{version}-root
81
82BuildArch:      noarch
83Packager:       munepi
84
85%description
86FFMpeg is a complete and free Internet live audio and video
87broadcasting solution for Linux/Unix. It also includes a
88digital VCR. It can encode in real time in many formats
89including MPEG1 audio and video, MPEG4, h263, ac3, asf, avi,
90real, mjpeg, and flash.
91
92If you install this package, it automaticaly downloads source
93code ,compile it, and create rpm packages of %{pkgname}-%{version}.
94And the created rpm packages are automatically installed
95if installation is executed by apt-get command or synaptic
96package manager.
97
98[Note]
99This package requires many other packages to compile
100target software. So it consume more disk space than usual.
101Also installation takes longer time because of compilation.
102(This will take a few minutes to quarter or half of an hour,
103depends on building environment)
104
105[About self-build package]
106For some kind of software, distributing of binary package
107may viorate the patent or law. Therefore we chose self-build
108packge, create binary package on your machine, for such kind
109of softwares instead of distributing binary package.
110
111Please obey the national law when you use the created binary
112packages. And if you want to use the softwares using patented
113thechnology, it may be required to get a permission, make an
114agreement or purchas a license. Please consider it with your
115purpose or way of use and take appropriate action.
116
117%description -l ja
118FFMpeg は Linux/Unix に対する完全にフリーなインターネットライ
119ブオーティオ・ビデオブロードキャスティングソリューションです.
120またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
121MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
122多様なフォーマットをリアルタイムにエンコードすることができます.
123
124このパッケージをインストールすると、自動的にソースコードを
125ダウンロードしてコンパイルし、%{pkgname}-%{version}
126の rpm パッケージを作成します。
127また apt-get コマンドや synaptic パッケージマネージャから実行
128した場合は、作成された rpm パッケージのインストールも自動的に
129行います。
130
131[注意]
132コンパイルに必要な多くの関連パッケージを要求するので通常より
133ディスクの領域を多く消費します。
134またインストール時にコンパイルを行うため、通常より時間がかか
135る場合があります。(環境にもよりますが数分から数十分程度)
136
137[self-build パッケージについて]
138ソフトウェアによってはバイナリパッケージの配布が特許や法律に
139違反する可能性があるものがあります。その為、このような問題が
140懸念されるソフトウェアについてはバイナリパッケージを直接配布
141せずに、ユーザの環境でバイナリを作成する self-build パッケー
142ジという方法を採っています。
143
144作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
145アのライセンス、および利用する国の各種法令に従ってください。
146また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
147センスの購入などが必要となる場合がありますので、利用する目的
148や形態に応じて各自で判断し適切な対応を取ってください。
149
150%prep
151[ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
152
153%install
154%{__rm} -rf ${RPM_BUILD_ROOT}
155%{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
156%{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
157#%{__install} -p -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
158#%{__install} -m 644 %{SOURCE2} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
159%{__install} -m 644 %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
160    ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
161%{__install} -m 644 %{SOURCE100} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
162
163%clean
164%{__rm} -rf ${RPM_BUILD_ROOT}
165
166%posttrans
167#/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec 77000
168/usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl6.spec "%{sourceurl0}" 77000
169/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
170                                 %{pkgname}-libs-%{version}-%{release} \
171                                 %{pkgname}-devel-%{version}-%{release}
172
173## Rebuild gpac with ffmpeg-devel
174# set locale
175case $LANG in
176    ja*)LOCALE=ja ;;
177    *) LOCALE=C ;;
178esac
179
180Rebuild_gpac_C(){
181    echo -n "     "
182    echo "Rebuild gpac with ffmpeg-devel"
183}
184
185Rebuild_gpac_ja(){
186    echo -n "     "
187    echo "ffmpeg-devel で gpac をリビルドします。"
188}
189
190Rebuild_x264_C(){
191    echo -n "     "
192    echo "Rebuild x264 with ffmpeg-devel"
193}
194
195Rebuild_x264_ja(){
196    echo -n "     "
197    echo "ffmpeg-devel で x264 をリビルドします。"
198}
199
200Rebuild_gpac_$LOCALE
201%{gpac_postinstall}
202
203Rebuild_x264_$LOCALE
204%{x264_postinstall}
205
206
207%files
208%defattr(-,root,root)
209%{_datadir}/%{name}
210
211%changelog
212* Thu Oct 17 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.7-2
213- added ffmpeg-0.6.7-gcc-check-cflags.patch
214
215* Sun Oct  6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.7-1
216- new upstream release
217- added %%x264_postinstall in %%posttrans
218
219* Tue Jul  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.6-1
220- new upstream release
221
222* Tue Dec 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.4-1
223- new upstream release
224
225* Sun Oct 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-3
226- applied two patches for CVE-2011-3973, CVE-2011-3974, CVE-2011-3362
227  from git.videolan.org
228
229* Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
230- added BuildArch: noarch
231
232* Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
233- new upstream release
234
235* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
236- new upstream release
237
238* Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
239- required latest x264 build
240- added BuildRequires: librtmp-devel >= 2.3
241
242* Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
243- new upstream release
244
245* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
246- unpacked source archives
247
248* Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
249- fixed some dependencies
250  - Requires(post): libva-devel
251  - Requires(post): libvpx-devel >= 0.9.1
252
253* Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
254- new upstream release
255
256* Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
257- bumped version to pre-0.6
258- updated source snapshot 20100410
259
260* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
261- fixed self-build log size
262
263* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
264- added ffprobe.1.gz
265
266* Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
267- updated source snapshot 20100401
268
269* Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
270- renamed %%{Source0} to ffmpeg-vl.spec
271
272* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
273- updated source snapshot 20100216
274  - rebuild with recent x264-devel
275- updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
276- added BuildRequires:  libvdpau-devel
277
278* Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
279- dropped BuildArch: noarch
280- added ffmpeg.1, ffplay.1, ffserver.1
281
282* Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
283- avoided to execute self-build-rpm.sh on RPM transaction
284  - moved %%post actions to %%posttrans
285
286* Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
287- added BuildArch: noarch
288- added ffmpeg-0.5-disable-texi2html.patch
289  - dropped PreReq: texi2html
290
291* Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
292- added %%{gpac_postinstall} in %%post
293
294* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
295- corrected release number
296
297* Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
298- new upstream release
299- added PreReq:
300  - speex-devel
301  - bzip2-devel
302
303* Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
304- change release to sync with ffmpeg
305
306* Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
307- changed to PreReq:  self-build-faad2 >= 2.0 from faad2-devel
308
309* Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
310- 20090202 snapshot
311
312* Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
313- 20090110 snapshot
314- dropped some patches
315
316* Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
317- source updated (r15488)
318- fixed License: GPLv2+
319- added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
320- added BuildRequires: yasm (only %%ix86)
321- applied ffmpeg-cpu.patch (merged from RPM Fusion)
322
323* Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
324- spec in utf8
325
326* Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
327- run pre-allocate-rpm.sh in %%post
328- set PreReq: self-build-setup >= 0.8
329- change release number
330
331* Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
332- add "Source1: %{pkgname}-%{version}.r%{svnrev}.tar.gz",
333  include Source1 in the binary package.
334- drop "Source100: ffmpeg-vine.patch".
335- drop "PreReq: subversion".
336
337* Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
338- build with new versioning policy
339- change to use svn export from svn checkout on post install
340- fix ffmpeg-vine.patch for libswscale/swscale.c.rej
341
342* Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
343- For all pre-required package that is provied by self-build, 
344  changed to its self-build package
345 
346* Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
347- initial build for Vine Linux 4.2
348- snapshot 2008/01/28 + some Rev.11662 2008/01/29
349
350### end of file
Note: See TracBrowser for help on using the repository browser.