source: projects/specs/branches/6/n/netcdf/netcdf-vl.spec @ 5569

Revision 5569, 3.5 KB checked in by Takemikaduchi, 12 years ago (diff)

rebuild packages

Line 
1Summary:        Libraries for the Unidata network Common Data Form
2Name:           netcdf
3Version:        4.0.1
4Release:        2%{?_dist_release}
5Source0:        ftp://ftp.unidata.ucar.edu/pub/netcdf/%{name}-%{version}.tar.gz
6Group:          Applications/Engineering
7License:        NetCDF
8URL:            http://my.unidata.ucar.edu/content/software/netcdf/index.html
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11#BuildRequires:  gcc-g77
12BuildRequires:  gcc-gfortran
13
14%description
15NetCDF (network Common Data Form) is an interface for
16array-oriented data access and a freely-distributed collection of
17software libraries for C, Fortran, C++, and perl that provides an
18implementation of the interface.  The NetCDF library also defines a
19machine-independent format for representing scientific data. Together,
20the interface, library, and format support the creation, access, and
21sharing of scientific data. The NetCDF software was developed at the
22Unidata Program Center in Boulder, Colorado.
23
24NetCDF data is:
25
26   o Self-Describing: A NetCDF file includes information about the
27     data it contains.
28
29   o Network-transparent:  A NetCDF file is represented in a form that
30     can be accessed by computers with different ways of storing
31     integers, characters, and floating-point numbers.
32
33   o Direct-access:  A small subset of a large dataset may be accessed
34     efficiently, without first reading through all the preceding
35     data.
36
37   o Appendable:  Data can be appended to a NetCDF dataset along one
38     dimension without copying the dataset or redefining its
39     structure. The structure of a NetCDF dataset can be changed,
40     though this sometimes causes the dataset to be copied.
41
42   o Sharable:  One writer and multiple readers may simultaneously
43     access the same NetCDF file.
44
45%package devel
46Summary:        Development files for netcdf
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51This package contains the netCDF header files, libs, and man
52pages.
53
54
55%prep
56%setup -q -n %{name}-%{version}
57
58
59%build
60#cd src
61%configure --enable-shared
62%__make
63
64%post
65/sbin/install-info /%{_infodir}/%{name}.info.gz /%{_infodir}/dir
66
67%preun
68if [ $1 = 0 ]; then
69        /sbin/install-info --delete /%{_infodir}/%{name}.info.gz /%{_infodir}/dir
70fi
71
72
73%install
74rm -rf ${RPM_BUILD_ROOT}
75mkdir ${RPM_BUILD_ROOT}
76mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/netcdf
77mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
78mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
79mkdir -p ${RPM_BUILD_ROOT}%{_mandir}
80#cd src
81%makeinstall INCDIR=${RPM_BUILD_ROOT}%{_includedir}/netcdf \
82  LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
83  MANDIR=${RPM_BUILD_ROOT}%{_mandir}
84
85# Remove unpackaged files
86rm ${RPM_BUILD_ROOT}%{_libdir}/*.la
87rm ${RPM_BUILD_ROOT}%{_infodir}/dir
88
89%clean
90rm -rf ${RPM_BUILD_ROOT}
91
92
93%files
94%defattr(-,root,root,-)
95%doc COPYRIGHT README
96%{_bindir}/*
97%{_libdir}/*.so.*
98%{_mandir}/man1/*
99%{_infodir}/*.info*
100
101%files devel
102%defattr(-,root,root,-)
103%{_includedir}/*
104%{_libdir}/*.so
105%{_libdir}/*.a
106%{_libdir}/pkgconfig/*
107%{_mandir}/man3/*
108
109
110%changelog
111* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-2
112- rebuild with Vine6 environment
113
114* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
115- new upstream release
116
117* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0.p1-1
118- new versioning policy
119
120* Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 3.6.0.p1-0vl2
121- changed BuildRequires gcc-g77 to gcc-gfortran
122
123* Fri Oct 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.0.p1-0vl1
124- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.