source: projects/specs/branches/6/n/netcdf/netcdf-vl.spec @ 7670

Revision 7670, 3.5 KB checked in by Takemikaduchi, 11 years ago (diff)

add BR: curl-devel

Line 
1Summary:        Libraries for the Unidata network Common Data Form
2Name:           netcdf
3Version:        4.2.1.1
4Release:        2%{?_dist_release}
5Source0:        http://www.unidata.ucar.edu/downloads/%{name}/ftp/%{name}-%{version}.tar.gz
6Group:          Applications/Engineering
7License:        NetCDF
8URL:            http://www.unidata.ucar.edu/downloads/netcdf/index.jsp
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11#BuildRequires:  gcc-g77
12BuildRequires:  gcc-gfortran
13BuildRequires:  zlib-devel
14BuildRequires:  hdf5-devel
15BuildRequires:  curl-devel
16
17%description
18NetCDF (network Common Data Form) is an interface for
19array-oriented data access and a freely-distributed collection of
20software libraries for C, Fortran, C++, and perl that provides an
21implementation of the interface.  The NetCDF library also defines a
22machine-independent format for representing scientific data. Together,
23the interface, library, and format support the creation, access, and
24sharing of scientific data. The NetCDF software was developed at the
25Unidata Program Center in Boulder, Colorado.
26
27NetCDF data is:
28
29   o Self-Describing: A NetCDF file includes information about the
30     data it contains.
31
32   o Network-transparent:  A NetCDF file is represented in a form that
33     can be accessed by computers with different ways of storing
34     integers, characters, and floating-point numbers.
35
36   o Direct-access:  A small subset of a large dataset may be accessed
37     efficiently, without first reading through all the preceding
38     data.
39
40   o Appendable:  Data can be appended to a NetCDF dataset along one
41     dimension without copying the dataset or redefining its
42     structure. The structure of a NetCDF dataset can be changed,
43     though this sometimes causes the dataset to be copied.
44
45   o Sharable:  One writer and multiple readers may simultaneously
46     access the same NetCDF file.
47
48%package devel
49Summary:        Development files for netcdf
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52
53%description devel
54This package contains the netCDF header files, libs, and man
55pages.
56
57
58%prep
59%setup -q -n %{name}-%{version}
60
61
62%build
63#cd src
64%configure \
65        --enable-shared \
66        --disable-static \
67        --enable-netcdf-4 \
68        --enable-dap
69%__make
70
71
72%install
73rm -rf ${RPM_BUILD_ROOT}
74mkdir ${RPM_BUILD_ROOT}
75mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/netcdf
76mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
77mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
78mkdir -p ${RPM_BUILD_ROOT}%{_mandir}
79#cd src
80%makeinstall INCDIR=${RPM_BUILD_ROOT}%{_includedir}/netcdf \
81  LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
82  MANDIR=${RPM_BUILD_ROOT}%{_mandir}
83
84find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
85
86%clean
87rm -rf ${RPM_BUILD_ROOT}
88
89%post -p /sbin/ldconfig
90
91%preun -p /sbin/ldconfig
92
93
94%files
95%defattr(-,root,root,-)
96%doc COPYRIGHT README
97%{_bindir}/*
98%{_libdir}/*.so.*
99%{_mandir}/man1/*
100
101%files devel
102%defattr(-,root,root,-)
103%{_includedir}/*
104%{_libdir}/*.so
105%{_libdir}/pkgconfig/*
106%{_mandir}/man3/*
107
108
109%changelog
110* Sun May 12 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-2
111- add configure options (--enable-netcdf-4, --enable-dap)
112- add BuildRequires: curl-devel
113
114* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.1.1-1
115- update to 4.2.1.1
116- add BuildRequires: zlib-devel, hdf5-devel
117
118* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.1-1
119- new upstream release
120
121* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.0.p1-1
122- new versioning policy
123
124* Sat Aug 25 2007 Shu KONNO <owa@bg.wakwak.com> 3.6.0.p1-0vl2
125- changed BuildRequires gcc-g77 to gcc-gfortran
126
127* Fri Oct 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.0.p1-0vl1
128- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.