source: projects/specs/branches/6/n/neon/neon-vl.spec @ 3821

Revision 3821, 8.5 KB checked in by Takemikaduchi, 13 years ago (diff)

neon: add Requires (-devel package), sitecopy: add Patch to build with neon-0.29.x

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: neon
4Summary: An HTTP and WebDAV client library.
5Summary(ja): HTTP と WebDAV クライアントのライブラリ
6Version: 0.29.3
7Release: 2%{?_dist_release}
8License: LGPLv2+
9Group: System Environment/Libraries
10URL: http://www.webdav.org/neon/
11Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13Requires: expat
14Requires: zlib >= 1.1.4
15Requires: krb5-libs
16BuildRequires: expat-devel
17BuildRequires: gnutls-devel
18BuildRequires: krb5-devel
19BuildRequires: libxml2-devel
20#BuildRequires: openssl-devel
21BuildRequires: sed
22BuildRequires: zlib-devel
23BuildRequires: keyutils-libs-devel
24
25%description
26neon is an HTTP and WebDAV client library, with a C interface;
27providing a high-level interface to HTTP and WebDAV methods along
28with a low-level interface for HTTP request handling.  neon
29supports persistent connections, proxy servers, basic, digest and
30Kerberos authentication, and has complete SSL support.
31
32%package devel
33Summary: Development libraries and C header files for the neon library
34Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
35Group: Development/Libraries
36Requires: %{name} = %{version}
37Requires: zlib-devel
38#Requires: openssl-devel
39Requires: expat-devel
40Requires: gnutls-devel
41Requires: krb5-devel
42Requires: keyutils-libs-devel
43
44%description devel
45The development library for the C language HTTP and WebDAV client library.
46
47%description devel -l ja
48C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
49
50## to build compat32 for x86_64 architecture support
51%package -n compat32-%{name}
52Summary: C language HTTP and WebDAV client library.
53Group: System Environment/Libraries
54Requires: expat
55Requires: zlib >= 1.1.4
56
57%description -n compat32-%{name}
58A C language HTTP and WebDAV client library.
59
60%package -n compat32-%{name}-devel
61Summary: A C language HTTP and WebDAV client library.
62Group: Development/Libraries
63Requires: compat32-%{name} = %{version}
64Requires: compat32-zlib-devel
65#Requires: compat32-openssl-devel
66Requires: compat32-expat-devel
67Requires: compat32-keyutils-libs-devel
68Requires: compat32-krb5-devel
69
70%description -n compat32-%{name}-devel
71The development library for the C language HTTP and WebDAV client library.
72
73%prep
74%setup -q
75
76%build
77%configure \
78        --with-expat \
79        --with-ssl=gnutls \
80        --enable-threadsafe-ssl=posix \
81        --enable-shared \
82        --disable-static \
83        --with-force-ssl
84%__make %{?_smp_mflags}
85
86%install
87%__rm -rf %{buildroot}
88%makeinstall
89
90sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
91      $RPM_BUILD_ROOT%{_libdir}/libneon.la
92
93%find_lang %{name}
94
95## remove unuse files
96rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
97
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%post -p /sbin/ldconfig
103
104%postun -p /sbin/ldconfig
105
106%post -n compat32-%{name} -p /sbin/ldconfig
107
108%postun -n compat32-%{name} -p /sbin/ldconfig
109
110%files -f %{name}.lang
111%defattr(-,root,root)
112%doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
113%doc doc/html
114%{_libdir}/*.so.*
115
116%files devel
117%defattr(-,root,root)
118%{_bindir}/*
119%{_includedir}/*
120%{_mandir}/man1/*
121%{_mandir}/man3/*
122#{_libdir}/*.a
123#{_libdir}/*.la
124%{_libdir}/*.so
125%{_libdir}/pkgconfig/*.pc
126
127%if %{build_compat32}
128%files -n compat32-%{name}
129%defattr(-,root,root)
130%{_libdir}/*.so.*
131
132%files -n compat32-%{name}-devel
133%defattr(-,root,root)
134#{_libdir}/*.a
135#{_libdir}/*.la
136%{_libdir}/pkgconfig/*.pc
137%endif
138
139%changelog
140* Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
141- add BuildRequires: keyutils-libs-devel
142- add Requires: krb5-devel, keyutils-libs-devel (-devel package)
143
144* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
145- new upstream release
146
147* Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
148- rebuilt with krb5-libs-1.8.2
149- removed BR: openssl-devel
150- removed static library from devel package
151
152* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
153- rebuilt with rpm-4.8.1 for pkg-config
154
155* Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
156- new upstream release with security fix (CVE-2009-2473, 2474)
157
158* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
159- rebuild with gnutls-2.6.3
160
161* Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
162- add Requires/BuildRequires krb5-libs/krb5-devel tags
163- add _smp_mflags into make section
164
165* Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
166- new upstream release with security fix (CVE-2008-3746)
167
168* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
169- removed *.la
170- spec in utf-8
171
172* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
173- added --with-ssl=gnutls --enable-threadsafe-ssl
174- added BuildRequires: gnutls-devel
175
176* Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
177- new upstream release
178
179* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
180- removed %%if !%%{build_compat32} case condition
181
182* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
183- rebuild with expat-2.0.1
184
185* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
186- new upstream release
187
188* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
189- add Requires: zlib-devel, openssl-devel, expat-devel
190
191* Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
192- move %%configure from %%prep to %%build
193- remove unneeded locales.patch (for neon-0.26.x or later)
194
195* Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
196- new upstream release
197- drop doc.patch (patch0)
198- use more macros
199- drop BuildRequires: autoconf, automake
200- add *.pc to -devel (and compat32's) package
201- change group
202- add Requires: %%{name} = %%{version} to -devel (and compat32's) package
203- add doc/html instead of doc/* to %%doc
204- move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
205- run ldconfig in %%post,postun
206- add locales.patch (patch0)
207
208* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
209- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
210
211* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
212- added compat32- packages for x86_64 architecture support
213- added --libdir=%{_libdir} option to configure
214
215* Sun Sep  5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
216- new upstream release
217
218* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
219- upstream release
220- update URL and Source0 tag: valid URL
221
222* Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
223- upstream release
224- add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
225- add Japanese Summary and %%description
226
227* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
228- build VineLinux
229
230* Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
231- Updated to 0.23.5.
232
233* Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
234- Upgraded to 0.23.2.
235
236* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
237- Upgraded to 0.22.0.
238- Fixed compilation from CVS.
239- Took out man pages until I can figure out xmlto program.
240
241* Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
242- Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
243  to RedHat 7.3 versions and fixing bug in spec file.
244- Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
245  work.
246
247* Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
248- Fixed file ownership problems.  Made them owned by root.
249
250* Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
251- Updated to neon 0.21.3.
252
253* Tue Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
254- Updated to neon 0.21.2.
255
256* Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
257- Updated to neon 0.21.1.
258- Now requires zlib >= 1.1.4.
259- Broke into zlib and zlib-devel.
260- Now builds shared library.
261
262* Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
263- Updated to neon 0.19.4.
264
265* Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
266- Updated to neon 0.19.2.
267
268* Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
269- Updated to neon 0.18.2.
270
271* Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
272- Took out dependency on libxml and w3c-libwww packages.
273- Added dependency on expat.
274
275* Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
276- Release 0.17.2-1: Updated neon.
277
278* Thu Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
279- Release 2: Fixed prefix to be /usr instead of /usr/local.
280
281* Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
282- Release 2001-10-20: Initial Version.
283
Note: See TracBrowser for help on using the repository browser.