source: projects/specs/branches/6/m/metacity/metacity-vl.spec @ 4460

Revision 4460, 14.6 KB checked in by daisuke, 13 years ago (diff)

metacity: fix vine theme to use with hiragino font.

Line 
1%define gettext_package metacity
2
3Summary: Metacity window manager
4Summary(ja): Metacity ウインドウマネージャ
5Name: metacity
6Version: 2.34.0
7Release: 5%{?_dist_release}
8URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
9License: GPL
10Group: User Interface/Desktops
11
12Source0: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.34/%{name}-%{version}.tar.bz2
13Source10: metacity-theme-vine-6.tar.bz2
14
15# update ja.po from git
16# http://git.gnome.org/browse/metacity/commit/?id=8c407025fb3c83262c17bbb28fe175a416fb29ab
17Source20: metacity-2.34.0-ja.po
18
19# change default theme to Vine
20Patch0: metacity-2.34.0-default-theme.patch
21# ctrl-alt-del call logout session
22Patch1: metacity-2.26.0-ctrlaltdel.patch
23# change default number of workspace
24# Patch2: metacity-2.26.0-num_workspace.patch
25# http://bugzilla.gnome.org/show_bug.cgi?id=558723
26Patch4: stop-spamming-xsession-errors.patch
27# enable compositing_manager
28Patch10: metacity-2.30.3-enable-compositing-manager.patch
29# change deafult (revert to 2.30 default)
30Patch11: metacity-2.34.0-revert-default-setting.patch
31
32# revert patch to work with compiz
33# http://git.gnome.org/browse/metacity/commit/?id=6a52883c2b670ad645257373515d1e704408b93d
34Patch20: metacity-2.34.0-revert-6a5288.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: gtk2-devel >= 2.20
38BuildRequires: pango-devel >= 1.28.0
39BuildRequires: GConf2-devel >= 2.28.0
40BuildRequires: desktop-file-utils >= 0.3
41BuildRequires: intltool >= 0.22
42BuildRequires: startup-notification-devel >= 0.7
43BuildRequires: libtool, automake, autoconf
44BuildRequires: xorg-x11-proto-devel
45BuildRequires: libSM-devel, libICE-devel, libX11-devel
46BuildRequires: libXext-devel, libXinerama-devel, libXrandr-devel
47BuildRequires: libXcursor-devel, libXrender-devel
48BuildRequires: libXcomposite-devel, libXdamage-devel
49BuildRequires: zenity
50BuildRequires: libcanberra-devel
51BuildRequires: libgtop2-devel
52BuildRequires: gnome-doc-utils
53Requires(post): GConf2
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60Metacity is a simple window manager that integrates nicely with
61the GNOME desktop.
62
63%package devel
64Summary: Development files for metacity
65Group: Development/Libraries
66Requires: gtk2-devel, libX11-devel
67Requires: pkgconfig
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71This package contains the files needed for compiling programs using
72the metacity-private library. Note that you are not supposed to write
73programs using the metacity-private library, since it is a private
74API. This package exists purely for technical reasons.
75
76%prep
77%setup -q
78
79%patch0 -p1 -b .default-theme
80%patch1 -p1 -b .ctrlaltdel
81# patch2 -p1 -b .num_workspace
82%patch4 -p1 -b .stop-spamming-xsession-errors
83%patch10 -p1 -b .enable-compositing-manager
84%patch11 -p1 -b .revert-default-settings
85
86%patch20 -p1 -b .revert-6a5288
87
88cp -a %{SOURCE20} po/ja.po
89
90%build
91intltoolize --copy --force
92libtoolize --copy --force
93autoreconf
94%configure
95%__make %{?_smp_mflags} INTLTOOL_MERGE=/usr/bin/intltool-merge
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
101make install DESTDIR=$RPM_BUILD_ROOT
102unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
103
104/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
106
107# install Vine Theme (default theme)
108tar xzvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/themes
109
110%find_lang %{gettext_package}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117SCHEMAS="metacity.schemas"
118for S in $SCHEMAS; do
119  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
120done
121
122%files -f %{gettext_package}.lang
123%defattr(-,root,root)
124%doc README AUTHORS COPYING NEWS HACKING doc/theme-format.txt doc/metacity-theme.dtd
125%{_bindir}/metacity
126%{_bindir}/metacity-message
127#{_libexecdir}/*
128%{_sysconfdir}/gconf/schemas/*.schemas
129%{_datadir}/metacity
130%{_datadir}/themes
131%{_libdir}/lib*.so.*
132%{_mandir}/man1/metacity.1.gz
133%{_mandir}/man1/metacity-message.1.gz
134%{_datadir}/gnome-control-center/keybindings/*
135%{_datadir}/applications/metacity.desktop
136%{_datadir}/gnome/wm-properties/metacity-wm.desktop
137%{_datadir}/gnome/help/creating-metacity-themes
138
139%files devel
140%defattr(-,root,root)
141%{_bindir}/metacity-theme-viewer
142%{_bindir}/metacity-window-demo
143%{_includedir}/*
144%{_libdir}/lib*.so
145%{_libdir}/pkgconfig/*
146%{_mandir}/man1/metacity-theme-viewer.1.gz
147%{_mandir}/man1/metacity-window-demo.1.gz
148
149%changelog
150* Tue Aug 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-5
151- fix Vine theme to use fixed size window buttons.
152  - some fonts breaks window title design..
153
154* Wed Jun 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-4
155- update metacity theme
156
157* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-3
158- add patch20 (revert patch)
159  - this commit breaks compiz window decoration.
160
161* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-2
162- update ja.po from git
163
164* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-1
165- update to 2.34.0
166- add patch11 to revert default settings
167  - default title font to Sans Bold 10
168  - add icon menu on titlebar
169- disable patch2 to change workspace num to 4 (factory default).
170
171* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-3
172- update metacity theme
173
174* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-2
175- update metacity theme
176- drop old old theme
177- add patch10 to enable compositing_manager by default
178
179* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
180- new upstream release
181
182* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
183- rebuild with rpm-4.8.1 for pkg-config file
184- add BuildRequires: gnome-doc-utils
185
186* Fri Apr 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-1
187- updated metacity to 2.30.1
188  - fixed crash when right-clicking on window frame
189
190* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
191- new upstream release
192
193* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.28.0-2
194- add BR: libgtop2-devel
195
196* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
197- new upstream release
198- dropped Patch5, 6 and 7 (merged into upstream)
199- removed BR: libglade2-devel
200
201* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
202- added BuildRequires: zenity, libcanberra-devel
203
204* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
205- Patch4: don't spam .xsession-errors so hard
206- Patch5: use libcanberra to play the alert sound
207- Patch6: don't force bell
208- Patch7: fix interaction with autohide panels
209
210* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
211- update Patch0,1,2
212  - apply patches to ".in.in" insread of ".in"
213
214* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
215- new upstream release
216- split development file to -devel subpackage
217  - remove static libs
218
219* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
220- new upstream release
221
222* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-2
223- rebuild to fix strange color problem.
224
225* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
226- new upstream release
227
228* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
229- new upstream release
230- added Requires(post): GConf2
231
232* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
233- new upstream release
234
235* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.13-0vl1
236- new upstream release
237
238* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
239- new upstream release
240
241* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
242- new upstream release
243- remove Patch20 which is merged in upstream
244- include ClearVine theme as default theme.
245
246* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
247- new upstream release
248
249* Fri Apr 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
250- add Patch20 to make configurable new window focus (bug 326159)
251
252* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
253- new upstream release
254
255* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.144-0vl1
256- new upstream release
257
258* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
259- new upstream release
260
261* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
262- new upstream release
263
264* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
265- new upstream release
266
267* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
268- new upstream release
269
270* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
271- new upstream release
272
273* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
274- new upstream release
275
276* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
277- new upstream version
278- include Vine metacity theme as default theme.
279- update Patch0 to change deafult theme.
280
281* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl2
282- update NeoVine metacity theme.
283
284* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl1
285- new upstream release
286
287* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
288- new upstream release
289
290* Sun Jun 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
291- new upstream release
292- add BuildRequires: libtoo,automake14, autoconf
293
294* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.6.3-0vl1
295- new upstream release
296- build with new toolchain
297
298* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
299- new upstream release
300
301* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
302- new upstream release
303
304* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl2
305- fixed missing locale files
306
307* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
308- new upstream release
309
310* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl2
311- add patch10 to increase workspaces (4->6).
312
313* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
314- new upstream release
315
316* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
317- new upstream release
318
319* Mon Jun 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl2
320- update ja.po
321- update NeoVine theme
322
323* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl1
324- new upstream release
325
326* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
327- fixed typo
328- NeoVine Metatheme moved to gnome-themes package.
329
330* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
331- new upstream release
332- add patch2 from rawhide.
333- drop patch1, merged in upstream.
334
335* Fri Jan 31 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.21-0vl2
336- add Patch1 to fix hang on all 64-bit platforms
337
338* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.21-0vl1
339- new upstream release
340
341* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl3
342- update NeoVine metatheme (use gnome default icons)
343
344* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl2
345- update neovine theme
346
347* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl1
348- new upstream release
349
350* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
351- drop patch0 to use system fonts.
352
353* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
354- update ja.po
355
356* Fri Dec 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl5
357- fixed NeoVine theme
358
359* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl4
360- add NeoVine theme ported from sawfish.
361- use neoVine as default theme. (Patch0)
362
363* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl3
364- change URL
365- add BuildRequires
366
367* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl2
368- add include files
369
370* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
371- build for Vine Linux
372- new upstream release from gnome-2.1.4
373
374* Tue Oct 29 2002 Havoc Pennington <hp@redhat.com>
375- 2.4.3
376- remove patches that have gone upstream
377
378* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
379- fix shaded window decorations in Bluecurve theme
380
381* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
382- fix the mplayer-disappears-on-de-fullscreen bug
383
384* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
385- add some fixes from CVS for #71163 #72379 #72478 #72513
386
387* Thu Aug 22 2002 Havoc Pennington <hp@redhat.com>
388- patch .schemas.in instead of .schemas so we get right default theme/fonts
389
390* Tue Aug 20 2002 Havoc Pennington <hp@redhat.com>
391- grow size of top resize, and display proper cursor on enter notify
392- require latest intltool to try and fix metacity.schemas by
393  regenerating it in non-UTF-8 locale
394
395* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
396- default to Sans Bold font, fixes #70920 and matches graphic design spec
397
398* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
399- 2.4.0.91 with raise/lower keybindings for msf, fixes to fullscreen
400- more apps that probably intend to be, fix for changing number of
401  workspaces, fix for moving windows in multihead
402
403* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
404- update build requires
405
406* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
407- upgrade to cvs snap 2.4.0.90 with pile of bugfixes from
408  this weekend
409- change default theme to bluecurve and require new redhat-artwork
410
411* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
412- 2.4.0
413- themes are moved, require appropriate redhat-artwork
414
415* Thu Aug  1 2002 Havoc Pennington <hp@redhat.com>
416- munge the desktop file to be in toplevel menus and
417  not show in KDE
418
419* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
420- don't use system font by default as metacity's
421  font is now in the system font dialog
422
423* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
424- 2.3.987.92 cvs snap
425
426* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
427- 2.3.987.91 cvs snap
428
429* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
430- 2.3.987.90 cvs snap
431
432* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
433- automated rebuild
434
435* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
436- rebuild for new libraries
437
438* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
439- rebuild in different environment
440
441* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
442- 2.3.987
443- default to redhat theme
444
445* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
446- rebuild in different environment
447
448* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
449- 2.3.610.90 cvs snap
450
451* Sun May 26 2002 Tim Powers <timp@redhat.com>
452- automated rebuild
453
454* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
455- rebuild in different environment
456
457* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
458- 2.3.377
459
460* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
461- 2.3.233
462
463* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
464- rebuild in different environment
465- add gconf schemas boilerplate
466
467* Mon Apr 15 2002 Havoc Pennington <hp@pobox.com>
468- 2.3.89
469
470* Tue Oct 30 2001 Havoc Pennington <hp@redhat.com>
471- 2.3.34
472
473* Fri Oct 13 2001 Havoc Pennington <hp@redhat.com>
474- 2.3.21
475
476* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
477- 2.3.8
478- 2.3.13
479
480* Wed Sep  5 2001 Havoc Pennington <hp@redhat.com>
481- Initial build.
482
483
Note: See TracBrowser for help on using the repository browser.