source: projects/specs/branches/6/lib/libt/libtiff/libtiff-vl.spec @ 7831

Revision 7831, 12.7 KB checked in by iwamoto, 11 years ago (diff)

libtiff: add patch for CVE-2013-4231,32,44

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.5
7Release: 9%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12
13Patch100: tiff-3.9.4-CVE-2012-1173.patch
14Patch110: libtiff-3.9.6-CVE-2012-2088.patch
15Patch120: libtiff-3.9.6-CVE-2012-2113.patch
16Patch130: libtiff-3.9.6-CVE-2012-3401.patch
17Patch140: libtiff-3.9.5_CVE-2012-4447.patch
18Patch150: libtiff-3.9.5_CVE-2012-4564.patch
19Patch160: libtiff-3.9.5_CVE-2012-5581.patch
20Patch170: libtiff-3.9.5_CVE-2013-4231.patch
21Patch180: libtiff-3.9.5_CVE-2013-4232.patch
22Patch190: libtiff-3.9.5_CVE-2013-4244.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
26Requires: zlib libjpeg
27%define LIBVER %(echo %{version} | cut -f-2 -d.)
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%description
33The libtiff package contains a library of functions for manipulating
34TIFF (Tagged Image File Format) image format files.  TIFF is a widely
35used file format for bitmapped images.  TIFF files usually end in the
36.tif extension and they are often quite large.
37
38The libtiff package should be installed if you need to manipulate TIFF
39format image files.
40
41%description -l ja
42libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
43扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
44広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
45拡張子が使われ,サイズは概して大きめです.
46
47TIFF 形式の画像ファイルを扱う必要があるならば,
48libtiff パッケージを是非インストールして下さい.
49
50
51%package devel
52Summary: Development tools for programs which will use the libtiff library.
53Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
54Group: Development/Libraries
55Requires: libtiff = %{version}
56
57
58%description devel
59This package contains the header files and static libraries for
60developing programs which will manipulate TIFF format image files
61using the libtiff library.
62
63If you need to develop programs which will manipulate TIFF format
64image files, you should install this package.  You'll also need to
65install the libtiff package.
66
67#'
68%description devel -l ja
69このパッケージには,libtiff ライブラリを使って TIFF 形式の
70画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
71スタティックライブラリが収められています.
72
73TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
74このパッケージをインストールして下さい.libtiff パッケージも同時に
75インストールする必要があります.
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: A library of functions for manipulating TIFF format image files.
80Group: System Environment/Libraries
81Requires: zlib libjpeg
82Requires: %{name} = %{version}
83%description -n compat32-%{name}
84The libtiff package contains a library of functions for manipulating
85TIFF (Tagged Image File Format) image format files.  TIFF is a widely
86used file format for bitmapped images.  TIFF files usually end in the
87.tif extension and they are often quite large.
88
89The libtiff package should be installed if you need to manipulate TIFF
90format image files.
91
92%package -n compat32-%{name}-devel
93Summary: Development tools for programs which will use the libtiff library.
94Group: Development/Libraries
95Requires: compat32-%{name} = %{version}
96%description -n compat32-%{name}-devel
97This package contains the header files and static libraries for
98developing programs which will manipulate TIFF format image files
99using the libtiff library.
100
101If you need to develop programs which will manipulate TIFF format
102image files, you should install this package.  You'll also need to
103install the libtiff package.
104
105#'
106%prep
107%setup -q -n tiff-%{version}
108
109%patch100 -p1 -b .CVE-2012-1173
110%patch110 -p1 -b .CVE-2012-2088
111%patch120 -p1 -b .CVE-2012-2113
112%patch130 -p1 -b .CVE-2012-3401
113%patch140 -p1 -b .CVE-2012-4447
114%patch150 -p1 -b .CVE-2012-4564
115%patch160 -p1 -b .CVE-2012-5581
116%patch170 -p1 -b .CVE-2013-4231
117%patch180 -p1 -b .CVE-2013-4232
118%patch190 -p1 -b .CVE-2013-4244
119
120
121%build
122%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
123%__make %{?_smp_mflags}
124%__make clean
125
126%install
127rm -fr $RPM_BUILD_ROOT
128%makeinstall
129rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
130
131# fix libdir in .la
132perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
133
134
135%post -p /sbin/ldconfig
136
137%postun -p /sbin/ldconfig
138
139%if %{build_compat32}
140%post -n compat32-%{name} -p /sbin/ldconfig
141%postun -n compat32-%{name} -p /sbin/ldconfig
142%endif
143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%files
148%defattr(-,root,root)
149%doc COPYRIGHT README RELEASE-DATE VERSION
150%{_bindir}/*
151%{_libdir}/libtiff*.so.*
152%{_mandir}/man1/*
153
154
155%files devel
156%defattr(-,root,root)
157%doc TODO html ChangeLog
158%{_includedir}/*
159%{_libdir}/libtiff*.so
160%{_libdir}/libtiff*.a
161# %{_libdir}/libtiff*.la
162%{_mandir}/man3/*
163
164## to build compat32 for x86_64 architecture support
165%if %{build_compat32}
166%files -n compat32-%{name}
167%defattr(-,root,root)
168%{_libdir}/libtiff.so.*
169
170%files -n compat32-%{name}-devel
171%defattr(-,root,root)
172%{_libdir}/libtiff.so
173%{_libdir}/libtiff.a
174# %{_libdir}/libtiff.la
175%endif
176
177
178%changelog
179* Tue Sep 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-9
180- add Patch170 for fix CVE-2013-4231 (gif2tiff)
181- add Patch180 for fix CVE-2013-4232 (tiff2pdf)
182- add Patch190 for fix CVE-2013-4244 (gif2tiff)
183
184* Sun Dec 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-8
185- update patch160 from rh
186
187* Fri Dec 21 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-7
188- add patch160 for fix CVE-2012-5581 (DOTRANGE tags)
189
190* Mon Nov 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-6
191- update patch150 (Thanks to debian team)
192
193* Wed Nov 14 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-5
194- add patch150 for fix CVE-2012-4564 (ppm2tiff)
195
196* Mon Oct 22 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-4
197- add patch140 for fix CVE-2012-4447 (PixarLog)
198
199* Mon Jul 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-3
200- add patch110 for fix CVE-2012-2088 (Bof)
201- add patch120 for fix CVE-2012-2113 (tiff2pdf BoF)
202- add patch130 for fix CVE-2012-3401
203- patches are from fc17, Thanks.
204
205* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-2
206- add patch100 for fix CVE-2012-1173 (TileSize entry)
207
208* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
209- new upstream release
210- drop all patches (are included in new release)
211- remove if-endif for Vine 4.x
212- add Vendor/Distri tags
213
214* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
215- add some patches from RHEL6 3.9.4-1.el6_0.3
216 - fix for CVE-2011-0192 (Patch11)
217 - fix for CVE-2011-1167 (Patch12)
218 - fix for CVE-2009-5022 (Patch13)
219
220* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
221- rebuilt with rpm-4.8.1-3
222
223* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
224- new upstream release
225- add patch4-10 from fedora
226
227* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
228- new upstream release
229- remove BC: freeglut-devel
230- add patch1,2,4,5 from fedora
231- drop obsolete patches
232
233* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
234- change if-endif to make both i386 and compat32 packages
235
236* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
237- add patch5 for fix CVE-2009-2347 (Integer Overflow)
238
239* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
240- add patch4 for fix lzw underflow security issue
241- add if branch Vine4/5 in devel files section (*.la are included or not)
242
243* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
244- removed *.la
245- spec in utf-8
246
247* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
248- fix changelog typo (3.8.4 -> 3.8.2)
249- new versioning policy
250- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
251
252* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
253- fix libdir in libtiff.la
254- add BuildConflicts: freeglut-devel
255
256* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
257- rebuilt without glut-devel
258
259* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
260- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
261
262* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
263- new upstream release
264- remove obsolete patches
265- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
266- delete duped docs
267- add --disable-cxx to configure option
268- add *.la to devel package
269
270* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
271- added compat32-* packages for x86_64 architecture support
272- added --with-jpeg-lib-dir=%{_libdir} to configure
273
274* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
275- new upstream release
276- remove obsolete patches
277- cleanup specs
278
279* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
280- rebuild for Vine3.1
281
282* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
283- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
284- update URL
285
286* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
287- build for Vine2.6
288
289* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
290- fix changelog: proper name
291
292* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
293- add symlink to shared lib by running ldconfig at compile time
294
295* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
296- add patch8-13 from Fedora Core
297--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
298--- fix some integer and buffer overflows (#134853, #134848)
299- add patch14 from SUSE LINUX
300--* Wed Oct 20 2004 - meissner@suse.de
301--- Do not crash if we are using unsupported codecs (like OJPEG).
302
303* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
304- rebuild with new toolchains
305- to use License instead of Copyright
306
307* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
308- 3.5.7-6vl1
309- based on 3.5.7-6 from Rawhide
310
311* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
312- 3.5.5-8vl1
313- based on 3.5.5-8 from Rawhide
314- added Japanese summary and description
315
316* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
317- rebuild
318
319* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
320- added a tiff-to-ps.fpi filter for printing
321
322* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
323- automatic rebuild
324
325* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
326- apply Peter Skarpetis's fix for the 32-bit conversion
327
328* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
329- make man pages non-executable (#12811)
330
331* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
332- remove CVS repo info from data directories
333
334* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
335- fix build rooting
336- fix syntax error in configure script
337- move man pages to %{_mandir}
338
339* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
340- rebuild for an errata release
341
342* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
343- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
344
345* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
346- fix fax2ps swapping height and width in the bounding box
347
348* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
349- move man pages from devel package to the regular one
350- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
351  of libtiff)
352- fix fax2ps breakage (bug #8345)
353
354* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
355- set MANDIR=man3 to make multifunction man pages friendlier
356
357* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
358- fix URLs
359
360* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
361- link shared library against libjpeg and libz
362
363* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
364- enable zip and jpeg codecs
365- change defattr in normal package to 0755
366- add defattr to -devel package
367
368* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
369- update to 3.5.4
370
371* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
372- auto rebuild in the new build environment (release 6)
373
374* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
375- build for glibc 2.1
376
377* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
378- translations modified for de
379
380* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
381- rebuilt against fixed jpeg libs (libjpeg-6b)
382
383* Thu May 07 1998 Prospector System <bugs@redhat.com>
384- translations modified for de, fr, tr
385
386* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
387- new version to replace the one from libgr
388- patched for glibc
389- added shlib support
Note: See TracBrowser for help on using the repository browser.