source: projects/specs/branches/6/lib/libt/libtiff/libtiff-vl.spec @ 7419

Revision 7419, 12.3 KB checked in by iwamoto, 11 years ago (diff)

libtiff, libxml2 updates

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.5
7Release: 8%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12
13Patch100: tiff-3.9.4-CVE-2012-1173.patch
14Patch110: libtiff-3.9.6-CVE-2012-2088.patch
15Patch120: libtiff-3.9.6-CVE-2012-2113.patch
16Patch130: libtiff-3.9.6-CVE-2012-3401.patch
17Patch140: libtiff-3.9.5_CVE-2012-4447.patch
18Patch150: libtiff-3.9.5_CVE-2012-4564.patch
19Patch160: libtiff-3.9.5_CVE-2012-5581.patch
20
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
23Requires: zlib libjpeg
24%define LIBVER %(echo %{version} | cut -f-2 -d.)
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30The libtiff package contains a library of functions for manipulating
31TIFF (Tagged Image File Format) image format files.  TIFF is a widely
32used file format for bitmapped images.  TIFF files usually end in the
33.tif extension and they are often quite large.
34
35The libtiff package should be installed if you need to manipulate TIFF
36format image files.
37
38%description -l ja
39libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
40扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
41広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
42拡張子が使われ,サイズは概して大きめです.
43
44TIFF 形式の画像ファイルを扱う必要があるならば,
45libtiff パッケージを是非インストールして下さい.
46
47
48%package devel
49Summary: Development tools for programs which will use the libtiff library.
50Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
51Group: Development/Libraries
52Requires: libtiff = %{version}
53
54
55%description devel
56This package contains the header files and static libraries for
57developing programs which will manipulate TIFF format image files
58using the libtiff library.
59
60If you need to develop programs which will manipulate TIFF format
61image files, you should install this package.  You'll also need to
62install the libtiff package.
63
64#'
65%description devel -l ja
66このパッケージには,libtiff ライブラリを使って TIFF 形式の
67画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
68スタティックライブラリが収められています.
69
70TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
71このパッケージをインストールして下さい.libtiff パッケージも同時に
72インストールする必要があります.
73
74## to build compat32 for x86_64 architecture support
75%package -n compat32-%{name}
76Summary: A library of functions for manipulating TIFF format image files.
77Group: System Environment/Libraries
78Requires: zlib libjpeg
79Requires: %{name} = %{version}
80%description -n compat32-%{name}
81The libtiff package contains a library of functions for manipulating
82TIFF (Tagged Image File Format) image format files.  TIFF is a widely
83used file format for bitmapped images.  TIFF files usually end in the
84.tif extension and they are often quite large.
85
86The libtiff package should be installed if you need to manipulate TIFF
87format image files.
88
89%package -n compat32-%{name}-devel
90Summary: Development tools for programs which will use the libtiff library.
91Group: Development/Libraries
92Requires: compat32-%{name} = %{version}
93%description -n compat32-%{name}-devel
94This package contains the header files and static libraries for
95developing programs which will manipulate TIFF format image files
96using the libtiff library.
97
98If you need to develop programs which will manipulate TIFF format
99image files, you should install this package.  You'll also need to
100install the libtiff package.
101
102#'
103%prep
104%setup -q -n tiff-%{version}
105
106%patch100 -p1 -b .CVE-2012-1173
107%patch110 -p1 -b .CVE-2012-2088
108%patch120 -p1 -b .CVE-2012-2113
109%patch130 -p1 -b .CVE-2012-3401
110%patch140 -p1 -b .CVE-2012-4447
111%patch150 -p1 -b .CVE-2012-4564
112%patch160 -p1 -b .CVE-2012-5581
113
114%build
115%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
116%__make %{?_smp_mflags}
117%__make clean
118
119%install
120rm -fr $RPM_BUILD_ROOT
121%makeinstall
122rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
123
124# fix libdir in .la
125perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
126
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%if %{build_compat32}
133%post -n compat32-%{name} -p /sbin/ldconfig
134%postun -n compat32-%{name} -p /sbin/ldconfig
135%endif
136
137%clean
138rm -rf $RPM_BUILD_ROOT
139
140%files
141%defattr(-,root,root)
142%doc COPYRIGHT README RELEASE-DATE VERSION
143%{_bindir}/*
144%{_libdir}/libtiff*.so.*
145%{_mandir}/man1/*
146
147
148%files devel
149%defattr(-,root,root)
150%doc TODO html ChangeLog
151%{_includedir}/*
152%{_libdir}/libtiff*.so
153%{_libdir}/libtiff*.a
154# %{_libdir}/libtiff*.la
155%{_mandir}/man3/*
156
157## to build compat32 for x86_64 architecture support
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/libtiff.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-,root,root)
165%{_libdir}/libtiff.so
166%{_libdir}/libtiff.a
167# %{_libdir}/libtiff.la
168%endif
169
170
171%changelog
172* Sun Dec 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-8
173- update patch160 from rh
174
175* Fri Dec 21 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-7
176- add patch160 for fix CVE-2012-5581 (DOTRANGE tags)
177
178* Mon Nov 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-6
179- update patch150 (Thanks to debian team)
180
181* Wed Nov 14 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-5
182- add patch150 for fix CVE-2012-4564 (ppm2tiff)
183
184* Mon Oct 22 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-4
185- add patch140 for fix CVE-2012-4447 (PixarLog)
186
187* Mon Jul 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-3
188- add patch110 for fix CVE-2012-2088 (Bof)
189- add patch120 for fix CVE-2012-2113 (tiff2pdf BoF)
190- add patch130 for fix CVE-2012-3401
191- patches are from fc17, Thanks.
192
193* Sat Apr 28 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-2
194- add patch100 for fix CVE-2012-1173 (TileSize entry)
195
196* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
197- new upstream release
198- drop all patches (are included in new release)
199- remove if-endif for Vine 4.x
200- add Vendor/Distri tags
201
202* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
203- add some patches from RHEL6 3.9.4-1.el6_0.3
204 - fix for CVE-2011-0192 (Patch11)
205 - fix for CVE-2011-1167 (Patch12)
206 - fix for CVE-2009-5022 (Patch13)
207
208* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
209- rebuilt with rpm-4.8.1-3
210
211* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
212- new upstream release
213- add patch4-10 from fedora
214
215* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
216- new upstream release
217- remove BC: freeglut-devel
218- add patch1,2,4,5 from fedora
219- drop obsolete patches
220
221* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
222- change if-endif to make both i386 and compat32 packages
223
224* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
225- add patch5 for fix CVE-2009-2347 (Integer Overflow)
226
227* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
228- add patch4 for fix lzw underflow security issue
229- add if branch Vine4/5 in devel files section (*.la are included or not)
230
231* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
232- removed *.la
233- spec in utf-8
234
235* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
236- fix changelog typo (3.8.4 -> 3.8.2)
237- new versioning policy
238- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
239
240* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
241- fix libdir in libtiff.la
242- add BuildConflicts: freeglut-devel
243
244* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
245- rebuilt without glut-devel
246
247* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
248- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
249
250* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
251- new upstream release
252- remove obsolete patches
253- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
254- delete duped docs
255- add --disable-cxx to configure option
256- add *.la to devel package
257
258* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
259- added compat32-* packages for x86_64 architecture support
260- added --with-jpeg-lib-dir=%{_libdir} to configure
261
262* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
263- new upstream release
264- remove obsolete patches
265- cleanup specs
266
267* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
268- rebuild for Vine3.1
269
270* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
271- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
272- update URL
273
274* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
275- build for Vine2.6
276
277* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
278- fix changelog: proper name
279
280* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
281- add symlink to shared lib by running ldconfig at compile time
282
283* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
284- add patch8-13 from Fedora Core
285--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
286--- fix some integer and buffer overflows (#134853, #134848)
287- add patch14 from SUSE LINUX
288--* Wed Oct 20 2004 - meissner@suse.de
289--- Do not crash if we are using unsupported codecs (like OJPEG).
290
291* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
292- rebuild with new toolchains
293- to use License instead of Copyright
294
295* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
296- 3.5.7-6vl1
297- based on 3.5.7-6 from Rawhide
298
299* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
300- 3.5.5-8vl1
301- based on 3.5.5-8 from Rawhide
302- added Japanese summary and description
303
304* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
305- rebuild
306
307* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
308- added a tiff-to-ps.fpi filter for printing
309
310* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
311- automatic rebuild
312
313* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
314- apply Peter Skarpetis's fix for the 32-bit conversion
315
316* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
317- make man pages non-executable (#12811)
318
319* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
320- remove CVS repo info from data directories
321
322* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
323- fix build rooting
324- fix syntax error in configure script
325- move man pages to %{_mandir}
326
327* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
328- rebuild for an errata release
329
330* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
331- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
332
333* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
334- fix fax2ps swapping height and width in the bounding box
335
336* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
337- move man pages from devel package to the regular one
338- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
339  of libtiff)
340- fix fax2ps breakage (bug #8345)
341
342* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
343- set MANDIR=man3 to make multifunction man pages friendlier
344
345* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
346- fix URLs
347
348* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
349- link shared library against libjpeg and libz
350
351* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
352- enable zip and jpeg codecs
353- change defattr in normal package to 0755
354- add defattr to -devel package
355
356* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
357- update to 3.5.4
358
359* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
360- auto rebuild in the new build environment (release 6)
361
362* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
363- build for glibc 2.1
364
365* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
366- translations modified for de
367
368* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
369- rebuilt against fixed jpeg libs (libjpeg-6b)
370
371* Thu May 07 1998 Prospector System <bugs@redhat.com>
372- translations modified for de, fr, tr
373
374* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
375- new version to replace the one from libgr
376- patched for glibc
377- added shlib support
Note: See TracBrowser for help on using the repository browser.