source: projects/specs/branches/6/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 7817

Revision 7817, 6.7 KB checked in by kudoh, 11 years ago (diff)
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        1.1.0
8Release:        2%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        wxWidgets
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:  autoconf, automake, libtool
17%ifarch %{ix86} x86_64
18BuildRequires:  nasm
19%endif
20
21Obsoletes:      libjpeg < 6b-50vl6
22Provides:       libjpeg = 6b-50vl6
23
24Patch0:         libjpeg-turbo11-noinst_jpgtest.patch
25Patch1:         ljt11-rh688712.patch
26
27Patch100:       libjpeg-turbo_CVE-2012-2806.patch
28
29%description
30The libjpeg-turbo package contains a library of functions for manipulating
31JPEG images
32
33%package devel
34Summary:        Headers for the libjpeg-turbo library
35Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
36Group:          Development/Libraries
37Obsoletes:      libjpeg-devel < 6b-50vl6
38Obsoletes:      libjpeg-static < 6b-50vl6
39Provides:       libjpeg-devel = 6b-50vl6
40Requires:       libjpeg-turbo = %{version}-%{release}
41
42%description devel
43This package contains header files necessary for developing programs which
44will manipulate JPEG files using the libjpeg-turbo library
45
46%package utils
47Summary:        Utilities for manipulating JPEG images
48Summary(ja):    JPEG イメージを操作するためのユーティリティ
49Group:          Applications/Multimedia
50Requires:       libjpeg-turbo = %{version}-%{release}
51
52%description utils
53The libjpeg-turbo-utils package contains simple client programs for
54accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
55rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
56Djpeg decompresses a JPEG file into a regular image file. Jpegtran
57can perform various useful transformations on JPEG files. Rdjpgcom
58displays any text comments included in a JPEG file. Wrjpgcom inserts
59text comments into a JPEG file.
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
64Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
65Group:          System Environment/Libraries
66Obsoletes:      compat32-libjpeg < 6b-50vl6
67Provides:       compat32-libjpeg = 6b-50vl6
68
69%description -n compat32-%{name}
70The libjpeg-turbo package contains a library of functions for manipulating
71JPEG images
72
73%package -n compat32-%{name}-devel
74Summary:        Headers for the libjpeg-turbo library
75Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
76Group:          Development/Libraries
77Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
78Provides:       compat32-libjpeg-devel = 6b-50vl6
79Requires:       libjpeg-turbo = %{version}-%{release}
80
81%description -n compat32-%{name}-devel
82This package contains header files necessary for developing programs which
83will manipulate JPEG files using the libjpeg-turbo library
84
85%prep
86%setup -q
87
88%patch0 -p1 -b .noinst_jpgtest
89%patch1 -p0 -b .rh688712
90
91%patch100 -p1 -b .CVE-2012-2806
92
93%build
94autoreconf -fiv
95
96%configure --disable-static
97
98make %{?_smp_mflags}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102make install DESTDIR=$RPM_BUILD_ROOT
103
104# Fix perms
105chmod -x README-turbo.txt
106
107# Remove unwanted files
108rm -f $RPM_BUILD_ROOT/%{_libdir}/lib{,turbo}jpeg.la
109
110# Don't distribute libjpegturbo because it is unversioned
111rm -f $RPM_BUILD_ROOT/%{_includedir}/turbojpeg.h
112rm -f $RPM_BUILD_ROOT/%{_libdir}/libturbojpeg.so
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%post -p /sbin/ldconfig
118%postun -p /sbin/ldconfig
119%post -n compat32-%{name} -p /sbin/ldconfig
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc README README-turbo.txt change.log ChangeLog.txt LGPL.txt LICENSE.txt
125%{_libdir}/libjpeg.so.62.0.0
126%{_libdir}/libjpeg.so.62
127
128%files devel
129%defattr(-,root,root,-)
130#%doc coderules.doc jconfig.doc libjpeg.doc structure.doc example.c
131%{_includedir}/jconfig.h
132%{_includedir}/jerror.h
133%{_includedir}/jmorecfg.h
134%{_includedir}/jpeglib.h
135%{_libdir}/libjpeg.so
136
137%files utils
138%defattr(-,root,root,-)
139#%doc usage.doc wizard.doc
140%{_bindir}/cjpeg
141%{_bindir}/djpeg
142%{_bindir}/jpegtran
143%{_bindir}/rdjpgcom
144%{_bindir}/wrjpgcom
145%{_mandir}/man1/cjpeg.1*
146%{_mandir}/man1/djpeg.1*
147%{_mandir}/man1/jpegtran.1*
148%{_mandir}/man1/rdjpgcom.1*
149%{_mandir}/man1/wrjpgcom.1*
150
151## to build compat32 for x86_64 architecture support
152%if %{build_compat32}
153%files -n compat32-%{name}
154%defattr(-,root,root)
155%{_libdir}/libjpeg.so.*
156
157%files -n compat32-%{name}-devel
158%defattr(-,root,root)
159%{_libdir}/*.so
160%endif
161
162%changelog
163* Sat Sep 21 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-2
164- added Patch100 to fix CVE-2012-2806
165- fixed %%doc error in -devel, -utils package
166
167* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
168- new upstream release
169
170* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
171- initial build for Vine Linux
172
173* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
174- fix huffman decoder to handle broken JPEGs well (#617469)
175
176* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
177- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
178  deps
179
180* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
181- update to 1.0.0
182- patches merged
183  - libjpeg-turbo-programs.patch
184  - libjpeg-turbo-nosimd.patch
185- add libjpeg provides to the main package to workaround problems with broken
186  java-1.6.0-openjdk package
187
188* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
189- remove libjpeg provides from -utils subpkg
190
191* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
192- move Obsoletes: libjpeg to main pkg
193
194* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
195- -utils: Requires: %%name ...
196
197* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
198- add Provides = libjpeg to -utils subpackage
199
200* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
201- merge review related fixes (#600243)
202
203* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
204- merge review related fixes (#600243)
205
206* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
207- obsolete -static libjpeg subpackage (#600243)
208
209* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
210- improve package description a little (#600243)
211- include example.c as %%doc in the -devel subpackage
212
213* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
214- don't use "fc12" disttag in obsoletes/provides (#600243)
215
216* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
217- fix compilation on platforms without MMX/SSE (#600243)
218
219* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
220- package review related fixes (#600243)
221
222* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
223- package review related fixes (#600243)
224
225* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
226- initial package
Note: See TracBrowser for help on using the repository browser.