source: projects/specs/branches/6/lib/libj/libjpeg-turbo/libjpeg-turbo-vl.spec @ 8025

Revision 8025, 7.1 KB checked in by iwamoto, 10 years ago (diff)

gimp, libjpeg-turbo, curl: security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
4Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
5
6Name:           libjpeg-turbo
7Version:        1.1.0
8Release:        3%{?_dist_release}
9
10Group:          System Environment/Libraries
11License:        wxWidgets
12URL:            http://sourceforge.net/projects/libjpeg-turbo
13Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
14BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
15
16BuildRequires:  autoconf, automake, libtool
17%ifarch %{ix86} x86_64
18BuildRequires:  nasm
19%endif
20
21Obsoletes:      libjpeg < 6b-50vl6
22Provides:       libjpeg = 6b-50vl6
23
24Patch0:         libjpeg-turbo11-noinst_jpgtest.patch
25Patch1:         ljt11-rh688712.patch
26
27Patch100:       libjpeg-turbo_CVE-2012-2806.patch
28Patch110:       libjpeg-turbo-CVE-2013-6629.patch
29Patch120:       libjpeg-turbo-CVE-2013-6630.patch
30
31Vendor:         Project Vine
32Distribution:   Vine Linux
33
34%description
35The libjpeg-turbo package contains a library of functions for manipulating
36JPEG images
37
38%package devel
39Summary:        Headers for the libjpeg-turbo library
40Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
41Group:          Development/Libraries
42Obsoletes:      libjpeg-devel < 6b-50vl6
43Obsoletes:      libjpeg-static < 6b-50vl6
44Provides:       libjpeg-devel = 6b-50vl6
45Requires:       libjpeg-turbo = %{version}-%{release}
46
47%description devel
48This package contains header files necessary for developing programs which
49will manipulate JPEG files using the libjpeg-turbo library
50
51%package utils
52Summary:        Utilities for manipulating JPEG images
53Summary(ja):    JPEG イメージを操作するためのユーティリティ
54Group:          Applications/Multimedia
55Requires:       libjpeg-turbo = %{version}-%{release}
56
57%description utils
58The libjpeg-turbo-utils package contains simple client programs for
59accessing the libjpeg functions. It contains cjpeg, djpeg, jpegtran,
60rdjpgcom and wrjpgcom. Cjpeg compresses an image file into JPEG format.
61Djpeg decompresses a JPEG file into a regular image file. Jpegtran
62can perform various useful transformations on JPEG files. Rdjpgcom
63displays any text comments included in a JPEG file. Wrjpgcom inserts
64text comments into a JPEG file.
65
66## to build compat32 for x86_64 architecture support
67%package -n compat32-%{name}
68Summary:        A MMX/SSE2 accelerated library for manipulating JPEG image files
69Summary(ja):    MMX/SSE2 でアクセラレーションされた libjpeg ライブラリ
70Group:          System Environment/Libraries
71Obsoletes:      compat32-libjpeg < 6b-50vl6
72Provides:       compat32-libjpeg = 6b-50vl6
73
74%description -n compat32-%{name}
75The libjpeg-turbo package contains a library of functions for manipulating
76JPEG images
77
78%package -n compat32-%{name}-devel
79Summary:        Headers for the libjpeg-turbo library
80Summary(ja):    libjpeg-turbo ライブラリのヘッダファイル
81Group:          Development/Libraries
82Obsoletes:      compat32-libjpeg-devel < 6b-50vl6
83Provides:       compat32-libjpeg-devel = 6b-50vl6
84Requires:       libjpeg-turbo = %{version}-%{release}
85
86%description -n compat32-%{name}-devel
87This package contains header files necessary for developing programs which
88will manipulate JPEG files using the libjpeg-turbo library
89
90%prep
91%setup -q
92
93%patch0 -p1 -b .noinst_jpgtest
94%patch1 -p0 -b .rh688712
95
96%patch100 -p1 -b .CVE-2012-2806
97%patch110 -p1 -b .CVE-2013-6629
98%patch120 -p1 -b .CVE-2013-6630
99
100%build
101autoreconf -fiv
102
103%configure --disable-static
104
105make %{?_smp_mflags}
106
107%install
108rm -rf $RPM_BUILD_ROOT
109make install DESTDIR=$RPM_BUILD_ROOT
110
111# Fix perms
112chmod -x README-turbo.txt
113
114# Remove unwanted files
115rm -f $RPM_BUILD_ROOT/%{_libdir}/lib{,turbo}jpeg.la
116
117# Don't distribute libjpegturbo because it is unversioned
118rm -f $RPM_BUILD_ROOT/%{_includedir}/turbojpeg.h
119rm -f $RPM_BUILD_ROOT/%{_libdir}/libturbojpeg.so
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126%post -n compat32-%{name} -p /sbin/ldconfig
127%postun -n compat32-%{name} -p /sbin/ldconfig
128
129%files
130%defattr(-,root,root,-)
131%doc README README-turbo.txt change.log ChangeLog.txt LGPL.txt LICENSE.txt
132%{_libdir}/libjpeg.so.62.0.0
133%{_libdir}/libjpeg.so.62
134
135%files devel
136%defattr(-,root,root,-)
137#%doc coderules.doc jconfig.doc libjpeg.doc structure.doc example.c
138%{_includedir}/jconfig.h
139%{_includedir}/jerror.h
140%{_includedir}/jmorecfg.h
141%{_includedir}/jpeglib.h
142%{_libdir}/libjpeg.so
143
144%files utils
145%defattr(-,root,root,-)
146#%doc usage.doc wizard.doc
147%{_bindir}/cjpeg
148%{_bindir}/djpeg
149%{_bindir}/jpegtran
150%{_bindir}/rdjpgcom
151%{_bindir}/wrjpgcom
152%{_mandir}/man1/cjpeg.1*
153%{_mandir}/man1/djpeg.1*
154%{_mandir}/man1/jpegtran.1*
155%{_mandir}/man1/rdjpgcom.1*
156%{_mandir}/man1/wrjpgcom.1*
157
158## to build compat32 for x86_64 architecture support
159%if %{build_compat32}
160%files -n compat32-%{name}
161%defattr(-,root,root)
162%{_libdir}/libjpeg.so.*
163
164%files -n compat32-%{name}-devel
165%defattr(-,root,root)
166%{_libdir}/*.so
167%endif
168
169%changelog
170* Thu Dec  5 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.0-3
171- add patch110,120 for fix CVE-2013-6629,6630 (jdmarker)
172- add Vendor/Distri Tags
173
174* Sat Sep 21 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.0-2
175- added Patch100 to fix CVE-2012-2806
176- fixed %%doc error in -devel, -utils package
177
178* Tue Mar 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
179- new upstream release
180
181* Tue Sep 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.0-1
182- initial build for Vine Linux
183
184* Wed Aug 04 2010 Adam Tkac <atkac redhat com> 1.0.0-3
185- fix huffman decoder to handle broken JPEGs well (#617469)
186
187* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-2
188- add libjpeg-devel%%{_isa} provides to -devel subpkg to satisfy imlib-devel
189  deps
190
191* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.0-1
192- update to 1.0.0
193- patches merged
194  - libjpeg-turbo-programs.patch
195  - libjpeg-turbo-nosimd.patch
196- add libjpeg provides to the main package to workaround problems with broken
197  java-1.6.0-openjdk package
198
199* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 0.0.93-13
200- remove libjpeg provides from -utils subpkg
201
202* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-12
203- move Obsoletes: libjpeg to main pkg
204
205* Wed Jun 30 2010 Rex Dieter <rdieter@fedoraproject.org> 0.0.93-11
206- -utils: Requires: %%name ...
207
208* Wed Jun 30 2010 Adam Tkac <atkac redhat com> 0.0.93-10
209- add Provides = libjpeg to -utils subpackage
210
211* Mon Jun 28 2010 Adam Tkac <atkac redhat com> 0.0.93-9
212- merge review related fixes (#600243)
213
214* Wed Jun 16 2010 Adam Tkac <atkac redhat com> 0.0.93-8
215- merge review related fixes (#600243)
216
217* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-7
218- obsolete -static libjpeg subpackage (#600243)
219
220* Mon Jun 14 2010 Adam Tkac <atkac redhat com> 0.0.93-6
221- improve package description a little (#600243)
222- include example.c as %%doc in the -devel subpackage
223
224* Fri Jun 11 2010 Adam Tkac <atkac redhat com> 0.0.93-5
225- don't use "fc12" disttag in obsoletes/provides (#600243)
226
227* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-4
228- fix compilation on platforms without MMX/SSE (#600243)
229
230* Thu Jun 10 2010 Adam Tkac <atkac redhat com> 0.0.93-3
231- package review related fixes (#600243)
232
233* Wed Jun 09 2010 Adam Tkac <atkac redhat com> 0.0.93-2
234- package review related fixes (#600243)
235
236* Fri Jun 04 2010 Adam Tkac <atkac redhat com> 0.0.93-1
237- initial package
Note: See TracBrowser for help on using the repository browser.