source: projects/specs/branches/6/lib/libb/libboost/libboost-vl.spec @ 2728

Revision 2728, 14.1 KB checked in by munepi, 13 years ago (diff)

updated libboost-vl.spec

Line 
1%define major 1
2%define minor 45
3%define teeny 0
4%define tarname boost
5%define lnkver %{major}_%{minor}
6%define pkgver %{major}_%{minor}_%{teeny}
7
8Summary: Portable C++ source libraries
9Summary(ja): ポータブルな C++ ソースライブラリ
10Name: libboost
11Version: %{major}.%{minor}.%{teeny}
12Release: 2%{?_dist_release}
13Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
14Source1: user-config.jam
15Patch0: https://svn.boost.org/trac/boost/attachment/ticket/4688/boost_filesystem.patch
16License: distributable
17Group: System Environment/Libraries
18URL: http://www.boost.org/
19
20BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
21BuildRequires: libaio-devel lam
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
28Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
29Obsoletes: %{name}-python-devel %{name}-regex-devel
30Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
31Obsoletes: %{name}-thread-devel %{name}-wave-devel
32
33%description
34Boost provides free peer-reviewed portable C++ source libraries.  The emphasis
35is on libraries which work well with the C++ Standard Library.  The libraries
36are intended to be widely useful, and are in regular use by thousands of
37programmers across a broad spectrum of applications.
38
39A further goal is to establish "existing practice" and provide reference
40implementations so that Boost libraries are suitable for eventual
41standardization. Ten Boost libraries will be included in the C++ Standards
42Committee's upcoming C++ Standard Library Technical Report as a step toward
43becoming part of a future C++ Standard.
44
45%description -l ja
46Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
47準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
48ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
49
50さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
51を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
52として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
53含まれる予定です。
54
55%package devel
56Summary: Header files and libraries for developing apps which will use %{name}
57Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62The %{name}-devel package contains the header files and libraries needed
63to develop programs that use the Boost library.
64
65%description devel -l ja
66%{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
67ヘッダファイルやライブラリを含んでいます。
68
69%package doc
70Summary: Documents of %{name}
71Summary(ja): %{name}のドキュメント
72Group: Applications/Documentation
73Requires: %{name} = %{version}-%{release}
74
75%description doc
76The %{name}-doc package contains the documents about the boost library.
77
78%description doc -l ja
79%{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
80
81%package date-time
82Summary: Set of data-time libralies in %{name}
83Group: System Environment/Libraries
84Requires: %{name} = %{version}-%{release}
85
86%description date-time
87Set of data-time libralies in %{name}
88
89%package filesystem
90Summary: Set of filesystem operation libralies in %{name}
91Group: System Environment/Libraries
92Requires: %{name} = %{version}-%{release}
93
94%description filesystem
95Set of filesystem operation libralies in %{name}
96
97%package graph
98Summary: Set of Graphviz libralies in %{name}
99Group: System Environment/Libraries
100Requires: %{name} = %{version}-%{release}
101
102%description graph
103Set of Graphviz libralies in %{name}
104
105%package iostreams
106Summary: Set of streams and i/o filters libralies in %{name}
107Group: System Environment/Libraries
108Requires: %{name} = %{version}-%{release}
109
110%description iostreams
111Set of streams and i/o filters libralies in %{name}
112
113%package math
114Summary: Set of math libralies in %{name}
115Group: System Environment/Libraries
116Requires: %{name} = %{version}-%{release}
117
118%description math
119Set of math libralies in %{name}
120
121%package program-options
122Summary: Set of program options libralies in %{name}
123Group: System Environment/Libraries
124Requires: %{name} = %{version}-%{release}
125
126%description program-options
127Set of program options libralies in %{name}
128
129%package python
130Summary: Set of Python libralies in %{name}
131Group: System Environment/Libraries
132Requires: %{name} = %{version}-%{release}
133
134%description python
135Set of Python libralies in %{name}
136
137%package random
138Summary: Set of random number generation libralies in %{name}
139Group: System Environment/Libraries
140Requires: %{name} = %{version}-%{release}
141
142%description random
143Set of random number generation libralies in %{name}
144
145%package regex
146Summary: Set of regular expression libralies in %{name}
147Group: System Environment/Libraries
148Requires: %{name} = %{version}-%{release}
149
150%description regex
151Set of regular expression libralies in %{name}
152
153%package serialization
154Summary: Set of serialization libralies in %{name}
155Group: System Environment/Libraries
156Requires: %{name} = %{version}-%{release}
157
158%description serialization
159Set of serialization libralies in %{name}
160
161%package signals
162Summary: Set of signals and slots libralies in %{name}
163Group: System Environment/Libraries
164Requires: %{name} = %{version}-%{release}
165
166%description signals
167Set of signals and slots libralies in %{name}
168
169%package system
170Summary: Operating system support
171Group: System Environment/Libraries
172Requires: %{name} = %{version}-%{release}
173
174%description system
175Operating system support, including the diagnostics support
176that will be part of the C++0x standard library
177
178%package test
179Summary: Set of libraries for writing and executing tests in %{name}
180Group: System Environment/Libraries
181Requires: %{name} = %{version}-%{release}
182
183%description test
184Set of libraries for writing and executing tests in %{name}
185
186%package thread
187Summary: Set of multi-thread libraries in %{name}
188Group: System Environment/Libraries
189Requires: %{name} = %{version}-%{release}
190
191%description thread
192Set of multi-thread libraries in %{name}
193
194%package wave
195Summary: Set of wave libraries in %{name}
196Group: System Environment/Libraries
197Requires: %{name} = %{version}-%{release}
198
199%description wave
200Set of wave libraries in %{name}
201
202%prep
203%setup -q -n %{tarname}_%{pkgver}
204cp %SOURCE1 user-config.jam
205
206%patch0 -p1 -b .filesystem
207
208%build
209## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
210## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
211./bootstrap.sh \
212        --prefix=%{_prefix} \
213        --libdir=%{_libdir} \
214        --includedir=%{_includedir} \
215        --with-icu=%{_prefix} \
216        --with-python-version=%{pyver}
217
218./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
219
220%install
221rm -rf $RPM_BUILD_ROOT
222## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
223
224./bjam \
225        --prefix=${RPM_BUILD_ROOT}%{_prefix} \
226        --libdir=${RPM_BUILD_ROOT}%{_libdir} \
227        --user-config=./user-config.jam \
228        link=shared \
229        install
230
231ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
232
233# remove unuse files
234rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
235
236# unnead for libboost-1.42
237## pushd $RPM_BUILD_ROOT/%{_libdir}
238## for i in libboost_*-mt.so
239## do
240##   ln -sf $i $(echo $i | cut -f1 -d-).so
241## done
242## popd
243
244## %post devel
245## if [ $1 = 2 ]; then
246##    rm -rf %{_includedir}/%{tarname}
247## fi
248## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
249##
250## %postun devel
251## if [ $1 = 0 ]; then
252##    rm -rf %{_includedir}/%{tarname}
253## fi
254
255%post date-time -p /sbin/ldconfig
256%post filesystem -p /sbin/ldconfig
257%post graph -p /sbin/ldconfig
258%post iostreams -p /sbin/ldconfig
259%post math -p /sbin/ldconfig
260%post program-options -p /sbin/ldconfig
261%post python -p /sbin/ldconfig
262%post regex -p /sbin/ldconfig
263%post serialization -p /sbin/ldconfig
264%post signals -p /sbin/ldconfig
265%post system -p /sbin/ldconfig
266%post test -p /sbin/ldconfig
267%post thread -p /sbin/ldconfig
268%post wave -p /sbin/ldconfig
269
270%postun date-time -p /sbin/ldconfig
271%postun filesystem -p /sbin/ldconfig
272%postun graph -p /sbin/ldconfig
273%postun iostreams -p /sbin/ldconfig
274%postun math -p /sbin/ldconfig
275%postun program-options -p /sbin/ldconfig
276%postun python -p /sbin/ldconfig
277%postun regex -p /sbin/ldconfig
278%postun serialization -p /sbin/ldconfig
279%postun signals -p /sbin/ldconfig
280%postun system -p /sbin/ldconfig
281%postun test -p /sbin/ldconfig
282%postun thread -p /sbin/ldconfig
283%postun wave -p /sbin/ldconfig
284
285%clean
286rm -rf $RPM_BUILD_ROOT
287
288%files
289%defattr(-,root,root)
290%doc LICENSE_1_0.txt
291
292%files devel
293%defattr(-,root,root)
294%{_includedir}/boost/
295%{_includedir}/boost-%{lnkver}/
296
297%files doc
298%doc index.htm index.html boost.css boost.png rst.css doc libs more
299
300%files date-time
301%{_libdir}/%{name}_date_time*.so*
302
303%files filesystem
304%{_libdir}/%{name}_filesystem*.so*
305
306%files graph
307%{_libdir}/%{name}_graph*.so*
308%{_libdir}/%{name}_mpi*.so*
309%{_libdir}/mpi*.so*
310
311%files iostreams
312%{_libdir}/%{name}_iostreams*.so*
313
314%files math
315%{_libdir}/%{name}_math_*.so*
316
317%files program-options
318%{_libdir}/%{name}_program_options*.so*
319
320%files python
321%{_libdir}/%{name}_python*.so*
322
323%files random
324%{_libdir}/%{name}_random*.so*
325
326%files regex
327%{_libdir}/%{name}_regex*.so*
328
329%files serialization
330%{_libdir}/%{name}_serialization*.so*
331%{_libdir}/%{name}_wserialization*.so*
332
333%files signals
334%{_libdir}/%{name}_signals*.so*
335
336%files system
337%{_libdir}/%{name}_system*.so*
338
339%files test
340%{_libdir}/%{name}_prg_exec_monitor*.so*
341%{_libdir}/%{name}_unit_test_framework*.so*
342
343%files thread
344%{_libdir}/%{name}_thread*.so*
345
346%files wave
347%{_libdir}/%{name}_wave*.so*
348
349%changelog
350* Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.45.0-2
351- fixed crashing throwing exception
352  "std::runtime_error: locale::facet::_S_create_c_locale name not valid"
353  on some systems (FreeBSD and some linuxes) when current locale
354  (LANG,LC_ALL) is not "C"
355
356* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
357- updated to boost_1_45_0
358- added random sub-package
359
360* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
361- rebuilt again on ppc
362
363* Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
364- rebuilt with libicu-4.4
365
366* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
367- added "-licui18n" to bjam
368- added BR: lam
369
370* Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
371- updated to boost_1_42_0
372- rebuilt with new toolchain and python-2.6
373- added user-config.jam to make libboost_mpi
374- added BR: libaio-devel
375- added %%{post,postun} -p /sbin/ldconfig
376- dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
377- dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
378- dropt %%{post,postun} devel section
379
380* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
381- rebuilt with libicu-4.0.1
382- changed Group to System Environment/Libraries (except devel package)
383
384* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
385- new upstream release
386- add -math subpackage
387
388* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
389- build with python-2.5
390- add libboost_XXXX.so symlinks
391
392* Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
393- upstream release
394- applied new versioning policy
395- add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
396- add new package libboost-system
397- Obsolete: *-devel packages
398
399* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
400- rebuilt with libicu-3.6
401- changed doc Group to Applications/Documentation
402
403* Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
404- upstream release
405
406* Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
407- add --libdir=%%{_libdir} to cope with x86_64 environment
408
409* Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
410- upstream release
411- use Easy Build and Install process with ./configure
412- add BuildRequires: libicu-devel
413- remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
414- add new packages: libboost-graph, libboost-graph-devel, libboost-wave
415- add files to doc package
416
417* Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
418- rebuilt with new toolchain
419
420* Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
421- upstream release
422
423* Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
424- fixed typo in Groups:
425- devel packages also moved to Development/Libraries group
426
427* Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
428- spec modified to avoid errors on non-ix86 archtecture
429  (previously the path linuxx86 was explicitly used)
430
431* Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
432- initial release for Vine Linux
433
434* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
435- link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
436
437* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
438- change package name from boost to libboost
439- separated into sub-packages
440
441* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
442- upstream release
443- add BuildRequires: bzip2-devel zlib-devel
444
445* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
446- added so.* file
447
448* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
449- moved %post, %postun script to -devel package
450
451* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
452- moved doc/html to -devel package
453- make a symbolic link on %{_includedir}/boost
454
455* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
456- fixed character code to euc-jp
457
458* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
459- add %doc files
460
461* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
462- remove Requires
463- split -devel package
464
465* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
466- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.