source: projects/specs/trunk/lib/libb/libboost/libboost-vl.spec @ 2527

Revision 2527, 13.7 KB checked in by owa, 13 years ago (diff)

update libboost to 1.45.0

Line 
1%define major 1
2%define minor 45
3%define teeny 0
4%define tarname boost
5%define lnkver %{major}_%{minor}
6%define pkgver %{major}_%{minor}_%{teeny}
7
8Summary: Portable C++ source libraries
9Summary(ja): ポータブルな C++ ソースライブラリ
10Name: libboost
11Version: %{major}.%{minor}.%{teeny}
12Release: 1%{?_dist_release}
13Source0: http://downloads.sourceforge.net/%{tarname}/%{tarname}_%{pkgver}.tar.bz2
14Source1: user-config.jam
15License: distributable
16Group: System Environment/Libraries
17URL: http://www.boost.org/
18
19BuildRequires: python-devel apache2-devel bzip2-devel zlib-devel libicu-devel
20BuildRequires: libaio-devel lam
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23Vendor: Project Vine
24Distribution: Vine Linux
25
26Obsoletes: %{name}-date-time-devel %{name}-filesystem-devel %{name}-graph-devel
27Obsoletes: %{name}-iostreams-devel %{name}-program-options-devel
28Obsoletes: %{name}-python-devel %{name}-regex-devel
29Obsoletes: %{name}-serialization-devel %{name}-signals-devel %{name}-test-devel
30Obsoletes: %{name}-thread-devel %{name}-wave-devel
31
32%description
33Boost provides free peer-reviewed portable C++ source libraries.  The emphasis
34is on libraries which work well with the C++ Standard Library.  The libraries
35are intended to be widely useful, and are in regular use by thousands of
36programmers across a broad spectrum of applications.
37
38A further goal is to establish "existing practice" and provide reference
39implementations so that Boost libraries are suitable for eventual
40standardization. Ten Boost libraries will be included in the C++ Standards
41Committee's upcoming C++ Standard Library Technical Report as a step toward
42becoming part of a future C++ Standard.
43
44%description -l ja
45Boost は公開レビューされたフリーのC++ライブラリ群です。 C++ の標準ライブラリに
46準拠することに重点を置いて開発されています。使いやすく、広い分野のアプリ
47ケーションにおいて日常的に多くの開発者に用いられることを目指しています。
48
49さらなる目標は、最終的な標準化に適合した「存在する実例」としてリファレンス実装
50を提供することです。10 の Boost ライブラリが、将来の C++ 標準になるための一歩
51として、C++ 標準化委員会が策定中の C++ 標準ライブラリテクニカルレポートに
52含まれる予定です。
53
54%package devel
55Summary: Header files and libraries for developing apps which will use %{name}
56Summary(ja): %{name}の開発に必要なヘッダファイル及びライブラリ
57Group: Development/Libraries
58Requires: %{name} = %{version}-%{release}
59
60%description devel
61The %{name}-devel package contains the header files and libraries needed
62to develop programs that use the Boost library.
63
64%description devel -l ja
65%{name}-devel パッケージは Boost ライブラリを使うプログラムの開発に必要な
66ヘッダファイルやライブラリを含んでいます。
67
68%package doc
69Summary: Documents of %{name}
70Summary(ja): %{name}のドキュメント
71Group: Applications/Documentation
72Requires: %{name} = %{version}-%{release}
73
74%description doc
75The %{name}-doc package contains the documents about the boost library.
76
77%description doc -l ja
78%{name}-doc パッケージは Boost ライブラリについてのドキュメントを含んでいます。
79
80%package date-time
81Summary: Set of data-time libralies in %{name}
82Group: System Environment/Libraries
83Requires: %{name} = %{version}-%{release}
84
85%description date-time
86Set of data-time libralies in %{name}
87
88%package filesystem
89Summary: Set of filesystem operation libralies in %{name}
90Group: System Environment/Libraries
91Requires: %{name} = %{version}-%{release}
92
93%description filesystem
94Set of filesystem operation libralies in %{name}
95
96%package graph
97Summary: Set of Graphviz libralies in %{name}
98Group: System Environment/Libraries
99Requires: %{name} = %{version}-%{release}
100
101%description graph
102Set of Graphviz libralies in %{name}
103
104%package iostreams
105Summary: Set of streams and i/o filters libralies in %{name}
106Group: System Environment/Libraries
107Requires: %{name} = %{version}-%{release}
108
109%description iostreams
110Set of streams and i/o filters libralies in %{name}
111
112%package math
113Summary: Set of math libralies in %{name}
114Group: System Environment/Libraries
115Requires: %{name} = %{version}-%{release}
116
117%description math
118Set of math libralies in %{name}
119
120%package program-options
121Summary: Set of program options libralies in %{name}
122Group: System Environment/Libraries
123Requires: %{name} = %{version}-%{release}
124
125%description program-options
126Set of program options libralies in %{name}
127
128%package python
129Summary: Set of Python libralies in %{name}
130Group: System Environment/Libraries
131Requires: %{name} = %{version}-%{release}
132
133%description python
134Set of Python libralies in %{name}
135
136%package random
137Summary: Set of random number generation libralies in %{name}
138Group: System Environment/Libraries
139Requires: %{name} = %{version}-%{release}
140
141%description random
142Set of random number generation libralies in %{name}
143
144%package regex
145Summary: Set of regular expression libralies in %{name}
146Group: System Environment/Libraries
147Requires: %{name} = %{version}-%{release}
148
149%description regex
150Set of regular expression libralies in %{name}
151
152%package serialization
153Summary: Set of serialization libralies in %{name}
154Group: System Environment/Libraries
155Requires: %{name} = %{version}-%{release}
156
157%description serialization
158Set of serialization libralies in %{name}
159
160%package signals
161Summary: Set of signals and slots libralies in %{name}
162Group: System Environment/Libraries
163Requires: %{name} = %{version}-%{release}
164
165%description signals
166Set of signals and slots libralies in %{name}
167
168%package system
169Summary: Operating system support
170Group: System Environment/Libraries
171Requires: %{name} = %{version}-%{release}
172
173%description system
174Operating system support, including the diagnostics support
175that will be part of the C++0x standard library
176
177%package test
178Summary: Set of libraries for writing and executing tests in %{name}
179Group: System Environment/Libraries
180Requires: %{name} = %{version}-%{release}
181
182%description test
183Set of libraries for writing and executing tests in %{name}
184
185%package thread
186Summary: Set of multi-thread libraries in %{name}
187Group: System Environment/Libraries
188Requires: %{name} = %{version}-%{release}
189
190%description thread
191Set of multi-thread libraries in %{name}
192
193%package wave
194Summary: Set of wave libraries in %{name}
195Group: System Environment/Libraries
196Requires: %{name} = %{version}-%{release}
197
198%description wave
199Set of wave libraries in %{name}
200
201%prep
202%setup -q -n %{tarname}_%{pkgver}
203cp %SOURCE1 user-config.jam
204
205%build
206## ./configure --prefix=/usr --libdir=%{_libdir} --with-icu
207## make EXPAT_INCLUDE=/usr/include EXPAT_LIBPATH=/usr/lib
208./bootstrap.sh \
209        --prefix=%{_prefix} \
210        --libdir=%{_libdir} \
211        --includedir=%{_includedir} \
212        --with-icu=%{_prefix} \
213        --with-python-version=%{pyver}
214
215./bjam -sICU_LINK="-L%{_libdir} -licui18n" --user-config=./user-config.jam link=shared
216
217%install
218rm -rf $RPM_BUILD_ROOT
219## ./tools/jam/src/bin.linux*/bjam -sICU_PATH=/usr -sEXPAT_INCLUDE=/usr/include -sEXPAT_LIBPATH=/usr/lib --user-config=user-config.jam --prefix=${RPM_BUILD_ROOT}/usr --libdir=${RPM_BUILD_ROOT}%{_libdir} install
220
221./bjam \
222        --prefix=${RPM_BUILD_ROOT}%{_prefix} \
223        --libdir=${RPM_BUILD_ROOT}%{_libdir} \
224        --user-config=./user-config.jam \
225        link=shared \
226        install
227
228ln -s ./%{tarname} ${RPM_BUILD_ROOT}/%{_includedir}/%{tarname}-%{lnkver}
229
230# remove unuse files
231rm -f ${RPM_BUILD_ROOT}/%{_libdir}/%{name}_*.a
232
233# unnead for libboost-1.42
234## pushd $RPM_BUILD_ROOT/%{_libdir}
235## for i in libboost_*-mt.so
236## do
237##   ln -sf $i $(echo $i | cut -f1 -d-).so
238## done
239## popd
240
241## %post devel
242## if [ $1 = 2 ]; then
243##    rm -rf %{_includedir}/%{tarname}
244## fi
245## ln -s %{_includedir}/%{tarname}-%{lnkver}/%{tarname} %{_includedir}/%{tarname}
246##
247## %postun devel
248## if [ $1 = 0 ]; then
249##    rm -rf %{_includedir}/%{tarname}
250## fi
251
252%post date-time -p /sbin/ldconfig
253%post filesystem -p /sbin/ldconfig
254%post graph -p /sbin/ldconfig
255%post iostreams -p /sbin/ldconfig
256%post math -p /sbin/ldconfig
257%post program-options -p /sbin/ldconfig
258%post python -p /sbin/ldconfig
259%post regex -p /sbin/ldconfig
260%post serialization -p /sbin/ldconfig
261%post signals -p /sbin/ldconfig
262%post system -p /sbin/ldconfig
263%post test -p /sbin/ldconfig
264%post thread -p /sbin/ldconfig
265%post wave -p /sbin/ldconfig
266
267%postun date-time -p /sbin/ldconfig
268%postun filesystem -p /sbin/ldconfig
269%postun graph -p /sbin/ldconfig
270%postun iostreams -p /sbin/ldconfig
271%postun math -p /sbin/ldconfig
272%postun program-options -p /sbin/ldconfig
273%postun python -p /sbin/ldconfig
274%postun regex -p /sbin/ldconfig
275%postun serialization -p /sbin/ldconfig
276%postun signals -p /sbin/ldconfig
277%postun system -p /sbin/ldconfig
278%postun test -p /sbin/ldconfig
279%postun thread -p /sbin/ldconfig
280%postun wave -p /sbin/ldconfig
281
282%clean
283rm -rf $RPM_BUILD_ROOT
284
285%files
286%defattr(-,root,root)
287%doc LICENSE_1_0.txt
288
289%files devel
290%defattr(-,root,root)
291%{_includedir}/boost/
292%{_includedir}/boost-%{lnkver}/
293
294%files doc
295%doc index.htm index.html boost.css boost.png rst.css doc libs more
296
297%files date-time
298%{_libdir}/%{name}_date_time*.so*
299
300%files filesystem
301%{_libdir}/%{name}_filesystem*.so*
302
303%files graph
304%{_libdir}/%{name}_graph*.so*
305%{_libdir}/%{name}_mpi*.so*
306%{_libdir}/mpi*.so*
307
308%files iostreams
309%{_libdir}/%{name}_iostreams*.so*
310
311%files math
312%{_libdir}/%{name}_math_*.so*
313
314%files program-options
315%{_libdir}/%{name}_program_options*.so*
316
317%files python
318%{_libdir}/%{name}_python*.so*
319
320%files random
321%{_libdir}/%{name}_random*.so*
322
323%files regex
324%{_libdir}/%{name}_regex*.so*
325
326%files serialization
327%{_libdir}/%{name}_serialization*.so*
328%{_libdir}/%{name}_wserialization*.so*
329
330%files signals
331%{_libdir}/%{name}_signals*.so*
332
333%files system
334%{_libdir}/%{name}_system*.so*
335
336%files test
337%{_libdir}/%{name}_prg_exec_monitor*.so*
338%{_libdir}/%{name}_unit_test_framework*.so*
339
340%files thread
341%{_libdir}/%{name}_thread*.so*
342
343%files wave
344%{_libdir}/%{name}_wave*.so*
345
346%changelog
347* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 1.45.0-1
348- updated to boost_1_45_0
349- added random sub-package
350
351* Wed Apr 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.42.0-4
352- rebuilt again on ppc
353
354* Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.42.0-3
355- rebuilt with libicu-4.4
356
357* Mon Feb 08 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-2
358- added "-licui18n" to bjam
359- added BR: lam
360
361* Sun Feb 07 2010 Shu KONNO <owa@bg.wakwak.com> 1.42.0-1
362- updated to boost_1_42_0
363- rebuilt with new toolchain and python-2.6
364- added user-config.jam to make libboost_mpi
365- added BR: libaio-devel
366- added %%{post,postun} -p /sbin/ldconfig
367- dropt no use parameter EXPAT_INCLUDE and EXPAT_LIBPATH
368- dropt %{_libdir}/%{name}_test_exec_monitor-*.a in %%files %{name}-test
369- dropt %%{post,postun} devel section
370
371* Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.36.0-2vl5
372- rebuilt with libicu-4.0.1
373- changed Group to System Environment/Libraries (except devel package)
374
375* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.36.0-1vl5
376- new upstream release
377- add -math subpackage
378
379* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.35.0-2vl5
380- build with python-2.5
381- add libboost_XXXX.so symlinks
382
383* Thu May 8 2008 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.35.0-1vl5
384- upstream release
385- applied new versioning policy
386- add EXPAT_INCLUDE and EXPAT_LIBPATH to enable GraphML support
387- add new package libboost-system
388- Obsolete: *-devel packages
389
390* Sat Sep  8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.34.1-0vl3
391- rebuilt with libicu-3.6
392- changed doc Group to Applications/Documentation
393
394* Sat Aug 18 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.1-0vl2
395- upstream release
396
397* Thu Jun 14 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl3
398- add --libdir=%%{_libdir} to cope with x86_64 environment
399
400* Sun Jun 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.34.0-0vl2
401- upstream release
402- use Easy Build and Install process with ./configure
403- add BuildRequires: libicu-devel
404- remove %%{_libdir}/libboost_test_exec_monitor-*.so* from %%files -n libboost-test
405- add new packages: libboost-graph, libboost-graph-devel, libboost-wave
406- add files to doc package
407
408* Sun May 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.1-0vl2
409- rebuilt with new toolchain
410
411* Sat Feb 4 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.1-0vl1
412- upstream release
413
414* Mon Dec 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.33.0-0vl3
415- fixed typo in Groups:
416- devel packages also moved to Development/Libraries group
417
418* Mon Sep 19 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.33.0-0vl2
419- spec modified to avoid errors on non-ix86 archtecture
420  (previously the path linuxx86 was explicitly used)
421
422* Sun Sep 11 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl1
423- initial release for Vine Linux
424
425* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.3
426- link /usr/include/boost_%{lnkver}/boost to /usr/include/boost
427
428* Sat Sep 10 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.2
429- change package name from boost to libboost
430- separated into sub-packages
431
432* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.33.0-0vl0.1
433- upstream release
434- add BuildRequires: bzip2-devel zlib-devel
435
436* Fri Jun 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.7
437- added so.* file
438
439* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.6
440- moved %post, %postun script to -devel package
441
442* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.5
443- moved doc/html to -devel package
444- make a symbolic link on %{_includedir}/boost
445
446* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.4
447- fixed character code to euc-jp
448
449* Mon Apr 25 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.3
450- add %doc files
451
452* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.2
453- remove Requires
454- split -devel package
455
456* Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.32.0-0vl0.1
457- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.