source: projects/specs/branches/6/l/ldns/ldns-vl.spec @ 3247

Revision 3247, 9.5 KB checked in by iwaim, 13 years ago (diff)

ldns 1.6.9-1

Line 
1%{?!with_python:      %global with_python      1}
2%{?!enable_gost:      %global enable_gost      0}
3
4%if %{with_python}
5%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
6%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
7%endif
8
9%if %{enable_gost}
10%define subdir_conf_opt --disable-rpath --disable-static
11%else
12%define subdir_conf_opt --disable-rpath --disable-static --disable-gost
13%endif
14
15
16Summary: Lowlevel DNS(SEC) library with API
17Summary(ja): 低レベルな DNS(SEC) ライブラリと API
18Name: ldns
19Version: 1.6.9
20Release: 1%{?_dist_release}
21License: BSD
22Url: http://www.nlnetlabs.nl/%{name}/
23Source: http://www.nlnetlabs.nl/downloads/%{name}-%{version}.tar.gz
24Group: System Environment/Libraries
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
27BuildRequires: perl, libpcap-devel
28%if %{enable_gost}
29BuildRequires: openssl-devel >= 1.0.0
30%else
31BuildRequires: openssl-devel
32%endif
33
34Requires: libpcap, openssl
35
36Distribution: Vine Linux
37Vendor: Project Vine
38Packager: iwaim
39
40%if %{with_python}
41BuildRequires:  python-devel, swig
42%endif
43
44%description
45ldns is a library with the aim to simplify DNS programing in C. All
46lowlevel DNS/DNSSEC operations are supported. We also define a higher
47level API which allows a programmer to (for instance) create or sign
48packets.
49
50%package devel
51Summary: Development package that includes the ldns header files
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The devel package contains the ldns library and the include files
57
58%if %{with_python}
59%package python
60Summary: Python extensions for ldns
61Group: Applications/System
62Requires: %{name} = %{version}-%{release}
63
64%description python
65Python extensions for ldns
66%endif
67
68
69%prep
70%setup -q
71
72%build
73%configure --disable-rpath --disable-static \
74%if %{with_python}
75 --with-pyldns \
76%endif
77%if !%{enable_gost}
78 --disable-gost \
79%endif
80 --with-sha2
81
82(cd drill ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
83(cd examples ; %configure %subdir_conf_opt --with-ldns=%{buildroot}/lib/ )
84
85make %{?_smp_mflags}
86( cd drill ; make %{?_smp_mflags} )
87( cd examples ; make %{?_smp_mflags} )
88make %{?_smp_mflags} doc
89
90%install
91rm -rf %{buildroot}
92
93make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
94make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
95
96%if %{with_python}
97# remove execute perms from python files
98chmod a-x %{buildroot}%{python_sitelib}/*py
99%endif
100
101# don't package building script in doc
102rm doc/doxyparse.pl
103#remove doc stubs
104rm -rf doc/.svn
105#remove double set of man pages
106rm -rf doc/man
107
108# remove .la files
109rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python_sitelib}/*.la
110(cd drill ; make DESTDIR=%{buildroot} install)
111(cd examples; make DESTDIR=%{buildroot} install)
112
113%clean
114rm -rf %{buildroot}
115
116%files
117%defattr(-,root,root)
118%{_libdir}/libldns*so.*
119%{_bindir}/drill
120%{_bindir}/ldnsd
121#%{_bindir}/ldns-*
122%{_bindir}/ldns-chaos
123%{_bindir}/ldns-compare-zones
124%{_bindir}/ldns-[d-z]*
125%doc README LICENSE
126%{_mandir}/*/*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libldns*so
131%{_bindir}/ldns-config
132%dir %{_includedir}/ldns
133%{_includedir}/ldns/*.h
134%doc doc Changelog README
135
136%if %{with_python}
137%files python
138%defattr(-,root,root)
139%{python_sitelib}/*
140%endif
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%changelog
147* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
148- new upstream release
149
150* Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
151- new upstream release
152
153* Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
154- new upstream release
155- add enable_gost flag: default disable
156- defined subdir_conf_opt rpm macro
157
158* Thu Sep  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
159- new upstream release
160
161* Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
162- new upstream release
163- drop unnecessary installfix patch (Patch1): upstream merged
164- drop unnecessary rpathfix patch (Patch2): upstream merged
165
166* Thu Jun  3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
167- rebuild with libpcap 1.1.1 on VineSeed
168
169* Wed May  5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
170- initial build for Vine Linux: based Fedora 1.6.4-2.fc13
171
172* Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
173- Fix missing _ldns.so causing ldns-python to not work
174- Patch for installing ldns-python files
175- Patch for rpath in ldns-python
176- Don't install .a file for ldns-python
177
178* Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
179- Upgraded to 1.6.4.
180- Added ldns-python sub package
181
182* Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
183- Upgraded to 1.6.3, which has minor bugfixes
184
185* Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
186- Upgraded to 1.6.2. This fixes various bugs.
187  (upstream released mostly to default with sha2 for the imminent
188   signed root, but we already enabled that in our builds)
189
190* Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
191- rebuilt with new openssl
192
193* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
194- Added openssl dependancy back in, since we get more functionality
195 when using openssl. Especially in 'drill'.
196
197* Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
198- Updated to 1.6.1
199
200* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203* Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
204- Fixed the ssl patch so it can now compile --without-ssl
205
206* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
207- Added patch to compile with --without-ssl
208- Removed openssl dependancies
209- Recompiled with --without-ssl
210
211* Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
212- Updated to 1.6.0
213- (did not yet compile with --without-ssl due to compile failures)
214
215* Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
216- Updated to 1.6.0
217- Compile without openssl
218
219* Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
220- Memory management bug when generating a sha256 key, see:
221  https://bugzilla.redhat.com/show_bug.cgi?id=493953
222
223* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
225
226* Mon Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
227- Updated to new version, 1.5.0 had a bug preventing
228  zone signing.
229
230* Mon Feb  9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
231- Updated to new version
232
233* Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
234- fixed configure flags
235
236* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
237- rebuild with new openssl
238
239* Fri Nov  7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
240- Updated to 1.4.0
241
242* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
243- enable SHA2 functionality
244
245* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
246- re-tag (don't do builds while renaming local repo dirs)
247
248* Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
249- Updated to latest release
250
251* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
252- Autorebuild for GCC 4.3
253
254* Wed Dec  5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
255- Rebuild for new libcrypto
256
257* Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
258- Upgraded to 1.2.2. Removed no longer needed race workaround
259
260* Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
261- Try to fix racing ln -s statements in parallel builds
262
263* Fri Nov  9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
264- Added patch for ldns-read-zone that does not put @. in RRDATA
265
266* Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
267- Use install -p to work around multilib conflicts for .h files
268
269* Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
270- Updated to 1.2.1
271- Removed patches that got moved into upstream
272
273* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
274- Patch for ldns-key2ds to write to stdout
275- Again remove extra set of man pages from doc
276- own /usr/include/ldns (bug 233858)
277
278* Wed Aug  8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
279- Added sha256 DS record patch to ldns-key2ds
280- Minor tweaks for proper doc/man page installation.
281- Workaround for parallel builds
282
283* Mon Aug  6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
284- Own the /usr/include/ldns directory (bug #233858)
285- Removed obsoleted patch
286- Remove files form previous libtool run accidentally packages by upstream
287
288* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
289- Commented out 1.1.0 make targets, put make 1.0.1 targets.
290
291* Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
292- Fixed changelog typo in date
293- Rebuild requested for PT_GNU_HASH support from gcc
294- Did not upgrade to 1.1.0 due to compile issues on x86_64
295
296* Fri Jan  6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
297- Upgraded to 1.0.1. Removed temporary clean hack from spec file.
298
299* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
300- Cannot use make clean because there are no Makefiles. Use hardcoded rm.
301
302* Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
303- Patched 'make clean' target to get rid of object files shipped with 1.0.0
304
305* Sun Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
306- added a make clean for 2.3.3 since .o files were left behind upstream,
307  causing failure on ppc platform
308
309* Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
310- minor cleanups
311
312* Wed Oct  5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
313- reworked for svn version
314
315* Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
316- Initial version
Note: See TracBrowser for help on using the repository browser.