source: projects/specs/branches/6/k/kde-partitionmanager/kde-partitionmanager-vl.spec @ 2775

Revision 2775, 3.9 KB checked in by inagaki, 13 years ago (diff)

updated: choqok, k3b, kaffeine, kdevelop, kdevplatform,

konversation, kde-partitionmanager, qjson, self-build-k3b-extra

NEW: skrooge

Line 
1Name:           kde-partitionmanager
2Summary:        KDE Partition Manager
3Summary(ja):    KDE パーティションマネージャ
4Version:        1.0.3
5Release:        1%{?_dist_release}
6
7Group:          Applications/Administration
8License:        GPLv2+
9URL:            http://partitionman.sourceforge.net/
10
11Source0:        http://downloads.sourceforge.net/project/partitionman/partitionmanager/1.0.3/partitionmanager-%{version}.tar.bz2
12
13## upstreamable patches
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  kdelibs4-devel
17BuildRequires:  parted-devel
18BuildRequires:  e2fsprogs-devel
19%if %{?_dist_release} !="vl5"
20BuildRequires:  libuuid-devel
21BuildRequires:  libblkid-devel
22%endif
23BuildRequires:  pkgconfig
24BuildRequires:  gettext
25BuildRequires:  cmake
26Requires:       parted
27Requires:       e2fsprogs
28
29%global kde4_version %((kde4-config --version 2>/dev/null || echo "KDE 4.4.5") | grep ^KDE | cut -d' ' -f2)
30
31#{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
32
33%description
34KDE Partition Manager is a utility program to help you manage the disk devices,
35partitions and file systems on your computer. It allows you to easily create,
36copy, move, delete, resize without losing data, backup and restore partitions.
37 
38KDE Partition Manager supports a large number of file systems,
39including ext2/3/4, reiserfs, NTFS, FAT16/32, jfs, xfs and more.
40 
41It makes use of external programs to get its job done, so you might have to
42install additional software (preferably packages from your distribution)
43to make use of all features and get full support for all file systems.
44
45%prep
46%setup -q -n partitionmanager-%{version}
47## Due to the name change
48mv src/partitionmanager.desktop src/kde-partitionmanager.desktop
49mv src/kcm/kcm_partitionmanager.desktop src/kcm/kcm_kde-partitionmanager.desktop
50sed -i 's,partitionmanager.desktop,kde-partitionmanager.desktop,' src/CMakeLists.txt
51
52%build
53mkdir -p %{_target_platform}
54pushd %{_target_platform}
55unset QTDIR || : ; . /etc/profile.d/qt4.sh
56%{cmake} \
57    -DCMAKE_BUILD_TYPE=release \
58    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
59    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
60    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
61    ..
62popd
63
64make %{?_smp_mflags} -C %{_target_platform}
65
66%install
67rm -rf %{buildroot}
68make install/fast -C %{_target_platform} DESTDIR=%{buildroot}
69%find_lang partitionmanager --with-kde
70
71%check
72desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/%{name}.desktop
73
74%clean
75rm -rf %{buildroot}
76
77%post
78touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
79
80%posttrans
81gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
82
83%postun
84if [ $1 -eq 0 ] ; then
85touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
86gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
87fi
88
89%files -f partitionmanager.lang
90%defattr(-,root,root,-)
91%doc README COPYING CHANGES
92%{_bindir}/partitionmanager*
93%{_libdir}/*.so
94%{_datadir}/applications/kde4/%{name}.desktop
95%{_datadir}/icons/hicolor/*/*/*.png
96%{_datadir}/kde4/apps/partitionmanager
97## %{_kde4_datadir}/kde4/services/kcm_kde-partitionmanager.desktop
98
99
100%changelog
101* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-1
102- new upstream release
103
104* Fri Jul 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-3
105- disabled BR: libuuid-devel, libblkid-devel on Vine Linux 5
106
107* Mon Jul 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-2
108- Initial build for Vine Linux
109
110* Tue May 18 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.2-1
111- bugfix release
112
113* Wed Mar 31 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.2
114- rebuild for new parted
115
116* Sun Feb 14 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1%{?dist}.1
117- DSO fix for rawhide
118
119* Mon Jan 25 2010 Thomas Janssen <thomasj@fedoraproject.org> 1.0.1-1
120- New upstream source
121
122* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-2
123- Moved desktop-file-validate to %%install
124- Removed superfluous BR qt4-devel
125
126* Wed Nov 18 2009 Thomas Janssen <thomasj@fedoraproject.org> 1.0.0-1
127- Initial Fedora release
128
Note: See TracBrowser for help on using the repository browser.