source: projects/specs/branches/6/j/jasper/jasper-vl.spec @ 3473

Revision 3473, 5.1 KB checked in by inagaki, 13 years ago (diff)

updated: autoconf213, jasper

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:        jasper
4Summary:     implementation of the JPEG-2000 standard, Part 1
5Version:     1.900.1
6Release:     8%{?_dist_release}
7
8Group:       Applications/Graphics
9License:     Modified BSD (see LICENSE)
10URL:         http://www.ece.uvic.ca/~mdadams/jasper/
11
12Source:      %{name}-%{version}.zip
13# Security fixes
14Patch100:    jasper-1.900.1_CVE-2007-2721.patch
15
16BuildRoot:   %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libjpeg-devel unzip
18BuildRequires: freeglut-devel
19Requires:    %{name}-libs = %{version}-%{release}
20
21Vendor:       Project Vine
22Distribution: Vine Linux
23
24%description
25JasPer is a collection of software (i.e., a library and application
26programs) for the coding and manipulation of images.  This software
27can handle image data in a variety of formats.  One such format
28supported by JasPer is the JPEG-2000 format defined in ISO/IEC 15444-1.
29
30%package devel
31Summary:     Include Files and Documentation for jasper
32Group:       Development/Libraries
33Requires:    %{name}-libs = %{version}-%{release}
34Requires:    libjpeg-devel
35
36%description devel
37This package contains libjasper, a library implementing the JPEG-2000
38image compression standard Part 1.
39
40%package libs
41Summary: Runtime libraries for %{name}
42Group:   System Environment/Libraries
43
44%description libs
45This package contains runtime libraries for JasPer.
46
47# compat32
48%package -n compat32-%{name}-devel
49Summary:     Include Files and Documentation for jasper
50Group:       Development/Libraries
51Requires:    %{name}-libs = %{version}-%{release}
52Requires:    compat32-libjpeg-devel
53
54%description -n compat32-%{name}-devel
55This package contains libjasper, a library implementing the JPEG-2000
56image compression standard Part 1.
57
58%package -n compat32-%{name}-libs
59Summary: Runtime libraries for %{name}
60Group:   System Environment/Libraries
61
62%description -n compat32-%{name}-libs
63This package contains runtime libraries for JasPer.
64
65
66%prep
67%setup -T -c %{name}-%{version}
68cd ..
69unzip %{SOURCE0}
70cd %{name}-%{version}
71
72# security fixes
73%patch100 -p1 -b .CVE-2007-2721
74
75%build
76./configure --prefix=%{_prefix} --libdir=%{_libdir} --mandir=%{_mandir} \
77            --enable-shared --disable-static
78make
79
80%install
81[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
82make install DESTDIR=$RPM_BUILD_ROOT
83
84# remove .la
85rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
86
87%clean
88[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
89
90%post libs -p /sbin/ldconfig
91
92%postun libs -p /sbin/ldconfig
93
94%post -n compat32-%{name}-libs -p /sbin/ldconfig
95
96%postun -n compat32-%{name}-libs -p /sbin/ldconfig
97
98%files
99%defattr(-,root,root)
100%doc COPYRIGHT ChangeLog INSTALL LICENSE NEWS README doc
101%{_bindir}/*
102%{_mandir}/man1/*
103
104%files libs
105%defattr(-,root,root)
106%{_libdir}/libjasper*.so.*
107
108%files devel
109%defattr(-,root,root)
110%{_includedir}/jasper
111%{_libdir}/libjasper*.so
112
113# compat32
114%if %{build_compat32}
115%files -n compat32-%{name}-libs
116%defattr(-,root,root)
117%{_libdir}/libjasper*.so.*
118
119%files -n compat32-%{name}-devel
120%defattr(-,root,root)
121%{_libdir}/libjasper*.so
122%endif
123
124%changelog
125* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-8
126- rebuilt with current VineSeed
127
128* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.900.1-7
129- added compat32 subpackage for x86_64 arch support.
130
131* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.900.1-6
132- splited out runtime library to sub package
133- enable opengl again, add BuildRequires: freeglut-devel
134
135* Wed Jun 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-5
136- remove .la
137- add --disable-static to configure option
138
139* Sun Jun 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl4
140- added Patch0 from VinePlus/4.0
141  * Thu Jun 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.900.1-0vl2.1
142  - add patch100 for fix CVE-2007-2721
143  - add Vendor/Distributin Tag
144
145* Fri May 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.900.1-0vl3
146- remove BuildPrereq: freeglut-devel and Requires freeglut
147- add --disable-opengl to configure option
148
149* Fri Mar 16 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.900.1-0vl2
150- add BuildPreReq: unzip (used in the %%pre section)
151
152* Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.1-0vl1
153- new upstream release
154
155* Tue Jan 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.900.0-0vl1
156- new upstream release
157- changed Group to System Environment/Libraries
158- added --mandir=%{_mandir}
159- added %post and %postun section
160
161* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.701.0-0vl3
162- added --libdir=%{_libdir} configure option
163
164* Tue Sep  5 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.701.0-0vl2
165- build with freeglut
166- change BuildPrereq and Requires
167
168* Tue Dec 14 2004 Satoshi MACHINO <machino@vinelinux.org> 1.701.0-0vl1
169- new upstream version (jasper-1.701.0)
170
171* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl2
172- rebuild for VineSeedPlus
173
174* Sat Nov 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.700.5-0vl1
175- source upgrade
176- change spec to build for VineLinux
177
178* Fri Oct 25 2002 Alexander D. Karaivanov <adk@medical-insight.com>
179- spec file created
Note: See TracBrowser for help on using the repository browser.