source: projects/specs/branches/6/g/graphviz/graphviz-vl.spec @ 2021

Revision 2021, 7.8 KB checked in by shaolin, 14 years ago (diff)
  • graphviz: add "dont_regard_tiger_as_the_only_ppc" patch :-P
Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.26.3
4Release:        2%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10Patch10:        %{name}-%{version}_dont_regard_tiger_as_the_only_ppc.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  bison
15BuildRequires:  cairo-devel
16BuildRequires:  expat-devel
17BuildRequires:  flex
18BuildRequires:  fontconfig-devel
19BuildRequires:  freetype2-devel
20BuildRequires:  gd-devel
21BuildRequires:  gtk2-devel
22BuildRequires:  guile-devel
23BuildRequires:  libjpeg-turbo-devel
24BuildRequires:  libpng-devel
25BuildRequires:  libSM-devel
26BuildRequires:  libtool-ltdl-devel >= 2.2.6a
27BuildRequires:  libXaw-devel
28BuildRequires:  libXext-devel
29BuildRequires:  m4
30BuildRequires:  perl
31BuildRequires:  python-devel
32BuildRequires:  ruby-devel
33BuildRequires:  swig
34BuildRequires:  tcl >= 8.4
35BuildRequires:  tk >= 8.4
36BuildRequires:  zlib-devel
37Requires:       urw-fonts
38
39# only for this release
40BuildConflicts: graphviz-devel
41
42%description
43A collection of tools and tcl packages for the manipulation and layout
44of graphs (as in nodes and edges, not as in barcharts).
45
46%package devel
47Group:          Development/Libraries
48Summary:        Development tools for version %{version} of %{name}
49Requires:       %{name} = %{version}
50
51%description devel
52The %{name}-devel package contains the header files
53and man3 pages necessary for developing programs
54using version %{version} of the %{name} libraries.
55
56%package doc
57Summary: PDF and HTML documents for graphviz
58Group:   Applications/Documentation
59
60%description doc
61Provides some additional PDF and HTML documentation for graphviz.
62
63%package guile
64Group:          Applications/Graphics
65Summary:        Guile extension for graphviz
66Requires:       %{name} = %{version}-%{release}, guile
67
68%description guile
69Guile extension for graphviz.
70
71%package perl
72Group:    Applications/Graphics
73Summary:  Perl extension for graphviz
74Requires: %{name} = %{version}-%{release}
75Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
76
77%description perl
78Perl extension for graphviz.
79
80%package python
81Group:    Applications/Graphics
82Summary:  Python extension for graphviz
83Requires: %{name} = %{version}-%{release}
84Requires: python
85
86%description python
87Python extension for graphviz.
88
89%package ruby
90Group:    Applications/Multimedia
91Summary:  Ruby extension for graphviz
92Requires: %{name} = %{version}-%{release}
93Requires: ruby
94
95%description ruby
96Ruby extension for graphviz.
97
98%package tcl
99Group:    Applications/Graphics
100Summary:  Tcl extension & tools for graphviz
101Requires: tcl >= 8.4, tk >= 8.4
102Requires: %{name} = %{version}
103
104%description tcl
105Various tcl packages (extensions) for the graphviz tools.
106
107
108%prep
109%setup -q
110%patch10 -p1
111
112# using archdir instead of sitearchdir for Vine
113sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
114
115autoreconf -f -i
116
117%build
118# XXX ix86 only used to have -ffast-math, let's use everywhere
119%{expand: %%define optflags %{optflags} -ffast-math}
120
121%configure \
122    --with-x \
123    --disable-static \
124    --with-mylibgd \
125    --with-ipsepcola \
126    --with-pangocairo \
127    --with-gdk-pixbuf \
128    --without-mylibgd \
129    --without-ming \
130    --disable-sharp \
131    --enable-guile \
132    --enable-io \
133    --disable-java \
134    --disable-lua \
135    --disable-ocaml \
136    --enable-perl \
137    --disable-php \
138    --enable-python \
139    --disable-r \
140    --enable-ruby \
141    --enable-tcl
142
143make %{?_smp_mflags}
144
145%install
146rm -rf $RPM_BUILD_ROOT __doc
147make DESTDIR=$RPM_BUILD_ROOT \
148    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
149    pkgconfigdir=%{_libdir}/pkgconfig \
150    install
151
152find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
153chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
154cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
155rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159
160# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
161%post
162/sbin/ldconfig
163%{_bindir}/dot -c
164
165# if there is no dot after everything else is done, then remove config
166%postun
167if [ $1 -eq 0 ]; then
168    rm -f %{_libdir}/graphviz/config || :
169fi
170/sbin/ldconfig
171
172
173%files
174%defattr(-,root,root)
175%doc AUTHORS COPYING ChangeLog NEWS README
176%{_bindir}/*
177%dir %{_datadir}/%{name}
178%{_datadir}/%{name}/lefty
179%{_mandir}/man1/*
180%{_mandir}/man7/*
181%dir %{_libdir}/%{name}
182%{_libdir}/*.so.*
183%{_libdir}/%{name}/*.so.*
184%exclude %{_libdir}/graphviz/*/*
185
186%files devel
187%defattr(-,root,root)
188%{_includedir}/%{name}
189%{_libdir}/*.so
190%{_libdir}/%{name}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_datadir}/%{name}/graphs
193%{_mandir}/man3/*.3.gz
194
195%files doc
196%defattr(-,root,root,-)
197%doc __doc/*
198
199%files guile
200%defattr(-,root,root,-)
201%{_libdir}/graphviz/guile/
202%{_mandir}/man3/gv.3guile*
203
204%files perl
205%defattr(-,root,root,-)
206%{_libdir}/graphviz/perl/
207%{perl_vendorarch}/*
208%{_mandir}/man3/gv.3perl*
209
210%files python
211%defattr(-,root,root,-)
212%{_libdir}/graphviz/python/
213%{_libdir}/python*/*
214%{_mandir}/man3/gv.3python*
215
216%files ruby
217%defattr(-,root,root,-)
218%{_libdir}/graphviz/ruby/
219%{rarchdir}/*
220%{_mandir}/man3/gv.3ruby*
221
222%files tcl
223%defattr(-,root,root)
224%{_libdir}/%{name}/tcl/*
225%{_libdir}/tcl*/*
226%{_datadir}/%{name}/demo
227# hack to include gv.3tcl only if available
228#  always includes tcldot.3tcl, gdtclft.3tcl
229%{_mandir}/man3/*.3tcl*
230%{_mandir}/man3/tkspline.3tk*
231
232
233%changelog
234* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
235- add Patch10 to avoid build failure on ppc
236
237* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
238- new upstream release
239- built with rpm-4.8.1
240- split doc, guile, perl, python, ruby subpackage
241
242* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
243- rebuild with libtool-2.2.6a
244
245* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
246- new upstream release
247
248* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
249- rebuild with libXaw.so.7 (libXaw-1.0.5)
250
251* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
252- new upstream release
253
254* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
255- new upstream release
256- build with expat-2.0.1
257- add man7
258
259* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
260- rebuild with tcl/tk-8.4.16
261
262* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
263- new upstream release
264- add BuildPrereq: swig
265- delete BuildPrereq: gd-progs gd-devel
266- add --with-mylibgd and --disable-FEATURE to configure option
267- update %%files
268
269* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
270- added BuildPrereq: ruby-devel
271
272* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
273- new upstream release
274- add BuildPrereq: libtool-ltdl-devel
275- move pkgconfig files to %%{_libdir}/pkgconfig
276- add --disable-rpath --disable-static to configure option
277- add %%post to every package
278
279* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
280- new upstream release
281- BuildPrereq: tcl >= 8.4, tk >= 8.4
282- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
283- update %%files
284- remove lines about Vine2.6
285- change License to CPL
286
287* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
288- source upgrade
289- remove patch0 and commented lines
290
291* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
292- build for VineSeed
293
294* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
295- source upgrade
296- change spec to build both VineSeed and Vine2.5/2.6
297- add BuildPrereq: expat-devel and Requires: libexpat
298- add patch0 to build against freetype2-2.1.7
299- stop using autogen.sh script
300- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
301- add graphviz-tcl package (VineSeed)
302
303* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
304- rebuild for new Vine
305
306* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
307- import from offical site (src.rpm)
308
Note: See TracBrowser for help on using the repository browser.