source: projects/specs/branches/6/g/graphviz/graphviz-vl.spec @ 8209

Revision 8209, 8.4 KB checked in by iwamoto, 10 years ago (diff)

graphviz: security fixes

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.26.3
4Release:        4%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10Patch10:        %{name}-%{version}_dont_regard_tiger_as_the_only_ppc.patch
11# security
12Patch100:       CVE-2014-0978.patch
13Patch110:       CVE-2014-1236.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  bison
18BuildRequires:  cairo-devel
19BuildRequires:  expat-devel
20BuildRequires:  flex
21BuildRequires:  fontconfig-devel
22BuildRequires:  freetype2-devel
23BuildRequires:  gd-devel
24BuildRequires:  gtk2-devel
25BuildRequires:  guile-devel
26BuildRequires:  libjpeg-turbo-devel
27BuildRequires:  libpng-devel
28BuildRequires:  libSM-devel
29BuildRequires:  libtool-ltdl-devel >= 2.2.6a
30BuildRequires:  libXaw-devel
31BuildRequires:  libXext-devel
32BuildRequires:  m4
33BuildRequires:  perl
34BuildRequires:  python-devel
35BuildRequires:  ruby
36BuildRequires:  ruby-devel
37BuildRequires:  swig
38BuildRequires:  tcl >= 8.4
39BuildRequires:  tk >= 8.4
40BuildRequires:  zlib-devel
41Requires:       urw-fonts
42
43# only for this release
44BuildConflicts: graphviz-devel
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48
49%description
50A collection of tools and tcl packages for the manipulation and layout
51of graphs (as in nodes and edges, not as in barcharts).
52
53%package devel
54Group:          Development/Libraries
55Summary:        Development tools for version %{version} of %{name}
56Requires:       %{name} = %{version}
57
58%description devel
59The %{name}-devel package contains the header files
60and man3 pages necessary for developing programs
61using version %{version} of the %{name} libraries.
62
63%package doc
64Summary: PDF and HTML documents for graphviz
65Group:   Applications/Documentation
66
67%description doc
68Provides some additional PDF and HTML documentation for graphviz.
69
70%package guile
71Group:          Applications/Graphics
72Summary:        Guile extension for graphviz
73Requires:       %{name} = %{version}-%{release}, guile
74
75%description guile
76Guile extension for graphviz.
77
78%package perl
79Group:    Applications/Graphics
80Summary:  Perl extension for graphviz
81Requires: %{name} = %{version}-%{release}
82Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
83
84%description perl
85Perl extension for graphviz.
86
87%package python
88Group:    Applications/Graphics
89Summary:  Python extension for graphviz
90Requires: %{name} = %{version}-%{release}
91Requires: python
92
93%description python
94Python extension for graphviz.
95
96%package ruby
97Group:    Applications/Multimedia
98Summary:  Ruby extension for graphviz
99Requires: %{name} = %{version}-%{release}
100Requires: ruby
101
102%description ruby
103Ruby extension for graphviz.
104
105%package tcl
106Group:    Applications/Graphics
107Summary:  Tcl extension & tools for graphviz
108Requires: tcl >= 8.4, tk >= 8.4
109Requires: %{name} = %{version}
110
111%description tcl
112Various tcl packages (extensions) for the graphviz tools.
113
114
115%prep
116%setup -q
117%patch10 -p1
118# security
119%patch100 -p1 -b .CVE-2014-0978
120%patch110 -p1 -b .CVE-2014-1236
121
122# using archdir instead of sitearchdir for Vine
123sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
124
125autoreconf -f -i
126
127%build
128# XXX ix86 only used to have -ffast-math, let's use everywhere
129%{expand: %%define optflags %{optflags} -ffast-math}
130
131%configure \
132    --with-x \
133    --disable-static \
134    --with-mylibgd \
135    --with-ipsepcola \
136    --with-pangocairo \
137    --with-gdk-pixbuf \
138    --without-mylibgd \
139    --without-ming \
140    --disable-sharp \
141    --enable-guile \
142    --enable-io \
143    --disable-java \
144    --disable-lua \
145    --disable-ocaml \
146    --enable-perl \
147    --disable-php \
148    --enable-python \
149    --disable-r \
150    --enable-ruby \
151    --enable-tcl
152
153make %{?_smp_mflags}
154
155%install
156rm -rf $RPM_BUILD_ROOT __doc
157make DESTDIR=$RPM_BUILD_ROOT \
158    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
159    pkgconfigdir=%{_libdir}/pkgconfig \
160    install
161
162find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
163chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
164cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
165rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
166
167%clean
168rm -rf $RPM_BUILD_ROOT
169
170# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
171%post
172/sbin/ldconfig
173%{_bindir}/dot -c
174
175# if there is no dot after everything else is done, then remove config
176%postun
177if [ $1 -eq 0 ]; then
178    rm -f %{_libdir}/graphviz/config || :
179fi
180/sbin/ldconfig
181
182
183%files
184%defattr(-,root,root)
185%doc AUTHORS COPYING ChangeLog NEWS README
186%{_bindir}/*
187%dir %{_datadir}/%{name}
188%{_datadir}/%{name}/lefty
189%{_mandir}/man1/*
190%{_mandir}/man7/*
191%dir %{_libdir}/%{name}
192%{_libdir}/*.so.*
193%{_libdir}/%{name}/*.so.*
194%exclude %{_libdir}/graphviz/*/*
195
196%files devel
197%defattr(-,root,root)
198%{_includedir}/%{name}
199%{_libdir}/*.so
200%{_libdir}/%{name}/*.so
201%{_libdir}/pkgconfig/*.pc
202%{_datadir}/%{name}/graphs
203%{_mandir}/man3/*.3.gz
204
205%files doc
206%defattr(-,root,root,-)
207%doc __doc/*
208
209%files guile
210%defattr(-,root,root,-)
211%{_libdir}/graphviz/guile/
212%{_mandir}/man3/gv.3guile*
213
214%files perl
215%defattr(-,root,root,-)
216%{_libdir}/graphviz/perl/
217%{perl_vendorarch}/*
218%{_mandir}/man3/gv.3perl*
219
220%files python
221%defattr(-,root,root,-)
222%{_libdir}/graphviz/python/
223%{_libdir}/python*/*
224%{_mandir}/man3/gv.3python*
225
226%files ruby
227%defattr(-,root,root,-)
228%{_libdir}/graphviz/ruby/
229%{rarchdir}/*
230%{_mandir}/man3/gv.3ruby*
231
232%files tcl
233%defattr(-,root,root)
234%{_libdir}/%{name}/tcl/*
235%{_libdir}/tcl*/*
236%{_datadir}/%{name}/demo
237# hack to include gv.3tcl only if available
238#  always includes tcldot.3tcl, gdtclft.3tcl
239%{_mandir}/man3/*.3tcl*
240%{_mandir}/man3/tkspline.3tk*
241
242
243%changelog
244* Thu Jan 16 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.26.3-4
245- add patch100 for fix CVE-2014-0978
246- add patch110 for fix CVE-2014-1236
247  These patches are from debian, Thanks to debian team
248- add Vendor/Distri tags
249
250* Sat Jul 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.26.3-3
251- rebuild with perl-5.12
252- add BuildRequires: ruby
253
254* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
255- add Patch10 to avoid build failure on ppc
256
257* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
258- new upstream release
259- built with rpm-4.8.1
260- split doc, guile, perl, python, ruby subpackage
261
262* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
263- rebuild with libtool-2.2.6a
264
265* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
266- new upstream release
267
268* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
269- rebuild with libXaw.so.7 (libXaw-1.0.5)
270
271* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
272- new upstream release
273
274* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
275- new upstream release
276- build with expat-2.0.1
277- add man7
278
279* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
280- rebuild with tcl/tk-8.4.16
281
282* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
283- new upstream release
284- add BuildPrereq: swig
285- delete BuildPrereq: gd-progs gd-devel
286- add --with-mylibgd and --disable-FEATURE to configure option
287- update %%files
288
289* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
290- added BuildPrereq: ruby-devel
291
292* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
293- new upstream release
294- add BuildPrereq: libtool-ltdl-devel
295- move pkgconfig files to %%{_libdir}/pkgconfig
296- add --disable-rpath --disable-static to configure option
297- add %%post to every package
298
299* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
300- new upstream release
301- BuildPrereq: tcl >= 8.4, tk >= 8.4
302- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
303- update %%files
304- remove lines about Vine2.6
305- change License to CPL
306
307* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
308- source upgrade
309- remove patch0 and commented lines
310
311* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
312- build for VineSeed
313
314* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
315- source upgrade
316- change spec to build both VineSeed and Vine2.5/2.6
317- add BuildPrereq: expat-devel and Requires: libexpat
318- add patch0 to build against freetype2-2.1.7
319- stop using autogen.sh script
320- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
321- add graphviz-tcl package (VineSeed)
322
323* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
324- rebuild for new Vine
325
326* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
327- import from offical site (src.rpm)
328
Note: See TracBrowser for help on using the repository browser.