source: projects/specs/branches/6/g/graphviz/graphviz-vl.spec @ 6646

Revision 6646, 8.0 KB checked in by Takemikaduchi, 12 years ago (diff)

fix broken package

Line 
1Name:           graphviz
2Summary:        Graph Visualization Tools
3Version:        2.26.3
4Release:        3%{?_dist_release}
5Group:          Applications/Graphics
6License:        CPL
7URL:            http://www.graphviz.org/
8
9Source:         http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
10Patch10:        %{name}-%{version}_dont_regard_tiger_as_the_only_ppc.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  bison
15BuildRequires:  cairo-devel
16BuildRequires:  expat-devel
17BuildRequires:  flex
18BuildRequires:  fontconfig-devel
19BuildRequires:  freetype2-devel
20BuildRequires:  gd-devel
21BuildRequires:  gtk2-devel
22BuildRequires:  guile-devel
23BuildRequires:  libjpeg-turbo-devel
24BuildRequires:  libpng-devel
25BuildRequires:  libSM-devel
26BuildRequires:  libtool-ltdl-devel >= 2.2.6a
27BuildRequires:  libXaw-devel
28BuildRequires:  libXext-devel
29BuildRequires:  m4
30BuildRequires:  perl
31BuildRequires:  python-devel
32BuildRequires:  ruby
33BuildRequires:  ruby-devel
34BuildRequires:  swig
35BuildRequires:  tcl >= 8.4
36BuildRequires:  tk >= 8.4
37BuildRequires:  zlib-devel
38Requires:       urw-fonts
39
40# only for this release
41BuildConflicts: graphviz-devel
42
43%description
44A collection of tools and tcl packages for the manipulation and layout
45of graphs (as in nodes and edges, not as in barcharts).
46
47%package devel
48Group:          Development/Libraries
49Summary:        Development tools for version %{version} of %{name}
50Requires:       %{name} = %{version}
51
52%description devel
53The %{name}-devel package contains the header files
54and man3 pages necessary for developing programs
55using version %{version} of the %{name} libraries.
56
57%package doc
58Summary: PDF and HTML documents for graphviz
59Group:   Applications/Documentation
60
61%description doc
62Provides some additional PDF and HTML documentation for graphviz.
63
64%package guile
65Group:          Applications/Graphics
66Summary:        Guile extension for graphviz
67Requires:       %{name} = %{version}-%{release}, guile
68
69%description guile
70Guile extension for graphviz.
71
72%package perl
73Group:    Applications/Graphics
74Summary:  Perl extension for graphviz
75Requires: %{name} = %{version}-%{release}
76Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
77
78%description perl
79Perl extension for graphviz.
80
81%package python
82Group:    Applications/Graphics
83Summary:  Python extension for graphviz
84Requires: %{name} = %{version}-%{release}
85Requires: python
86
87%description python
88Python extension for graphviz.
89
90%package ruby
91Group:    Applications/Multimedia
92Summary:  Ruby extension for graphviz
93Requires: %{name} = %{version}-%{release}
94Requires: ruby
95
96%description ruby
97Ruby extension for graphviz.
98
99%package tcl
100Group:    Applications/Graphics
101Summary:  Tcl extension & tools for graphviz
102Requires: tcl >= 8.4, tk >= 8.4
103Requires: %{name} = %{version}
104
105%description tcl
106Various tcl packages (extensions) for the graphviz tools.
107
108
109%prep
110%setup -q
111%patch10 -p1
112
113# using archdir instead of sitearchdir for Vine
114sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
115
116autoreconf -f -i
117
118%build
119# XXX ix86 only used to have -ffast-math, let's use everywhere
120%{expand: %%define optflags %{optflags} -ffast-math}
121
122%configure \
123    --with-x \
124    --disable-static \
125    --with-mylibgd \
126    --with-ipsepcola \
127    --with-pangocairo \
128    --with-gdk-pixbuf \
129    --without-mylibgd \
130    --without-ming \
131    --disable-sharp \
132    --enable-guile \
133    --enable-io \
134    --disable-java \
135    --disable-lua \
136    --disable-ocaml \
137    --enable-perl \
138    --disable-php \
139    --enable-python \
140    --disable-r \
141    --enable-ruby \
142    --enable-tcl
143
144make %{?_smp_mflags}
145
146%install
147rm -rf $RPM_BUILD_ROOT __doc
148make DESTDIR=$RPM_BUILD_ROOT \
149    docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
150    pkgconfigdir=%{_libdir}/pkgconfig \
151    install
152
153find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
154chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
155cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
156rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
157
158%clean
159rm -rf $RPM_BUILD_ROOT
160
161# run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
162%post
163/sbin/ldconfig
164%{_bindir}/dot -c
165
166# if there is no dot after everything else is done, then remove config
167%postun
168if [ $1 -eq 0 ]; then
169    rm -f %{_libdir}/graphviz/config || :
170fi
171/sbin/ldconfig
172
173
174%files
175%defattr(-,root,root)
176%doc AUTHORS COPYING ChangeLog NEWS README
177%{_bindir}/*
178%dir %{_datadir}/%{name}
179%{_datadir}/%{name}/lefty
180%{_mandir}/man1/*
181%{_mandir}/man7/*
182%dir %{_libdir}/%{name}
183%{_libdir}/*.so.*
184%{_libdir}/%{name}/*.so.*
185%exclude %{_libdir}/graphviz/*/*
186
187%files devel
188%defattr(-,root,root)
189%{_includedir}/%{name}
190%{_libdir}/*.so
191%{_libdir}/%{name}/*.so
192%{_libdir}/pkgconfig/*.pc
193%{_datadir}/%{name}/graphs
194%{_mandir}/man3/*.3.gz
195
196%files doc
197%defattr(-,root,root,-)
198%doc __doc/*
199
200%files guile
201%defattr(-,root,root,-)
202%{_libdir}/graphviz/guile/
203%{_mandir}/man3/gv.3guile*
204
205%files perl
206%defattr(-,root,root,-)
207%{_libdir}/graphviz/perl/
208%{perl_vendorarch}/*
209%{_mandir}/man3/gv.3perl*
210
211%files python
212%defattr(-,root,root,-)
213%{_libdir}/graphviz/python/
214%{_libdir}/python*/*
215%{_mandir}/man3/gv.3python*
216
217%files ruby
218%defattr(-,root,root,-)
219%{_libdir}/graphviz/ruby/
220%{rarchdir}/*
221%{_mandir}/man3/gv.3ruby*
222
223%files tcl
224%defattr(-,root,root)
225%{_libdir}/%{name}/tcl/*
226%{_libdir}/tcl*/*
227%{_datadir}/%{name}/demo
228# hack to include gv.3tcl only if available
229#  always includes tcldot.3tcl, gdtclft.3tcl
230%{_mandir}/man3/*.3tcl*
231%{_mandir}/man3/tkspline.3tk*
232
233
234%changelog
235* Sat Jul 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.26.3-3
236- rebuild with perl-5.12
237- add BuildRequires: ruby
238
239* Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
240- add Patch10 to avoid build failure on ppc
241
242* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
243- new upstream release
244- built with rpm-4.8.1
245- split doc, guile, perl, python, ruby subpackage
246
247* Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
248- rebuild with libtool-2.2.6a
249
250* Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
251- new upstream release
252
253* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
254- rebuild with libXaw.so.7 (libXaw-1.0.5)
255
256* Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
257- new upstream release
258
259* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
260- new upstream release
261- build with expat-2.0.1
262- add man7
263
264* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
265- rebuild with tcl/tk-8.4.16
266
267* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
268- new upstream release
269- add BuildPrereq: swig
270- delete BuildPrereq: gd-progs gd-devel
271- add --with-mylibgd and --disable-FEATURE to configure option
272- update %%files
273
274* Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
275- added BuildPrereq: ruby-devel
276
277* Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
278- new upstream release
279- add BuildPrereq: libtool-ltdl-devel
280- move pkgconfig files to %%{_libdir}/pkgconfig
281- add --disable-rpath --disable-static to configure option
282- add %%post to every package
283
284* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
285- new upstream release
286- BuildPrereq: tcl >= 8.4, tk >= 8.4
287- add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
288- update %%files
289- remove lines about Vine2.6
290- change License to CPL
291
292* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
293- source upgrade
294- remove patch0 and commented lines
295
296* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
297- build for VineSeed
298
299* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
300- source upgrade
301- change spec to build both VineSeed and Vine2.5/2.6
302- add BuildPrereq: expat-devel and Requires: libexpat
303- add patch0 to build against freetype2-2.1.7
304- stop using autogen.sh script
305- add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
306- add graphviz-tcl package (VineSeed)
307
308* Thu Aug  7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
309- rebuild for new Vine
310
311* Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
312- import from offical site (src.rpm)
313
Note: See TracBrowser for help on using the repository browser.