source: projects/specs/branches/6/g/gnash/gnash-vl.spec @ 3751

Revision 3751, 18.0 KB checked in by Takemikaduchi, 13 years ago (diff)

fix BuildRequires?

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3# ghelp/omf/scrollkeeper support
4# not working as of version 0.8.7
5%define scrollkeeper 0
6
7# kde and klash support
8%define kde_support 0
9
10Name:           gnash
11Version:        0.8.7
12Release:        4%{?_dist_release}
13Summary:        GNU flash movie player
14
15Group:          Applications/Multimedia
16License:        GPLv3+
17URL:            http://www.gnu.org/software/gnash/
18Source0:        http://ftp.gnu.org/gnu/gnash/%{version}/%{name}-%{version}.tar.bz2
19Source1:        http://www.getgnash.org/gnash-splash.swf
20Source2:        gnash.desktop
21
22# register KComponentData properly in KDE 4 KPart
23Patch0:         gnash-0.8.3-fix-kde4-port.patch
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires:  libxml2-devel libpng-devel libjpeg-devel libogg-devel
27BuildRequires:  libboost-devel curl-devel freetype-devel fontconfig-devel
28BuildRequires: libboost-date-time libboost-serialization libboost-thread
29BuildRequires:  SDL-devel
30BuildRequires:  agg-devel
31BuildRequires:  python-devel
32BuildRequires:  libXv-devel
33%if %{kde_support}
34#BuildRequires:  kde-filesystem
35BuildRequires:  kdelibs-devel
36%endif
37BuildRequires:  gtkglext-devel
38BuildRequires:  docbook2X
39#BuildRequires:  %{_bindir}/docbook2pdf
40BuildRequires:  gstreamer-devel >= 0.10%
41BuildRequires:  gstreamer-plugins-base-devel >= 0.10
42%if %{scrollkeeper}
43BuildRequires:  scrollkeeper
44%endif
45BuildRequires:  giflib-devel
46BuildRequires:  gettext
47BuildRequires:  desktop-file-utils
48BuildRequires:  speex-devel
49BuildRequires:  gstreamer-plugins-base-devel
50BuildRequires:  pygtk2-devel
51BuildRequires:  libtool-ltdl-devel
52BuildRequires(check): dejagnu
53
54%if %{scrollkeeper}
55Requires(post): scrollkeeper
56Requires(postun): scrollkeeper
57%endif
58Requires(post): /sbin/ldconfig
59Requires(postun): /sbin/ldconfig
60Requires(post): /sbin/install-info
61Requires(preun): /sbin/install-info
62
63%description
64Gnash is capable of reading up to SWF v9 files and opcodes, but primarily
65supports SWF v7, with better SWF v8 and v9 support under heavy development.
66Gnash includes initial parser support for SWF v8 and v9. Not all
67ActionScript 2 classes are implemented yet, but all of the most heavily
68used ones are. Many ActionScript 2 classes are partially implemented;
69there is support for all of the commonly used methods of each
70class.
71
72%package plugin
73Summary:   Web-client flash movie player plugin
74Requires:  %{name} = %{version}-%{release}
75# this doesn't prevent wrong dependencies, in case a package
76# provides %%{_libdir}/mozilla/plugins (like kdebase for konqueror)
77# and another unrelated webbrowser is installed, like w3m-el.
78# Moreover konqueror could provide webclient some day
79Requires:  %{_libdir}/mozilla/plugins webclient
80Group:     Applications/Internet
81
82%description plugin
83The gnash flash movie player plugin for firefox or mozilla.
84
85%if %{kde_support}
86%package klash
87Summary:   Konqueror flash movie player plugin
88Requires:  %{name} = %{version}-%{release}
89Group:     Applications/Multimedia
90
91%description klash
92The gnash flash movie player plugin for Konqueror.
93
94%endif
95
96%package cygnal
97Summary:   Streaming media server
98Requires:  %{name} = %{version}-%{release}
99Group:     Applications/Multimedia
100
101%description cygnal
102Cygnal is a streaming media server that's Flash aware.
103
104%package devel
105Summary:   Gnash header files
106Requires:  %{name} = %{version}-%{release}
107Group:     Development/Libraries
108
109%description devel
110Gnash header files can be used to write external Gnash extensions or to embed
111the Gnash GTK+ widget into a C/C++ application.
112
113%package -n python-gnash
114Summary:   Gnash Python bindings
115Requires:  %{name} = %{version}-%{release}
116Group:     Applications/Multimedia
117
118%description -n python-gnash
119Python bindings for the Gnash widget. Can be used to embed Gnash into any PyGTK
120application.
121
122%prep
123%setup -q
124%patch0 -p1 -b .fix-kde4
125%if %{kde_support}
126# Hack as autoreconf breaks build
127sed -i -e 's!kapp.h!kapplication.h!g' configure
128sed -i -e 's!libkdeui.la!libkdeui.so!g' configure
129# Currently kde4-gnash (from kde4 branch) links against various KDE libraries,
130# but only needs Qt -- remove the superfluous linkage
131sed -i -e 's!\$(KDE4_LIBS)!!g' gui/Makefile.in
132%endif
133# we don't want any builtin ltdl built, configure wants always either
134# ltdl-install or ltdl-convenience, hack that out
135sed -i -e 's/test x"\${enable_ltdl_convenience-no}" != xno/false/g' configure
136# and don't build the loader part of libltdl either
137sed -i -e 's/\$(LT_DLLOADERS)//g' libltdl/Makefile.in
138# link to the system libltdl instead of the bundled one
139# this is hardcoded in the makefiles, so --without-included-ltdl doesn't help
140sed -i -e 's!\$(top_builddir)/libltdl/libltdlc.la!-lltdl!g' \
141  */Makefile.in */*/Makefile.in
142# delete bundled libltdl stuff to make sure it's not used
143rm -f libltdl/*.[ch] libltdl/*/*.[ch]
144
145iconv -f latin1 -t utf8 < AUTHORS > AUTHORS.utf8
146touch -r AUTHORS AUTHORS.utf8
147mv AUTHORS.utf8 AUTHORS
148
149%build
150%configure --disable-static --with-npapi-plugindir=%{_libdir}/mozilla/plugins \
151  --enable-docbook --enable-ghelp --enable-media=GST \
152  --disable-dependency-tracking --disable-rpath \
153  --enable-cygnal \
154  --enable-sdkinstall \
155  --enable-python \
156%if %{kde_support}
157  --enable-gui=gtk,kde4,sdl,fb \
158  --with-kde4-prefix=%{_kde4_prefix} \
159  --with-kde4-lib=%{_kde4_libdir}/kde4/devel \
160  --with-kde4-incl=%{_kde4_includedir} \
161%else
162  --enable-gui=gtk,sdl,fb \
163%endif
164  --without-included-ltdl
165
166%if %{kde_support}
167# make sure the Qt 4 moc etc. tools are found
168export PATH=%{_qt4_prefix}/bin:$PATH
169#doesn't work currently: %%{?_smp_mflags}
170# override KDE4_LIBS because configure doesn't detect it properly
171make KDE4_LIBS='-L%{_kde4_libdir}/kde4/devel -lkparts -lkdeui -lkdecore'
172%else
173#doesn't work currently: %%{?_smp_mflags}
174make
175%endif
176
177%install
178rm -rf $RPM_BUILD_ROOT
179make install install-plugins \
180 DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p' \
181%if %{kde_support}
182 KDE4_PLUGINDIR=%{_kde4_libdir}/kde4 \
183 KDE4_SERVICESDIR=%{_kde4_datadir}/kde4/services \
184 KDE4_CONFIGDIR=%{_kde4_configdir} \
185 KDE4_APPSDATADIR=%{_kde4_appsdir}/klash
186%endif
187
188rm $RPM_BUILD_ROOT%{_libdir}/gnash/*.la
189
190%if %{kde_support}
191# KDE 4 doesn't need the .la file anymore, thankfully
192rm $RPM_BUILD_ROOT%{_kde4_libdir}/kde4/libklashpart.la
193%endif
194
195rm -f $RPM_BUILD_ROOT%{_infodir}/dir
196
197rm -rf __dist_docs
198mkdir __dist_docs
199mv $RPM_BUILD_ROOT%{_datadir}/doc/gnash/* __dist_docs/
200rmdir $RPM_BUILD_ROOT%{_datadir}/doc/gnash
201
202cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/gnash/
203
204mkdir -p $RPM_BUILD_ROOT%{_libexecdir}
205# a wrapper to avoid gnash erroring out if there is no argument.
206# Instead open gnash-splash.swf.
207# this should not be needed in the next version.
208# FIXME: Do we still need this with 0.8.7?
209cat > $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper << EOF
210#! /bin/sh
211if [ "z\$1" = 'z' ]; then
212 gnash %{_datadir}/gnash/gnash-splash.swf
213else
214 gnash "\$@"
215fi
216EOF
217
218chmod a+x $RPM_BUILD_ROOT%{_libexecdir}/gnash-wrapper
219
220sed -e 's;/usr/libexec;%{_libexecdir};' %{SOURCE2} > gnash.desktop
221mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
222desktop-file-install --vendor="fedora" \
223 --dir=$RPM_BUILD_ROOT%{_datadir}/applications/ \
224 gnash.desktop
225
226mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
227cp -p ./gui/images/GnashG.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
228
229%find_lang %{name}
230
231%clean
232rm -rf $RPM_BUILD_ROOT
233
234
235%post
236/sbin/ldconfig
237%if %{scrollkeeper}
238scrollkeeper-update -q -o %{_datadir}/omf/%{name} || :
239%endif
240/sbin/install-info %{_infodir}/gnash_ref.info %{_infodir}/dir || :
241/sbin/install-info %{_infodir}/gnash_user.info %{_infodir}/dir || :
242
243update-desktop-database &> /dev/null || :
244
245touch --no-create %{_datadir}/icons/hicolor
246if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
247  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
248fi
249
250
251%preun
252if [ $1 = 0 ]; then
253    /sbin/install-info --delete %{_infodir}/gnash_ref.info %{_infodir}/dir || :
254    /sbin/install-info --delete %{_infodir}/gnash_user.info %{_infodir}/dir || :
255fi
256
257%postun
258/sbin/ldconfig
259%if %{scrollkeeper}
260scrollkeeper-update -q || :
261%endif
262
263update-desktop-database &> /dev/null || :
264
265touch --no-create %{_datadir}/icons/hicolor
266if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
267  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
268fi
269
270
271%files -f %{name}.lang
272%defattr(-,root,root,-)
273%doc README AUTHORS COPYING NEWS
274%doc __dist_docs/*
275%config(noreplace) %{_sysconfdir}/gnashpluginrc
276%config(noreplace) %{_sysconfdir}/gnashrc
277%{_bindir}/dumpshm
278%{_bindir}/fb-gnash
279%{_bindir}/flvdumper
280%{_bindir}/gtk-gnash
281%{_bindir}/sdl-gnash
282%{_bindir}/soldumper
283%{_bindir}/gnash
284%{_bindir}/gprocessor
285%{_bindir}/findmicrophones
286%{_bindir}/findwebcams
287%dir %{_libdir}/gnash
288%{_libdir}/gnash/*.so*
289%{_mandir}/man1/gnash.1*
290%{_mandir}/man1/dumpshm.1*
291%{_mandir}/man1/gprocessor.1*
292%{_mandir}/man1/soldumper.1*
293%{_mandir}/man1/flvdumper.1*
294%{_mandir}/man1/findmicrophones.1*
295%{_mandir}/man1/findwebcams.1*
296%{_mandir}/man1/gtk-gnash.1*
297%{_infodir}/gnash*
298%{_datadir}/gnash/
299%{_datadir}/icons/hicolor/32x32/apps/*.png
300%{_datadir}/applications/*.desktop
301%{_libexecdir}/gnash-wrapper
302%if %{scrollkeeper}
303%{_datadir}/omf/gnash/
304%endif
305
306%files plugin
307%defattr(-,root,root,-)
308%{_libdir}/mozilla/plugins/libgnashplugin.so
309
310%if %{kde_support}
311%files klash
312%defattr(-,root,root,-)
313%{_kde4_bindir}/kde4-gnash
314%{_kde4_libdir}/kde4/libklashpart.so
315%{_kde4_appsdir}/klash/
316%{_kde4_datadir}/kde4/services/klash_part.desktop
317%{_mandir}/man1/kde4-gnash.1*
318%endif
319
320%files cygnal
321%defattr(-,root,root,-)
322%config(noreplace) %{_sysconfdir}/cygnalrc
323%{_bindir}/cygnal
324%{_mandir}/man1/cygnal.1*
325%{_mandir}/man1/rtmpget.1*
326%dir %{_libdir}/cygnal
327%{_libdir}/cygnal/plugins/*.so*
328
329%files devel
330%defattr(-,root,root,-)
331%{_includedir}/gnash/
332%{_libdir}/pkgconfig/gnash.pc
333
334%files -n python-gnash
335%defattr(-,root,root,-)
336%{python_sitearch}/gtk-2.0/*
337
338%changelog
339* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.7-4
340- add BuildRequires: python-devel, libXv-devel
341
342* Tue Jan 18 2011 Shu KONNO <owa@bg.wakwak.com> 0.8.7-3
343- rebuilt with libboost-1.45.0
344
345* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.7-2
346- rebuilt with rpm-4.8.1 for pkg-config
347
348* Wed Mar 17 2010 IWAI, Masaharu <iwai@alib.jp> 0.8.7-1
349- initial build for Vine Linux: based Fedora 0.8.7-1.fc14
350
351* Sat Feb 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.7-1
352- update to 0.8.7
353- make scrollkeeper a conditional (still disabled as it's not working)
354- drop gnash-0.8.3-manual.patch, should no longer be needed
355- drop gnash-0.8.6-python-install-dir.patch, fixed upstream
356
357* Fri Feb 12 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-13
358- delete bundled libltdl stuff to make sure it's not used
359
360* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-12
361- don't build libltdlc.a
362
363* Thu Feb 11 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-11
364- --without-included-ltdl (CVE-2009-3736)
365
366* Fri Jan 22 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-10
367- Rebuild for new Boost (1.41.0)
368
369* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-9
370- Add missing Epoch to Requires
371
372* Sat Jan 02 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1:0.8.6-8
373- Install icon to the correct place (#551621)
374
375* Wed Dec 30 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-7
376- One more try at using the correct dir
377
378* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-6
379- Patch was reversed
380
381* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-5
382- Patch Makefile.in, not Makefile.am
383
384* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-4
385- Pick up python modules from the right dir
386
387* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-3
388- Install python modules in the right dir
389
390* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-2
391- Add cygnal plugins
392
393* Tue Dec 29 2009 Tomeu Vizoso <tomeu@sugarlabs.org> - 1:0.8.6-1
394- Update to 0.8.6, increase epoch.
395
396* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.8.20090910bzr11506
397- update to HEAD
398
399* Thu Sep 10 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.7.20090910bzr11505
400- update to HEAD
401
402* Mon Aug 10 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.6.20090809bzr11401
403- don't package headers in -widget, only in -devel (no duplicate files)
404- own %%{_includedir}/gnash/ in -devel
405- add missing %%defattr for -devel and -widget
406- make -devel and -widget require the main package (with exact VR)
407- fix -devel group and description
408- rename gnash-widget to python-gnash as per the naming guidelines
409
410* Sun Aug 09 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.9.0-0.5.20090809bzr11401
411- use %%{_includedir}, not %%{_prefix}/include
412
413* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.4.20090809bzr11401
414- Install the python module in the sitearch dir
415
416* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11401
417- One more 64bit fix
418
419* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.3.20090809bzr11400
420- Fix the packaging in 64bits
421
422* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.2.20090809bzr11400
423- upload the .swf file
424
425* Sun Aug 09 2009 Tomeu Vizoso <tomeu@sugarlabs.org> 0.9.0-0.1.20090809bzr11400
426- merge upstream changes into the spec
427
428* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.5-5
429- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
430
431* Fri May 22 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-4
432- rebuild for new Boost
433
434* Fri Mar 06 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.5-3
435- explicitly link the KlashPart against the libraries it uses
436
437* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-2
438- add missing speex-devel and gstreamer-plugins-base-devel BR
439 
440* Fri Mar 06 2009 Jaroslav Reznik <jreznik@redhat.com> 0.8.5-1
441- update to 0.8.5
442- remove use_kde3_executable_hack
443- remove autoreconf
444
445* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> 0.8.4-7
446- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
447
448* Thu Dec 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-6
449- rebuild for new boost
450
451* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-5
452- add missing portions of KDE 4 port from upstream kde4 branch
453
454* Thu Nov 13 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-4
455- add 3 more patches from bero to fix the KDE 4 viewer executable
456- disable use_kde3_executable hack
457
458* Sun Oct 19 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-3
459- add a desktop file
460
461* Sat Oct 18 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.4-2
462- update KDE 4 patch (undo the backporting and use original patch)
463- patch to make autoreconf work
464- add missing BR giflib-devel, gettext
465- omit unrecognized --with-qtdir
466
467* Sat Oct 18 2008 Patrice Dumas <pertusus@free.fr> 0.8.4-1
468- update to 0.8.4
469
470* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-6
471- use the KDE 3 executable with the KDE 4 KPart for now (making this conditional
472  so it can easily be disabled or removed once the KDE 4 executable is fixed)
473
474* Thu Oct  4 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-5
475- register KComponentData properly in KDE 4 KPart
476
477* Wed Oct  3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.8.3-4
478- KDE 4 port of klash by Benjamin Wolsey and Bernhard Rosenkränzer
479
480* Fri Aug 29 2008 Michael Schwendt <mschwendt@fedoraproject.org> 0.8.3-3
481- include %%_libdir/gnash directory
482
483* Wed Jun 25 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-2
484- add glib in the link, thanks Daniel Drake (#452767)
485
486* Sun Jun 22 2008 Patrice Dumas <pertusus@free.fr> 0.8.3-1
487- update to 0.8.3
488
489* Wed Apr  9 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-3
490- ship libklashpart (#441601)
491
492* Mon Mar 10 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-2
493- don't ship libltdl.so.3 (#436725)
494
495* Fri Mar  7 2008 Patrice Dumas <pertusus@free.fr> 0.8.2-1
496- update to 0.8.2
497
498* Sat Oct 27 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-6
499- add patch from Martin Stransky to fix wrapped plugin #281061
500
501* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-5
502- info files are empty, don't install them
503
504* Thu Sep 20 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-4
505- omf/scrollkeeper doc is broken, remove it
506
507* Fri Sep  7 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-3
508- better documentation generation
509
510* Wed Sep  5 2007 Patrice Dumas <pertusus@free.fr> 0.8.1-2
511- update to 0.8.1
512- agg is now the default renderer
513
514* Fri Aug  3 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-2
515- rebuild for boost soname change
516
517* Sun Jun 17 2007 Patrice Dumas <pertusus@free.fr> 0.8.0-1
518- update to 0.8.0
519
520* Wed May  9 2007 Patrice Dumas <pertusus@free.fr> 0.7.2-2
521- fix CVE-2007-2500 (fix 239213)
522
523* Sat Nov  6 2006 Patrice Dumas <pertusus@free.fr> 0.7.2-1
524- update for 0.7.2 release.
525
526* Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.7.1-9
527 - rebuilt for unwind info generation, broken in gcc-4.1.1-21
528
529* Sun Sep 24 2006 Patrice Dumas <pertusus@free.fr> 0.7.1-8
530- plugin requires %%{_libdir}/mozilla/plugins. Fix (incompletly and
531  temporarily, but there is no better solution yet) #207613
532
533* Sun Aug 27 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-7
534- add defattr for klash
535- add warnings in the description about stability
536
537* Mon Aug 21 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-6
538- remove superfluous buildrequires autoconf
539- rename last patch to gnash-plugin-tempfile-dir.patch
540- add README.fedora to plugin to explain tmpdirs
541
542* Wed Aug 16 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-5
543- source qt.sh and configure --with-qtdir (Dominik Mierzejewski)
544- add plugin-tempfile-dir.patch for plugin to use a safe tempdir
545
546* Fri Jul 28 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-4
547- buildrequire autotools (Michael Knox)
548
549* Fri Jun  2 2006 Patrice Dumas <pertusus@free.fr> - 0.7.1-3
550- add gnash-continue_on_info_install_error.patch to avoid
551- buildrequire libXmu-devel
552
553* Wed May 17 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-2
554- configure with --disable-rpath
555- buildrequire docbook2X
556- remove devel files
557
558* Sun May  7 2006 Jens Petersen <petersen@redhat.com> - 0.7.1-1
559- update to 0.7.1 alpha release
560
561* Sat Apr  22 2006 Rob Savoye <rob@welcomehome.org> - 0.7-1
562- install the info file. Various tweaks for my system based on
563Patrice's latest patch,
564
565* Fri Feb  3 2006 Patrice Dumas <dumas@centre-cired.fr> - 0.7-1
566- initial packaging
Note: See TracBrowser for help on using the repository browser.