source: projects/specs/branches/6/g/gdk-pixbuf2/gdk-pixbuf2-vl.spec @ 2219

Revision 2219, 7.0 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3# biarch support
4%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
5%define _query_suffix %{nil}
6%if %{build_compat32}
7%define _query_suffix -32
8%endif
9
10Name:           gdk-pixbuf2
11Version:        2.22.1
12Release:        1%{?_dist_release}
13Summary:        An image loading library
14
15Group:          System Environment/Libraries
16License:        LGPLv2+
17URL:            http://www.gt.org
18Source0:        http://download.gnome.org/sources/gdk-pixbuf/2.22/gdk-pixbuf-%{version}.tar.bz2
19
20BuildRequires:  glib2-devel >= 2.26.0
21BuildRequires:  libpng-devel
22BuildRequires:  libjpeg-turbo-devel
23BuildRequires:  libtiff-devel
24BuildRequires:  jasper-devel
25BuildRequires:  libX11-devel
26BuildRequires:  gobject-introspection-devel
27
28# gdk-pixbuf does a configure time check which uses the GIO mime
29# layer; we need to actually have the mime type database.
30BuildRequires:  shared-mime-info
31
32BuildRequires: gtk-doc
33## BuildRequires: libtool >= 2.2.10
34BuildRequires: libtool
35BuildRequires: gettext
36
37# We also need MIME information at runtime
38Requires: shared-mime-info
39
40# gdk-pixbuf was included in gtk2 until 2.21.2
41Conflicts: gtk2 <= 2.21.2
42
43# https://bugzilla.gnome.org/show_bug.cgi?id=624712
44Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
45
46%description
47gdk-pixbuf is an image loading library that can be extended by loadable
48modules for new image formats. It is used by toolkits such as GTK+ or
49clutter.
50
51%package devel
52Summary: Development files for gdk-pixbuf
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: glib2-devel
56Requires: gobject-introspection-devel
57Requires: libpng-devel
58
59# gdk-pixbuf was included in gtk2 until 2.21.2
60Conflicts: gtk2-devel <= 2.21.2
61
62%description devel
63This package contains the libraries and header files that are needed
64for writing applications that are using gdk-pixbuf.
65
66%if %{build_compat32}
67#######################################################################
68# compat32
69%package -n compat32-%{name}
70Summary:        An image loading library
71Group:          System Environment/Libraries
72Requires(post): compat32-glib2 >= %{glib2_version}
73# gdk-pixbuf was included in gtk2 until 2.21.2
74Conflicts: compat32-gtk2 <= 2.21.2
75
76%description -n compat32-%{name}
77gdk-pixbuf is an image loading library that can be extended by loadable
78modules for new image formats. It is used by toolkits such as GTK+ or
79clutter.
80
81%package -n compat32-%{name}-devel
82Summary: Development files for gdk-pixbuf
83Group: Development/Libraries
84Requires: compat32-%{name} = %{version}-%{release}
85Requires: %{name} = %{version}-%{release}
86Requires: compat32-libpng-devel
87
88# gdk-pixbuf was included in gtk2 until 2.21.2
89Conflicts: compat32-gtk2-devel <= 2.21.2
90
91%description -n compat32-%{name}-devel
92This package contains the libraries and header files that are needed
93for writing applications that are using gdk-pixbuf.
94
95%endif
96
97
98%prep
99%setup -q -n gdk-pixbuf-%{version}
100## %patch0 -p1 -b .libpng-linking
101
102%build
103libtoolize --copy --force
104autoreconf
105(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
106 %configure $CONFIGFLAGS \
107        --with-libjasper             \
108        --with-included-loaders=png  \
109        --enable-introspection=yes  )
110make %{?_smp_mflags}
111
112
113%install
114make install DESTDIR=$RPM_BUILD_ROOT    \
115             RUN_QUERY_LOADER_TEST=false
116
117# Remove unpackaged files
118rm $RPM_BUILD_ROOT%{_libdir}/*.la
119rm $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.la
120
121touch $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
122
123%if %{build_compat32}
124   cp $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders \
125      $RPM_BUILD_ROOT%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
126%endif
127
128%find_lang gdk-pixbuf
129
130%post
131/sbin/ldconfig
132gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
133
134%postun
135/sbin/ldconfig
136if [ $1 -gt 0 ]; then
137  gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
138fi
139
140%if %{build_compat32}
141%post -n compat32-%{name}
142/sbin/ldconfig
143gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
144
145%postun -n compat32-%{name}
146/sbin/ldconfig
147if [ $1 -gt 0 ]; then
148  gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
149fi
150%endif
151
152
153%files -f gdk-pixbuf.lang
154%defattr(-,root,root,-)
155%doc AUTHORS COPYING NEWS
156%{_libdir}/libgdk_pixbuf-2.0.so.*
157%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
158%{_libdir}/girepository-1.0
159%dir %{_libdir}/gdk-pixbuf-2.0
160%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
161%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
162%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
163%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
164%{_bindir}/gdk-pixbuf-query-loaders
165%{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
166
167%files devel
168%defattr(-,root,root,-)
169%{_includedir}/gdk-pixbuf-2.0
170%{_libdir}/libgdk_pixbuf-2.0.so
171%{_libdir}/libgdk_pixbuf_xlib-2.0.so
172%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
173%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
174%{_bindir}/gdk-pixbuf-csource
175%{_datadir}/gtk-doc/html/*
176%{_datadir}/gir-1.0
177%{_mandir}/man1/gdk-pixbuf-csource.1.gz
178
179%if %{build_compat32}
180%files -n compat32-%{name}
181%defattr(-,root,root,-)
182%{_libdir}/libgdk_pixbuf-2.0.so.*
183%{_libdir}/libgdk_pixbuf_xlib-2.0.so.*
184%dir %{_libdir}/gdk-pixbuf-2.0
185%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
186%dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
187%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
188%ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
189%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
190
191%files -n compat32-%{name}-devel
192%defattr(-,root,root,-)
193%{_libdir}/libgdk_pixbuf-2.0.so
194%{_libdir}/libgdk_pixbuf_xlib-2.0.so
195%{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
196%{_libdir}/pkgconfig/gdk-pixbuf-xlib-2.0.pc
197%endif
198
199%changelog
200* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
201- new upstream release
202
203* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
204- new upstream release
205- add configure option (--enable-introspection=yes)
206- drop Patch0
207
208* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
209- initial build for Vine Linux
210
211
212* Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
213- Require libpng for linking
214
215* Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
216- Rebuild with new gobject-introspection
217
218* Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
219- Update to 2.21.6
220
221* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
222- Also Require shared-mime-info for same reason
223
224* Fri Jul  2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
225- BR shared-mime-info; see comment above it
226
227* Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
228- Changes to support snapshot builds
229
230* Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
231- Update to 2.21.5
232
233* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
234- Rename to gdk-pixbuf2 to avoid conflict with the
235  existing gdk-pixbuf package
236
237* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
238- Update to 2.21.4
239- Incorporate package review feedback
240
241* Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
242- Initial packaging
Note: See TracBrowser for help on using the repository browser.