source: projects/specs/branches/6/g/gamin/gamin-vl.spec @ 3519

Revision 3519, 13.0 KB checked in by iwaim, 13 years ago (diff)

gamin 0.1.10-4

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
3Summary: Library providing the FAM File Alteration Monitor API
4Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
5Name: gamin
6Version: 0.1.10
7Release: 4%{?_dist_release}
8License: LGPLv2
9Group: System Environment/Daemons
10Source: gamin-%{version}.tar.bz2
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13URL: http://www.gnome.org/~veillard/gamin/
14Obsoletes: fam
15Provides: fam
16BuildRequires: glib2-devel, python, python-devel
17
18
19%description
20The Gamin library provides an API and ABI compatible file alteration
21monitor mechanism compatible with FAM but not dependent on a system wide
22daemon.
23
24%description -l ja
25Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
26します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
27パープログラムをオンデマンドに起動します。
28
29%package devel
30Summary: Development files for the Gamin library
31Summary(ja): Gamin ライブラリの開発用ファイル
32Group: Development/Libraries
33Requires: gamin = %{version}-%{release}
34Obsoletes: fam-devel
35Provides: fam-devel
36
37%description devel
38The Gamin library provides an API and ABI compatible file alteration
39monitor mechanism compatible with FAM but not dependent on a system wide
40daemon.
41
42%description devel -l ja
43Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
44します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
45パープログラムをオンデマンドに起動します。
46
47%package python
48Summary: Python bindings for the Gamin library
49Summary(ja): Gamin ライブラリ用の Python バインディング
50Group: Development/Libraries
51Requires: gamin = %{version}-%{release}
52Requires: python
53#Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
54
55%description python
56The gamin-python package contains a module that allow monitoring of
57files and directories from the Python language based on the support
58of the gamin package.
59
60%description python -l ja
61gamin-python は gamin ライブラリを利用して Python 言語からファイルや
62ディレクトリのモニタリングを行うためのモジュールです。
63
64## to build compat32 for x86_64 architecture support
65%package -n compat32-%{name}
66Summary: Library providing the FAM File Alteration Monitor API
67Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
68Group: System Environment/Daemons
69Requires: gamin = %{version}-%{release}
70
71%description -n compat32-%{name}
72The Gamin library provides an API and ABI compatible file alteration
73monitor mechanism compatible with FAM but not dependent on a system wide
74daemon.
75
76%description -n compat32-%{name} -l ja
77Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
78します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
79パープログラムをオンデマンドに起動します。
80
81%package -n compat32-%{name}-devel
82Summary: Development files for the Gamin library
83Summary(ja): Gamin ライブラリの開発用ファイル
84Group: Development/Libraries
85Requires: compat32-gamin = %{version}-%{release}
86
87%description -n compat32-%{name}-devel
88The Gamin library provides an API and ABI compatible file alteration
89monitor mechanism compatible with FAM but not dependent on a system wide
90daemon.
91
92%description -n compat32-%{name}-devel -l ja
93Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
94します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
95
96%prep
97%setup -q
98
99%build
100%configure
101%__make %{?_smp_mflags}
102
103%install
104rm -fr %{buildroot}
105
106%makeinstall
107
108## remove unuse files
109rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
110rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
111
112
113%clean
114rm -fr %{buildroot}
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%post -n compat32-%{name} -p /sbin/ldconfig
121
122%postun -n compat32-%{name} -p /sbin/ldconfig
123
124%files
125%defattr(-, root, root)
126
127%doc AUTHORS ChangeLog NEWS README Copyright TODO
128%doc doc/*.html
129%doc doc/*.gif
130%doc doc/*.txt
131%{_libdir}/lib*.so.*
132%{_libexecdir}/gam_server
133
134%files devel
135%defattr(-, root, root)
136
137%{_libdir}/lib*.so
138%{_libdir}/*a
139%{_includedir}/fam.h
140%{_libdir}/pkgconfig/gamin.pc
141
142%files python
143%defattr(-, root, root)
144%doc AUTHORS ChangeLog NEWS README Copyright TODO
145%{_libdir}/python*/site-packages/gamin.py*
146%{_libdir}/python*/site-packages/_gamin*
147%doc python/tests/*.py
148%doc doc/python.html
149
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-, root, root)
153%{_libdir}/lib*.so.*
154
155%files -n compat32-%{name}-devel
156%defattr(-, root, root)
157%{_libdir}/lib*.so
158%{_libdir}/*a
159%{_libdir}/pkgconfig/gamin.pc
160%endif
161
162%changelog
163* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 0.1.10-4
164- update Requires for python subpackage
165 - drop directory dependency
166
167* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
168- build with rpm-4.8.1-1 for pkg-config file
169
170* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
171- rebuild with python-2.6
172
173* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
174- new upstream release
175
176* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
177- fix license tag to LGPLv2
178- import patches from Fedora development
179  - Patch0: don't poll for non-existant watched files
180  - Patch1: Fix a memory leak
181  - Patch2: workaround for missing struct ucred in glibc headers
182    (fixed x86_64/ppc compilation)
183
184* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
185- spec in utf-8
186- removed *.la
187
188* Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
189- added compat32-* packages for x86_64 architecture support
190- applied new versioning policy
191
192* Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
193- new upstream release
194- Patch10 was included in upstream, dropped
195
196* Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
197- added Patch10 (<BTS:507>) which should be fixed in the new upstream release
198
199* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
200- new upstream release
201
202* Mon Sep  4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
203- stop removing *.la
204
205* Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
206- initial build for Vine Linux
207
208* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
209- bump again for double-long bug on ppc(64)
210
211* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
212- rebuilt for new gcc4.1 snapshot and glibc changes
213
214* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
215- rebuilt
216
217* Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
218- hopefully fixes gam_server crashes
219- some portability fixes
220- removed a minor leak
221* Thu Sep  8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
222- revamp of the inotify back-end
223- memory leak fix
224- various fixes and cleanups
225* Tue Aug  9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
226- Improvement of configuration, system wide configuration files and
227  per filesystem type default
228- Rewrite of the inotify back-end, reduce resources usage, tuning in
229  case of busy resources
230- Documentation updates
231- Changes to compile inotify back-end on various architectures
232- Debugging output improvements
233* Tue Aug  2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
234- Fix to compile on older gcc versions
235- Inotify back-end changes and optimizations
236- Debug ouput cleanup, pid and process name reports
237- Dropped kernel monitor bugfix
238- Removed the old glist copy used for debugging
239- Maintain mounted filesystems knowledge, and per fstype preferences
240* Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
241- inotify back end patches, ready for the new inotify support in kernel
242- lot of server code cleanup patches
243- fixed an authentication problem
244* Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
245- gamin_data_conn_event fix
246- crash from bug gnome #303932
247- Inotify and mounted media #171201
248- mounted media did not show up on Desktop #159748
249- write may not be atomic
250- Monitoring a directory when it is a file
251- Portability to Hurd/Mach and various code cleanups
252- Added support for ~ as user home alias in .gaminrc
253* Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
254- Close inherited file descriptors on exec of gam_server
255- Cancelling a monitor send back a FAMAcknowledge
256- Fixed for big files > 2GB
257- Bug when monitoring a non existing directory
258- Make client side thread safe
259- Unreadable directory fixes
260- Better flow control handling
261- Updated to latest inotify version: 0.23-6
262* Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
263- Fix an include problem showing up with gcc4</li>
264- Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
265- removed an incompatibility with SGI FAM #149822
266* Tue Mar  1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
267- Fix a configure problem reported by Martin Schlemmer
268- Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
269- Fix the monitoring of directory using poll and not kernel
270* Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
271- more documentation
272- lot of serious bug fixes including Gnome Desktop refresh bug
273- extending the framework for more debug (configure --enable-debug-api)
274- extending the python bindings for watching the same resource multiple times
275  and adding debug framework support
276- growing the regression tests a lot based on python bindings
277- inotify-0.19 patch from John McCutchan
278- renamed python private module to _gamin to follow Python PEP 8
279
280* Tue Feb  8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
281- memory corruption fix from Mark on the client side
282- extending the protocol and API to allow skipping Exists and EndExists
283  events to avoid deadlock on reconnect or when they are not used.
284
285* Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
286- bit of python bindings improvements, added test
287- fixed 3 bugs
288
289* Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
290- Added Python support
291- Updated for inotify-0.18
292
293* Thu Jan  6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
294- Frederic Crozat seems to have found the GList corruption which may fix
295  #132354 and related problems
296- Frederic Crozat also fixed poll only mode
297
298* Fri Dec  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
299- still chasing the loop bug, made another pass at checking GList,
300  added own copy with memory poisonning of GList implementation.
301- fixed a compile issue when compiling without debug
302
303* Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
304- still chasing the loop bug, checked and cleaned up all GList use
305- patch from markmc to minimize load on busy apps
306
307* Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
308- chasing #132354, lot of debugging, checking and testing and a bit
309  of refactoring
310
311* Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
312- workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
313
314* Sun Oct  3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
315- Found and fixed the annoying bug where update were not received
316  should fix bugs ##132429, #133665 and #134413
317- new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
318- Added documentation about internals
319
320* Fri Oct  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
321- applied portability fixes
322- hardened the code while chasing a segfault
323
324* Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
325- potential fix for a hard to reproduce looping problem.
326
327* Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
328- update to the latest version of inotify
329- inotify support compiled in by default
330- fix ABI FAM compatibility problems #133162
331
332* Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
333- more documentation
334- Added support for a configuration file $HOME/.gaminrc
335- fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
336
337* Wed Sep  1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
338- fix crash with konqueror #130967
339- exclude kernel (dnotify) monitoring for /mnt//* /media//*
340
341* Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
342- Fixes crashes of the gam_server
343- try to correct the kernel/poll switching mode
344
345* Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
346- add support for both polling and dnotify simultaneously
347- fixes monitoring of initially missing files
348- load control on very busy resources #124361, desactivating
349  dnotify and falling back to polling for CPU drain
350
351* Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
352- fixes simple file monitoring should close RH #129974
353- relocate gam_server in $(libexec)
354
355* Thu Aug  5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
356- Fix a crash when the client binary forks the gam_server and an
357  atexit handler is run.
358
359* Wed Aug  4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
360- should fix KDE build problems
Note: See TracBrowser for help on using the repository browser.