source: projects/specs/branches/6/e/expat/expat-vl.spec @ 7687

Revision 7687, 7.5 KB checked in by iwamoto, 11 years ago (diff)

expat update

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.0.1
4%define release 9%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
15Patch100:       expat-2.0.1-CVE-2009-3560-revised.patch
16Patch110:       expat-2.0.1_CVE-2009-3720.patch
17Patch120:       expat-2.0.1-CVE-2012-0876.patch
18Patch130:       expat-2.0.1-CVE-2012-1148.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
21Requires:       lib%{name} = %{version}-%{release}
22BuildRequires:  libtool
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28This is Expat, a C library for parsing XML, written by James Clark.
29Expat is a stream-oriented XML parser.  This means that you register
30handlers with the parser before starting the parse.  These handlers
31are called when the parser discovers the associated structures in the
32document being parsed.  A start tag is an example of the kind of
33structures for which you may register handlers.
34
35%package -n lib%{name}
36Summary:        Runtime library of expat
37Summary(ja):    Expat のための実行ライブラリ
38Group:          System Environment/Libraries
39
40
41%description -n lib%{name}
42This package contains the runtime, shared library of expat, the C
43library for parsing XML.
44
45%description -n lib%{name} -l ja
46Expat を動作させるために必用となるライブラリです.
47
48%package devel
49Summary:        Development environment for the expat XML parser
50Summary(ja):    expat XML パーサ用開発環境
51Group:          Development/Libraries
52Requires:       lib%{name} = %{version}-%{release}
53
54%description devel
55Development environment for the expat XML parser
56
57%description devel -l ja
58expat XML パーサ用開発環境です.
59
60## to build compat32 for x86_64 architecture support
61%package -n compat32-lib%{name}
62Summary:        Runtime library of expat
63Summary(ja):    Expat のための実行ライブラリ
64Group:          System Environment/Libraries
65Requires:       lib%{name} = %{version}-%{release}
66
67%description -n compat32-lib%{name}
68This package contains the runtime, shared library of expat, the C
69library for parsing XML.
70
71%description -n compat32-lib%{name} -l ja
72Expat を動作させるために必用となるライブラリです.
73
74%package -n compat32-%{name}-devel
75Summary:        Development environment for the expat XML parser
76Summary(ja):    expat XML パーサ用開発環境
77Group:          Development/Libraries
78Requires:       %{name}-devel = %{version}-%{release}
79Requires:       compat32-lib%{name} = %{version}-%{release}
80
81%description -n compat32-%{name}-devel
82Development environment for the expat XML parser
83
84%description -n compat32-%{name}-devel -l ja
85expat XML パーサ用開発環境です.
86
87%prep
88%setup -q
89%patch100 -p1 -b .CVE-2009-3560
90%patch110 -p1 -b .CVE-2009-3720
91%patch120 -p1 -b .CVE-2012-0876
92%patch130 -p1 -b .CVE-2012-1148
93
94%build
95export CFLAGS="$RPM_OPT_FLAGS -fPIC"
96%configure --enable-shared
97make %{?_smp_mflags}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101
102rm -f examples/*.dsp
103chmod 644 README COPYING Changes doc/* examples/*
104
105make DESTDIR=$RPM_BUILD_ROOT install
106rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -n lib%{name} -p /sbin/ldconfig
112
113%postun -n lib%{name} -p /sbin/ldconfig
114
115%post -n compat32-lib%{name} -p /sbin/ldconfig
116
117%postun -n compat32-lib%{name} -p /sbin/ldconfig
118
119%files
120%defattr(-,root,root)
121%doc COPYING Changes README
122%{_bindir}/xmlwf
123%{_mandir}/man1/xmlwf.1*
124
125%files -n lib%{name}
126%defattr(-,root,root)
127%doc COPYING Changes README
128%{_libdir}/libexpat.so.*
129
130%files devel
131%defattr(-,root,root)
132%doc COPYING Changes README doc/* examples
133%{_includedir}/*
134%{_libdir}/libexpat.a
135%{_libdir}/libexpat.so
136
137## to build compat32 for x86_64 architecture support
138%if %{build_compat32}
139%files -n compat32-lib%{name}
140%defattr(-,root,root)
141%{_libdir}/libexpat.so.*
142
143%files -n compat32-%{name}-devel
144%defattr(-,root,root)
145%{_libdir}/libexpat.a
146%{_libdir}/libexpat.so
147%endif
148
149%changelog
150* Tue Aug  7 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-9
151- add patch120 for fix CVE-2012-0876 (xmlparse.c)
152- add patch130 for fix CVE-2012-1148 (Memory leak in the poolGrow function)
153
154* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
155- update patch100 to regrassion fix (same as debian bug #561658)
156- add Vendor and Distribution tags
157
158* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
159- rebuilt with rpm-4.8.1-3
160
161* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
162- rebuilt with gcc-4.4.3-3 on ppc
163
164* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
165- rebuilt with new toolchains (for VineSeed)
166
167* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
168- add patch110 for fix CVE-2009-3720 (xml parser)
169
170* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
171- add Patch100 for fix CVE-2009-3560 (xml parser)
172
173* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
174- added Requires: tag to compat32-* sub-packages.
175- removed unnecessary %%configure CC='gcc -m32' option
176
177* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
178- applied new versioning policy and spec in utf-8
179
180* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
181- removed %%if !%%{build_compat32} case condition
182
183* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
184- new upstream release
185- drop Patch0
186- drop .la
187- chmod 644 the documentation
188- strip DSP files from examples
189- update description and drop description-ja
190- add -fPIC
191
192* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
193- rebuilt
194
195* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
196- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
197
198* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
199- added compat32* packages for x86_64 architecture support
200
201* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
202- add missing header file (expat_external.h) to %%files.
203
204* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
205- updated/revised Patch1 (%%install will fail without this patch)
206
207* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
208- new upstream release
209        -- dropped patch1
210
211* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
212- updated to 1.95.7
213- changed URL and Group
214- fixed License to MIT/X (based on rpm package at sourceforge)
215
216* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
217- version up to 1.95.6
218- drop expat-xmlwf-dynamiclink.patch (Patch0)
219- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
220- add manpage (xmlwf.1)
221
222* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
223- fixed license ( s/MPL or GPL/distributable/ )
224- use License tag
225
226* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
227- new sub-package libexpat.
228- added BuildPreReq: libtool
229
230* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
231- updated to 1.95.2 release
232
233* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
234- 1.95.1-3vl1
235- based on 1.95.1-3mdk from Mandrake 8.0
236- added Japanese summary and description
237- modified spec macros for Vine
238
239* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
240- real version is 1.95.1
241- reenable optimisations
242
243* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
244- release .
245
246* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
247- Don't try to use optimizations
248- Bzip2 sources
249
250* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
251- first version
Note: See TracBrowser for help on using the repository browser.