source: projects/specs/branches/6/e/expat/expat-vl.spec @ 10665

Revision 10665, 8.2 KB checked in by tomop, 8 years ago (diff)

expat-2.0.1-10

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define name   expat
3%define version 2.0.1
4%define release 10%{?_dist_release}
5
6Summary:        Expat is an XML 1.0 parser written in C
7Summary(ja):    C で書かれた XML 1.0 パーサ
8Name:           %{name}
9Version:        %{version}
10Release:        %{release}
11License:        MIT/X
12Group:          Applications/Text
13URL:            http://www.libexpat.org/
14Source:         http://download.sourceforge.net/expat/%{name}-%{version}.tar.gz
15# Patch100 includes CVE-2009-2625
16Patch100:       expat-2.0.1-CVE-2009-3560-revised.patch
17Patch110:       expat-2.0.1_CVE-2009-3720.patch
18Patch120:       expat-2.0.1-CVE-2012-0876.patch
19Patch130:       expat-2.0.1-CVE-2012-1148.patch
20
21# imported from ubuntu
22Patch201:       CVE-2015-1283.dpatch
23Patch202:       CVE-2015-1283-refix.dpatch
24Patch203:       CVE-2016-0718.dpatch
25Patch204:       CVE-2012-6702-1.dpatch
26Patch205:       CVE-2016-5300-1.dpatch
27Patch206:       CVE-2016-5300-2.dpatch
28Patch207:       CVE-2012-6702-2.dpatch
29
30BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
31Requires:       lib%{name} = %{version}-%{release}
32BuildRequires:  libtool
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37%description
38This is Expat, a C library for parsing XML, written by James Clark.
39Expat is a stream-oriented XML parser.  This means that you register
40handlers with the parser before starting the parse.  These handlers
41are called when the parser discovers the associated structures in the
42document being parsed.  A start tag is an example of the kind of
43structures for which you may register handlers.
44
45%package -n lib%{name}
46Summary:        Runtime library of expat
47Summary(ja):    Expat のための実行ライブラリ
48Group:          System Environment/Libraries
49
50
51%description -n lib%{name}
52This package contains the runtime, shared library of expat, the C
53library for parsing XML.
54
55%description -n lib%{name} -l ja
56Expat を動作させるために必用となるライブラリです.
57
58%package devel
59Summary:        Development environment for the expat XML parser
60Summary(ja):    expat XML パーサ用開発環境
61Group:          Development/Libraries
62Requires:       lib%{name} = %{version}-%{release}
63
64%description devel
65Development environment for the expat XML parser
66
67%description devel -l ja
68expat XML パーサ用開発環境です.
69
70## to build compat32 for x86_64 architecture support
71%package -n compat32-lib%{name}
72Summary:        Runtime library of expat
73Summary(ja):    Expat のための実行ライブラリ
74Group:          System Environment/Libraries
75Requires:       lib%{name} = %{version}-%{release}
76
77%description -n compat32-lib%{name}
78This package contains the runtime, shared library of expat, the C
79library for parsing XML.
80
81%description -n compat32-lib%{name} -l ja
82Expat を動作させるために必用となるライブラリです.
83
84%package -n compat32-%{name}-devel
85Summary:        Development environment for the expat XML parser
86Summary(ja):    expat XML パーサ用開発環境
87Group:          Development/Libraries
88Requires:       %{name}-devel = %{version}-%{release}
89Requires:       compat32-lib%{name} = %{version}-%{release}
90
91%description -n compat32-%{name}-devel
92Development environment for the expat XML parser
93
94%description -n compat32-%{name}-devel -l ja
95expat XML パーサ用開発環境です.
96
97%prep
98%setup -q
99%patch100 -p1 -b .CVE-2009-3560
100%patch110 -p1 -b .CVE-2009-3720
101%patch120 -p1 -b .CVE-2012-0876
102%patch130 -p1 -b .CVE-2012-1148
103
104%patch201 -p1 -b .CVE-2015-1283
105%patch202 -p1 -b .CVE-2015-1283-refix
106%patch203 -p1 -b .CVE-2016-0718
107%patch204 -p1 -b .CVE-2012-6702-1
108%patch205 -p1 -b .CVE-2016-5300-1
109%patch206 -p1 -b .CVE-2016-5300-2
110%patch207 -p1 -b .CVE-2012-6702-2
111
112%build
113export CFLAGS="$RPM_OPT_FLAGS -fPIC"
114%configure --enable-shared
115make %{?_smp_mflags}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119
120rm -f examples/*.dsp
121chmod 644 README COPYING Changes doc/* examples/*
122
123make DESTDIR=$RPM_BUILD_ROOT install
124rm -f $RPM_BUILD_ROOT/%{_libdir}/libexpat.la
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -n lib%{name} -p /sbin/ldconfig
130
131%postun -n lib%{name} -p /sbin/ldconfig
132
133%post -n compat32-lib%{name} -p /sbin/ldconfig
134
135%postun -n compat32-lib%{name} -p /sbin/ldconfig
136
137%files
138%defattr(-,root,root)
139%doc COPYING Changes README
140%{_bindir}/xmlwf
141%{_mandir}/man1/xmlwf.1*
142
143%files -n lib%{name}
144%defattr(-,root,root)
145%doc COPYING Changes README
146%{_libdir}/libexpat.so.*
147
148%files devel
149%defattr(-,root,root)
150%doc COPYING Changes README doc/* examples
151%{_includedir}/*
152%{_libdir}/libexpat.a
153%{_libdir}/libexpat.so
154
155## to build compat32 for x86_64 architecture support
156%if %{build_compat32}
157%files -n compat32-lib%{name}
158%defattr(-,root,root)
159%{_libdir}/libexpat.so.*
160
161%files -n compat32-%{name}-devel
162%defattr(-,root,root)
163%{_libdir}/libexpat.a
164%{_libdir}/libexpat.so
165%endif
166
167%changelog
168* Wed Jul 20 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.1-10
169- added Patch201-207 to fix vulnerabilities.
170  - CVE-2015-1283
171  - CVE-2016-0718
172  - CVE-2016-5300
173  - CVE-2012-6702
174
175* Tue Aug  7 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-9
176- add patch120 for fix CVE-2012-0876 (xmlparse.c)
177- add patch130 for fix CVE-2012-1148 (Memory leak in the poolGrow function)
178
179* Tue Apr 26 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.1-8
180- update patch100 to regrassion fix (same as debian bug #561658)
181- add Vendor and Distribution tags
182
183* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.0.1-7
184- rebuilt with rpm-4.8.1-3
185
186* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.0.1-6
187- rebuilt with gcc-4.4.3-3 on ppc
188
189* Mon Feb  1 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-5
190- rebuilt with new toolchains (for VineSeed)
191
192* Tue Dec 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-4
193- add patch110 for fix CVE-2009-3720 (xml parser)
194
195* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.0.1-3
196- add Patch100 for fix CVE-2009-3560 (xml parser)
197
198* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-2
199- added Requires: tag to compat32-* sub-packages.
200- removed unnecessary %%configure CC='gcc -m32' option
201
202* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
203- applied new versioning policy and spec in utf-8
204
205* Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.0.1-0vl2
206- removed %%if !%%{build_compat32} case condition
207
208* Mon Feb 18 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.0.1-0vl1
209- new upstream release
210- drop Patch0
211- drop .la
212- chmod 644 the documentation
213- strip DSP files from examples
214- update description and drop description-ja
215- add -fPIC
216
217* Fri Sep 07 2007 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl6
218- rebuilt
219
220* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl5
221- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
222
223* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.95.8-0vl4
224- added compat32* packages for x86_64 architecture support
225
226* Tue Feb 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.95.8-0vl3
227- add missing header file (expat_external.h) to %%files.
228
229* Tue Feb 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.8-0vl2
230- updated/revised Patch1 (%%install will fail without this patch)
231
232* Tue Feb 08 2005 Satoshi MACHINO <machino@vinelinux.org> 1.95.8-0vl1
233- new upstream release
234        -- dropped patch1
235
236* Fri Jan 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.95.7-1vl1
237- updated to 1.95.7
238- changed URL and Group
239- fixed License to MIT/X (based on rpm package at sourceforge)
240
241* Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 1.95.6-0vl1
242- version up to 1.95.6
243- drop expat-xmlwf-dynamiclink.patch (Patch0)
244- add expat-1.95.6-mandir.patch for installing manpage (Patch0)
245- add manpage (xmlwf.1)
246
247* Mon Mar 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.95.2-0vl3
248- fixed license ( s/MPL or GPL/distributable/ )
249- use License tag
250
251* Sun Oct 07 2001 akira yamada <akira@vinelinux.org> 1.95.2-0vl2
252- new sub-package libexpat.
253- added BuildPreReq: libtool
254
255* Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.95.2-0vl1
256- updated to 1.95.2 release
257
258* Sun Jun 17 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
259- 1.95.1-3vl1
260- based on 1.95.1-3mdk from Mandrake 8.0
261- added Japanese summary and description
262- modified spec macros for Vine
263
264* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95.1-3mdk
265- real version is 1.95.1
266- reenable optimisations
267
268* Thu Feb 15 2001  Daouda Lo <daouda@mandrakesoft.com> 1.95-1mdk
269- release .
270
271* Sun Jan 07 2001 David BAUDENS <baudens@mandrakesoft.com> 1.1-2mdk
272- Don't try to use optimizations
273- Bzip2 sources
274
275* Mon Nov 20 2000 Frederic Lepied <flepied@mandrakesoft.com> 1.1-1mdk
276- first version
Note: See TracBrowser for help on using the repository browser.