source: projects/specs/branches/6/d/deluge/deluge-vl.spec @ 2390

Revision 2390, 22.8 KB checked in by kudoh, 13 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           deluge
5Version:        1.3.1
6Release:        1%{?_dist_release}
7Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
8Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
9Group:          Applications/Internet
10License:        GPLv3 with exceptions
11URL:            http://deluge-torrent.org/
12
13Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.gz
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18Patch10:        workaround_build.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildArch:      noarch
22
23BuildRequires:  desktop-file-utils
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26## The build script checks for the libtorrent module and skips compiling the
27## in-tarball one if this is found.
28BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
29
30Requires:       gnome-python
31## Required for the proper ownership of icon dirs.
32Requires:       hicolor-icon-theme
33Requires:       notify-python
34Requires:       pygtk2-libglade
35Requires:       pyOpenSSL
36Requires:       python-chardet
37Requires:       python-mako
38Requires:       python-setuptools
39Requires:       python-simplejson
40Requires:       python-twisted
41Requires:       pyxdg
42Requires:       libtorrent-rasterbar-python >= 0.14.9
43
44%description
45Deluge is a new BitTorrent client, created using Python and GTK+. It is
46intended to bring a native, full-featured client to Linux GTK+ desktop
47environments such as GNOME and Xfce.
48
49%description -l ja
50Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
51GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
52クライアントを提供することを意図しています。
53
54
55%package        flags
56Summary:        Country flags for peer location display in Deluge
57Group:          Applications/Internet
58License:        GPLv3
59Requires:       %{name} = %{version}-%{release}
60
61%description    flags
62The %{name}-flags package contains optional country flags which are used to
63display the location of peers in the "Peers" information tab.
64
65
66%prep
67%setup -qn "%{name}-%{version}"
68#%patch0 -p0 -b .fix-scalable-icon-dir
69%patch1 -p1
70%patch10 -p1
71
72
73%build
74CFLAGS="%{optflags}" %{__python} setup.py build
75
76
77%install
78rm -rf %{buildroot}
79%{__python} setup.py install -O1 --skip-build --root %{buildroot}
80desktop-file-install --vendor vine                      \
81        --dir %{buildroot}%{_datadir}/applications      \
82        --copy-name-to-generic-name                     \
83        --add-mime-type=application/x-bittorrent        \
84        --delete-original                               \
85        --remove-category=Application                   \
86        %{buildroot}%{_datadir}/applications/%{name}.desktop
87
88## NOTE: The lang files should REEEAALLLY be in a standard place such as
89##       /usr/share/locale or similar. It'd make things so much nicer for
90##       the packaging. :O
91## A bit of sed magic to mark the translation files with %%lang, taken from
92## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
93## cannot (unfortunately) call find-lang directly since it's not on a
94## "$PREFIX/share/locale/"-ish directory tree.
95pushd %{buildroot}
96        find -type f -o -type l \
97                | sed '
98                        s:%{buildroot}%{python_sitelib}::
99                        s:^\.::
100                        s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
101                        s:^\([^%].*\)::
102                        s:%lang(C) ::
103                        /^$/d' \
104        > %{name}.filelist
105
106## We've got the .mo files now; but we need the rest of the files in those
107## dirs. We can't just glob in the %%files, as that would add duplicate
108## entries for the .mo files which we've already marked with appropriate
109## %%lang-fu.
110        find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
111                | grep -v 'pixmaps/flags' | sed -e 's:^\./::' -e 's| |*|g' >> %{name}.filelist
112        find ./%{python_sitelib}/%{name} -type d  | grep -v 'pixmaps/flags' \
113                | sed 's:^\./:%%dir :' >> %{name}.filelist
114
115## Now we move that list back to our sources, so that '%%files -f' can find it
116## properly.
117popd && mv %{buildroot}/%{name}.filelist .
118
119
120%clean
121rm -rf %{buildroot}
122
123
124%files -f %{name}
125%defattr(-,root,root,-)
126%doc ChangeLog LICENSE README
127%{python_sitelib}/
128%{_bindir}/%{name}
129%{_bindir}/%{name}-*
130%{_bindir}/%{name}d
131%{_datadir}/applications/vine-%{name}.desktop
132%{_datadir}/pixmaps/%{name}.*
133%{_datadir}/icons/hicolor/*/apps/%{name}.*
134%{_datadir}/icons/scalable/apps/
135%{_mandir}/man?/%{name}*
136
137%files  flags
138%defattr(-,root,root,-)
139%doc LICENSE
140%{python_sitelib}/%{name}/data/pixmaps/flags/
141
142
143%post
144update-desktop-database &>/dev/null ||:
145touch --no-create %{_datadir}/icons/hicolor
146if [ -x %{_bindir}/gtk-update-icon-cache ]; then
147        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
148fi
149
150
151%postun
152update-desktop-database &> /dev/null ||:
153touch --no-create %{_datadir}/icons/hicolor
154if [ -x %{_bindir}/gtk-update-icon-cache ]; then
155        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
156fi
157
158
159%changelog
160* Sat Dec 25 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.1-1
161- new upstream release
162- added patch10 to work around building problem
163  - disabled svn access
164
165* Sun Sep 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
166- new upstream release
167
168* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
169- new upstream release
170
171* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
172- new upstream release
173- added Requires: python-mako, notify-python, gnome-python
174- removed Requires: /bin/sh, dbus-python, dbus-x11
175- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
176- applied new naming policy to spec
177
178* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
179- rebuilt with python-2.6.4
180
181* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
182- new upstream release
183- added Patch1 from Debian to disable update
184- added Requires: python-twisted, python-simplejson
185
186* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
187- initial build for VineSeed
188
189* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
190- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
191
192* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
193- Fixed rb_libtorrent-python dependency, so as not to use the
194  %%min_rblibtorrent_ver macro any more (#510264).
195
196* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
197- Update to new upstream bug-fix release (1.1.9).
198- Do not hard-code minimum rb_libtorrent version. (We're only building against
199  the system rb_libtorrent for Fedora 11+, which already has the necessary
200  version.)
201
202* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
203- Update to new upstream release (1.1.8) for bug-fixes and some translation
204  updates. Adds dependency on chardet for fixing lots of bugs with torrents
205  which are not encoded as UTF-8.
206- Add back the flags, in an optional -flags subpackage as per the new Flags
207  policy (Package_Maintainers_Flags_Policy on the wiki).
208- Add LICENSE and README to installed documentation.
209
210* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
211- Rebuild for the Boost 1.39.0 update.
212
213* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
214- Update to new upstream bug-fix release (1.1.7).
215
216* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
217- Update to new upstream bug-fix release (1.1.6)
218- Fix GPL version, add OpenSSL exception to License.
219- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
220  necessary when building the in-tarball libtorrent copy).
221
222* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
223- Update to new upstream bug-fix release (1.1.5)
224- Remove FIXME comment about parallel-compilation. We're not building the
225  in-tarball libtorrent copy anymore, so no compilation (other than the python
226  bytecode) happens and we no longer need to worry about this.
227
228* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
229- Fix the installed location of the scalable (SVG) icon (#483443).
230  + scalable-icon-dir.diff
231
232* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
233- Update to new upstream bug-fix release (1.1.4)
234
235* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
237
238* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
239- Update to new upstream bug-fix release (1.1.3)
240
241* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
242- Fix scalable icon directory ownership (#483443).
243
244* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
245- Update to new upstream bug-fix release (1.1.2)
246
247* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
248- Update to new upstream bug-fix release (1.1.1)
249
250* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
251- Update to new upstream release (1.1.0 Final - yay!)
252- Drop the get_tracker_host patch (fixed upstream):
253  - fix-get_tracker-host-if-no-tracker.patch
254 
255* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
256- Do not package the country flags data.
257- Resolves: #479265 (country flags should not be used in Deluge)
258
259* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
260- Add patch from upstream SVN to fix an error where torrents are not shown (or
261  possibly shown in "Error" states) due to a bad inet_aton call:
262  + fix-get_tracker-host-if-no-tracker.patch
263- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
264  the bug report.
265- Fix day of previous %%changelog entry.
266
267* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
268- Update to new upstream release candidate (1.1.0 RC3)
269- Build against the system rb_libtorrent instead of using the in-tarball copy
270  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
271  the hacked setup.py script formerly used to enable this (fixed upstream):
272  - fixed-setup.py
273- Make it a noarch package now that it's just python scripts and related
274  data files (translations, images, etc.)
275
276* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
277- Update to new upstream release candidate (1.1.0 RC2)
278
279* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
280- Rebuild for new boost.
281
282* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
283- Update to new upstream bug-fix release (1.0.7)
284- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
285
286* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
287- Update to new upstream release (1.0.6)
288- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
289- Properly mark translation files with %%lang.
290
291* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
292- Fix locations for Python 2.6
293
294* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
295- Rebuild for Python 2.6
296
297* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
298- Update to new upstream release (1.0.5)
299
300* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
301- Update to new upstream release (1.0.4).
302
303* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
304- Update to new upstream release (1.0.3)
305
306* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
307- Update to new upstream release (1.0.2)
308- Drop multithreaded boost compilation patch (fixed upstream, again).
309  - mt-boost-fix.patch
310 
311* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
312- Update to new upstream release (1.0.0 Final)
313- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
314  libraries once more:
315  + mt-boost-fix.patch
316- Resolves: #464151 (About 1.0.0 build failure)
317
318* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
319- Update to new upstream release candidate (1.0.0 RC9)
320- Drop mt-boost patch (fixed upstream):
321  - use-mt-boost.patch
322
323* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
324- Update to new upstream release candidate (1.0.0 RC8)
325- Drop state_upgrade script from the documentation. (This is now handled
326  automatically.)
327- Fix version in previous %%changelog entry.
328
329* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
330- Update to new upstream release candidate (1.0.0 RC7)
331- Drop desktop file icon name hack (fixed upstream).
332
333* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
334- Update to new upstream release candidate (1.0.0 RC6)
335- Drop desktop file icon name hack (fixed upstream).
336
337* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
338- Update to new upstream release candidate (1.0.0 RC4)
339
340* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
341- Add setuptools runtime dependency, to fix "No module named pkg_resources"
342  error messages.
343
344* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
345- Update to new upstream release candidate (1.0.0 RC3)
346- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
347  complete.)
348
349* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
350- Update to new upstream release candidate (1.0.0 RC2)
351- Force building against the multithreaded Boost libs.
352  + use-mt-boost.patch
353- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
354  is just clutter.)
355- Remove the blocklist plugin, at upstream's recommendation.
356
357* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
358- Update to new upstream release (0.5.9.3)
359
360* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
361- Update to new upstream release (0.5.9.1)
362
363* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
364- Update to new upstream release (0.5.9.0)
365- Drop upstreamed default-preferences patch for disabling new version
366  notifications:
367  - default-prefs-no-release-notifications.patch
368
369* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
370- Update to new upstream release (0.5.8.9)
371
372* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
373- Update to new upstream release (0.5.8.7)
374
375* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
376- Update to new upstream release (0.5.8.6)
377
378* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
379- Update to new upstream release (0.5.8.5)
380
381* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
382- Update to new upstream release (0.5.8.4)
383- Rebuild for GCC 4.3
384
385* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
386- Update to new upstream security fix release (0.5.8.3), which includes a fix
387  for a potential remotely-exploitable stack overflow with a malformed
388  bencoded message.
389
390* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
391- Update to new upstream bugfix release (0.5.8.1)
392
393* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
394- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
395  428106 (Missing BR dbus-x11).
396- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
397
398* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
399- Update to new upstream release (0.5.8)
400- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
401  patch.
402 
403* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
404- Update to new upstream release candidate (0.5.8 RC2)
405
406* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
407- Update to new upstream release candidate (0.5.8 RC1)
408- Completely suppress updates notification (bug 299601, 426642)
409
410* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
411- Add missing icon cache %%post and %%postun scriptlets.
412- Add missing egg-info to the %%files list.
413
414* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
415- Update to new upstream bug-fix release (0.5.7.1).
416- Sort %%files list (aesthetic-only change).
417
418* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
419- Fix previous %%changelog Version.
420- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
421  in rawhide  bad .desktop file.)
422
423* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
424- Rebuild for deps
425
426* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
427- Update to new upstream release (0.5.7)
428
429* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
430- Update to new upstream release candidate (0.5.7 RC2)
431- Drop plugin error patch (fixed upstream):
432  - plugin-not-found-OK.patch
433
434* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
435- Update to new upstream release candidate (0.5.7 RC)
436- Update Source0 url
437- Add upstream patch to prevent dying if plugin in prefs.state is not found on
438  the filesystem:
439  + plugin-not-found-OK.patch
440
441* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
442- Update to new upstream bug-fix release (0.5.6.2)
443
444* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
445- Update to new upstream bug-fix release (0.5.6.1)
446- Drop use-mt-boost build script patch (fixed upstream):
447  - use-mt-boost.patch
448
449* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
450- Update to new upstream release (0.5.6)
451
452* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
453- Update to new upstream release candidate (0.5.6 RC1)
454
455* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
456- Fix release on previous %%changelog entry.
457- Disable the version update notifications by default:
458  + default-prefs-no-release-notifications.patch
459  (Resolves bug 299601: Deluge alerts of new versions)
460
461* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
462- Update to new upstream release (0.5.5)
463
464* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
465- Update to new upstream release candidate (0.5.5 RC1)
466
467* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
468- Update to new upstream release (0.5.4.1)
469- Build with new binutils to gain BuildID debugging goodness.
470
471* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
472- Update to new upstream release (0.5.4)
473
474* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
475- Update License tag (GPLv2+).
476- Rebuild against new Boost libraries, adding a patch to build against the
477  multi-threaded ("*-mt") libraries:
478  + use-mt-boost.patch
479
480* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
481- Update to new upstream release candidate (0.5.3)
482- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
483  properly determines this and adds the AMD64 compiler definition if necessary.
484
485* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
486- Update to new upstream release candidate (0.5.3 RC1)
487- Drop stale persistence fix patch (applied upstream):
488  - fix-persistence-upgrade-rhbz_247927.patch
489
490* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
491- Add patch to fix the existence of stale persistence files by automatically
492  updating the deluge.deluge module name to deluge.core, or removing them if
493  empty (bug 247927):
494  + fix-persistence-upgrade-rhbz_247927.patch
495
496* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
497- Update to new upstream release (0.5.2)
498- Update Summary and %%description to reflect new µTorrent-compatible Peer
499  Exchange ("PEX") functionality.
500
501* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
502- Update to new upstream release (0.5.1 Beta 2)
503
504* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
505- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
506 
507* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
508- Update to new upstream release (0.5.0).
509
510* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
511- Update to new upstream release (0.5 RC2).
512- Drop IndexError exception-handling fix (applied upstream):
513  - delugegtk.py-fix-IndexError-exception-handling.patch
514- Use the system libtool instead of the one from the sources to ensure
515  that no unnecessary RPATH hacks are added to the final build.
516
517* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
518- Add a patch (submitted upstream) to properly catch a thrown IndexError in
519  state message updates. This should resolve the bug wherein the UI stops
520  updating its details and torrent listing.
521  + delugegtk.py-fix-IndexError-exception-handling.patch
522 
523* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
524- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
525  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
526  - 64bit-python_long patch
527  (This should fix the bug where, even though torrents are active, they are not
528  shown in the GtkTreeView listing.)
529
530* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
531- Update to new upstream release (0.5 RC1).
532- Use rewritten setup.py instead of patching it so much, since it's easier to
533  maintain across version upgrades and whatnot:
534  + fixed-setup.py
535- Remove the setup.py patches (no longer needed, since I'm packaging my own):
536  - setup.py-dont-store-the-install-dir.patch
537  - setup.py-build-against-system-libtorrent.patch
538
539* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
540- Update to new upstream release (0.5 Beta 3).
541- Add patch to fix storing of installation directory:
542  + setup.py-dont-store-the-install-dir.patch
543    (to be applied after setup.py-build-against-system-libtorrent.patch)
544
545* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
546- Add patch to fix 64-bit python_long type.
547  +  64bit-python_long.patch
548
549* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
550- Update to new upstream release (0.5 Beta 2)
551- Add patch to force building against system copy of rb_libtorrent:
552  + setup.py-build-against-system-libtorrent.patch
553- Remove python-libtorrent and a few other dependencies that are no longer
554  used.
555
556* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
557- Fix Source0 URL.
558
559* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
560- Make notify-python dependency conditional (FC6+ only)
561- Strip the unneeded shebang lines from the plugin scripts, since they are not
562  meant to be directly executed.
563
564* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
565- Update .desktop file: Icon should not have the "-256" size suffix.
566- Add Requires: notify-python
567- Remove strict dependency on python 2.3+, since we're targetting FC5+
568  only, which has 2.4+.
569
570* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
571- Use install instead of the cp/find/chmod fiasco of earlier releases for
572  clarity and proper permissions setting.
573- Be more consistent about use of %%{name} and other macros in file naming as
574  well as whitespace between sections.
575
576* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
577- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
578  64-bit systems.
579
580* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
581- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.