source: projects/specs/branches/6/d/dbus/dbus-vl.spec @ 7739

Revision 7739, 18.8 KB checked in by Takemikaduchi, 11 years ago (diff)

rebuild packages & security fix

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.9
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.4.1
14Release: 2%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# fix CVE-2012-3524
28Patch7: dbus-1.4.x-CVE-2012-3524.patch
29
30# fix CVE-2013-2168
31Patch8: dbus-1.4.1-CVE-2013-2168.patch
32
33# Workaround for deny send_interface
34# http://bugs.freedesktop.org/show_bug.cgi?id=18961
35Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38Requires(post): chkconfig >= 1.3.34
39Requires(preun): chkconfig >= 1.3.34
40Requires(pre): shadow-utils
41BuildRequires: libtool
42BuildRequires: expat-devel >= %{expat_version}
43BuildRequires: libxml2-devel
44BuildRequires: python-pyrex >= %{pyrex_version}
45BuildRequires: doxygen
46BuildRequires: xmlto
47BuildRequires: libxslt
48BuildRequires: gettext
49BuildRequires: libX11-devel
50BuildRequires: libcap
51BuildRequires: libSM-devel
52Requires: libxml2-python
53
54Vendor: Project Vine
55Distribution: Vine Linux
56
57%description
58D-BUS is a system for sending messages between applications. It is
59used both for the systemwide message bus service, and as a
60per-user-login-session messaging facility.
61
62%description -l ja
63D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
64システム全体のメッセージバスサービスとしても利用されますが、同様に
65ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
66
67%package devel
68Summary: Libraries and headers for D-BUS
69Summary(ja): D-BUS 用のライブラリとヘッダファイル
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Requires: glib2-devel
73
74%description devel
75Headers and static libraries for D-BUS.
76
77%package x11
78Summary: X11-requiring add-ons for D-BUS
79Summary(ja): X11 を利用する D-BUS 用ツール
80Group: Applications/System
81Requires: %{name} = %{version}-%{release}
82
83%description x11
84D-BUS contains some tools that require Xlib to be installed, those are
85in this separate package so server systems need not install X.
86
87# compat32
88%package -n compat32-%{name}
89Summary: D-BUS message bus
90Summary(ja): D-BUS メッセージバスシステム
91Group: System Environment/Libraries
92
93%description -n compat32-%{name}
94D-BUS is a system for sending messages between applications. It is
95used both for the systemwide message bus service, and as a
96per-user-login-session messaging facility.
97
98%description -n compat32-%{name} -l ja
99D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
100システム全体のメッセージバスサービスとしても利用されますが、同様に
101ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
102
103%package -n compat32-%{name}-devel
104Summary: Libraries and headers for D-BUS
105Summary(ja): D-BUS 用のライブラリとヘッダファイル
106Group: Development/Libraries
107Requires: compat32-%{name} = %{version}-%{release}
108Requires: %{name}-devel = %{version}-%{release}
109Requires: compat32-glib2-devel
110
111%description -n compat32-%{name}-devel
112Headers and static libraries for D-BUS.
113
114%prep
115%setup -q
116## %patch0 -p1 -b .start-early
117%patch1 -p1 -b .generate-xml-docs
118%patch6 -p1 -b .increase-timeout
119
120mv configure.in configure.ac
121%patch7 -p1 -b .CVE-2012-3524
122%patch8 -p1 -b .CVE-2013-2168
123
124%patch10 -p1 -b .workaround-dbus-sendinterface
125
126%build
127autoreconf -f -i
128
129COMMON_ARGS="--enable-selinux=no \
130             --with-init-scripts=redhat \
131             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
132             --with-dbus-user=dbus \
133             --libdir=/%{_lib} --bindir=/bin \
134             --libexecdir=/%{_lib}/dbus-1 \
135             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
136
137%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
138%__make
139
140doxygen Doxyfile
141
142xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
143
144%install
145rm -rf %{buildroot}
146
147%__make install DESTDIR=$RPM_BUILD_ROOT
148
149mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
150
151#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
152sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
153rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
154
155mkdir -p $RPM_BUILD_ROOT/%{_bindir}
156mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
157mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
158mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
159rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
160
161rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
162rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
163
164mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
165mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
166
167cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
168cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
169cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
170cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
171cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
172
173## %find_lang %{gettext_package}
174
175mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
176
177%clean
178rm -rf %{buildroot}
179
180%pre
181# Add the "dbus" user
182/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
183        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
184
185%post
186/sbin/ldconfig
187/sbin/chkconfig --add messagebus
188/sbin/chkconfig messagebus resetpriorities
189
190%preun
191if [ $1 = 0 ]; then
192    service messagebus stop > /dev/null 2>&1
193    /sbin/chkconfig --del messagebus
194fi
195
196%postun
197/sbin/ldconfig
198
199%post -n compat32-%{name} -p /sbin/ldconfig
200
201%postun -n compat32-%{name} -p /sbin/ldconfig
202
203%files
204%defattr(-,root,root)
205%doc COPYING ChangeLog NEWS
206%dir %{_sysconfdir}/dbus-1
207%config %{_sysconfdir}/dbus-1/*.conf
208%{_sysconfdir}/rc.d/init.d/*
209%dir %{_sysconfdir}/dbus-1/system.d
210%dir %{_sysconfdir}/dbus-1/session.d
211%dir %{_localstatedir}/run/dbus
212%dir %{_localstatedir}/lib/dbus/
213/bin/dbus-daemon
214/bin/dbus-send
215/bin/dbus-cleanup-sockets
216/bin/dbus-monitor
217/bin/dbus-uuidgen
218/%{_lib}/*dbus-1*.so.*
219%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
220%{_datadir}/man/man*/dbus-daemon.1.gz
221%{_datadir}/man/man*/dbus-monitor.1.gz
222%{_datadir}/man/man*/dbus-send.1.gz
223%{_datadir}/man/man*/dbus-uuidgen.1.gz
224%dir %{_datadir}/dbus-1
225%{_datadir}/dbus-1/services
226%{_datadir}/dbus-1/system-services
227%{_datadir}/dbus-1/interfaces
228%dir /%{_lib}/dbus-1
229%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
230
231%files devel
232%defattr(-,root,root)
233/%{_lib}/lib*.so
234%{_libdir}/dbus-1.0/include
235%{_libdir}/pkgconfig/*
236%{_includedir}/*
237%{_datadir}/devhelp/books/dbus
238
239%files x11
240%defattr(-,root,root)
241%{_bindir}/dbus-launch
242%{_datadir}/man/man*/dbus-launch.1.gz
243
244# compat32
245%if %{build_compat32}
246%files -n compat32-%{name}
247/%{_lib}/*dbus-1*.so.*
248
249%files -n compat32-%{name}-devel
250%defattr(-,root,root)
251/%{_lib}/lib*.so
252%{_libdir}/dbus-1.0/include
253%{_libdir}/pkgconfig/*
254%endif
255
256%changelog
257* Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-2
258- add Patch7 (dbus-1.4.x-CVE-2012-3524.patch)
259   (including security fix for CVE-2012-3524)
260- add Patch8 (dbus-1.4.1-CVE-2013-2168.patch)
261   (including security fix for CVE-2013-2168)
262
263* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
264- new upstream release
265
266* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
267- new upstream release
268
269* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
270- add BuildRequires: libSM-devel
271
272* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
273- rebuilt with rpm-4.8.1
274
275* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
276- new upstream release
277- drop Patch0
278
279* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
280- rebuilt with new toolchain
281
282* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
283- new upstream release
284
285* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
286- new upstream release
287- do not restart dbus on upgrade
288
289* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
290- added compat32 package for x86_64 arch support
291
292* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
293- add Patch10 for workaround deny send_interface
294  http://bugs.freedesktop.org/show_bug.cgi?id=18961
295  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
296  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
297  It's really always wrong to use them without also using send_destination.
298  - XXX: this should be fixed in each dbus configuration.
299
300* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
301- new upstream release with security fix (CVE-2008-4311)
302
303* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
304- new upstream release with security fix (CVE-2008-3834)
305
306* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
307- new upstream release
308
309* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
310- own the directories /usr/share/dbus-1/{system-services,interfaces}
311- set 'dbus' instead of '81' to --with-dbus-user
312 
313* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
314- import some patches from fedora
315- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
316
317* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
318- new upstream release
319
320* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
321- new upstream release
322
323* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
324- rebuild with expat-2.0.1
325
326* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
327- rebuild with new environment/toolchain
328
329* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
330- require new chkconfig to reset initscript priorities
331
332* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
333- new upstream release
334- split out bindings
335- move base binaries and libraries to /bin and /%{_lib}
336
337* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
338- rebuilt for VineSeed
339
340* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
341- add Vendor/Distribution tag
342
343* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
344- add patch100 for fix CVE-2006-6107
345
346* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
347- new upstream release
348
349* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
350- disabled dbus-qt
351- added BuildConflicts: qt-devel
352- removed work around for 64 bit archs
353
354* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
355- new upstream release
356
357* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
358- new upstream release
359
360* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
361- new upstream release
362
363* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
364- new upstream release
365- enable python bindings
366
367* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
368- initial build for Vine Linux based on FC package
369- disable python bindings
370- disable selinux
371
372* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
373- Explicitly pass in the pid file location to ./configure instead of
374  letting it guess based on the build enviornment
375
376* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
377- Add patch to fix random users from connecting to a users session bus
378
379* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
380- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
381
382* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
383- Update to upstream version 0.23
384- Drop all patches except for the UDI patch as they have been
385  integrated upstream
386- List of API changes:
387      * add setgroups() to drop supplementary groups
388      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
389      * added support for int64 and uint64 to the python bindings
390      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
391
392* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
393- rebuild against python 2.4
394
395* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
396- Add a requires for glib2-devel in the devel package
397- Add SE-Linux backport from Colin Walters that fixes
398  messages getting lost in SE-Linux contexts
399
400* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
401- Bump up release and rebuild
402
403* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
404- Run /sbin/ldconfig for glib sub-package (bug #134062).
405
406* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
407- Fixed patch to use dbus-1 instead of dbus-1.0
408- (configure.in): Exported just the datadir instead of
409  the full path to the dbus datadir for consistency
410
411* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
412- Adding patch to move /usr/lib/dbus-1.0/services to
413  /usr/share/dbus-1.0/services
414
415* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
416- reverting BuildRequires: redhat-release because of issues with build system
417- added precompiled version of the messagebus init script
418
419* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
420- changed /etc/redhat-release to the package redhat-release
421
422* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
423- added python int64 patch from davidz
424
425* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
426- added BuildRequires: /etc/redhat-release (RH Bug #132436)
427
428* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
429- Added Steve Grubb's spec file patch (RH Bug #130201)
430
431* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
432- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
433
434* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
435- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
436  no longer requires X or GTK libraries. (RH Bug #130029)
437
438* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
439- Update to new 0.22 release
440
441* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
442- Added BuildRequires for libselinux-devel and Requires for libselinux
443
444* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
445- Add SE-DBus patch
446
447* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
448- Added lib64 workaround for python bindings installing to
449  the wrong lib directory on 64 bit archs
450
451* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
452- Updated console-auth patch
453- rebuild
454 
455* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
456- Update to upstream CVS build
457- Added console-auth patch
458
459* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
460- Workaround added to fix gcc-3.4 bug on ia64
461
462* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
463- require new Pyrex version and see if it builds this time
464
465* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
466- rebuild with updated Pyrex (0.9.2.1)
467
468* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
469- rebuilt
470
471* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
472- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
473  into the dbus-glib package so that the main dbus
474  package does not depend on glib (Bug #125285)
475
476* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
477- rebuilt
478
479* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
480- added my Python patch
481- took out the qt build requires
482- added a gtk+ build requires
483
484* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
485- Changed build requirement to version 0.9-3 of Pyrex
486  to fix problem with builing on x86_64
487
488* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
489- update to upstream 0.21
490- removed dbus-0.20-varargs.patch patch (fixed upstream)
491
492* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
493- added a dbus-python package to generate python bindings
494- added Pyrex build dependacy
495
496* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
497- rebuilt
498
499* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
500- fix dbus error functions on x86-64 (#116324)
501- add prereq (#112027)
502
503* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
504- rebuilt
505
506* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
507- Conflict with cups prior to configuration file change, so that the
508  %%postun service condrestart works.
509
510* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
511- rebuild in fc2, cups now updated
512
513* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
514- update to upstream 0.20
515
516* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
517- hmm, dbus doesn't support uids in the config file. fix.
518
519* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
520- put uid instead of username in the config file, to keep things working with name change
521
522* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
523- make subpackages require the specific release, not just version, of base package
524
525* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
526- change system user "messagebus" -> "dbus" to be under 8 chars
527
528* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
529- see if removing qt subpackage for now will get us through the build system,
530  qt bindings not useful yet anyway
531
532* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
533- 0.13 fixes a little security oops
534
535* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
536- break the tiny dbus-launch that depends on X into separate package
537  so a CUPS server doesn't need X installed
538
539* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
540- rebuilt
541
542* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
543- 0.11.91 cvs snap properly merges system.d
544
545* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
546- build a cvs snap with a few more fixes
547
548* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
549- fix a crash that was breaking cups
550
551* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
552- 0.11
553
554* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
555- use rc.d/init.d not init.d, bug #90192
556- include the new man pages
557
558* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
559- 0.9
560- export QTDIR explicitly
561- re-enable qt, the problem was most likely D-BUS configure
562
563* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
564- update from CVS with a fix to set uid after gid
565
566* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
567- new cvs snap that actually forks to background and changes
568  user it's running as and so forth
569- create our system user in pre
570
571* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
572- fix for "make check" test that required a home directory
573
574* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
575- disable qt for now because beehive hates me
576- pull a slightly newer cvs snap that creates socket directory
577- cat the make check log after make check fails
578
579* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
580- initial build
581
Note: See TracBrowser for help on using the repository browser.