source: projects/specs/branches/6/d/dbus/dbus-vl.spec @ 10712

Revision 10712, 19.8 KB checked in by tomop, 8 years ago (diff)

dbus-1.8.20-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define dbus_user_uid           81
6
7%define _localstatedir %{_var}
8
9Summary: D-BUS message bus
10Summary(ja): D-BUS メッセージバスシステム
11Name: dbus
12Version: 1.8.20
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15License: AFL/GPLv2
16Group: System Environment/Libraries
17
18Source0: %{name}-%{version}.tar.gz
19Source1: doxygen_to_devhelp.xsl
20
21# from fedora package
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Requires(post): chkconfig >= 1.3.34
25Requires(preun): chkconfig >= 1.3.34
26Requires(pre): shadow-utils
27BuildRequires: libtool
28BuildRequires: expat-devel >= %{expat_version}
29BuildRequires: libxml2-devel
30BuildRequires: python-devel
31BuildRequires: doxygen
32BuildRequires: xmlto
33BuildRequires: libxslt
34BuildRequires: gettext
35BuildRequires: libX11-devel
36BuildRequires: libSM-devel
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42D-BUS is a system for sending messages between applications. It is
43used both for the systemwide message bus service, and as a
44per-user-login-session messaging facility.
45
46%description -l ja
47D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
48システム全体のメッセージバスサービスとしても利用されますが、同様に
49ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
50
51%package devel
52Summary: Libraries and headers for D-BUS
53Summary(ja): D-BUS 用のライブラリとヘッダファイル
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Headers and static libraries for D-BUS.
59
60%package x11
61Summary: X11-requiring add-ons for D-BUS
62Summary(ja): X11 を利用する D-BUS 用ツール
63Group: Applications/System
64Requires: %{name} = %{version}-%{release}
65
66%description x11
67D-BUS contains some tools that require Xlib to be installed, those are
68in this separate package so server systems need not install X.
69
70%package doc
71Summary: Developer documentation for D-BUS
72Group: Documentation
73Requires: %{name} = %{version}-%{release}
74BuildArch: noarch
75
76%description doc
77This package contains developer documentation for D-Bus along with
78other supporting documentation such as the introspect dtd file.
79
80# compat32
81%package -n compat32-%{name}
82Summary: D-BUS message bus
83Summary(ja): D-BUS メッセージバスシステム
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87D-BUS is a system for sending messages between applications. It is
88used both for the systemwide message bus service, and as a
89per-user-login-session messaging facility.
90
91%description -n compat32-%{name} -l ja
92D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
93システム全体のメッセージバスサービスとしても利用されますが、同様に
94ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
95
96%package -n compat32-%{name}-devel
97Summary: Libraries and headers for D-BUS
98Summary(ja): D-BUS 用のライブラリとヘッダファイル
99Group: Development/Libraries
100Requires: compat32-%{name} = %{version}-%{release}
101Requires: %{name}-devel = %{version}-%{release}
102
103%description -n compat32-%{name}-devel
104Headers and static libraries for D-BUS.
105
106%prep
107%setup -q
108
109%build
110autoreconf -f -i
111
112COMMON_ARGS="--enable-selinux=no \
113                --disable-libaudit \
114                --with-init-scripts=redhat \
115                --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
116                --with-dbus-user=dbus \
117                --libdir=/%{_lib} --bindir=/bin \
118                --libexecdir=/%{_lib}/dbus-1 \
119                --sysconfdir=%{_sysconfdir} --exec-prefix=/"
120
121%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
122%__make
123
124doxygen Doxyfile
125
126xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
127
128%install
129rm -rf %{buildroot}
130
131%__make install DESTDIR=$RPM_BUILD_ROOT
132
133mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
134
135#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
136sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
137rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
138
139mkdir -p $RPM_BUILD_ROOT/%{_bindir}
140mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
141mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
142mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
143rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
144
145rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
146rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
147
148mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
149mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
150
151cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
152cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
153cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
154cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
155cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
156
157## %find_lang %{gettext_package}
158
159mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
160
161%clean
162rm -rf %{buildroot}
163
164%pre
165# Add the "dbus" user
166/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
167        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
168
169%post
170/sbin/ldconfig
171/sbin/chkconfig --add messagebus
172/sbin/chkconfig messagebus resetpriorities
173
174%preun
175if [ $1 = 0 ]; then
176    service messagebus stop > /dev/null 2>&1
177    /sbin/chkconfig --del messagebus
178fi
179
180%postun
181/sbin/ldconfig
182
183%post -n compat32-%{name} -p /sbin/ldconfig
184
185%postun -n compat32-%{name} -p /sbin/ldconfig
186
187%files
188%defattr(-,root,root)
189%doc COPYING ChangeLog NEWS
190%dir %{_sysconfdir}/dbus-1
191%config %{_sysconfdir}/dbus-1/*.conf
192%{_sysconfdir}/rc.d/init.d/*
193%dir %{_sysconfdir}/dbus-1/system.d
194%dir %{_sysconfdir}/dbus-1/session.d
195%dir %{_localstatedir}/run/dbus
196%dir %{_localstatedir}/lib/dbus/
197/bin/dbus-daemon
198/bin/dbus-send
199/bin/dbus-cleanup-sockets
200/bin/dbus-monitor
201/bin/dbus-run-session
202/bin/dbus-uuidgen
203/%{_lib}/*dbus-1*.so.*
204%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
205%{_datadir}/man/man*/dbus-daemon.1.gz
206%{_datadir}/man/man*/dbus-monitor.1.gz
207%{_datadir}/man/man*/dbus-run-session.1.gz
208%{_datadir}/man/man*/dbus-send.1.gz
209%{_datadir}/man/man*/dbus-uuidgen.1.gz
210%dir %{_datadir}/dbus-1
211%{_datadir}/dbus-1/services
212%{_datadir}/dbus-1/system-services
213%{_datadir}/dbus-1/interfaces
214%dir /%{_lib}/dbus-1
215%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
216
217%files devel
218%defattr(-,root,root)
219/%{_lib}/lib*.so
220%{_libdir}/dbus-1.0/include
221%{_libdir}/pkgconfig/*
222%{_includedir}/*
223%{_datadir}/devhelp/books/dbus
224
225%files x11
226%defattr(-,root,root)
227%{_bindir}/dbus-launch
228%{_datadir}/man/man*/dbus-launch.1.gz
229
230%files doc
231%defattr(-,root,root)
232%doc %{_docdir}/dbus
233
234# compat32
235%if %{build_compat32}
236%files -n compat32-%{name}
237/%{_lib}/*dbus-1*.so.*
238
239%files -n compat32-%{name}-devel
240%defattr(-,root,root)
241/%{_lib}/lib*.so
242%{_libdir}/dbus-1.0/include
243%endif
244
245%changelog
246* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
247- new upstream release
248
249* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
250- new upstream release
251
252* Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
253- new upstream release
254
255* Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
256- new upstream release
257
258* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
259- new upstream release
260
261* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
262- new upstream release
263
264* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
265- new upstream release
266
267* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
268- new upstream release
269
270* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
271- new upstream release
272
273* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
274- new upstream release
275
276* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
277- new upstream release
278
279* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
280- remove BuildRequires: audit-libs-devel, libcap-ng-devel
281
282* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
283- new upstream release
284- remove old patches
285
286* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
287- new upstream release
288- add BuildRequires: audit-libs-devel, libcap-ng-devel
289
290* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
291- new upstream release
292- remove Requires: libxml2-python
293
294* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
295- new upstream release
296
297* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
298- new upstream release
299- drop Patch1
300- create -doc sub package
301
302* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
303- new upstream release
304
305* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
306- new upstream release
307
308* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
309- add BuildRequires: libSM-devel
310
311* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
312- rebuilt with rpm-4.8.1
313
314* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
315- new upstream release
316- drop Patch0
317
318* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
319- rebuilt with new toolchain
320
321* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
322- new upstream release
323
324* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
325- new upstream release
326- do not restart dbus on upgrade
327
328* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
329- added compat32 package for x86_64 arch support
330
331* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
332- add Patch10 for workaround deny send_interface
333  http://bugs.freedesktop.org/show_bug.cgi?id=18961
334  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
335  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
336  It's really always wrong to use them without also using send_destination.
337  - XXX: this should be fixed in each dbus configuration.
338
339* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
340- new upstream release with security fix (CVE-2008-4311)
341
342* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
343- new upstream release with security fix (CVE-2008-3834)
344
345* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
346- new upstream release
347
348* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
349- own the directories /usr/share/dbus-1/{system-services,interfaces}
350- set 'dbus' instead of '81' to --with-dbus-user
351 
352* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
353- import some patches from fedora
354- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
355
356* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
357- new upstream release
358
359* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
360- new upstream release
361
362* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
363- rebuild with expat-2.0.1
364
365* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
366- rebuild with new environment/toolchain
367
368* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
369- require new chkconfig to reset initscript priorities
370
371* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
372- new upstream release
373- split out bindings
374- move base binaries and libraries to /bin and /%{_lib}
375
376* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
377- rebuilt for VineSeed
378
379* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
380- add Vendor/Distribution tag
381
382* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
383- add patch100 for fix CVE-2006-6107
384
385* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
386- new upstream release
387
388* Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
389- disabled dbus-qt
390- added BuildConflicts: qt-devel
391- removed work around for 64 bit archs
392
393* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
394- new upstream release
395
396* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
397- new upstream release
398
399* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
400- new upstream release
401
402* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
403- new upstream release
404- enable python bindings
405
406* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
407- initial build for Vine Linux based on FC package
408- disable python bindings
409- disable selinux
410
411* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
412- Explicitly pass in the pid file location to ./configure instead of
413  letting it guess based on the build enviornment
414
415* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
416- Add patch to fix random users from connecting to a users session bus
417
418* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
419- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
420
421* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
422- Update to upstream version 0.23
423- Drop all patches except for the UDI patch as they have been
424  integrated upstream
425- List of API changes:
426      * add setgroups() to drop supplementary groups
427      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
428      * added support for int64 and uint64 to the python bindings
429      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
430
431* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
432- rebuild against python 2.4
433
434* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
435- Add a requires for glib2-devel in the devel package
436- Add SE-Linux backport from Colin Walters that fixes
437  messages getting lost in SE-Linux contexts
438
439* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
440- Bump up release and rebuild
441
442* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
443- Run /sbin/ldconfig for glib sub-package (bug #134062).
444
445* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
446- Fixed patch to use dbus-1 instead of dbus-1.0
447- (configure.in): Exported just the datadir instead of
448  the full path to the dbus datadir for consistency
449
450* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
451- Adding patch to move /usr/lib/dbus-1.0/services to
452  /usr/share/dbus-1.0/services
453
454* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
455- reverting BuildRequires: redhat-release because of issues with build system
456- added precompiled version of the messagebus init script
457
458* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
459- changed /etc/redhat-release to the package redhat-release
460
461* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
462- added python int64 patch from davidz
463
464* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
465- added BuildRequires: /etc/redhat-release (RH Bug #132436)
466
467* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
468- Added Steve Grubb's spec file patch (RH Bug #130201)
469
470* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
471- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
472
473* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
474- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
475  no longer requires X or GTK libraries. (RH Bug #130029)
476
477* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
478- Update to new 0.22 release
479
480* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
481- Added BuildRequires for libselinux-devel and Requires for libselinux
482
483* Mon Aug 02 2004 Colin Walters <walters@redhat.com>
484- Add SE-DBus patch
485
486* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
487- Added lib64 workaround for python bindings installing to
488  the wrong lib directory on 64 bit archs
489
490* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
491- Updated console-auth patch
492- rebuild
493 
494* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
495- Update to upstream CVS build
496- Added console-auth patch
497
498* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
499- Workaround added to fix gcc-3.4 bug on ia64
500
501* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
502- require new Pyrex version and see if it builds this time
503
504* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
505- rebuild with updated Pyrex (0.9.2.1)
506
507* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
508- rebuilt
509
510* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
511- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
512  into the dbus-glib package so that the main dbus
513  package does not depend on glib (Bug #125285)
514
515* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
516- rebuilt
517
518* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
519- added my Python patch
520- took out the qt build requires
521- added a gtk+ build requires
522
523* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
524- Changed build requirement to version 0.9-3 of Pyrex
525  to fix problem with builing on x86_64
526
527* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
528- update to upstream 0.21
529- removed dbus-0.20-varargs.patch patch (fixed upstream)
530
531* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
532- added a dbus-python package to generate python bindings
533- added Pyrex build dependacy
534
535* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
536- rebuilt
537
538* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
539- fix dbus error functions on x86-64 (#116324)
540- add prereq (#112027)
541
542* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
546- Conflict with cups prior to configuration file change, so that the
547  %%postun service condrestart works.
548
549* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
550- rebuild in fc2, cups now updated
551
552* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
553- update to upstream 0.20
554
555* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
556- hmm, dbus doesn't support uids in the config file. fix.
557
558* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
559- put uid instead of username in the config file, to keep things working with name change
560
561* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
562- make subpackages require the specific release, not just version, of base package
563
564* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
565- change system user "messagebus" -> "dbus" to be under 8 chars
566
567* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
568- see if removing qt subpackage for now will get us through the build system,
569  qt bindings not useful yet anyway
570
571* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
572- 0.13 fixes a little security oops
573
574* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
575- break the tiny dbus-launch that depends on X into separate package
576  so a CUPS server doesn't need X installed
577
578* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
579- rebuilt
580
581* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
582- 0.11.91 cvs snap properly merges system.d
583
584* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
585- build a cvs snap with a few more fixes
586
587* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
588- fix a crash that was breaking cups
589
590* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
591- 0.11
592
593* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
594- use rc.d/init.d not init.d, bug #90192
595- include the new man pages
596
597* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
598- 0.9
599- export QTDIR explicitly
600- re-enable qt, the problem was most likely D-BUS configure
601
602* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
603- update from CVS with a fix to set uid after gid
604
605* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
606- new cvs snap that actually forks to background and changes
607  user it's running as and so forth
608- create our system user in pre
609
610* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
611- fix for "make check" test that required a home directory
612
613* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
614- disable qt for now because beehive hates me
615- pull a slightly newer cvs snap that creates socket directory
616- cat the make check log after make check fails
617
618* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
619- initial build
620
Note: See TracBrowser for help on using the repository browser.