source: projects/specs/branches/6/c/cyrus-sasl/cyrus-sasl-vl.spec @ 4646

Revision 4646, 24.0 KB checked in by iwamoto, 13 years ago (diff)

cyrus-sasl-vl: fix pam support / add Vendor,Distri tag

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 10%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43
44Patch102: configure.patch
45
46Buildroot: %{_tmppath}/%{name}-%{version}-root
47BuildRequires: autoconf, automake, libtool
48# Note: berkeley db for sasl2, gdbm for sasl1.
49BuildRequires: db4-devel, openssl-devel, pam-devel
50%if %{includev1}
51BuildRequires: gdbm-devel
52%endif
53BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
54BuildRequires: pkgconfig
55BuildRequires: krb5-devel
56BuildRequires: groff
57Requires(post): /sbin/ldconfig, chkconfig
58Requires(postun): /sbin/ldconfig, chkconfig
59
60Vendor: Project Vine
61Distribution: Vine Linux
62
63%description
64The %{name} package contains the Cyrus implementation of SASL.
65SASL is the Simple Authentication and Security Layer, a method for
66adding authentication support to connection-based protocols.
67
68%package devel
69Requires: %{name} = %{version}-%{release}
70Group: Development/Libraries
71Summary: Files needed for developing applications with Cyrus SASL.
72
73%description devel
74The %{name}-devel package contains files needed for developing and
75compiling applications which use the Cyrus SASL library.
76
77%package gssapi
78Requires: %{name} = %{version}-%{release}
79Group: System Environment/Libraries
80Summary: GSSAPI support for Cyrus SASL.
81
82%description gssapi
83The %{name}-gssapi package contains the Cyrus SASL plugins which
84support GSSAPI authentication. GSSAPI is commonly used for Kerberos
85authentication.
86
87%package plain
88Requires: %{name} = %{version}-%{release}
89Group: System Environment/Libraries
90Summary: PLAIN and LOGIN support for Cyrus SASL.
91
92%description plain
93The %{name}-plain package contains the Cyrus SASL plugins which support
94PLAIN and LOGIN authentication schemes.
95
96%package md5
97Requires: %{name} = %{version}-%{release}
98Group: System Environment/Libraries
99Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
100
101%description md5
102The %{name}-md5 package contains the Cyrus SASL plugins which support
103CRAM-MD5 and DIGEST-MD5 authentication schemes.
104
105%package ntlm
106Requires: %{name} = %{version}-%{release}
107Group: System Environment/Libraries
108Summary: NTLM support for Cyrus SASL.
109
110%description ntlm
111The %{name}-ntlm package contains the Cyrus SASL plugin which supports
112the NTLM authentication schemes.
113
114# This would more appropriately be named cyrus-sasl-auxprop-sql.
115%package sql
116#Requires: %{name}-lib = %{version}-%{release}
117Requires: %{name} = %{version}-%{release}
118Group: System Environment/Libraries
119Summary: SQL auxprop support for Cyrus SASL
120
121%description sql
122The %{name}-sql package contains the Cyrus SASL plugin which supports
123using a RDBMS for storing shared secrets.
124
125# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
126%package ldap
127#Requires: %{name}-lib = %{version}-%{release}
128Requires: %{name} = %{version}-%{release}
129Group: System Environment/Libraries
130Summary: LDAP auxprop support for Cyrus SASL
131
132%description ldap
133The %{name}-ldap package contains the Cyrus SASL plugin which supports using
134a directory server, accessed using LDAP, for storing shared secrets.
135
136
137## to build compat32 for x86_64 architecture support
138%package -n compat32-%{name}
139Summary: The Cyrus SASL library.
140Group: System Environment/Libraries
141
142%description -n compat32-%{name}
143The %{name} package contains the Cyrus implementation of SASL.
144SASL is the Simple Authentication and Security Layer, a method for
145adding authentication support to connection-based protocols.
146
147%package -n compat32-%{name}-devel
148Group: Development/Libraries
149Summary: Files needed for developing applications with Cyrus SASL.
150
151%description -n compat32-%{name}-devel
152The %{name}-devel package contains files needed for developing and
153compiling applications which use the Cyrus SASL library.
154
155%package -n compat32-%{name}-gssapi
156Group: System Environment/Libraries
157Summary: GSSAPI support for Cyrus SASL.
158
159%description -n compat32-%{name}-gssapi
160The %{name}-gssapi package contains the Cyrus SASL plugins which
161support GSSAPI authentication. GSSAPI is commonly used for Kerberos
162authentication.
163
164%package -n compat32-%{name}-plain
165Group: System Environment/Libraries
166Summary: PLAIN and LOGIN support for Cyrus SASL.
167
168%description -n compat32-%{name}-plain
169The %{name}-plain package contains the Cyrus SASL plugins which support
170PLAIN and LOGIN authentication schemes.
171
172%package -n compat32-%{name}-md5
173Group: System Environment/Libraries
174Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
175
176%description -n compat32-%{name}-md5
177The %{name}-md5 package contains the Cyrus SASL plugins which support
178CRAM-MD5 and DIGEST-MD5 authentication schemes.
179
180%package -n compat32-%{name}-ntlm
181Group: System Environment/Libraries
182Summary: NTLM support for Cyrus SASL.
183
184%description -n compat32-%{name}-ntlm
185The %{name}-ntlm package contains the Cyrus SASL plugin which supports
186the NTLM authentication schemes.
187
188# %package -n compat32-%{name}-sql
189# Group: System Environment/Libraries
190# Summary: SQL auxprop support for Cyrus SASL
191
192# %description -n compat32-%{name}-sql
193# The %{name}-sql package contains the Cyrus SASL plugin which supports
194# using a RDBMS for storing shared secrets.
195
196%package -n compat32-%{name}-ldap
197Group: System Environment/Libraries
198Summary: LDAP auxprop support for Cyrus SASL
199
200%description -n compat32-%{name}-ldap
201The %{name}-ldap package contains the Cyrus SASL plugin which supports using
202a directory server, accessed using LDAP, for storing shared secrets.
203
204
205
206%prep
207%setup -q -c -a 2
208%if %{includev1}
209pushd cyrus-sasl-%{cs1_version}
210%patch0 -p1 -b .rpath
211%patch1 -p1 -b .autoconf25
212%patch2 -p1 -b .automake17
213%patch3 -p1 -b .automake18
214%patch4 -p1 -b .saslauthd2
215%patch5 -p1 -b .CVE-2009-0688
216libtoolize -f -c
217aclocal -I config -I cmulocal
218automake -a -c -f
219autoheader
220autoconf -f
221popd
222%endif
223
224pushd cyrus-sasl-%{version}
225chmod -x doc/*.html
226chmod -x include/*.h
227%patch10 -p1 -b .db_bundle
228%patch11 -p1 -b .no_rpath
229%patch15 -p1 -b .path
230%patch24 -p1 -b .sizes
231%patch25 -p1 -b .typo
232%patch26 -p2 -b .digest-commas
233%patch27 -p1 -b .automake-1.10
234%patch28 -p1 -b .keytab
235
236%patch100 -p1 -b .db48
237%patch101 -p1 -b .gcc44
238
239%patch102 -p0 -b .configure
240
241# FIXME - we remove these files directly so that we can avoid using the -f
242# flag, which has a nasty habit of overwriting files like COPYING.
243rm -f config/config.guess config/config.sub
244rm -f config/ltconfig config/ltmain.sh config/libtool.m4
245rm -fr autom4te.cache
246libtoolize -c
247aclocal -I config -I cmulocal
248automake -a -c
249autoheader
250autoconf
251
252pushd saslauthd
253rm -f config/config.guess config/config.sub
254rm -f config/ltconfig config/ltmain.sh config/libtool.m4
255rm -fr autom4te.cache
256libtoolize -c
257aclocal -I config -I ../cmulocal -I ../config
258automake -a -c
259autoheader
260autoconf
261popd
262
263%if %{includev1}
264# Sort of merge the docs.
265mkdir cyrus-sasl-%{version}/%{cs1_version}
266mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
267cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
268cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
269# Remove duplicate RFCs.
270pushd cyrus-sasl-%{version}/%{cs1_version}-devel
271for file in * ; do
272        if [ -f ../doc/${file} ] ; then
273                rm -f ${file}
274        fi
275done
276popd
277%endif
278
279%build
280%if %{includev1}
281pushd cyrus-sasl-%{cs1_version}
282%configure \
283        --enable-static --enable-staticdlopen --with-pic --enable-shared \
284        --with-plugindir=%{_plugindir} \
285        --disable-krb4 \
286        --with-rc4 \
287        --with-dblib=gdbm \
288        --enable-anon \
289        --enable-cram \
290        --enable-digest \
291        --enable-plain \
292        --enable-login
293make %{?_smp_mflags} sasldir=%{_plugindir}
294popd
295%endif
296
297pushd cyrus-sasl-%{version}
298CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
299
300# Find OpenSSL.
301LIBS="-lcrypt"; export LIBS
302if pkg-config openssl ; then
303        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
304        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
305        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
306fi
307
308# Find the SQL libraries used needed by the SQL auxprop plugin.
309mysql_config=mysql_config
310pg_config=pg_config
311SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
312SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
313SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
314SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
315SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
316echo $SQL_LDFLAGS
317SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
318echo $SQL_LIBS
319
320cleanup_flags() {
321        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
322               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
323               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
324               -e 's,[[:blank:]]+, ,g'
325}
326CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
327CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
328LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
329
330%configure \
331        --disable-static --enable-shared --disable-java \
332        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
333        --disable-krb4 \
334        --with-rc4 \
335        --with-dblib=berkeley \
336        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
337        --with-ldap \
338        --with-devrandom=/dev/urandom \
339        --enable-anon \
340        --enable-cram \
341        --enable-digest \
342        --enable-ntlm \
343        --enable-plain \
344        --enable-login \
345        --disable-otp \
346        --enable-ldapdb \
347        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
348        --without-sqlite \
349        "$@"
350        # --enable-auth-sasldb -- EXPERIMENTAL
351make %{?_smp_mflags} sasldir=%{_plugindir2}
352make %{?_smp_mflags} -C saslauthd testsaslauthd
353make -C sample
354popd
355
356%install
357test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
358%if %{includev1}
359pushd cyrus-sasl-%{cs1_version}
360%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
361install -m755 -d $RPM_BUILD_ROOT%{_bindir}
362libtool --mode=install \
363install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
364libtool --mode=install \
365install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
366popd
367%endif
368
369pushd cyrus-sasl-%{version}
370make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
371make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
372
373install -m755 -d $RPM_BUILD_ROOT%{_bindir}
374./libtool --tag=CC --mode=install \
375install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
376./libtool --tag=CC --mode=install \
377install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
378./libtool --tag=CC --mode=install \
379install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
380./libtool --tag=CC --mode=install \
381install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
382
383# Install the saslauthd mdoc page in the expected location.  Sure, it's not
384# really a man page, but groff seems to be able to cope with it.
385install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
386install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
387
388# Create the saslauthd listening directory.
389install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
390
391# Install the init script for saslauthd and the init script's config file.
392install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
393install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
394install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
395popd
396
397# Install the config dirs if they're not already there.
398install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
399install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
400
401# Remove unpackaged files from the buildroot.
402rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
403rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
404rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
405rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
406rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
407
408%clean
409test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
410
411%post
412/sbin/ldconfig
413/sbin/chkconfig --add saslauthd
414
415%preun
416if [ $1 = 0 ] ; then
417        /sbin/chkconfig --del saslauthd
418fi
419
420%postun
421/sbin/ldconfig
422if [ $1 != 0 ] ; then
423        /sbin/service saslauthd condrestart 2>&1 > /dev/null
424fi
425
426%files
427%defattr(-,root,root)
428%if %{includev1}
429%doc %{name}-%{version}/%{cs1_version}
430%endif
431%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
432%doc $RPM_SOURCE_DIR/README.RPM
433%dir %{_sysconfdir}/sasl2
434%{_libdir}/libsasl*.so.*
435%if %{includev1}
436%dir %{_plugindir}/
437%endif
438%dir %{_plugindir2}/
439%if %{includev1}
440%{_plugindir}/*anonymous*.so*
441%{_plugindir}/*anonymous*.la
442%endif
443%{_plugindir2}/*anonymous*.so*
444%{_plugindir2}/*sasldb*.so*
445%{_mandir}/man8/*
446%{_sbindir}/dbconverter-2
447%if %{includev1}
448%{_sbindir}/saslpasswd
449%{_sbindir}/sasldblistusers
450%endif
451%{_sbindir}/saslpasswd2
452%{_sbindir}/sasldblistusers2
453%{_sbindir}/pluginviewer
454%{_sbindir}/saslauthd
455%{_sbindir}/testsaslauthd
456%config(noreplace) /etc/sysconfig/saslauthd
457%config /etc/rc.d/init.d/saslauthd
458/var/run/saslauthd
459
460%files gssapi
461%defattr(-,root,root)
462%{_plugindir2}/*gssapi*.so*
463
464%files plain
465%defattr(-,root,root)
466%if %{includev1}
467%{_plugindir}/*plain*.so*
468%{_plugindir}/*plain*.la
469%{_plugindir}/*login*.so*
470%{_plugindir}/*login*.la
471%endif
472%{_plugindir2}/*plain*.so*
473%{_plugindir2}/*login*.so*
474
475%files md5
476%defattr(-,root,root)
477%if %{includev1}
478%{_plugindir}/*crammd5*.so*
479%{_plugindir}/*crammd5*.la
480%{_plugindir}/*digestmd5*.so*
481%{_plugindir}/*digestmd5*.la
482%endif
483%{_plugindir2}/*crammd5*.so*
484%{_plugindir2}/*digestmd5*.so*
485
486%files ntlm
487%defattr(-,root,root)
488%{_plugindir2}/*ntlm*.so*
489
490%files sql
491%defattr(-,root,root)
492%{_plugindir2}/*sql*.so*
493
494%files ldap
495%defattr(-,root,root)
496%{_plugindir2}/*ldapdb*.so*
497
498%files devel
499%defattr(-,root,root)
500%if %{includev1}
501%doc %{name}-%{version}/%{cs1_version}-devel
502%endif
503%doc %{name}-%{version}/doc/*.txt
504%defattr(-,root,root)
505%if %{includev1}
506%{_bindir}/sasl-sample-client
507%{_bindir}/sasl-sample-server
508%endif
509%{_bindir}/sasl2-sample-client
510%{_bindir}/sasl2-sample-server
511%{_includedir}/*
512%{_libdir}/libsasl*.so
513%if %{includev1}
514%{_plugindir}/*anonymous*.a
515%{_plugindir}/*crammd5*.a
516%{_plugindir}/*digestmd5*.a
517%{_plugindir}/*login*.a
518%{_plugindir}/*plain*.a
519%endif
520%{_mandir}/man3/*
521
522## to build compat32 for x86_64 architecture support
523%if %{build_compat32}
524%files -n compat32-%{name}
525%defattr(-,root,root)
526%{_libdir}/libsasl*.so.*
527%dir %{_plugindir2}/
528%{_plugindir2}/*anonymous*.so*
529%{_plugindir2}/*sasldb*.so*
530
531%files -n compat32-%{name}-gssapi
532%defattr(-,root,root)
533%{_plugindir2}/*gssapi*.so*
534
535%files -n compat32-%{name}-plain
536%defattr(-,root,root)
537%{_plugindir2}/*plain*.so*
538%{_plugindir2}/*login*.so*
539
540%files -n compat32-%{name}-md5
541%defattr(-,root,root)
542%{_plugindir2}/*crammd5*.so*
543%{_plugindir2}/*digestmd5*.so*
544
545%files -n compat32-%{name}-ntlm
546%defattr(-,root,root)
547%{_plugindir2}/*ntlm*.so*
548
549# %files -n compat32-%{name}-sql
550# %defattr(-,root,root)
551# %{_plugindir2}/*sql*.so*
552
553%files -n compat32-%{name}-ldap
554%defattr(-,root,root)
555%{_plugindir2}/*ldapdb*.so*
556
557%files -n compat32-%{name}-devel
558%defattr(-,root,root)
559%{_libdir}/libsasl*.so
560%endif
561
562
563%changelog
564* Mon Aug 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-10
565- add Vendor/Distri Tags
566
567* Mon Aug 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-9
568- fixed pam support.
569- fixed MySQL support.
570
571* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.1.23-8
572- rebuilt with postgresql-9.0.3
573
574* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.23-7
575- rebuild with krb5-libs-1.8.2 and openssl-1.0.0d
576
577* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.23-6
578- rebuild with openssl-1.0.0c
579- add BuildRequires: groff
580
581* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
582- rebuilt with db4-4.8
583- updated Patch100: cyrus-sasl-2.1.22-db4.patch
584- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
585
586* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
587- dropped compat32-%%{name}-sql
588
589* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
590- added compat32 subpackages
591
592* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
593- rebuilt with MySQL-5.1.34.
594
595* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
596- new upstream release with security fix (CVE-2009-0688)
597- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
598  (No effect in Current VineSeed package)
599
600* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
601- rebuilt with openldap-2.4.11
602
603* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
604- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
605
606* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
607- added gssapi subpackage
608
609* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
610- rebuilt against db-4.6.21 with Patch100
611- import Patch27 from Fedora
612
613* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
614- updated to 2.1.22
615- added Patches from Fedora
616  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
617  - fix a typo in sasl_client_start(3) (#196066)
618  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
619  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
620    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
621    to a non-zero value, for testing purposes
622- added subpackages for the ldapdb auxprop support
623- added --disable-static option to %%configure
624
625* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
626- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
627- rebuilt with openssl-0.9.8
628
629* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
630- disable version 1 now (no VineSeed package require version 1)
631- enable ntlm subpackage now
632- rebuilt with new toolchain and db4-4.3.x
633
634* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
635- rebuilt for VineSeed
636
637* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
638- SECURITY FIX for Vine 3.2: CVE-2006-1721
639   - add 23_CVE-2006-1721.diff ( Patch16 )
640       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
641
642* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
643- rebuild for VineSeed
644
645* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
646- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
647  from Mandrakelinux.
648
649* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
650- rebuilt with db4-4.2.52
651
652* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
653- new upstream release
654- rebuild with openssl-0.9.7d
655- import some patch from fedora package
656
657* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
658- new upstream release
659- remove prereq initscripts
660- merged with fedora package
661  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
662  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
663  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
664  use it to seed the libc RNG only (#103378)
665  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
666  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
667  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
668  - install saslauthd's mdoc page instead of the pre-formatted man page, which
669    would get formatted again
670  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
671  - include testsaslauthd
672  - note in the README that the saslauthd protocol is different for v1 and v2,
673    so v1's clients can't talk to the v2 server
674  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
675  - add logic to build with gssapi libs in either /usr or /usr/kerberos
676  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
677  - update to 2.1.15
678  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
679  - update to 2.1.14
680
681* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
682- new upstream version
683- merged with rawhide version
684        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
685        -- - change -m argument to saslauthd to be a directory instead of a path
686        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
687        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
688             can always be loaded
689        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
690        -- - update to 2.1.13
691- disable gssapi because Vine Linux don't support Kerberos
692
693* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
694- upstream release
695- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
696- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
697- added BuildPrereq: gdbm-devel, pam-devel
698
699* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
700- 1.5.24-17vl2
701- rebuilt with openssl-0.9.6b
702
703* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
704- merged Rawhide Package
705
706* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
707- build for Vine Linux
708- build with gcc-2.95.3
709- removed kerberos and gssapi
710
711* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
712- enable static libraries, but always build with -fPIC
713
714* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
715- make sure the version of 1.5.24 in the package matches the masters (#18968)
716
717* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
718- re-add the libsasl.so symlink to the -devel package (oops)
719
720* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
721- move .so files for modules to their respective packages -- they're not -devel
722  links meant for use by ld anyway
723
724* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
725- split off -devel subpackage
726- add a -gssapi subpackage for the gssapi plugins
727
728* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
729- fix the summary text
730
731* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
732- re-enable arcfour and CRAM
733
734* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
735- force use of gdbm for database files to avoid DB migration weirdness
736- enable login mechanism
737- disable gssapi until it can coexist peacefully with non-gssapi setups
738- actually do a make in the build section (#15410)
739
740* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
741- update to 1.5.24
742
743* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
744- automatic rebuild
745
746* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
747- rebuild in new environment (release 3)
748
749* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
750- don't muck with syslogd in post
751- remove patch for db-3.0 wackiness, no longer needed
752
753* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
754- FHS cleanup
755- don't strip anything by default
756
757* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
758- fixed man pages not being gzipped
759
760* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
761- incorporated changes from Mads Kiilerich
762- release number is 1, not mk1
763
764* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
765- updated to sasl 1.5.11
766- configure --disable-krb4 --without-rc4 --disable-cram
767  because of missing libraries and pine having cram as default...
768- handle changing libsasl.so versions
769
770* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
771- changed group
772
773* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
774- first build for Powertools
Note: See TracBrowser for help on using the repository browser.