source: projects/specs/branches/6/c/cyrus-sasl/cyrus-sasl-vl.spec @ 7832

Revision 7832, 24.2 KB checked in by iwamoto, 11 years ago (diff)

cyrus-sasl: add patch for CVE-2013-4122

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 11%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43Patch102: configure.patch
44
45#security
46Patch200: cyrus-sasl-2.1.23_CVE-2013-4122.patch
47
48Buildroot: %{_tmppath}/%{name}-%{version}-root
49BuildRequires: autoconf, automake, libtool
50# Note: berkeley db for sasl2, gdbm for sasl1.
51BuildRequires: db4-devel, openssl-devel, pam-devel
52%if %{includev1}
53BuildRequires: gdbm-devel
54%endif
55BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
56BuildRequires: pkgconfig
57BuildRequires: krb5-devel
58BuildRequires: groff
59Requires(post): /sbin/ldconfig, chkconfig
60Requires(postun): /sbin/ldconfig, chkconfig
61
62Vendor: Project Vine
63Distribution: Vine Linux
64
65%description
66The %{name} package contains the Cyrus implementation of SASL.
67SASL is the Simple Authentication and Security Layer, a method for
68adding authentication support to connection-based protocols.
69
70%package devel
71Requires: %{name} = %{version}-%{release}
72Group: Development/Libraries
73Summary: Files needed for developing applications with Cyrus SASL.
74
75%description devel
76The %{name}-devel package contains files needed for developing and
77compiling applications which use the Cyrus SASL library.
78
79%package gssapi
80Requires: %{name} = %{version}-%{release}
81Group: System Environment/Libraries
82Summary: GSSAPI support for Cyrus SASL.
83
84%description gssapi
85The %{name}-gssapi package contains the Cyrus SASL plugins which
86support GSSAPI authentication. GSSAPI is commonly used for Kerberos
87authentication.
88
89%package plain
90Requires: %{name} = %{version}-%{release}
91Group: System Environment/Libraries
92Summary: PLAIN and LOGIN support for Cyrus SASL.
93
94%description plain
95The %{name}-plain package contains the Cyrus SASL plugins which support
96PLAIN and LOGIN authentication schemes.
97
98%package md5
99Requires: %{name} = %{version}-%{release}
100Group: System Environment/Libraries
101Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
102
103%description md5
104The %{name}-md5 package contains the Cyrus SASL plugins which support
105CRAM-MD5 and DIGEST-MD5 authentication schemes.
106
107%package ntlm
108Requires: %{name} = %{version}-%{release}
109Group: System Environment/Libraries
110Summary: NTLM support for Cyrus SASL.
111
112%description ntlm
113The %{name}-ntlm package contains the Cyrus SASL plugin which supports
114the NTLM authentication schemes.
115
116# This would more appropriately be named cyrus-sasl-auxprop-sql.
117%package sql
118#Requires: %{name}-lib = %{version}-%{release}
119Requires: %{name} = %{version}-%{release}
120Group: System Environment/Libraries
121Summary: SQL auxprop support for Cyrus SASL
122
123%description sql
124The %{name}-sql package contains the Cyrus SASL plugin which supports
125using a RDBMS for storing shared secrets.
126
127# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
128%package ldap
129#Requires: %{name}-lib = %{version}-%{release}
130Requires: %{name} = %{version}-%{release}
131Group: System Environment/Libraries
132Summary: LDAP auxprop support for Cyrus SASL
133
134%description ldap
135The %{name}-ldap package contains the Cyrus SASL plugin which supports using
136a directory server, accessed using LDAP, for storing shared secrets.
137
138
139## to build compat32 for x86_64 architecture support
140%package -n compat32-%{name}
141Summary: The Cyrus SASL library.
142Group: System Environment/Libraries
143
144%description -n compat32-%{name}
145The %{name} package contains the Cyrus implementation of SASL.
146SASL is the Simple Authentication and Security Layer, a method for
147adding authentication support to connection-based protocols.
148
149%package -n compat32-%{name}-devel
150Group: Development/Libraries
151Summary: Files needed for developing applications with Cyrus SASL.
152
153%description -n compat32-%{name}-devel
154The %{name}-devel package contains files needed for developing and
155compiling applications which use the Cyrus SASL library.
156
157%package -n compat32-%{name}-gssapi
158Group: System Environment/Libraries
159Summary: GSSAPI support for Cyrus SASL.
160
161%description -n compat32-%{name}-gssapi
162The %{name}-gssapi package contains the Cyrus SASL plugins which
163support GSSAPI authentication. GSSAPI is commonly used for Kerberos
164authentication.
165
166%package -n compat32-%{name}-plain
167Group: System Environment/Libraries
168Summary: PLAIN and LOGIN support for Cyrus SASL.
169
170%description -n compat32-%{name}-plain
171The %{name}-plain package contains the Cyrus SASL plugins which support
172PLAIN and LOGIN authentication schemes.
173
174%package -n compat32-%{name}-md5
175Group: System Environment/Libraries
176Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
177
178%description -n compat32-%{name}-md5
179The %{name}-md5 package contains the Cyrus SASL plugins which support
180CRAM-MD5 and DIGEST-MD5 authentication schemes.
181
182%package -n compat32-%{name}-ntlm
183Group: System Environment/Libraries
184Summary: NTLM support for Cyrus SASL.
185
186%description -n compat32-%{name}-ntlm
187The %{name}-ntlm package contains the Cyrus SASL plugin which supports
188the NTLM authentication schemes.
189
190# %package -n compat32-%{name}-sql
191# Group: System Environment/Libraries
192# Summary: SQL auxprop support for Cyrus SASL
193
194# %description -n compat32-%{name}-sql
195# The %{name}-sql package contains the Cyrus SASL plugin which supports
196# using a RDBMS for storing shared secrets.
197
198%package -n compat32-%{name}-ldap
199Group: System Environment/Libraries
200Summary: LDAP auxprop support for Cyrus SASL
201
202%description -n compat32-%{name}-ldap
203The %{name}-ldap package contains the Cyrus SASL plugin which supports using
204a directory server, accessed using LDAP, for storing shared secrets.
205
206%prep
207%setup -q -c -a 2
208%if %{includev1}
209pushd cyrus-sasl-%{cs1_version}
210%patch0 -p1 -b .rpath
211%patch1 -p1 -b .autoconf25
212%patch2 -p1 -b .automake17
213%patch3 -p1 -b .automake18
214%patch4 -p1 -b .saslauthd2
215%patch5 -p1 -b .CVE-2009-0688
216libtoolize -f -c
217aclocal -I config -I cmulocal
218automake -a -c -f
219autoheader
220autoconf -f
221popd
222%endif
223
224pushd cyrus-sasl-%{version}
225chmod -x doc/*.html
226chmod -x include/*.h
227%patch10 -p1 -b .db_bundle
228%patch11 -p1 -b .no_rpath
229%patch15 -p1 -b .path
230%patch24 -p1 -b .sizes
231%patch25 -p1 -b .typo
232%patch26 -p2 -b .digest-commas
233%patch27 -p1 -b .automake-1.10
234%patch28 -p1 -b .keytab
235
236%patch100 -p1 -b .db48
237%patch101 -p1 -b .gcc44
238%patch102 -p0 -b .configure
239
240%patch200 -p1 -b .CVE-2013-4122
241
242# FIXME - we remove these files directly so that we can avoid using the -f
243# flag, which has a nasty habit of overwriting files like COPYING.
244rm -f config/config.guess config/config.sub
245rm -f config/ltconfig config/ltmain.sh config/libtool.m4
246rm -fr autom4te.cache
247libtoolize -c
248aclocal -I config -I cmulocal
249automake -a -c
250autoheader
251autoconf
252
253pushd saslauthd
254rm -f config/config.guess config/config.sub
255rm -f config/ltconfig config/ltmain.sh config/libtool.m4
256rm -fr autom4te.cache
257libtoolize -c
258aclocal -I config -I ../cmulocal -I ../config
259automake -a -c
260autoheader
261autoconf
262popd
263
264%if %{includev1}
265# Sort of merge the docs.
266mkdir cyrus-sasl-%{version}/%{cs1_version}
267mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
268cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
269cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
270# Remove duplicate RFCs.
271pushd cyrus-sasl-%{version}/%{cs1_version}-devel
272for file in * ; do
273        if [ -f ../doc/${file} ] ; then
274                rm -f ${file}
275        fi
276done
277popd
278%endif
279
280%build
281%if %{includev1}
282pushd cyrus-sasl-%{cs1_version}
283%configure \
284        --enable-static --enable-staticdlopen --with-pic --enable-shared \
285        --with-plugindir=%{_plugindir} \
286        --disable-krb4 \
287        --with-rc4 \
288        --with-dblib=gdbm \
289        --enable-anon \
290        --enable-cram \
291        --enable-digest \
292        --enable-plain \
293        --enable-login
294make %{?_smp_mflags} sasldir=%{_plugindir}
295popd
296%endif
297
298pushd cyrus-sasl-%{version}
299CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
300
301# Find OpenSSL.
302LIBS="-lcrypt"; export LIBS
303if pkg-config openssl ; then
304        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
305        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
306        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
307fi
308
309# Find the SQL libraries used needed by the SQL auxprop plugin.
310mysql_config=mysql_config
311pg_config=pg_config
312SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
313SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
314SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
315SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
316SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
317echo $SQL_LDFLAGS
318SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
319echo $SQL_LIBS
320
321cleanup_flags() {
322        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
323               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
324               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
325               -e 's,[[:blank:]]+, ,g'
326}
327CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
328CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
329LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
330
331%configure \
332        --disable-static --enable-shared --disable-java \
333        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
334        --disable-krb4 \
335        --with-rc4 \
336        --with-dblib=berkeley \
337        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
338        --with-ldap \
339        --with-devrandom=/dev/urandom \
340        --enable-anon \
341        --enable-cram \
342        --enable-digest \
343        --enable-ntlm \
344        --enable-plain \
345        --enable-login \
346        --disable-otp \
347        --enable-ldapdb \
348        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
349        --without-sqlite \
350        "$@"
351        # --enable-auth-sasldb -- EXPERIMENTAL
352make %{?_smp_mflags} sasldir=%{_plugindir2}
353make %{?_smp_mflags} -C saslauthd testsaslauthd
354make -C sample
355popd
356
357%install
358test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
359%if %{includev1}
360pushd cyrus-sasl-%{cs1_version}
361%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
362install -m755 -d $RPM_BUILD_ROOT%{_bindir}
363libtool --mode=install \
364install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
365libtool --mode=install \
366install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
367popd
368%endif
369
370pushd cyrus-sasl-%{version}
371make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
372make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
373
374install -m755 -d $RPM_BUILD_ROOT%{_bindir}
375./libtool --tag=CC --mode=install \
376install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
377./libtool --tag=CC --mode=install \
378install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
379./libtool --tag=CC --mode=install \
380install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
381./libtool --tag=CC --mode=install \
382install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
383
384# Install the saslauthd mdoc page in the expected location.  Sure, it's not
385# really a man page, but groff seems to be able to cope with it.
386install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
387install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
388
389# Create the saslauthd listening directory.
390install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
391
392# Install the init script for saslauthd and the init script's config file.
393install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
394install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
395install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
396popd
397
398# Install the config dirs if they're not already there.
399install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
400install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
401
402# Remove unpackaged files from the buildroot.
403rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
404rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
405rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
406rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
407rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
408
409%clean
410test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
411
412%post
413/sbin/ldconfig
414/sbin/chkconfig --add saslauthd
415
416%preun
417if [ $1 = 0 ] ; then
418        /sbin/chkconfig --del saslauthd
419fi
420
421%postun
422/sbin/ldconfig
423if [ $1 != 0 ] ; then
424        /sbin/service saslauthd condrestart 2>&1 > /dev/null
425fi
426
427%files
428%defattr(-,root,root)
429%if %{includev1}
430%doc %{name}-%{version}/%{cs1_version}
431%endif
432%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
433%doc $RPM_SOURCE_DIR/README.RPM
434%dir %{_sysconfdir}/sasl2
435%{_libdir}/libsasl*.so.*
436%if %{includev1}
437%dir %{_plugindir}/
438%endif
439%dir %{_plugindir2}/
440%if %{includev1}
441%{_plugindir}/*anonymous*.so*
442%{_plugindir}/*anonymous*.la
443%endif
444%{_plugindir2}/*anonymous*.so*
445%{_plugindir2}/*sasldb*.so*
446%{_mandir}/man8/*
447%{_sbindir}/dbconverter-2
448%if %{includev1}
449%{_sbindir}/saslpasswd
450%{_sbindir}/sasldblistusers
451%endif
452%{_sbindir}/saslpasswd2
453%{_sbindir}/sasldblistusers2
454%{_sbindir}/pluginviewer
455%{_sbindir}/saslauthd
456%{_sbindir}/testsaslauthd
457%config(noreplace) /etc/sysconfig/saslauthd
458%config /etc/rc.d/init.d/saslauthd
459/var/run/saslauthd
460
461%files gssapi
462%defattr(-,root,root)
463%{_plugindir2}/*gssapi*.so*
464
465%files plain
466%defattr(-,root,root)
467%if %{includev1}
468%{_plugindir}/*plain*.so*
469%{_plugindir}/*plain*.la
470%{_plugindir}/*login*.so*
471%{_plugindir}/*login*.la
472%endif
473%{_plugindir2}/*plain*.so*
474%{_plugindir2}/*login*.so*
475
476%files md5
477%defattr(-,root,root)
478%if %{includev1}
479%{_plugindir}/*crammd5*.so*
480%{_plugindir}/*crammd5*.la
481%{_plugindir}/*digestmd5*.so*
482%{_plugindir}/*digestmd5*.la
483%endif
484%{_plugindir2}/*crammd5*.so*
485%{_plugindir2}/*digestmd5*.so*
486
487%files ntlm
488%defattr(-,root,root)
489%{_plugindir2}/*ntlm*.so*
490
491%files sql
492%defattr(-,root,root)
493%{_plugindir2}/*sql*.so*
494
495%files ldap
496%defattr(-,root,root)
497%{_plugindir2}/*ldapdb*.so*
498
499%files devel
500%defattr(-,root,root)
501%if %{includev1}
502%doc %{name}-%{version}/%{cs1_version}-devel
503%endif
504%doc %{name}-%{version}/doc/*.txt
505%defattr(-,root,root)
506%if %{includev1}
507%{_bindir}/sasl-sample-client
508%{_bindir}/sasl-sample-server
509%endif
510%{_bindir}/sasl2-sample-client
511%{_bindir}/sasl2-sample-server
512%{_includedir}/*
513%{_libdir}/libsasl*.so
514%if %{includev1}
515%{_plugindir}/*anonymous*.a
516%{_plugindir}/*crammd5*.a
517%{_plugindir}/*digestmd5*.a
518%{_plugindir}/*login*.a
519%{_plugindir}/*plain*.a
520%endif
521%{_mandir}/man3/*
522
523## to build compat32 for x86_64 architecture support
524%if %{build_compat32}
525%files -n compat32-%{name}
526%defattr(-,root,root)
527%{_libdir}/libsasl*.so.*
528%dir %{_plugindir2}/
529%{_plugindir2}/*anonymous*.so*
530%{_plugindir2}/*sasldb*.so*
531
532%files -n compat32-%{name}-gssapi
533%defattr(-,root,root)
534%{_plugindir2}/*gssapi*.so*
535
536%files -n compat32-%{name}-plain
537%defattr(-,root,root)
538%{_plugindir2}/*plain*.so*
539%{_plugindir2}/*login*.so*
540
541%files -n compat32-%{name}-md5
542%defattr(-,root,root)
543%{_plugindir2}/*crammd5*.so*
544%{_plugindir2}/*digestmd5*.so*
545
546%files -n compat32-%{name}-ntlm
547%defattr(-,root,root)
548%{_plugindir2}/*ntlm*.so*
549
550# %files -n compat32-%{name}-sql
551# %defattr(-,root,root)
552# %{_plugindir2}/*sql*.so*
553
554%files -n compat32-%{name}-ldap
555%defattr(-,root,root)
556%{_plugindir2}/*ldapdb*.so*
557
558%files -n compat32-%{name}-devel
559%defattr(-,root,root)
560%{_libdir}/libsasl*.so
561%endif
562
563
564%changelog
565* Mon Sep 16 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-11
566- add patch200 for fix CVE-2013-4122 (NULL ptr. dereference)
567
568* Mon Aug 22 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-10
569- add Vendor/Distri Tags
570
571* Mon Aug 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-9
572- fixed pam support.
573- fixed MySQL support.
574
575* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.1.23-8
576- rebuilt with postgresql-9.0.3
577
578* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.23-7
579- rebuild with krb5-libs-1.8.2 and openssl-1.0.0d
580
581* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.23-6
582- rebuild with openssl-1.0.0c
583- add BuildRequires: groff
584
585* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
586- rebuilt with db4-4.8
587- updated Patch100: cyrus-sasl-2.1.22-db4.patch
588- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
589
590* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
591- dropped compat32-%%{name}-sql
592
593* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
594- added compat32 subpackages
595
596* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
597- rebuilt with MySQL-5.1.34.
598
599* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
600- new upstream release with security fix (CVE-2009-0688)
601- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
602  (No effect in Current VineSeed package)
603
604* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
605- rebuilt with openldap-2.4.11
606
607* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
608- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
609
610* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
611- added gssapi subpackage
612
613* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
614- rebuilt against db-4.6.21 with Patch100
615- import Patch27 from Fedora
616
617* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
618- updated to 2.1.22
619- added Patches from Fedora
620  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
621  - fix a typo in sasl_client_start(3) (#196066)
622  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
623  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
624    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
625    to a non-zero value, for testing purposes
626- added subpackages for the ldapdb auxprop support
627- added --disable-static option to %%configure
628
629* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
630- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
631- rebuilt with openssl-0.9.8
632
633* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
634- disable version 1 now (no VineSeed package require version 1)
635- enable ntlm subpackage now
636- rebuilt with new toolchain and db4-4.3.x
637
638* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
639- rebuilt for VineSeed
640
641* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
642- SECURITY FIX for Vine 3.2: CVE-2006-1721
643   - add 23_CVE-2006-1721.diff ( Patch16 )
644       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
645
646* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
647- rebuild for VineSeed
648
649* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
650- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
651  from Mandrakelinux.
652
653* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
654- rebuilt with db4-4.2.52
655
656* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
657- new upstream release
658- rebuild with openssl-0.9.7d
659- import some patch from fedora package
660
661* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
662- new upstream release
663- remove prereq initscripts
664- merged with fedora package
665  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
666  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
667  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
668  use it to seed the libc RNG only (#103378)
669  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
670  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
671  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
672  - install saslauthd's mdoc page instead of the pre-formatted man page, which
673    would get formatted again
674  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
675  - include testsaslauthd
676  - note in the README that the saslauthd protocol is different for v1 and v2,
677    so v1's clients can't talk to the v2 server
678  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
679  - add logic to build with gssapi libs in either /usr or /usr/kerberos
680  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
681  - update to 2.1.15
682  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
683  - update to 2.1.14
684
685* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
686- new upstream version
687- merged with rawhide version
688        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
689        -- - change -m argument to saslauthd to be a directory instead of a path
690        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
691        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
692             can always be loaded
693        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
694        -- - update to 2.1.13
695- disable gssapi because Vine Linux don't support Kerberos
696
697* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
698- upstream release
699- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
700- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
701- added BuildPrereq: gdbm-devel, pam-devel
702
703* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
704- 1.5.24-17vl2
705- rebuilt with openssl-0.9.6b
706
707* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
708- merged Rawhide Package
709
710* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
711- build for Vine Linux
712- build with gcc-2.95.3
713- removed kerberos and gssapi
714
715* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
716- enable static libraries, but always build with -fPIC
717
718* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
719- make sure the version of 1.5.24 in the package matches the masters (#18968)
720
721* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
722- re-add the libsasl.so symlink to the -devel package (oops)
723
724* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
725- move .so files for modules to their respective packages -- they're not -devel
726  links meant for use by ld anyway
727
728* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
729- split off -devel subpackage
730- add a -gssapi subpackage for the gssapi plugins
731
732* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
733- fix the summary text
734
735* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
736- re-enable arcfour and CRAM
737
738* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
739- force use of gdbm for database files to avoid DB migration weirdness
740- enable login mechanism
741- disable gssapi until it can coexist peacefully with non-gssapi setups
742- actually do a make in the build section (#15410)
743
744* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
745- update to 1.5.24
746
747* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
748- automatic rebuild
749
750* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
751- rebuild in new environment (release 3)
752
753* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
754- don't muck with syslogd in post
755- remove patch for db-3.0 wackiness, no longer needed
756
757* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
758- FHS cleanup
759- don't strip anything by default
760
761* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
762- fixed man pages not being gzipped
763
764* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
765- incorporated changes from Mads Kiilerich
766- release number is 1, not mk1
767
768* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
769- updated to sasl 1.5.11
770- configure --disable-krb4 --without-rc4 --disable-cram
771  because of missing libraries and pine having cram as default...
772- handle changing libsasl.so versions
773
774* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
775- changed group
776
777* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
778- first build for Powertools
Note: See TracBrowser for help on using the repository browser.