source: projects/specs/branches/6/c/curl/curl-vl.spec @ 9240

Revision 9240, 12.9 KB checked in by iwamoto, 9 years ago (diff)

curl: fix CVE-2014-8150

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 8%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# patch making libcurl multilib ready
20Patch101: 0101-curl-7.32.0-multilib.patch
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.32.0-debug.patch
23# make the curl tool link SSL libraries also used by src/tool_metalink.c
24Patch103: 0103-curl-7.32.0-metalink.patch
25# use localhost6 instead of ip6-localhost in the curl test-suite
26Patch104: 0104-curl-7.19.7-localhost6.patch
27# disable valgrind for certain test-cases (libssh2 problem)
28Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
29# work around valgrind bug (#678518)
30Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
31
32# Fix character encoding of docs, which are of mixed encoding originally so
33# a simple iconv can't fix them
34Patch108: 0108-curl-7.32.0-utf8.patch
35
36# Security fixes
37Patch200: curl-7.32.0_CVE-2013-4545.patch
38Patch210: http://curl.haxx.se/cve-2013-6422.patch
39Patch220: curl-7.32.0_CVE-2014-0015.patch
40Patch230: curl-7.32.0_CVE-2014-0138.patch
41Patch240: http://curl.haxx.se/libcurl-reject-cert-ip-wildcards.patch
42Patch250: curl-7.32.0_CVE-2014-3613.patch
43Patch260: curl-7.32.0_CVE-2014-3620.patch
44Patch270: curl-7.32.0_CVE-2014-3707.patch
45Patch280: curl-7.32.0_CVE-2014-8150.patch
46
47BuildRoot: %{_tmppath}/%{name}-%{version}-root
48BuildRequires: openssl-devel libidn-devel zlib-devel
49BuildRequires: openldap-devel gnutls-devel
50BuildRequires: openssh-server
51BuildRequires: openssh-clients
52BuildRequires: pkgconfig
53%if "%{?_dist_release}" != "vl6"
54BuildRequires: libssh2-devel
55%endif
56Requires: ca-certificates
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%description
63cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
64Dict servers, using any of the supported protocols. cURL is designed
65to work without user interaction or any kind of interactivity. cURL
66offers many useful capabilities, like proxy support, user
67authentication, FTP upload, HTTP post, and file transfer resume.
68
69%package devel
70Summary: Files needed for building applications with libcurl.
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73Requires: openssl-devel libidn-devel zlib-devel
74
75%description devel
76cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
77Dict servers, using any of the supported protocols. The curl-devel
78package includes files needed for developing applications which can
79use cURL's capabilities internally.
80#'
81
82
83## to build compat32 for x86_64 architecture support
84%package -n compat32-%{name}
85Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
86Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
87Group: System Environment/Libraries
88
89%description -n compat32-%{name}
90cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
91Dict servers, using any of the supported protocols. cURL is designed
92to work without user interaction or any kind of interactivity. cURL
93offers many useful capabilities, like proxy support, user
94authentication, FTP upload, HTTP post, and file transfer resume.
95
96%package -n compat32-%{name}-devel
97Summary: Files needed for building applications with libcurl.
98Group: Development/Libraries
99
100%description -n compat32-%{name}-devel
101cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
102Dict servers, using any of the supported protocols. The curl-devel
103package includes files needed for developing applications which can
104use cURL's capabilities internally.
105#'
106
107%prep
108%setup -q
109
110# upstream patches
111%patch1 -p1
112%patch2 -p1
113
114# Fedora patches
115%patch101 -p1
116%patch102 -p1
117%patch103 -p1
118%patch104 -p1
119%patch106 -p1
120%patch107 -p1
121%patch108 -p1
122
123# Security fixes
124%patch200 -p1 -b .CVE-2013-4545
125%patch210 -p1 -b .CVE-2013-6422
126%patch220 -p1 -b .CVE-2014-0015
127%patch230 -p1 -b .CVE-2014-0138
128%patch240 -p1 -b .CVE-2014-0139
129%patch250 -p1 -b .CVE-2014-3613
130%patch260 -p1 -b .CVE-2014-3620
131%patch270 -p1 -b .CVE-2014-3707
132%patch280 -p1 -b .CVE-2014-8150
133
134%build
135%configure \
136  --with-ssl=%{_prefix} \
137  --with-gnutls \
138  --with-libidn \
139  --enable-ipv6 \
140  --enable-threaded-resolver \
141  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
142%if "%{?_dist_release}" != "vl6"
143  --with-libssh2 \
144%endif
145  --enable-ldaps \
146  --disable-static
147
148make %{?_smp_mflags}
149
150%install
151rm -rf $RPM_BUILD_ROOT
152make DESTDIR=$RPM_BUILD_ROOT install
153
154rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
155
156%clean
157rm -rf $RPM_BUILD_ROOT
158
159%post -p /sbin/ldconfig
160
161%postun -p /sbin/ldconfig
162
163%files
164%defattr(-,root,root)
165%doc CHANGES COPYING README
166%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
167%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
168%doc docs/TheArtOfHttpScripting docs/TODO
169%{_bindir}/curl
170#{_datadir}/curl/*
171%{_libdir}/*.so.*
172%{_mandir}/man1/*.1*
173
174%files devel
175%defattr(-,root,root)
176%{_bindir}/curl-config
177%{_includedir}/curl
178%{_libdir}/*.so
179%{_libdir}/pkgconfig/*.pc
180%{_mandir}/man1/curl-config.1*
181%{_mandir}/man3/*
182
183
184## to build compat32 for x86_64 architecture support
185%if %{build_compat32}
186%files -n compat32-%{name}
187%defattr(-,root,root)
188%{_libdir}/*.so.*
189
190%files -n compat32-%{name}-devel
191%defattr(-,root,root)
192%{_libdir}/*.so
193%{_libdir}/pkgconfig/*.pc
194%endif
195
196%changelog
197* Sun Jan 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-8
198- add patch280 for fix CVE-2014-8150
199- fix changelog typo...
200
201* Sat Nov  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-7
202- add patch270 for fix CVE-2014-3707
203  (This pacth is from fc20, thanks)
204
205* Sun Sep 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-6
206- add patch250 for fix CVE-2014-3613
207- add patch260 for fix CVE-2014-3620
208
209* Tue Apr 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-5
210- add patch230 for fix CVE-2014-0138 (wrong re-use of connections)
211  this patch is from fc20, thanks.
212- add patch240 for fix CVE-2014-0139 (IP address wildcard)
213
214* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
215- add patch212 for fix CVE-2014-0015 (NTLM auth)
216
217* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
218- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
219
220* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
221- add patch200 for fix CVE-2013-4545 (cert name check ignore)
222
223* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
224- new upstream release
225- import upstream/fedora patches
226- disable libssh2 on Vine Linux 6
227
228* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
229- new upstream reelase
230
231* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
232- update to 7.28.0
233- add configure options
234  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
235- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
236 
237- use ca-certificates package
238  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
239  - R: ca-certificates
240
241* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
242- new upstream release
243
244* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
245- add patch100 for fix CVE-2011-2192 (gssapi)
246- add Vendor/Distri tags
247
248* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
249- rebuild with openssl-1.0.0c
250
251* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
252- rebuilt with rpm-4.8.1 for pkg-config
253
254* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
255- new upstream release
256
257* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
258- new upstream release with security fix
259
260* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
261- added compat32 subpackages
262
263* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
264- new upstream release
265- use "_smp_mflags" flag
266
267* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
268- rebuild with openldap-2.4.11
269- add BR: openldap-devel
270- remove static library
271
272* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
273- new upstream release with security fix (CVE-2009-0037)
274
275* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
276- new upstream release
277
278* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
279- new upstream release
280
281* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
282- new upstream release
283
284* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
285- new upstream release
286
287* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
288- new upstream release
289
290* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
291- rebuilt with openssl-0.9.8e
292
293* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
294- new upstream release
295
296* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
297- new upstream release
298
299* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
300- new upstream release
301- add pkgconfig file to devel package
302
303* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
304- new upstream release
305
306* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
307- new upstream release
308
309* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
310- new upstream release
311
312* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
313- added libidn, zlib in Requires
314- added libidn-devel, zlib-devel in BuildPrereq
315- added zlib-devel in curl-devel's Requires
316
317* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
318- added openssl-devel, libidn-devel in curl-devel's Requires
319
320* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
321- new upstream release
322
323* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
324- new upstream release
325- rebuild with openssl-0.9.7d
326
327* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
328- upstream release
329
330* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
331- add %%{_datadir}/curl/* to %%files section
332
333* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
334- source upgrade
335
336* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
337- source upgrade
338- add PreReq: ldconfig
339- add %%{_libdir}/*.la to %%files devel section
340
341* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
342- build for VineSeed
343- add Requires: openssl
344
345* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
346- automated rebuild
347
348* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
349- 7.9.2
350
351* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
352- include curl-config in curl-devel
353- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
354
355* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
356- added openssl-devel build req
357
358* Mon May 21 2001 Tim Powers <timp@redhat.com>
359- built for the distro
360
361* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
362- upgrade to curl-7.7.2.
363- enable IPv6.
364
365* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
366- rebuilt against openssl-0.9.6-1
367
368* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
369- fixed mising ldconfigs
370- updated to 7.5.2, bug fixes
371
372* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
373- updated to 7.5.1
374
375* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
376- update to 7.4.1 to fix bug #20337, problems with curl -c
377- not using patch anymore, it's included in the new source. Keeping
378  for reference
379
380* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
381- fix bogus req in -devel package
382
383* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
384- devel package needed defattr so that root owns the files
385
386* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
387- update to 7.3
388- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
389
390* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
391- enable SSL support
392- fix packager tag
393- move buildroot to %%{_tmppath}
394
395* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
396- fixed vendor tag for bug #15028
397
398* Mon Jul 24 2000 Prospector <prospector@redhat.com>
399- rebuilt
400
401* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
402- workaround alpha build problems with optimizations
403
404* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
405- rebuilt
406
407* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
408- put man pages in correct place
409- use %%makeinstall
410
411* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
412- updated to 6.5.2
413
414* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
415- updated sources to 6.2
416- gzip man page
417
418* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
419- changed group
420
421* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
422- changelog started
423- general cleanups, changed prefix to /usr, added manpage to files section
424- including in Powertools
Note: See TracBrowser for help on using the repository browser.