source: projects/specs/branches/6/c/curl/curl-vl.spec @ 9671

Revision 9671, 13.7 KB checked in by iwamoto, 9 years ago (diff)

curl: fix CVE-2015-3143,45,48

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.32.0
7Release: 9%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12
13Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
14
15# make sure that NSS is initialized prior to calling PK11_GenerateRandom()
16Patch1: 0001-curl-7.32.0-204126a5.patch
17# avoid delay if FTP is aborted in CURLOPT_HEADERFUNCTION callback (#1005686)
18Patch2: 0002-curl-7.32.0-c639d725.patch
19# auth failure on duplicated 'WWW-Authenticate: Negotiate' header (#1093348)
20Patch10: 0010-curl-7.32.0-ec5fde24.patch
21# fix endless loop with GSSAPI proxy auth (patches by David Woodhouse,
22# #1118751)
23Patch12: 0012-curl-7.32.0-gssapi.patch
24# patch making libcurl multilib ready
25Patch101: 0101-curl-7.32.0-multilib.patch
26# prevent configure script from discarding -g in CFLAGS (#496778)
27Patch102: 0102-curl-7.32.0-debug.patch
28# make the curl tool link SSL libraries also used by src/tool_metalink.c
29Patch103: 0103-curl-7.32.0-metalink.patch
30# use localhost6 instead of ip6-localhost in the curl test-suite
31Patch104: 0104-curl-7.19.7-localhost6.patch
32# disable valgrind for certain test-cases (libssh2 problem)
33Patch106: 0106-curl-7.21.0-libssh2-valgrind.patch
34# work around valgrind bug (#678518)
35Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
36# Fix character encoding of docs, which are of mixed encoding originally so
37# a simple iconv can't fix them
38Patch108: 0108-curl-7.32.0-utf8.patch
39
40# Security fixes
41Patch200: curl-7.32.0_CVE-2013-4545.patch
42Patch210: http://curl.haxx.se/cve-2013-6422.patch
43Patch220: curl-7.32.0_CVE-2014-0015-2.patch
44Patch230: curl-7.32.0_CVE-2014-0138-2.patch
45Patch240: http://curl.haxx.se/libcurl-reject-cert-ip-wildcards.patch
46Patch250: curl-7.32.0_CVE-2014-3613.patch
47Patch260: curl-7.32.0_CVE-2014-3620.patch
48Patch270: curl-7.32.0_CVE-2014-3707.patch
49Patch280: curl-7.32.0_CVE-2014-8150.patch
50Patch290: curl-7.32.0-CVE-2015-3143.patch
51Patch300: curl-7.32.0-CVE-2015-3145.patch
52Patch310: curl-7.32.0-CVE-2015-3148.patch
53
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55BuildRequires: openssl-devel libidn-devel zlib-devel
56BuildRequires: openldap-devel gnutls-devel
57BuildRequires: openssh-server
58BuildRequires: openssh-clients
59BuildRequires: pkgconfig
60%if "%{?_dist_release}" != "vl6"
61BuildRequires: libssh2-devel
62%endif
63Requires: ca-certificates
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: daisuke
68
69%description
70cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
71Dict servers, using any of the supported protocols. cURL is designed
72to work without user interaction or any kind of interactivity. cURL
73offers many useful capabilities, like proxy support, user
74authentication, FTP upload, HTTP post, and file transfer resume.
75
76%package devel
77Summary: Files needed for building applications with libcurl.
78Group: Development/Libraries
79Requires: %{name} = %{version}-%{release}
80Requires: openssl-devel libidn-devel zlib-devel
81
82%description devel
83cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
84Dict servers, using any of the supported protocols. The curl-devel
85package includes files needed for developing applications which can
86use cURL's capabilities internally.
87#'
88
89
90## to build compat32 for x86_64 architecture support
91%package -n compat32-%{name}
92Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
93Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
94Group: System Environment/Libraries
95
96%description -n compat32-%{name}
97cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
98Dict servers, using any of the supported protocols. cURL is designed
99to work without user interaction or any kind of interactivity. cURL
100offers many useful capabilities, like proxy support, user
101authentication, FTP upload, HTTP post, and file transfer resume.
102
103%package -n compat32-%{name}-devel
104Summary: Files needed for building applications with libcurl.
105Group: Development/Libraries
106
107%description -n compat32-%{name}-devel
108cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
109Dict servers, using any of the supported protocols. The curl-devel
110package includes files needed for developing applications which can
111use cURL's capabilities internally.
112#'
113
114%prep
115%setup -q
116
117# upstream patches
118%patch1 -p1
119%patch2 -p1
120%patch10 -p1
121%patch12 -p1
122
123# Fedora patches
124%patch101 -p1
125%patch102 -p1
126%patch103 -p1
127%patch104 -p1
128%patch106 -p1
129%patch107 -p1
130%patch108 -p1
131
132# Security fixes
133%patch200 -p1 -b .CVE-2013-4545
134%patch210 -p1 -b .CVE-2013-6422
135%patch220 -p1 -b .CVE-2014-0015
136%patch230 -p1 -b .CVE-2014-0138
137%patch240 -p1 -b .CVE-2014-0139
138%patch250 -p1 -b .CVE-2014-3613
139%patch260 -p1 -b .CVE-2014-3620
140%patch270 -p1 -b .CVE-2014-3707
141%patch280 -p1 -b .CVE-2014-8150
142%patch290 -p1 -b .CVE-2015-3143
143%patch300 -p1 -b .CVE-2015-3145
144%patch310 -p1 -b .CVE-2015-3148
145
146%build
147%configure \
148  --with-ssl=%{_prefix} \
149  --with-gnutls \
150  --with-libidn \
151  --enable-ipv6 \
152  --enable-threaded-resolver \
153  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
154%if "%{?_dist_release}" != "vl6"
155  --with-libssh2 \
156%endif
157  --enable-ldaps \
158  --disable-static
159
160make %{?_smp_mflags}
161
162%install
163rm -rf $RPM_BUILD_ROOT
164make DESTDIR=$RPM_BUILD_ROOT install
165
166rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
167
168%clean
169rm -rf $RPM_BUILD_ROOT
170
171%post -p /sbin/ldconfig
172
173%postun -p /sbin/ldconfig
174
175%files
176%defattr(-,root,root)
177%doc CHANGES COPYING README
178%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
179%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
180%doc docs/TheArtOfHttpScripting docs/TODO
181%{_bindir}/curl
182#{_datadir}/curl/*
183%{_libdir}/*.so.*
184%{_mandir}/man1/*.1*
185
186%files devel
187%defattr(-,root,root)
188%{_bindir}/curl-config
189%{_includedir}/curl
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_mandir}/man1/curl-config.1*
193%{_mandir}/man3/*
194
195
196## to build compat32 for x86_64 architecture support
197%if %{build_compat32}
198%files -n compat32-%{name}
199%defattr(-,root,root)
200%{_libdir}/*.so.*
201
202%files -n compat32-%{name}-devel
203%defattr(-,root,root)
204%{_libdir}/*.so
205%{_libdir}/pkgconfig/*.pc
206%endif
207
208%changelog
209* Mon Jul 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-9
210- add patch10,12 from fc20
211- update patch220,230 from fc20
212- add Patch290 for fix CVE-2015-3143
213- add Patch300 for fix CVE-2015-3145
214- add Patch310 for fix CVE-2015-3148
215
216* Sun Jan 11 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-8
217- add patch280 for fix CVE-2014-8150
218- fix changelog typo...
219
220* Sat Nov  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-7
221- add patch270 for fix CVE-2014-3707
222  (This pacth is from fc20, thanks)
223
224* Sun Sep 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-6
225- add patch250 for fix CVE-2014-3613
226- add patch260 for fix CVE-2014-3620
227
228* Tue Apr 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-5
229- add patch230 for fix CVE-2014-0138 (wrong re-use of connections)
230  this patch is from fc20, thanks.
231- add patch240 for fix CVE-2014-0139 (IP address wildcard)
232
233* Sat Feb  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-4
234- add patch212 for fix CVE-2014-0015 (NTLM auth)
235
236* Fri Dec 20 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-3
237- add patch210 for fix CVE-2013-6422 (certificate CN or SAN name field)
238
239* Tue Dec  3 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.32.0-2
240- add patch200 for fix CVE-2013-4545 (cert name check ignore)
241
242* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
243- new upstream release
244- import upstream/fedora patches
245- disable libssh2 on Vine Linux 6
246
247* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
248- new upstream reelase
249
250* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
251- update to 7.28.0
252- add configure options
253  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
254- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
255 
256- use ca-certificates package
257  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
258  - R: ca-certificates
259
260* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
261- new upstream release
262
263* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
264- add patch100 for fix CVE-2011-2192 (gssapi)
265- add Vendor/Distri tags
266
267* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
268- rebuild with openssl-1.0.0c
269
270* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
271- rebuilt with rpm-4.8.1 for pkg-config
272
273* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
274- new upstream release
275
276* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
277- new upstream release with security fix
278
279* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
280- added compat32 subpackages
281
282* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
283- new upstream release
284- use "_smp_mflags" flag
285
286* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
287- rebuild with openldap-2.4.11
288- add BR: openldap-devel
289- remove static library
290
291* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
292- new upstream release with security fix (CVE-2009-0037)
293
294* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
295- new upstream release
296
297* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
298- new upstream release
299
300* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
301- new upstream release
302
303* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
304- new upstream release
305
306* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
307- new upstream release
308
309* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
310- rebuilt with openssl-0.9.8e
311
312* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
313- new upstream release
314
315* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
316- new upstream release
317
318* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
319- new upstream release
320- add pkgconfig file to devel package
321
322* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
323- new upstream release
324
325* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
326- new upstream release
327
328* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
329- new upstream release
330
331* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
332- added libidn, zlib in Requires
333- added libidn-devel, zlib-devel in BuildPrereq
334- added zlib-devel in curl-devel's Requires
335
336* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
337- added openssl-devel, libidn-devel in curl-devel's Requires
338
339* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
340- new upstream release
341
342* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
343- new upstream release
344- rebuild with openssl-0.9.7d
345
346* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
347- upstream release
348
349* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
350- add %%{_datadir}/curl/* to %%files section
351
352* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
353- source upgrade
354
355* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
356- source upgrade
357- add PreReq: ldconfig
358- add %%{_libdir}/*.la to %%files devel section
359
360* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
361- build for VineSeed
362- add Requires: openssl
363
364* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
365- automated rebuild
366
367* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
368- 7.9.2
369
370* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
371- include curl-config in curl-devel
372- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
373
374* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
375- added openssl-devel build req
376
377* Mon May 21 2001 Tim Powers <timp@redhat.com>
378- built for the distro
379
380* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
381- upgrade to curl-7.7.2.
382- enable IPv6.
383
384* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
385- rebuilt against openssl-0.9.6-1
386
387* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
388- fixed mising ldconfigs
389- updated to 7.5.2, bug fixes
390
391* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
392- updated to 7.5.1
393
394* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
395- update to 7.4.1 to fix bug #20337, problems with curl -c
396- not using patch anymore, it's included in the new source. Keeping
397  for reference
398
399* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
400- fix bogus req in -devel package
401
402* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
403- devel package needed defattr so that root owns the files
404
405* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
406- update to 7.3
407- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
408
409* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
410- enable SSL support
411- fix packager tag
412- move buildroot to %%{_tmppath}
413
414* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
415- fixed vendor tag for bug #15028
416
417* Mon Jul 24 2000 Prospector <prospector@redhat.com>
418- rebuilt
419
420* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
421- workaround alpha build problems with optimizations
422
423* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
424- rebuilt
425
426* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
427- put man pages in correct place
428- use %%makeinstall
429
430* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
431- updated to 6.5.2
432
433* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
434- updated sources to 6.2
435- gzip man page
436
437* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
438- changed group
439
440* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
441- changelog started
442- general cleanups, changed prefix to /usr, added manpage to files section
443- including in Powertools
Note: See TracBrowser for help on using the repository browser.