source: projects/specs/branches/6/c/chromium14/chromium14-vl.spec @ 4605

Revision 4605, 29.3 KB checked in by munepi, 13 years ago (diff)

updated chromium13-vl.spec; NEW: chromium14

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15Name:           chromium14
16#Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        14.0.835.89
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-14.0.835.XXX.tar.bz2
28Source3:        pack_chromium14_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34# Set default prefs
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37##!!Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39Source99:       chrome-wrapper
40##!!Source100:      chromium-browser.sh
41Source100:      chromium-browser-vine.sh
42##!!Source101:      chromium-browser.desktop
43Source101:      chromium-browser-vine.desktop
44Source102:      chromium-browser.xml
45Source103:      chromium-browser-rpmlintrc
46##!!Source104:      chromium-icons.tar.bz2
47
48%{?nosrc:NoSource: 0}
49
50Provides:       chromium-unstable = %{version}-%{release}
51Obsoletes:      chromium13
52Conflicts:      chromium-stable
53# Provides:       chromium-stable = %{version}-%{release}
54# Conflicts:      chromium-unstable
55
56## Start Patches
57# OpenSuse and Fedora
58# Many changes to the gyp systems so we can use system libraries
59#Patch1:         chromium-gcc46.patch
60Patch4:         chromium-no-sqlite-debug.patch
61Patch8:         chromium-codechanges-zlib.patch
62Patch12:        chromium-no-test-sources.patch
63Patch13:        chromium-no-courgette.patch
64Patch14:        chromium-master-prefs-path.patch
65Patch17:        chromium-system-glew.patch
66Patch18:        chromium-system-expat.patch
67Patch19:        chromium-system-zlib.patch
68Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
69Patch21:        chromium-7.0.542.0-media-probe.patch
70Patch25:        tcmalloc-factory.patch
71Patch26:        chromium-remoting-build-fix.diff
72Patch28:        chromium-7.0.500.0-system-speex.patch
73Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
74Patch32:        chromium-7.0.542.0-system-libvpx.patch
75Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
76Patch62:        chromium-norpath.patch
77Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
78
79Patch999:       buildfix.patch
80
81# Vine
82Patch100:       chromium-14.0.835.31-no-tests.patch
83
84
85##!!BuildRequires:  Mesa-devel
86BuildRequires:  mesa-libGLU-devel
87##!!BuildRequires:  alsa-devel
88BuildRequires:  alsa-lib-devel
89BuildRequires:  pulseaudio-libs-devel
90BuildRequires:  bison
91BuildRequires:  cups-devel
92BuildRequires:  desktop-file-utils
93BuildRequires:  fdupes
94BuildRequires:  flex
95BuildRequires:  freetype2-devel
96BuildRequires:  gcc gcc-c++
97BuildRequires:  gperf
98BuildRequires:  hunspell-devel
99##!!BuildRequires:  libbz2-devel
100BuildRequires:  bzip2-devel
101BuildRequires:  libevent
102##!!BuildRequires:  libexpat-devel
103BuildRequires:  expat-devel
104##!!BuildRequires:  libgnutls-devel
105BuildRequires:  gnutls-devel
106BuildRequires:  libjpeg-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libstdc++-devel >= 4.4
109%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
110BuildRequires:  libxslt-devel
111BuildRequires:  libzip-devel
112##!!BuildRequires:  lzma
113BuildRequires:  xz
114##!!BuildRequires:  mozilla-nspr-devel
115BuildRequires:  nspr-devel
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118BuildRequires:  openssl-devel
119BuildRequires:  pam-devel
120##!!BuildRequires:  perl(Switch)
121BuildRequires:  perl
122##!!BuildRequires:  pkg-config
123BuildRequires:  cairo-devel >= 1.6
124BuildRequires:  dbus-devel
125##!!BuildRequires:  gconf2-devel
126BuildRequires:  GConf2-devel
127BuildRequires:  glib2-devel
128BuildRequires:  gtk2-devel
129BuildRequires:  libxml2-devel
130BuildRequires:  python
131##!!BuildRequires:  python-xml
132BuildRequires:  python-pyxml
133BuildRequires:  sqlite3-devel
134##!!BuildRequires:  update-desktop-files
135%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
136##!!BuildRequires:  wdiff
137BuildRequires:  zlib-devel
138
139BuildRequires:  libgnome-keyring-devel
140BuildRequires:  python-devel
141
142#BuildRequires:  glew-devel
143BuildRequires:  libevent-devel
144%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
145#BuildRequires:  libjingle-devel >= 0.4.0-7
146#BuildRequires:  srtp-devel
147BuildRequires:  speex-devel
148
149##Vine Linux
150#BuildRequires:  libpaper-devel
151BuildRequires:  libXScrnSaver-devel
152BuildRequires:  libXtst-devel
153BuildRequires:  libXdamage-devel
154BuildRequires:  libXt-devel
155%ifarch x86_64
156Requires:  nspluginwrapper
157%endif
158
159##!!Requires:       alsa
160Requires:       alsa-lib
161Requires:       pulseaudio-libs
162Requires:       xdg-utils
163%{?with_system_v8:Requires:       v8 = %{v8_ver}}
164
165BuildRoot:      %{_tmppath}/%{name}-%{version}-root
166
167%description
168Chromium is the open-source project behind Google Chrome.
169We invite you to join us in our effort to help build a safer, faster,
170and more stable way for all Internet users to experience the web,
171and to create a powerful platform for developing a new generation of
172web applications.
173
174%description -l ja
175Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
176ウェブを体験しているすべてのインターネットユーザに対して
177より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
178そして、ウェブアプリケーションの新しい世代を発展させ、
179強力なプラットホームを作成するために、
180私たちの取り組みにぜひ参加してください。
181
182
183%prep
184#%setup -q
185[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
186xz -dc %{SOURCE0} | %__tar -xf - || exit 1
187%setup -D -T -n %{pkgname}-%{version}
188
189#%patch1 -p1
190%patch62 -p1
191%{?with_system_v8:%patch63 -p1}
192%patch100 -p1 -b .vine
193%patch4 -p1
194%patch8 -p1
195%patch12 -p1
196%patch13 -p1
197%patch14 -p1
198%patch17 -p1
199%patch18 -p1
200%patch19 -p1
201%patch20 -p1
202%patch21 -p1
203%patch25 -p1
204%patch26 -p1
205%patch28 -p1
206%patch29 -p1
207%{?with_system_vpx:%patch32 -p1}
208%{?with_system_v8:%patch34 -p1}
209%patch999 -p1
210
211
212pushd src/third_party/ffmpeg/
213%__tar xf %{SOURCE8} || exit 1
214## built header file: avconfig.h
215[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
216cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
217/* Generated by ffconf */
218#ifndef AVUTIL_AVCONFIG_H
219#define AVUTIL_AVCONFIG_H
220#define AV_HAVE_BIGENDIAN 0
221#endif /* AVUTIL_AVCONFIG_H */
222EOF
223popd
224
225#%__rm -rf src/third_party/libvpx/
226%__rm -rf src/third_party/speex/
227%__rm -rf src/third_party/nss src/third_party/nspr
228
229# apply vendor patch after substitution
230%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
231
232%build
233
234## create make files
235
236PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
237for i in src/build/common.gypi; do
238        %__sed -i "s|'-march=pentium4',||g" $i
239        %__sed -i "s|'-mfpmath=sse',||g" $i
240        %__sed -i "s|'-O<(debug_optimize)',||g" $i
241        %__sed -i "s|'-m32',||g" $i
242        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
243        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
244done
245# '
246
247pushd src
248
249./build/gyp_chromium -f make build/all.gyp \
250    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
251    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
252    -Ddisable_nacl=1 \
253    -Duse_openssl=0 \
254    -Duse_system_ffmpeg=1 \
255    -Duse_system_zlib=1 \
256    -Duse_system_libpng=1 \
257    -Duse_system_bzip2=1 \
258    -Duse_system_libbz2=1 \
259    -Duse_system_libjpeg=1 \
260    -Duse_system_libxml=1 \
261    -Duse_system_libxslt=1 \
262    -Duse_system_libevent=1 \
263    %{?with_system_vpx:-Duse_system_vpx=1} \
264    %{!?with_system_vpx:-Duse_system_vpx=0} \
265    -Dremove_webcore_debug_symbols=1 \
266    %{?with_system_v8:-Duse_system_v8=1} \
267    %{!?with_system_v8:-Duse_system_v8=0} \
268    %{?with_system_icu:-Duse_system_icu=1} \
269    %{!?with_system_icu:-Duse_system_icu=0} \
270    %{?_with_shared_library:-Dlibrary=shared_library} \
271    -Dproprietary_codecs=1 \
272    -Djavascript_engine=v8 \
273    -Dlinux_fpic=1 \
274    -Ddisable_sse2=1 \
275    %ifarch %{ix86}
276        -Dtarget_arch=ia32 \
277    %endif
278    %ifarch x86_64
279        -Dtarget_arch=x64 \
280    %endif
281    -Dno_strict_aliasing=1 \
282    -Drelease_extra_cflags=-fPIC \
283    %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
284        -Dgcc_version=44 \
285    %endif
286    ;
287
288#%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
289%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
290
291popd
292
293%install
294%{__rm} -rf %{buildroot}
295
296%__mkdir -p %{buildroot}%{_bindir}
297%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
298# x86_64 capable systems need this
299%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
300%__mkdir -p %{buildroot}%{_libdir}/chromium/
301%__mkdir -p %{buildroot}%{_mandir}/man1/
302pushd src/out/Release
303%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
304%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
305%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
306%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
307%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
308%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
309%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
310fdupes %{buildroot}%{_mandir}/man1/
311popd
312
313%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
314%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
315for i in 16 22 24 32 48 64 128 256; do
316    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
317    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
318done
319
320%__mkdir_p %{buildroot}%{_datadir}/applications/
321desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
322
323%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
324%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
325
326# # link to browser plugin path.  Plugin patch doesn't work. Why?
327# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
328# pushd %{buildroot}%{_libdir}/%{pkgname}
329# %{__ln_s} %{_libdir}/browser-plugins plugins
330# popd
331pushd %{buildroot}%{_libdir}/%{pkgname}
332%ifarch x86_64
333%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
334%else
335%{__ln_s} %{_libdir}/mozilla/plugins plugins
336%endif
337
338## support ffmpeg libs
339touch %{buildroot}%{_libdir}/libavcodec.so.52
340%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
341touch %{buildroot}%{_libdir}/libavformat.so.52
342%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
343touch %{buildroot}%{_libdir}/libavutil.so.50
344%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
345popd
346
347# Install the master_preferences file
348%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
349#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
350%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
351#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
352
353%clean
354%{__rm} -rf %{buildroot}
355
356%post
357touch --no-create %{_datadir}/icons/hicolor
358if [ -x %{_bindir}/gtk-update-icon-cache ]; then
359  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
360fi
361%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
362
363%postun
364%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
365touch --no-create %{_datadir}/icons/hicolor
366if [ -x %{_bindir}/gtk-update-icon-cache ]; then
367  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
368fi || :
369
370
371%files
372%defattr(-,root,root,-)
373%config %{_sysconfdir}/%{pkgname}
374%dir %{_datadir}/gnome-control-center
375%dir %{_datadir}/gnome-control-center/default-apps
376%dir %{_libdir}/chromium/
377%{_bindir}/chromium
378%{_libdir}/chromium/chromium
379%{_libdir}/chromium/plugins/
380%{_libdir}/chromium/resources/
381%{_libdir}/chromium/xdg-settings
382%{_mandir}/man1/chrom*
383%{_datadir}/pixmaps/chromium-browser.png
384%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
385%{_datadir}/applications/*.desktop
386%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
387#%{_datadir}/icons/oxygen/
388%{_libdir}/chromium/chrome.pak
389%{_libdir}/chromium/resources.pak
390%{_libdir}/chromium/locales/
391%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
392%{_libdir}/chromium/libavcodec.so.52
393%{_libdir}/chromium/libavutil.so.50
394%{_libdir}/chromium/libavformat.so.52
395%exclude %{_libdir}/libavcodec.so.52
396%exclude %{_libdir}/libavutil.so.50
397%exclude %{_libdir}/libavformat.so.52
398
399%changelog
400* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
401- added Obsoletes: chromium-unstable < %{version}-%{release}
402
403* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
404- updated to 14.0.835.35
405- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
406- changed to Name: chromium14
407  - Provides:  chromium-unstable = %%{version}
408  - Conflicts: chromium-stable
409
410* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
411- changed to Name: chromium
412- updated to 13.0.782.107
413
414* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
415- updated to 13.0.782.88
416- added BuildRequires: libzip-devel
417- added Provides: chromium-unstable = %%{version}
418- added Conflicts: chromium-stable
419
420* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
421- fix user-agent string (chromium-vendor-vine.patch.in)
422  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
423
424* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
425- updated to 12.0.742.93
426- fixed icon field of chromium-browser-vine.desktop
427
428* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
429- updated to 12.0.742.91
430
431* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
432- updated to 12.0.742.77
433
434* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
435- updated to 12.0.742.63
436
437* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
438- updated to 12.0.742.42
439
440* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
441- updated to 12.0.742.6
442- dropped/upstreamed patches
443- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
444
445* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
446- updated to 11.0.696.50
447- dropped some Patches for MeeGo Netbook
448
449* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
450- updated to 11.0.696.35
451
452* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
453- updated to 11.0.696.29
454- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
455
456* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
457- updated to 11.0.696.22
458- improved chromium-browser-vine.sh
459  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
460
461* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
462- updated to 11.0.696.20
463- improved chromium-browser-vine.desktop
464
465* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
466- updated to 11.0.696.17
467
468* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
469- updated to 11.0.696.15
470  - ready for Vine Linux 6 release
471- dropped BuildRequires: v8-devel, libicu-devel
472
473* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
474- updated to 11.0.696.5 with v8 3.2.0
475- added BuildRequires: pam-devel
476
477* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
478- rebuilt with libevent-2.0.10
479
480* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
481- updated to 10.0.651.0 with v8 3.0.12
482- added BuildRequires:
483  - libpaper-devel
484  - python-devel
485- added built header file: libavutil/avconfig.h %%prep
486- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
487
488* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
489- updated to 10.0.622.0
490- added BuildRequires: libXt-devel
491
492* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
493- updated to 10.0.605.0
494- added BuildRequires:
495  - libXdamage-devel
496  - hunspell-devel
497
498* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
499- updated to 9.0.598
500
501* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
502- updated to 9.0.593
503
504* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
505- updated to 9.0.582
506- added Requires: xdg-utils
507
508* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
509- updated to 9.0.578
510
511* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
512- updated to 9.0.569
513
514  * Mon Oct 25 2010 tittiatcoke@gmail.com
515  - Update to 9.0.564 build
516    * Added specific patches for MeeGo.
517    * We are now using shared libraries for Chromium
518    * Spec-file cleanup (Thanks to prusnak)
519
520* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
521- updated to snapshot 8.0.556
522
523* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
524- updated to snapshot 8.0.551
525
526* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
527- updated to snapshot 7.0.527
528
529* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
530- updated to snapshot 7.0.519
531
532* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
533- updated to snapshot 7.0.513
534  - updated chromium-vendor-vine.patch.in
535
536* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
537- updated to snapshot 7.0.507
538
539* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
540- updated to snapshot 7.0.498
541
542* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
543- updated to snapshot 6.0.493
544- used with_system_icu (for vl6)
545  - added BuildRequires: libicu-devel
546
547* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
548- build for Vine Linux 5.x
549  - add BuildRequires: gnome-keyring-devel
550
551* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
552- updated to snapshot 6.0.454
553- added BuildRequires:
554  - sqlite3-devel
555  - gnutls-devel
556  - libgnome-keyring-devel
557
558* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
559- updated to snapshot 6.0.431.0 r49253
560- added BuildRequires: cups-devel
561
562* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
563- updated to snapshot 6.0.405.0 r47263
564
565* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
566- unused with_system_icu (for vl6)
567  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
568
569* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
570- updated to snapshot 5.0.378.0 r44472
571  - used with_system_icu (for vl6)
572  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
573
574* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
575- updated to snapshot 5.0.372.0 r43947
576- added BuildRequires: glew-devel
577- changed Group tag to Applications/Internet
578- added Summary(ja) and %%description -l ja
579
580* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
581- updated to snapshot 5.0.365.0 r42966
582- merged 5.0.353.0-4vl5
583 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
584 - build on Vine Linux 5.1
585   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
586
587* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
588- updated to snapshot 5.0.364.0 r42779
589
590* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
591- updated to snapshot 5.0.359.0 r42116
592- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
593
594* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
595- fixed master_preferences.vine, little
596
597* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
598- fixed to install master_preferences
599- dropped chromium-5.0.353-no-ffmpeg-vine.patch
600
601* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
602- applied chromium-5.0.353-no-ffmpeg-vine.patch
603
604* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
605- updated to snapshot 5.0.353.0 r41449
606  * Wed Mar 10 2010 bgmerrell@novell.com
607  - Add master_preferences source file and install it to /etc/chromium.
608  - Create a new patch (chromium-master-prefs-path.patch) which tells
609    chromium to look in /etc/chromium for the master_preferences file
610    (instead of looking in the default directory, which is the same
611    directory as the 'chrome' binary).
612
613* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
614- updated to snapshot 5.0.335.0 r39556
615
616* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
617- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
618
619* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
620- updated to snapshot 5.0.330.0 r39074
621
622* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
623- use_system_ffmpeg
624
625* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
626- added Requires:  nspluginwrapper
627- fixed a symbolic link of plugins directory with nspluginwrapper
628
629* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
630- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
631
632* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
633- added BuildRequires: mesa-libGLU-devel
634- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
635
636* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
637- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
638
639  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
640  - Update to 4.0.260
641  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
642  - Update to 4.0.259
643  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
644  - Update to 4.0.258
645  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
646  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
647    changed to having an built-in v8
648  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
649  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
650  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
651  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
652  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
653  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
654  - update to newer svn snapshot
655    + Obsoletes fwrite patch (included upstream)
656  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
657  - update to newer svn snapshot
658    + Requires newer version of v8
659  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
660  - do not force SSE on x86 (drop-sse.patch)
661  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
662  - Update to newer svn snapshot
663  - Fixed spec file in order to build
664  - Included patch to build with system zlib
665  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
666  - package renamed to chromium
667  - cleaned up spec file
668  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
669  - v8 is now built as a separate package, and is required
670  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
671  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
672  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
673  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
674  - initial build
675
676#% changelog
677* Sun Jan 24 2010 prusnak@suse.cz
678- added vendor to user agent (chromium-vendor.patch.in)
679* Sun Nov 29 2009 prusnak@suse.cz
680- added --enable-sync to wrapper to enable bookmark sync
681* Sun Nov 29 2009 tittiatcoke@gmail.com 
682- Update to 4.0.260
683* Fri Nov 27 2009 tittiatcoke@gmail.com 
684- Update to 4.0.259
685* Thu Nov 26 2009 tittiatcoke@gmail.com 
686- Update to 4.0.258
687* Tue Nov 24 2009 tittatcoke@gmai.com 
688- In order to complete prevent the wrong v8 version to be used,
689  the Chromium build has been changed to having an built-in v8
690* Tue Nov 24 2009 dbuck@example.com 
691- Re-base patches.
692- Fixed a few patch errors.
693- Rename some patches to better correspond with function.
694- Removed some patches.
695- Minor SPEC changes.
696- I changed the v8 requirement to be exact, instead of greater than a specific version.
697* Fri Nov 13 2009 tittiatcoke@gmail.com
698- update to 247.0 svn 31928
699* Fri Oct 30 2009 tittiatcoke@gmail.com
700- update to 229.0 svn 30454
701  + Fix regression where popups and app frames lost their titlebars.
702  + Makes it so that when a folder is open on the bookmark bar
703    and the mouse moves over another folder, the menu for that
704    folder is shown.
705  + Lazily create the find bar.
706  + Polish to the gmail checker sample.
707  * New, crisper icons that are exactly 19x19
708  * Add a loading animation at the beginning before Gmail
709    responds.
710  * Fix a bug where we sometimes don't update the UI after a
711    logout/login cycle.
712  + Refactor widget methods to support desktop notifications,
713    including GTK stubs.
714  + Find-in-page should not ding while deleting characters.
715  + Add SSL wrapper for linux and mac.  This allows notifier to
716    use chrome's SSL layer instead of OpenSSL.
717  + Add three of the six extensions to PAC that Internet Explorer supports.
718  + WebSocket support in chromium. (Run with --enable-web-sockets
719    enables WebSocket features.)
720  + Do not allow GTK File Chooser dialogs to return directories.
721  + Fix the notifier SSL layer to make notifications work for
722    Linux Bookmark sync.
723  + linux: don't override mouse selection behavior in omnibox
724* Sun Oct 25 2009 tittiatcoke@gmail.com
725- Update to 224.4 svn 30027
726  + First cut at new page and browser action docs based
727    on new API. Deleted old stuff.
728  + Add suppression for new memory leak caused by WebKit merge 49830:49844
729  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
730  + Minimize dependency of user scripts
731  + Fixup the flip_framer eof-handling semantics now that we have
732    the FIN bit in place
733  + app depends on x11 because of active_window_watcher_x
734  + Adding two images for the new Extension managment UI
735  + Removing hard-coded Chrome Frame output path
736  + Rearrange clipboard code
737  + Fix crash bug when attempting to download a url with unsupported scheme,
738    e.g. 'data:', by 'Alt + Click'
739  + GTK: Change text for extension download UI
740  + Ignore invalid urls on command line
741  + Make dropped tabs animate from where they were dropped.
742  + Make room for the full width of the tab placeholder.
743  + Make tab dragging as smooth as glass.
744  + Remove an annoying NOTIMPLEMNETED
745  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
746  + If we're in the middle of a drag, don't allow the user to middle
747    click to close or right click for the context menu
748  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
749  + Remove +x bit from files that shouldn't have it
750  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
751  + Adding new image needed for the managment UI
752  + Fix a race bug where content scripts would not apply to the first page load
753  + Make escape remove a bookmark if it's just been added (but not if it already existed)
754  + Fix bubbles deactivating the opaque frame
755  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
756  + ake all pepper plugins default to windowless and transparent
757  + Add styles for printing
758  + Implement the new extension management UI
759  + Add support for to automation interface load install and load extensions
760  + GTK: theme the info bar border
761  + Update V8 to version 1.3.16.1
762  + Introduce WebSecurityPolicy for security related methods
763  + New button scheme...borders are separate from the inner contents so
764    that they can be highlighted / depressed independently
765  + When opening Chrome maximized with an application window already
766    running, the Chrome window was not activated
767  + Fix compatibility problems with FileZilla FTP Server
768  + Remove the extension shelf on Linux
769  + Fix the proxy host and port string to start with http:// if it does not already
770  + Enable HTML5 databases for all extension renderer processes
771* Sat Oct 24 2009 prusnak@opensuse.org 
772- don't create desktop files in wrapper
773- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
774* Tue Oct 20 2009 tittiatcoke@gmail.com 
775- update to newer svn snapshot
776  + Obsoletes fwrite patch (included upstream)
777* Fri Oct 16 2009 tittiatcoke@gmail.com 
778- update to newer svn snapshot
779  + Requires newer version of v8
780* Thu Oct 15 2009 prusnak@suse.cz 
781- do not force SSE on x86 (drop-sse.patch)
782* Tue Oct 13 2009 tittiatcoke@gmail.com 
783- Update to newer svn snapshot
784- Fixed spec file in order to build
785- Included patch to build with system zlib
786* Mon Oct 12 2009 prusnak@suse.cz 
787- package renamed to chromium
788- cleaned up spec file
789* Tue Oct  6 2009 dbuck@example.com 
790- v8 is now built as a separate package, and is required
791- included many patches to use system libraries:
792    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
793* Thu Oct  1 2009 dbuck@example.com 
794- included a newer DEP than is in svn, native_client@823
795- things should compile cleanly now
796* Mon Aug 31 2009 dbuck@example.com 
797- initial build
Note: See TracBrowser for help on using the repository browser.