source: projects/specs/branches/6/c/chromium14/chromium14-vl.spec @ 4742

Revision 4742, 29.5 KB checked in by munepi, 13 years ago (diff)

updated chromium{13,14}-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15Name:           chromium14
16#Name:           chromium
17Summary:        Google's opens source browser project
18Summary(ja):    Googleのオープンソースウェブブラウザ
19#'
20Version:        14.0.835.157
21Release:        1%{?_dist_release}
22License:        BSD
23Group:          Applications/Internet
24Source0:        %{pkgname}-%{version}.tar.xz
25# Script used to create the %{pkgname}-%{version}.tar.xz archive from
26# a official tarball:
27# http://build.chromium.org/official/chromium-14.0.835.XXX.tar.bz2
28Source3:        pack_chromium14_source-vine.sh
29# Official ffmpeg headers
30Source8:        ffmpeg-0.6-headers.tar.xz
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34# Set default prefs
35##!!Source30:       master_preferences
36Source30:       master_preferences.vine
37##!!Source31:       default_bookmarks.html
38#Source31:       default_bookmarks.html.vine
39Source99:       chrome-wrapper
40##!!Source100:      chromium-browser.sh
41Source100:      chromium-browser-vine.sh
42##!!Source101:      chromium-browser.desktop
43Source101:      chromium-browser-vine.desktop
44Source102:      chromium-browser.xml
45Source103:      chromium-browser-rpmlintrc
46##!!Source104:      chromium-icons.tar.bz2
47
48%{?nosrc:NoSource: 0}
49
50Provides:       chromium-unstable = %{version}-%{release}
51Obsoletes:      chromium13
52Conflicts:      chromium-stable
53# Provides:       chromium-stable = %{version}-%{release}
54# Conflicts:      chromium-unstable
55
56## Start Patches
57# OpenSuse and Fedora
58# Many changes to the gyp systems so we can use system libraries
59#Patch1:         chromium-gcc46.patch
60Patch4:         chromium-no-sqlite-debug.patch
61Patch8:         chromium-codechanges-zlib.patch
62Patch12:        chromium-no-test-sources.patch
63Patch13:        chromium-no-courgette.patch
64Patch14:        chromium-master-prefs-path.patch
65Patch17:        chromium-system-glew.patch
66Patch18:        chromium-system-expat.patch
67Patch19:        chromium-system-zlib.patch
68Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
69Patch21:        chromium-7.0.542.0-media-probe.patch
70Patch25:        tcmalloc-factory.patch
71Patch26:        chromium-remoting-build-fix.diff
72Patch28:        chromium-7.0.500.0-system-speex.patch
73Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
74Patch32:        chromium-7.0.542.0-system-libvpx.patch
75Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
76Patch62:        chromium-norpath.patch
77Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
78
79Patch999:       buildfix.patch
80
81# Vine
82Patch100:       chromium-14.0.835.31-no-tests.patch
83
84
85##!!BuildRequires:  Mesa-devel
86BuildRequires:  mesa-libGLU-devel
87##!!BuildRequires:  alsa-devel
88BuildRequires:  alsa-lib-devel
89BuildRequires:  pulseaudio-libs-devel
90BuildRequires:  bison
91BuildRequires:  cups-devel
92BuildRequires:  desktop-file-utils
93BuildRequires:  fdupes
94BuildRequires:  flex
95BuildRequires:  freetype2-devel
96BuildRequires:  gcc gcc-c++
97BuildRequires:  gperf
98BuildRequires:  hunspell-devel
99##!!BuildRequires:  libbz2-devel
100BuildRequires:  bzip2-devel
101BuildRequires:  libevent
102##!!BuildRequires:  libexpat-devel
103BuildRequires:  expat-devel
104##!!BuildRequires:  libgnutls-devel
105BuildRequires:  gnutls-devel
106BuildRequires:  libjpeg-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libstdc++-devel >= 4.4
109%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
110BuildRequires:  libxslt-devel
111BuildRequires:  libzip-devel
112##!!BuildRequires:  lzma
113BuildRequires:  xz
114##!!BuildRequires:  mozilla-nspr-devel
115BuildRequires:  nspr-devel
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118BuildRequires:  openssl-devel
119BuildRequires:  pam-devel
120##!!BuildRequires:  perl(Switch)
121BuildRequires:  perl
122##!!BuildRequires:  pkg-config
123BuildRequires:  cairo-devel >= 1.6
124BuildRequires:  dbus-devel
125##!!BuildRequires:  gconf2-devel
126BuildRequires:  GConf2-devel
127BuildRequires:  glib2-devel
128BuildRequires:  gtk2-devel
129BuildRequires:  libxml2-devel
130BuildRequires:  python
131##!!BuildRequires:  python-xml
132BuildRequires:  python-pyxml
133BuildRequires:  sqlite3-devel
134##!!BuildRequires:  update-desktop-files
135%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
136##!!BuildRequires:  wdiff
137BuildRequires:  zlib-devel
138
139BuildRequires:  libgnome-keyring-devel
140BuildRequires:  python-devel
141
142#BuildRequires:  glew-devel
143BuildRequires:  libevent-devel
144%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
145#BuildRequires:  libjingle-devel >= 0.4.0-7
146#BuildRequires:  srtp-devel
147BuildRequires:  speex-devel
148
149##Vine Linux
150#BuildRequires:  libpaper-devel
151BuildRequires:  libXScrnSaver-devel
152BuildRequires:  libXtst-devel
153BuildRequires:  libXdamage-devel
154BuildRequires:  libXt-devel
155%ifarch x86_64
156Requires:  nspluginwrapper
157%endif
158
159##!!Requires:       alsa
160Requires:       alsa-lib
161Requires:       pulseaudio-libs
162Requires:       xdg-utils
163%{?with_system_v8:Requires:       v8 = %{v8_ver}}
164
165BuildRoot:      %{_tmppath}/%{name}-%{version}-root
166
167%description
168Chromium is the open-source project behind Google Chrome.
169We invite you to join us in our effort to help build a safer, faster,
170and more stable way for all Internet users to experience the web,
171and to create a powerful platform for developing a new generation of
172web applications.
173
174%description -l ja
175Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
176ウェブを体験しているすべてのインターネットユーザに対して
177より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
178そして、ウェブアプリケーションの新しい世代を発展させ、
179強力なプラットホームを作成するために、
180私たちの取り組みにぜひ参加してください。
181
182
183%prep
184#%setup -q
185[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
186xz -dc %{SOURCE0} | %__tar -xf - || exit 1
187%setup -D -T -n %{pkgname}-%{version}
188
189#%patch1 -p1
190%patch62 -p1
191%{?with_system_v8:%patch63 -p1}
192%patch100 -p1 -b .vine
193%patch4 -p1
194%patch8 -p1
195%patch12 -p1
196%patch13 -p1
197%patch14 -p1
198%patch17 -p1
199%patch18 -p1
200%patch19 -p1
201%patch20 -p1
202%patch21 -p1
203%patch25 -p1
204%patch26 -p1
205%patch28 -p1
206%patch29 -p1
207%{?with_system_vpx:%patch32 -p1}
208%{?with_system_v8:%patch34 -p1}
209%patch999 -p1
210
211
212pushd src/third_party/ffmpeg/
213%__tar xf %{SOURCE8} || exit 1
214## built header file: avconfig.h
215[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
216cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
217/* Generated by ffconf */
218#ifndef AVUTIL_AVCONFIG_H
219#define AVUTIL_AVCONFIG_H
220#define AV_HAVE_BIGENDIAN 0
221#endif /* AVUTIL_AVCONFIG_H */
222EOF
223popd
224
225#%__rm -rf src/third_party/libvpx/
226%__rm -rf src/third_party/speex/
227%__rm -rf src/third_party/nss src/third_party/nspr
228
229# apply vendor patch after substitution
230%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
231
232%build
233
234## create make files
235
236PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
237for i in src/build/common.gypi; do
238        %__sed -i "s|'-march=pentium4',||g" $i
239        %__sed -i "s|'-mfpmath=sse',||g" $i
240        %__sed -i "s|'-O<(debug_optimize)',||g" $i
241        %__sed -i "s|'-m32',||g" $i
242        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
243        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
244done
245# '
246
247pushd src
248
249./build/gyp_chromium -f make build/all.gyp \
250    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
251    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
252    -Ddisable_nacl=1 \
253    -Duse_openssl=0 \
254    -Duse_system_ffmpeg=1 \
255    -Duse_system_zlib=1 \
256    -Duse_system_libpng=1 \
257    -Duse_system_bzip2=1 \
258    -Duse_system_libbz2=1 \
259    -Duse_system_libjpeg=1 \
260    -Duse_system_libxml=1 \
261    -Duse_system_libxslt=1 \
262    -Duse_system_libevent=1 \
263    %{?with_system_vpx:-Duse_system_vpx=1} \
264    %{!?with_system_vpx:-Duse_system_vpx=0} \
265    -Dremove_webcore_debug_symbols=1 \
266    %{?with_system_v8:-Duse_system_v8=1} \
267    %{!?with_system_v8:-Duse_system_v8=0} \
268    %{?with_system_icu:-Duse_system_icu=1} \
269    %{!?with_system_icu:-Duse_system_icu=0} \
270    %{?_with_shared_library:-Dlibrary=shared_library} \
271    -Dproprietary_codecs=1 \
272    -Djavascript_engine=v8 \
273    -Dlinux_fpic=1 \
274    -Ddisable_sse2=1 \
275    %ifarch %{ix86}
276        -Dtarget_arch=ia32 \
277    %endif
278    %ifarch x86_64
279        -Dtarget_arch=x64 \
280    %endif
281    -Dno_strict_aliasing=1 \
282    -Drelease_extra_cflags=-fPIC \
283    %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
284        -Dgcc_version=44 \
285    %endif
286    ;
287
288#%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
289%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
290
291popd
292
293%install
294%{__rm} -rf %{buildroot}
295
296%__mkdir -p %{buildroot}%{_bindir}
297%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
298# x86_64 capable systems need this
299%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
300%__mkdir -p %{buildroot}%{_libdir}/chromium/
301%__mkdir -p %{buildroot}%{_mandir}/man1/
302pushd src/out/Release
303%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
304%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
305%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
306%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
307%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
308%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
309%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
310fdupes %{buildroot}%{_mandir}/man1/
311popd
312
313%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
314%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
315for i in 16 22 24 32 48 64 128 256; do
316    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
317    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
318done
319
320%__mkdir_p %{buildroot}%{_datadir}/applications/
321desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
322
323%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
324%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
325
326# # link to browser plugin path.  Plugin patch doesn't work. Why?
327# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
328# pushd %{buildroot}%{_libdir}/%{pkgname}
329# %{__ln_s} %{_libdir}/browser-plugins plugins
330# popd
331pushd %{buildroot}%{_libdir}/%{pkgname}
332%ifarch x86_64
333%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
334%else
335%{__ln_s} %{_libdir}/mozilla/plugins plugins
336%endif
337
338## support ffmpeg libs
339touch %{buildroot}%{_libdir}/libavcodec.so.52
340%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
341touch %{buildroot}%{_libdir}/libavformat.so.52
342%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
343touch %{buildroot}%{_libdir}/libavutil.so.50
344%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
345popd
346
347# Install the master_preferences file
348%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
349#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
350%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
351#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
352
353%clean
354%{__rm} -rf %{buildroot}
355
356%post
357touch --no-create %{_datadir}/icons/hicolor
358if [ -x %{_bindir}/gtk-update-icon-cache ]; then
359  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
360fi
361%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
362
363%postun
364%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
365touch --no-create %{_datadir}/icons/hicolor
366if [ -x %{_bindir}/gtk-update-icon-cache ]; then
367  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
368fi || :
369
370
371%files
372%defattr(-,root,root,-)
373%config %{_sysconfdir}/%{pkgname}
374%dir %{_datadir}/gnome-control-center
375%dir %{_datadir}/gnome-control-center/default-apps
376%dir %{_libdir}/chromium/
377%{_bindir}/chromium
378%{_libdir}/chromium/chromium
379%{_libdir}/chromium/plugins/
380%{_libdir}/chromium/resources/
381%{_libdir}/chromium/xdg-settings
382%{_mandir}/man1/chrom*
383%{_datadir}/pixmaps/chromium-browser.png
384%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
385%{_datadir}/applications/*.desktop
386%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
387#%{_datadir}/icons/oxygen/
388%{_libdir}/chromium/chrome.pak
389%{_libdir}/chromium/resources.pak
390%{_libdir}/chromium/locales/
391%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
392%{_libdir}/chromium/libavcodec.so.52
393%{_libdir}/chromium/libavutil.so.50
394%{_libdir}/chromium/libavformat.so.52
395%exclude %{_libdir}/libavcodec.so.52
396%exclude %{_libdir}/libavutil.so.50
397%exclude %{_libdir}/libavformat.so.52
398
399%changelog
400* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
401- updated to 14.0.835.157
402
403* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
404- updated to 14.0.835.102
405
406* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
407- updated to 14.0.835.89
408- added Obsoletes: chromium-unstable < %{version}-%{release}
409
410* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
411- updated to 14.0.835.35
412- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
413- changed to Name: chromium14
414  - Provides:  chromium-unstable = %%{version}
415  - Conflicts: chromium-stable
416
417* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
418- changed to Name: chromium
419- updated to 13.0.782.107
420
421* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
422- updated to 13.0.782.88
423- added BuildRequires: libzip-devel
424- added Provides: chromium-unstable = %%{version}
425- added Conflicts: chromium-stable
426
427* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
428- fix user-agent string (chromium-vendor-vine.patch.in)
429  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
430
431* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
432- updated to 12.0.742.93
433- fixed icon field of chromium-browser-vine.desktop
434
435* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
436- updated to 12.0.742.91
437
438* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
439- updated to 12.0.742.77
440
441* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
442- updated to 12.0.742.63
443
444* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
445- updated to 12.0.742.42
446
447* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
448- updated to 12.0.742.6
449- dropped/upstreamed patches
450- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
451
452* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
453- updated to 11.0.696.50
454- dropped some Patches for MeeGo Netbook
455
456* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
457- updated to 11.0.696.35
458
459* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
460- updated to 11.0.696.29
461- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
462
463* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
464- updated to 11.0.696.22
465- improved chromium-browser-vine.sh
466  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
467
468* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
469- updated to 11.0.696.20
470- improved chromium-browser-vine.desktop
471
472* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
473- updated to 11.0.696.17
474
475* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
476- updated to 11.0.696.15
477  - ready for Vine Linux 6 release
478- dropped BuildRequires: v8-devel, libicu-devel
479
480* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
481- updated to 11.0.696.5 with v8 3.2.0
482- added BuildRequires: pam-devel
483
484* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
485- rebuilt with libevent-2.0.10
486
487* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
488- updated to 10.0.651.0 with v8 3.0.12
489- added BuildRequires:
490  - libpaper-devel
491  - python-devel
492- added built header file: libavutil/avconfig.h %%prep
493- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
494
495* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
496- updated to 10.0.622.0
497- added BuildRequires: libXt-devel
498
499* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
500- updated to 10.0.605.0
501- added BuildRequires:
502  - libXdamage-devel
503  - hunspell-devel
504
505* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
506- updated to 9.0.598
507
508* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
509- updated to 9.0.593
510
511* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
512- updated to 9.0.582
513- added Requires: xdg-utils
514
515* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
516- updated to 9.0.578
517
518* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
519- updated to 9.0.569
520
521  * Mon Oct 25 2010 tittiatcoke@gmail.com
522  - Update to 9.0.564 build
523    * Added specific patches for MeeGo.
524    * We are now using shared libraries for Chromium
525    * Spec-file cleanup (Thanks to prusnak)
526
527* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
528- updated to snapshot 8.0.556
529
530* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
531- updated to snapshot 8.0.551
532
533* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
534- updated to snapshot 7.0.527
535
536* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
537- updated to snapshot 7.0.519
538
539* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
540- updated to snapshot 7.0.513
541  - updated chromium-vendor-vine.patch.in
542
543* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
544- updated to snapshot 7.0.507
545
546* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
547- updated to snapshot 7.0.498
548
549* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
550- updated to snapshot 6.0.493
551- used with_system_icu (for vl6)
552  - added BuildRequires: libicu-devel
553
554* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
555- build for Vine Linux 5.x
556  - add BuildRequires: gnome-keyring-devel
557
558* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
559- updated to snapshot 6.0.454
560- added BuildRequires:
561  - sqlite3-devel
562  - gnutls-devel
563  - libgnome-keyring-devel
564
565* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
566- updated to snapshot 6.0.431.0 r49253
567- added BuildRequires: cups-devel
568
569* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
570- updated to snapshot 6.0.405.0 r47263
571
572* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
573- unused with_system_icu (for vl6)
574  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
575
576* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
577- updated to snapshot 5.0.378.0 r44472
578  - used with_system_icu (for vl6)
579  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
580
581* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
582- updated to snapshot 5.0.372.0 r43947
583- added BuildRequires: glew-devel
584- changed Group tag to Applications/Internet
585- added Summary(ja) and %%description -l ja
586
587* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
588- updated to snapshot 5.0.365.0 r42966
589- merged 5.0.353.0-4vl5
590 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
591 - build on Vine Linux 5.1
592   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
593
594* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
595- updated to snapshot 5.0.364.0 r42779
596
597* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
598- updated to snapshot 5.0.359.0 r42116
599- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
600
601* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
602- fixed master_preferences.vine, little
603
604* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
605- fixed to install master_preferences
606- dropped chromium-5.0.353-no-ffmpeg-vine.patch
607
608* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
609- applied chromium-5.0.353-no-ffmpeg-vine.patch
610
611* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
612- updated to snapshot 5.0.353.0 r41449
613  * Wed Mar 10 2010 bgmerrell@novell.com
614  - Add master_preferences source file and install it to /etc/chromium.
615  - Create a new patch (chromium-master-prefs-path.patch) which tells
616    chromium to look in /etc/chromium for the master_preferences file
617    (instead of looking in the default directory, which is the same
618    directory as the 'chrome' binary).
619
620* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
621- updated to snapshot 5.0.335.0 r39556
622
623* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
624- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
625
626* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
627- updated to snapshot 5.0.330.0 r39074
628
629* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
630- use_system_ffmpeg
631
632* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
633- added Requires:  nspluginwrapper
634- fixed a symbolic link of plugins directory with nspluginwrapper
635
636* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
637- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
638
639* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
640- added BuildRequires: mesa-libGLU-devel
641- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
642
643* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
644- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
645
646  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
647  - Update to 4.0.260
648  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
649  - Update to 4.0.259
650  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
651  - Update to 4.0.258
652  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
653  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
654    changed to having an built-in v8
655  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
656  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
657  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
658  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
659  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
660  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
661  - update to newer svn snapshot
662    + Obsoletes fwrite patch (included upstream)
663  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
664  - update to newer svn snapshot
665    + Requires newer version of v8
666  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
667  - do not force SSE on x86 (drop-sse.patch)
668  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
669  - Update to newer svn snapshot
670  - Fixed spec file in order to build
671  - Included patch to build with system zlib
672  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
673  - package renamed to chromium
674  - cleaned up spec file
675  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
676  - v8 is now built as a separate package, and is required
677  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
678  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
679  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
680  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
681  - initial build
682
683#% changelog
684* Sun Jan 24 2010 prusnak@suse.cz
685- added vendor to user agent (chromium-vendor.patch.in)
686* Sun Nov 29 2009 prusnak@suse.cz
687- added --enable-sync to wrapper to enable bookmark sync
688* Sun Nov 29 2009 tittiatcoke@gmail.com 
689- Update to 4.0.260
690* Fri Nov 27 2009 tittiatcoke@gmail.com 
691- Update to 4.0.259
692* Thu Nov 26 2009 tittiatcoke@gmail.com 
693- Update to 4.0.258
694* Tue Nov 24 2009 tittatcoke@gmai.com 
695- In order to complete prevent the wrong v8 version to be used,
696  the Chromium build has been changed to having an built-in v8
697* Tue Nov 24 2009 dbuck@example.com 
698- Re-base patches.
699- Fixed a few patch errors.
700- Rename some patches to better correspond with function.
701- Removed some patches.
702- Minor SPEC changes.
703- I changed the v8 requirement to be exact, instead of greater than a specific version.
704* Fri Nov 13 2009 tittiatcoke@gmail.com
705- update to 247.0 svn 31928
706* Fri Oct 30 2009 tittiatcoke@gmail.com
707- update to 229.0 svn 30454
708  + Fix regression where popups and app frames lost their titlebars.
709  + Makes it so that when a folder is open on the bookmark bar
710    and the mouse moves over another folder, the menu for that
711    folder is shown.
712  + Lazily create the find bar.
713  + Polish to the gmail checker sample.
714  * New, crisper icons that are exactly 19x19
715  * Add a loading animation at the beginning before Gmail
716    responds.
717  * Fix a bug where we sometimes don't update the UI after a
718    logout/login cycle.
719  + Refactor widget methods to support desktop notifications,
720    including GTK stubs.
721  + Find-in-page should not ding while deleting characters.
722  + Add SSL wrapper for linux and mac.  This allows notifier to
723    use chrome's SSL layer instead of OpenSSL.
724  + Add three of the six extensions to PAC that Internet Explorer supports.
725  + WebSocket support in chromium. (Run with --enable-web-sockets
726    enables WebSocket features.)
727  + Do not allow GTK File Chooser dialogs to return directories.
728  + Fix the notifier SSL layer to make notifications work for
729    Linux Bookmark sync.
730  + linux: don't override mouse selection behavior in omnibox
731* Sun Oct 25 2009 tittiatcoke@gmail.com
732- Update to 224.4 svn 30027
733  + First cut at new page and browser action docs based
734    on new API. Deleted old stuff.
735  + Add suppression for new memory leak caused by WebKit merge 49830:49844
736  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
737  + Minimize dependency of user scripts
738  + Fixup the flip_framer eof-handling semantics now that we have
739    the FIN bit in place
740  + app depends on x11 because of active_window_watcher_x
741  + Adding two images for the new Extension managment UI
742  + Removing hard-coded Chrome Frame output path
743  + Rearrange clipboard code
744  + Fix crash bug when attempting to download a url with unsupported scheme,
745    e.g. 'data:', by 'Alt + Click'
746  + GTK: Change text for extension download UI
747  + Ignore invalid urls on command line
748  + Make dropped tabs animate from where they were dropped.
749  + Make room for the full width of the tab placeholder.
750  + Make tab dragging as smooth as glass.
751  + Remove an annoying NOTIMPLEMNETED
752  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
753  + If we're in the middle of a drag, don't allow the user to middle
754    click to close or right click for the context menu
755  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
756  + Remove +x bit from files that shouldn't have it
757  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
758  + Adding new image needed for the managment UI
759  + Fix a race bug where content scripts would not apply to the first page load
760  + Make escape remove a bookmark if it's just been added (but not if it already existed)
761  + Fix bubbles deactivating the opaque frame
762  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
763  + ake all pepper plugins default to windowless and transparent
764  + Add styles for printing
765  + Implement the new extension management UI
766  + Add support for to automation interface load install and load extensions
767  + GTK: theme the info bar border
768  + Update V8 to version 1.3.16.1
769  + Introduce WebSecurityPolicy for security related methods
770  + New button scheme...borders are separate from the inner contents so
771    that they can be highlighted / depressed independently
772  + When opening Chrome maximized with an application window already
773    running, the Chrome window was not activated
774  + Fix compatibility problems with FileZilla FTP Server
775  + Remove the extension shelf on Linux
776  + Fix the proxy host and port string to start with http:// if it does not already
777  + Enable HTML5 databases for all extension renderer processes
778* Sat Oct 24 2009 prusnak@opensuse.org 
779- don't create desktop files in wrapper
780- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
781* Tue Oct 20 2009 tittiatcoke@gmail.com 
782- update to newer svn snapshot
783  + Obsoletes fwrite patch (included upstream)
784* Fri Oct 16 2009 tittiatcoke@gmail.com 
785- update to newer svn snapshot
786  + Requires newer version of v8
787* Thu Oct 15 2009 prusnak@suse.cz 
788- do not force SSE on x86 (drop-sse.patch)
789* Tue Oct 13 2009 tittiatcoke@gmail.com 
790- Update to newer svn snapshot
791- Fixed spec file in order to build
792- Included patch to build with system zlib
793* Mon Oct 12 2009 prusnak@suse.cz 
794- package renamed to chromium
795- cleaned up spec file
796* Tue Oct  6 2009 dbuck@example.com 
797- v8 is now built as a separate package, and is required
798- included many patches to use system libraries:
799    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
800* Thu Oct  1 2009 dbuck@example.com 
801- included a newer DEP than is in svn, native_client@823
802- things should compile cleanly now
803* Mon Aug 31 2009 dbuck@example.com 
804- initial build
Note: See TracBrowser for help on using the repository browser.