source: projects/specs/branches/6/c/choqok/choqok-vl.spec @ 2775

Revision 2775, 4.9 KB checked in by inagaki, 13 years ago (diff)

updated: choqok, k3b, kaffeine, kdevelop, kdevplatform,

konversation, kde-partitionmanager, qjson, self-build-k3b-extra

NEW: skrooge

Line 
1%if %{?_dist_release} != "vl5"
2%define kde KDE
3%else
4%define kde KDE4
5%endif
6
7Summary: Choqok %{kde} Micro-Blogging Client
8Summary(ja): %{kde} マイクロブログクライアント
9Name: choqok
10Version: 1.0
11Release: 1%{?_dist_release}
12
13License: GPLv3
14Group: Applications/Internet
15URL: http://choqok.gnufolks.org/
16
17Source0: http://choqok.gnufolks.org/pkgs/%{name}-%{version}.tar.bz2
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: cmake >= 2.6
21BuildRequires: desktop-file-utils
22BuildRequires: kdelibs4-devel
23BuildRequires: gettext
24BuildRequires: qjson-devel
25BuildRequires: qoauth-devel
26BuildRequires: attica-devel
27%if %{?_dist_release} != "vl5"
28BuildRequires: libindicate-qt-devel
29%endif
30
31Requires: %{name}-libs = %{version}-%{release}
32
33%description
34A Free/Open Source micro-blogging client for %{kde}.
35The name comes from an ancient Persian word, which means Sparrow!
36Choqok currently supports Twitter.com and Identi.ca services.
37
38%package libs
39Summary: Runtime libraries for %{name}
40Summary(ja): %{name} のランタイムライブラリ
41Group:   System Environment/Libraries
42# Requires: %{name} = %{version}-%{release}
43# for kwallet, among other goodies
44Requires: kdebase-runtime
45
46%description libs
47%{summary}
48
49%package devel
50Summary:  Development files for %{name}
51Summary(ja): %{name} の開発用ファイル
52Group:    Development/Libraries
53Requires: %{name}-libs = %{version}-%{release}
54Requires: kdelibs4-devel
55
56%description devel
57%{summary}
58
59
60%prep
61%setup -q
62
63%build
64mkdir -p %{_target_platform}
65pushd %{_target_platform}
66unset QTDIR || : ; . /etc/profile.d/qt4.sh
67PATH=$PATH:%{_prefix}/kerberos/bin \
68%cmake \
69    -DCMAKE_BUILD_TYPE=release \
70    -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
71    -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
72    -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
73    -DLIB_INSTALL_DIR:PATH=%{_libdir} \
74    -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
75    -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
76    ..
77popd
78
79make %{?_smp_mflags} -C %{_target_platform}
80
81%install
82rm -rf %{buildroot}
83
84make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
85
86%find_lang %{name}
87
88%check
89desktop-file-validate %{buildroot}%{_datadir}/applications/kde4/choqok.desktop
90
91%clean
92rm -rf %{buildroot}
93
94%post
95touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96
97%postun
98if [ $1 -eq 0 ] ; then
99touch --no-create %{_datadir}/icons/hicolor &> /dev/null
100gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
101fi
102
103%posttrans
104gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
105
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc COPYING README AUTHORS changelog TODO
110%{_bindir}/choqok
111%{_libdir}/kde4/choqok_*.so
112%{_libdir}/kde4/kcm_choqok_*.so
113%{_libdir}/kde4/konqchoqokplugin.so
114%{_datadir}/icons/hicolor/*/actions/retweet.png
115%{_datadir}/icons/hicolor/*/apps/*.png
116%{_datadir}/applications/kde4/choqok.desktop
117%{_datadir}/config.kcfg/*.kcfg
118%{_datadir}/kde4/services/choqok_*.desktop
119%{_datadir}/kde4/apps/choqok
120%{_datadir}/kde4/apps/choqok_*/*.rc
121%{_datadir}/kde4/apps/dbus-1/services/*
122%{_datadir}/kde4/apps/khtml/kpartplugins/*
123%{_datadir}/kde4/services/ServiceMenus/*.desktop
124%{_datadir}/kde4/servicetypes/choqok*.desktop
125%doc %{_docdir}/HTML/*
126
127%files libs
128%defattr(-,root,root,-)
129%{_libdir}/lib*.so.*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/kde4/choqok
134%{_libdir}/lib*.so
135%{_datadir}/kde4/apps/cmake/*
136
137
138%changelog
139* Sat Feb 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0-1
140- new upstream release
141
142* Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.98-1
143- new upstream release
144- added BR: qjson-devel, qoauth-devel
145
146* Sat May 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.55-15
147- initial build for Vine Linux
148
149* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-14
150- Add dependency from -libs to choqok
151
152* Tue Mar 09 2010 Rex Dieter <rdieter@fedoraprojecdt.org> - 0.9.55-13
153- Requires: kdebase-runtime (not kdeutils)
154
155* Tue Mar 09 2010 Tejas Dinkar <tejas@gja.in> - 0.9.55-12
156- choqok 1.0-beta
157
158* Wed Sep 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.6.6-9
159- add icon/desktop-file scriptlets
160
161* Sun Aug 16 2009 Tejas Dinkar <tejas@gja.in> - 0.6.6-8
162- Added Dependency on kdeutils
163- Choqok 0.6.6 is out
164
165* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-8
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
167
168* Sun Jun 14 2009 Tejas Dinkar <tejas@gja.in> - 0.6.1-7
169- Choqok 0.6.1 is out with the below two patches
170
171* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-6
172- Fixed the inreplyto (via patch)
173
174* Sat Jun 13 2009 Tejas Dinkar <tejas@gja.in> - 0.6-5
175- Fixed the twitpocalypse (via patch)
176
177* Wed May 27 2009 Tejas Dinkar <tejas@gja.in> - 0.6-4
178- Changed to 0.6
179
180* Fri Apr 10 2009 Tejas Dinkar <tejas@gja.in> - 0.5-3
181- Added the TweetAll patch, remove this by 0.6
182
183* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-2
184- Added AUTHORS changelog and TODO to doc
185
186* Fri Mar 27 2009 Tejas Dinkar <tejas@gja.in> - 0.5-1
187- Initial Version for Fedora
Note: See TracBrowser for help on using the repository browser.