source: projects/specs/branches/6/c/check/check-vl.spec @ 1958

Revision 1958, 3.0 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Summary:        A unit test framework for C
2Summary(ja):    C 言語用単体テストフレームワーク
3Name:           check
4Version:        0.9.8
5Release:        2%{?_dist_release}
6License:        LGPL
7Group:          Development/Tools
8URL:            http://check.sourceforge.net/
9Source0:        http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
10Patch0:         %{name}-examples-bootstrap.patch
11Patch1:         check-0.9.5-fPIC.patch
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  docbook-utils
14Requires(post,preun): /sbin/install-info
15
16Vendor:         Project Vine
17Distribution:   Vine Linux
18Packager:       USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
19
20%description
21Check is a unit test framework for C. It features a simple interface
22for defining unit tests, putting little in the way of the developer.
23Tests are run in a separate address space, so Check can catch both
24assertion failures and code errors that cause segmentation faults or
25other signals. The output from unit tests can be used within source
26code editors and IDEs.
27
28
29%package devel
30Summary:        Libraries and headers for developing programs with check
31Summary(ja):    Check を使ったプログラム開発用ライブラリとヘッダファイル
32Group:          Development/Libraries
33Requires:       pkgconfig
34Requires:       %{name} = %{version}-%{release}
35
36%description devel
37Libraries and headers for developing programs with check
38
39
40%prep
41%setup -q
42%patch0 -p1
43#patch1 -p1 -b .fPIC
44
45
46%build
47%configure --disable-static
48make %{?_smp_mflags}
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%makeinstall
54rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
55rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
56
57rm -rf example
58cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
59rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post
67/sbin/ldconfig
68/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
69
70
71%postun -p /sbin/ldconfig
72
73%preun
74if [ $1 = 0 ]; then
75    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
76fi
77
78
79%files
80%defattr(-,root,root)
81%doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
82%{_libdir}/libcheck.so.*
83%{_infodir}/check.info*
84
85
86%files devel
87%defattr(-,root,root)
88%doc example
89%{_includedir}/check.h
90%{_libdir}/libcheck.so
91%{_libdir}/pkgconfig/check.pc
92%{_datadir}/aclocal/check.m4
93
94
95%changelog
96* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
97- rebuilt with rpm-4.8.1 for pkg-config
98
99* Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
100- new upstream release
101- dropt Patch1
102
103* Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
104- spec in UTF-8
105- split devel subpackage
106
107* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
108- new upstream release
109- updated Patch1
110
111* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
112- enable -fPIC to build gstreamer on x86_64
113
114* Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
115- upstream release
116- add BuildRequires: docbook-utils instead of lyx
117
118* Fri Aug  1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
119- Rebuild for new Vine.
120
121* Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
122- Initial build.
123
Note: See TracBrowser for help on using the repository browser.