source: projects/specs/branches/6/b/bzip2/bzip2-vl.spec @ 6579

Revision 6579, 8.9 KB checked in by iwamoto, 12 years ago (diff)

bzip2: fix CVE-2010-0405

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define buildpdf 0
3
4Summary:     A file compression utility.
5Summary(ja): ファイル圧縮ユーティリティ
6Name: bzip2
7Version: 1.0.5
8Release: 6%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11URL: http://www.bzip.org/
12Source: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
13Patch: bzip2-1.0.5-autoconflibtoolize.patch
14Patch1: bzip2-1.0.5-saneso.patch
15
16# P2 implements a progress counter (in %). It also
17# display the percentage of the original file the new file is (size).
18# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
19Patch2: bzip2-1.0.2.diff.bz2
20
21# Security Patches
22# Patch3: bzip2-1.0.2-tempfile.patch
23# Patch4: bzip2-1.0.2-chmod.patch
24# Patch5: bzip2-1.0.2-NULL-ptr-check.patch
25# Patch6: bzip2-1.0.2-bzgrep.patch
26Patch7: bzip2-1.0.5_CVE-2010-0405.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29
30%if %buildpdf
31BuildRequires: tetex-dvips tetex-latex
32%endif
33BuildRequires: texinfo
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39Bzip2 is a freely available, patent-free, high quality data compressor.
40Bzip2 compresses files to within 10 to 15 percent of the capabilities
41of the best techniques available.  However, bzip2 has the added benefit
42of being approximately two times faster at compression and six times
43faster at decompression than those techniques.  Bzip2 is not the
44fastest compression utility, but it does strike a balance between speed
45and compression capability.
46
47Install bzip2 if you need a compression utility.
48
49
50%package devel
51Summary: Header files and libraries for developing apps which will use bzip2.
52Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55
56%description devel
57Header files and a static library of bzip2 functions, for developing apps
58which will use the library.
59
60## to build compat32 for x86_64 architecture support
61%package -n compat32-%{name}
62Summary: A file compression utility.
63Summary(ja): ファイル圧縮ユーティリティ
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description -n compat32-%{name}
68Bzip2 is a freely available, patent-free, high quality data compressor.
69Bzip2 compresses files to within 10 to 15 percent of the capabilities
70of the best techniques available.  However, bzip2 has the added benefit
71of being approximately two times faster at compression and six times
72faster at decompression than those techniques.  Bzip2 is not the
73fastest compression utility, but it does strike a balance between speed
74and compression capability.
75
76Install bzip2 if you need a compression utility.
77
78%package -n compat32-%{name}-devel
79Summary: Header files and libraries for developing apps which will use bzip2.
80Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
81Group: Development/Libraries
82Requires: compat32-%{name} = %{version}-%{release}
83Requires: %{name}-devel = %{version}-%{release}
84
85%description -n compat32-%{name}-devel
86Header files and a static library of bzip2 functions, for developing apps
87which will use the library.
88
89%prep
90%setup -q
91
92%patch -p1 -b .autoconf
93%patch1 -p1
94%patch2 -p1
95
96%patch7 -p1 -b .CVE-2010-0405
97
98cp CHANGES ChangeLog
99mv CHANGES NEWS
100mv LICENSE COPYING
101cp m4/largefile.m4 .
102chmod a+x configure
103libtoolize -f --automake
104aclocal
105autoconf
106automake -a --foreign
107autoheader
108
109%build
110%configure --libdir=%{_libdir} --enable-shared --disable-static
111make
112
113%if %buildpdf
114texi2dvi --pdf manual.texi
115%endif
116
117%install
118rm -rf %{buildroot}
119
120%makeinstall
121
122cp bzgrep %{buildroot}%{_bindir}
123chmod 0755 %{buildroot}%{_bindir}/bzgrep
124
125rm -f %{buildroot}%{_libdir}/*.{a,la}
126
127%post -p /sbin/ldconfig
128
129%postun -p /sbin/ldconfig
130
131%post -n compat32-%{name} -p /sbin/ldconfig
132
133%postun -n compat32-%{name} -p /sbin/ldconfig
134
135%clean
136rm -rf %{buildroot}
137
138%files
139%defattr(-,root,root)
140%doc AUTHORS COPYING README README.COMPILATION.PROBLEMS NEWS ChangeLog
141%{_bindir}/*
142%{_mandir}/*/*
143%{_libdir}/*so.*
144
145%files devel
146%defattr(-,root,root)
147%{_includedir}/*
148%{_libdir}/*so
149
150## to build compat32 for x86_64 architecture support
151%if %{build_compat32}
152%files -n compat32-%{name}
153%defattr(-,root,root)
154%{_libdir}/*so.*
155
156%files -n compat32-%{name}-devel
157%defattr(-,root,root)
158%{_libdir}/*so
159%endif
160
161%changelog
162* Fri Jul 13 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-6vl6
163- add patch7 for fix CVE-2010-0405 (BZ2_decompress)
164
165
166* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
167- build on current VineSeed
168- update URL and Source0 tags URL
169
170* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
171- rebuild with new toolchain
172
173* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
174- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
175- removed unneccesary %if !%{build_compat32} case condition
176
177* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
178- spec in utf-8
179- remove static library
180
181* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
182- new upstream release with security fix
183- drop old patches (patch3-6) which are included in new release
184- build under new versioning policy
185
186* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
187- changed Group to Applications/Archiving
188- changed compat32-bzip2 Group to System Environment/Libraries
189
190* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
191- new upstream release
192- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
193
194* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
195- fixed %%postun (missing to build as scriptlet by invalid comment)
196
197* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
198- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
199
200* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
201- added compat32- packages for x86_64 architecture support
202- changed autoconf-2.13 to current autoconf
203
204* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
205- added patch 1 from Rawhide 1.0.2-8
206- added patch 2 from Mandrake 1.0.2-14mdk
207
208* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
209- previous patch is so incomplete that "bzip2 -f" fails.
210  instead, update the source which fixes this and other bugs.
211
212* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
213- fix race condition.
214
215* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
216- 1.0.1-3vl2
217- added Japanese summary
218- rebuilt under new %%{_mandir} definition
219
220* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
221- build on Vine Linux with gcc-2.95.3
222- partially used rpmmacros
223 
224* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
225- new URL and source location
226
227* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
228- automatic rebuild
229
230* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
231- 1.0.1
232- ported my patch
233
234* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
235- FHS packaging to build on solaris2.5.1.
236- remove config.cache from autoconf patch.
237- sparc: use %%configure, but not the m4 macros.
238
239* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
240- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
241
242* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
243- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
244
245* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
246- use soft links, not hardlinks, for binaries
247- mv .so to devel
248
249* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
250- autoconfed and libtoolized package
251- fixed Copyright (it's BSD, not GPL)
252- dumped bzless (less works fine with bz2-files)
253- rewrote build and install parts
254- separated main package and devel package
255
256* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
257- 1.0pre8
258
259* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
260- Add bzgrep (a version of zgrep hacked to do bzip2)
261
262* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
263- handle compressed manpages
264
265* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
266- 0.9.5d
267- Update download URL, add URL: tag in header
268
269* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
270- upgrade to 0.9.5c.
271
272* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
273- install actual bzip2 binary, not libtool cruft.
274
275* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
276- run ldconfig to get shared library.
277
278* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
279- create shared libbz1.so.* library.
280
281* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
282- update to bzip2-0.9.0c.
283
284* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
285- auto rebuild in the new build environment (release 4)
286
287* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
288- build against glibc 2.1
289
290* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
291- force compilation with egcs to avoid gcc optimization bug (thank God
292  we haven't been beaten by it)
293
294* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
295- version 0.9.0b
296
297* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
298- updated to 0.9.0
299
300* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
301- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.