source: projects/specs/branches/6/b/bzip2/bzip2-vl.spec @ 10647

Revision 10647, 9.2 KB checked in by tomop, 8 years ago (diff)

bzip2-1.0.6-4

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define buildpdf 0
3
4Summary:     A file compression utility.
5Summary(ja): ファイル圧縮ユーティリティ
6Name: bzip2
7Version: 1.0.6
8Release: 4%{?_dist_release}
9License: BSD
10Group: Applications/Archiving
11URL: http://www.bzip.org/
12Source: http://www.bzip.org/%{version}/bzip2-%{version}.tar.gz
13Patch0: bzip2-1.0.5-autoconflibtoolize.patch
14Patch1: bzip2-1.0.4-saneso.patch
15Patch2: bzip2-1.0.4-cflags.patch
16Patch3: bzip2-1.0.4-bzip2recover.patch
17
18# P2 implements a progress counter (in %). It also
19# display the percentage of the original file the new file is (size).
20# URL: http://www.vanheusden.com/Linux/bzip2-1.0.2.diff.gz
21Patch10: bzip2-1.0.2.diff.bz2
22
23# security patch(es)
24Patch1000: CVE-2016-3189.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27
28%if %buildpdf
29BuildRequires: tetex-dvips tetex-latex
30%endif
31BuildRequires: texinfo
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Bzip2 is a freely available, patent-free, high quality data compressor.
38Bzip2 compresses files to within 10 to 15 percent of the capabilities
39of the best techniques available.  However, bzip2 has the added benefit
40of being approximately two times faster at compression and six times
41faster at decompression than those techniques.  Bzip2 is not the
42fastest compression utility, but it does strike a balance between speed
43and compression capability.
44
45Install bzip2 if you need a compression utility.
46
47
48%package devel
49Summary: Header files and libraries for developing apps which will use bzip2.
50Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description devel
55Header files and a static library of bzip2 functions, for developing apps
56which will use the library.
57
58## to build compat32 for x86_64 architecture support
59%package -n compat32-%{name}
60Summary: A file compression utility.
61Summary(ja): ファイル圧縮ユーティリティ
62Group: System Environment/Libraries
63Requires: %{name} = %{version}-%{release}
64
65%description -n compat32-%{name}
66Bzip2 is a freely available, patent-free, high quality data compressor.
67Bzip2 compresses files to within 10 to 15 percent of the capabilities
68of the best techniques available.  However, bzip2 has the added benefit
69of being approximately two times faster at compression and six times
70faster at decompression than those techniques.  Bzip2 is not the
71fastest compression utility, but it does strike a balance between speed
72and compression capability.
73
74Install bzip2 if you need a compression utility.
75
76%package -n compat32-%{name}-devel
77Summary: Header files and libraries for developing apps which will use bzip2.
78Summary(ja): bzip2 を使うプログラム開発に必要なヘッダファイルとライブラリ
79Group: Development/Libraries
80Requires: compat32-%{name} = %{version}-%{release}
81Requires: %{name}-devel = %{version}-%{release}
82
83%description -n compat32-%{name}-devel
84Header files and a static library of bzip2 functions, for developing apps
85which will use the library.
86
87%prep
88%setup -q
89
90%patch0 -p1 -b .autoconf
91%patch1 -p1 -b .saneso
92%patch2 -p1 -b .cflags
93%patch3 -p1 -b .bz2recover
94
95%patch10 -p1
96
97%patch1000 -p1 -b .CVE-2016-3189
98
99cp CHANGES ChangeLog
100mv CHANGES NEWS
101mv LICENSE COPYING
102cp m4/largefile.m4 .
103chmod a+x configure
104libtoolize -f --automake
105aclocal
106autoconf
107automake -a --foreign
108autoheader
109
110%build
111%configure --libdir=%{_libdir} --enable-shared --disable-static
112make
113
114%if %buildpdf
115texi2dvi --pdf manual.texi
116%endif
117
118%install
119rm -rf %{buildroot}
120
121%makeinstall
122
123cp bzgrep %{buildroot}%{_bindir}
124chmod 0755 %{buildroot}%{_bindir}/bzgrep
125
126rm -f %{buildroot}%{_libdir}/*.{a,la}
127
128%post -p /sbin/ldconfig
129
130%postun -p /sbin/ldconfig
131
132%post -n compat32-%{name} -p /sbin/ldconfig
133
134%postun -n compat32-%{name} -p /sbin/ldconfig
135
136%clean
137rm -rf %{buildroot}
138
139%files
140%defattr(-,root,root)
141%{!?_licensedir:%global license %%doc}
142%license COPYING
143%doc AUTHORS README README.COMPILATION.PROBLEMS NEWS ChangeLog
144%{_bindir}/*
145%{_mandir}/*/*
146%{_libdir}/*so.*
147
148%files devel
149%defattr(-,root,root)
150%{_includedir}/*
151%{_libdir}/*so
152
153## to build compat32 for x86_64 architecture support
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-,root,root)
157%{_libdir}/*so.*
158
159%files -n compat32-%{name}-devel
160%defattr(-,root,root)
161%{_libdir}/*so
162%endif
163
164%changelog
165* Tue Jul 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-4
166- fixed %%files.
167
168* Tue Jul  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.6-3
169- added Patch1000 to fix CVE-2016-3189.
170
171* Wed Jan  1 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.6-2
172- rebuilt with new vineseed toolchain
173
174* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
175- update to 1.0.6
176
177* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.5-5vl6
178- build on current VineSeed
179- update URL and Source0 tags URL
180
181* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
182- rebuild with new toolchain
183
184* Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.5-3
185- updated Patch0: bzip2-1.0.5-autoconflibtoolize.patch
186- removed unneccesary %if !%{build_compat32} case condition
187
188* Tue Mar 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
189- spec in utf-8
190- remove static library
191
192* Thu Mar 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-1
193- new upstream release with security fix
194- drop old patches (patch3-6) which are included in new release
195- build under new versioning policy
196
197* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl2
198- changed Group to Applications/Archiving
199- changed compat32-bzip2 Group to System Environment/Libraries
200
201* Tue Feb 21 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.3-0vl1
202- new upstream release
203- add Patch3-6 from Fedora Core (includes CAN-2005-0758/0953)
204
205* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl5
206- fixed %%postun (missing to build as scriptlet by invalid comment)
207
208* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl4
209- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
210
211* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
212- added compat32- packages for x86_64 architecture support
213- changed autoconf-2.13 to current autoconf
214
215* Mon May 05 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.0.2-0vl2
216- added patch 1 from Rawhide 1.0.2-8
217- added patch 2 from Mandrake 1.0.2-14mdk
218
219* Sun Sep 29 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.0.2-0vl1
220- previous patch is so incomplete that "bzip2 -f" fails.
221  instead, update the source which fixes this and other bugs.
222
223* Fri May 24 2002 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
224- fix race condition.
225
226* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
227- 1.0.1-3vl2
228- added Japanese summary
229- rebuilt under new %%{_mandir} definition
230
231* Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 1.0.1-3vl1
232- build on Vine Linux with gcc-2.95.3
233- partially used rpmmacros
234 
235* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
236- new URL and source location
237
238* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
239- automatic rebuild
240
241* Sat Jul 01 2000 Trond Eivind Glomsr <teg@redhat.com>
242- 1.0.1
243- ported my patch
244
245* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
246- FHS packaging to build on solaris2.5.1.
247- remove config.cache from autoconf patch.
248- sparc: use %%configure, but not the m4 macros.
249
250* Tue Jun 06 2000 Trond Eivind Glomsr <teg@redhat.com>
251- Use %%configure, %%makeinstall, %%{_manpath} and %%{_tmpdir}
252
253* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
254- 1.0.0 - ported my 1.0pre8 libtoolizedautoconf patch
255
256* Tue May 16 2000 Trond Eivind Glomsr <teg@redhat.com>
257- use soft links, not hardlinks, for binaries
258- mv .so to devel
259
260* Mon May 15 2000 Trond Eivind Glomsr <teg@redhat.com>
261- autoconfed and libtoolized package
262- fixed Copyright (it's BSD, not GPL)
263- dumped bzless (less works fine with bz2-files)
264- rewrote build and install parts
265- separated main package and devel package
266
267* Mon May  8 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
268- 1.0pre8
269
270* Fri Apr 14 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
271- Add bzgrep (a version of zgrep hacked to do bzip2)
272
273* Mon Feb  7 2000 Bill Nottingham <notting@redhat.com>
274- handle compressed manpages
275
276* Fri Dec 31 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
277- 0.9.5d
278- Update download URL, add URL: tag in header
279
280* Tue Aug 10 1999 Jeff Johnson <jbj@redhat.com>
281- upgrade to 0.9.5c.
282
283* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
284- install actual bzip2 binary, not libtool cruft.
285
286* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
287- run ldconfig to get shared library.
288
289* Mon Aug  2 1999 Jeff Johnson <jbj@redhat.com>
290- create shared libbz1.so.* library.
291
292* Sun Apr  4 1999 Jeff Johnson <jbj@redhat.com>
293- update to bzip2-0.9.0c.
294
295* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
296- auto rebuild in the new build environment (release 4)
297
298* Thu Dec 17 1998 Cristian Gafton <gafton@redhat.com>
299- build against glibc 2.1
300
301* Wed Sep 30 1998 Cristian Gafton <gafton@redhat.com>
302- force compilation with egcs to avoid gcc optimization bug (thank God
303  we haven't been beaten by it)
304
305* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
306- version 0.9.0b
307
308* Tue Sep 08 1998 Cristian Gafton <gafton@redhat.com>
309- updated to 0.9.0
310
311* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
312- first build for Manhattan
Note: See TracBrowser for help on using the repository browser.