source: projects/specs/branches/6/b/bind/bind-vl.spec @ 9359

Revision 9359, 21.4 KB checked in by iwamoto, 9 years ago (diff)

bind: update to 9.9.6-P2 to fix CVE-2015-1349

Line 
1%define _localstatedir /var
2
3%define pversion 9.9.6.P2
4%define sversion 9.9.6-P2
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 1%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23URL: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool readline-devel
27BuildRequires: libxml2-devel libcap-devel
28Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires(pre): shadow-utils
31Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
32Requires(post): bind-utils = %{bind_epoch}:%{version}-%{release}
33Requires(post): coreutils, chkconfig
34Requires(preun): initscripts, chkconfig
35Conflicts: bind9 <= 9.2.1-0vl5, bind-current
36Obsoletes: bind9 <= 9.2.1-0vl5
37Epoch: %{bind_epoch}
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%description
43BIND (Berkeley Internet Name Domain) is an implementation of the DNS
44(Domain Name System) protocols. BIND includes a DNS server (named),
45which resolves host names to IP addresses, and a resolver library
46(routines for applications to use when interfacing with DNS).  A DNS
47server allows clients to name resources or objects and share the
48information with other network machines.  The named DNS server can be
49used on workstations as a caching name server, but is generally only
50needed on one machine for an entire network.  Note that the
51configuration files for making BIND act as a simple caching nameserver
52are included in the caching-nameserver package. 
53
54Install the bind package if you need a DNS server for your network.  If
55you want bind to act a caching name server, you will also need to install
56the caching-nameserver package.
57
58
59%package libs
60Summary: Libraries used by various DNS packages
61Group: System Environment/Libraries
62Conflicts: bind-current-libs
63
64%description libs
65Contains libraries used by both the bind server package as well as the utils packages.
66
67
68%package utils
69Summary: Utilities for querying DNS name servers.
70Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
71Group: Applications/System
72Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
73Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
74Obsoletes: bind9-utils <= 9.2.1-0vl5
75
76
77%description utils
78Bind-utils contains a collection of utilities for querying DNS (Domain
79Name Service) name servers to find out information about Internet hosts.
80These tools will provide you with the IP addresses for given host names,
81as well as other information about registered domains and network
82addresses.
83
84You should install bind-utils if you need to get information from DNS name
85servers.
86
87
88%package devel
89Summary: Include files and libraries needed for bind DNS development.
90Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
91Group: Development/Libraries
92Requires: bind = %{bind_epoch}:%{version}-%{release}
93Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
94Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
95Obsoletes: bind9-devel <= 9.2.1-0vl5
96
97
98%description devel
99The bind-devel package contains all the include files and the
100library required for DNS (Domain Name Service) development for
101BIND versions 9.x.x.
102
103You should install bind-devel if you want to develop bind DNS
104applications. If you install bind-devel, you'll also need to install
105bind.
106#'
107
108%prep
109%setup -n bind-%{sversion} -q
110%patch1 -p1 -b .key
111perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
112
113%build
114libtoolize --copy --force
115aclocal
116autoconf
117# %configure --with-libtool --with-openssl=/usr --enable-threads
118%configure \
119  --with-libtool \
120  --with-openssl=/usr \
121  --disable-openssl-version-ceck \
122  --enable-threads \
123  --enable-ipv6 \
124  --with-pic \
125  --with-dlz-dlopen \
126  --enable-filter-aaaa \
127  --enable-fixed-rrset
128make %{?_smp_mflags}
129
130%install
131rm -rf $RPM_BUILD_ROOT
132mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
133mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
134mkdir -p ${RPM_BUILD_ROOT}/var/named
135mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
136mkdir -p ${RPM_BUILD_ROOT}/var/run/named
137
138make DESTDIR=$RPM_BUILD_ROOT install
139install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
140install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
141install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
142install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
143touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
144gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
145cd $RPM_BUILD_ROOT%{_mandir}
146tar xjf %{SOURCE1}
147# newer version is contained in source
148rm -f man5/named.conf.5.gz
149mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
150cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
151
152chmod +x %{buildroot}%{_libdir}/*.so.*
153
154%pre
155if [ "$1" -eq 1 ]; then
156  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
157  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
158fi;
159:;
160
161%post
162/sbin/ldconfig
163/sbin/chkconfig --add named
164if [ "$1" -eq 1 ]; then
165  if [ ! -e /etc/rndc.key ]; then
166    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
167  fi
168  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
169  # rndc.key has to have correct perms and ownership, CVE-2007-6283
170  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
171  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
172
173  # Check DNSSEC settings if this is a fresh install
174  if [ -r /etc/sysconfig/dnssec ]; then
175    . /etc/sysconfig/dnssec
176    [ -x /usr/sbin/dnssec-configure ] && \
177      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
178        /dev/null 2>&1
179  fi;
180fi
181:;
182
183%preun
184if [ "$1" -eq 0 ]; then
185   /sbin/service named stop >/dev/null 2>&1 || :
186   /sbin/chkconfig --del named ||:
187fi
188exit 0
189
190
191%postun
192if [ "$1" -ge 1 ]; then
193        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
194fi
195/sbin/ldconfig
196
197%triggerpostun -- bind < 8.2.2_P5-15
198/sbin/chkconfig --add named
199/sbin/ldconfig
200
201%clean
202rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
203
204
205%post libs
206/sbin/ldconfig
207
208%postun libs
209/sbin/ldconfig
210
211
212%files
213%defattr(-,root,root)
214%doc CHANGES README
215%doc doc/arm doc/draft doc/rfc doc/misc
216%config(noreplace) %{_sysconfdir}/logrotate.d/named
217%config %{_sysconfdir}/rc.d/init.d/named
218%config(noreplace) %{_sysconfdir}/sysconfig/named
219%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
220%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
221%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
222
223%{_sbindir}/dnssec*
224%{_sbindir}/lwresd
225%{_sbindir}/named
226%{_sbindir}/named-bootconf
227%{_sbindir}/named-check*
228%{_sbindir}/named-compilezone
229%{_sbindir}/rndc*
230%{_sbindir}/dns-keygen
231%{_sbindir}/arpaname
232%{_sbindir}/ddns-confgen
233%{_sbindir}/genrandom
234%{_sbindir}/isc-hmac-fixup
235%{_sbindir}/named-journalprint
236%{_sbindir}/nsec3hash
237
238%{_mandir}/man1/arpaname.1*
239%{_mandir}/man5/resolv.conf.5*
240%{_mandir}/man5/named.conf.5*
241%{_mandir}/man5/rndc.conf.5*
242%{_mandir}/man8/rndc.8*
243%{_mandir}/man8/named.8*
244%{_mandir}/man8/lwresd.8*
245%{_mandir}/man8/dnssec*.8*
246%{_mandir}/man8/named-checkconf.8*
247%{_mandir}/man8/named-checkzone.8*
248%{_mandir}/man8/named-compilezone.8*
249%{_mandir}/man8/rndc-confgen.8*
250%{_mandir}/man8/ddns-confgen.8*
251%{_mandir}/man8/genrandom.8*
252%{_mandir}/man8/isc-hmac-fixup.8*
253%{_mandir}/man8/named-journalprint.8*
254%{_mandir}/man8/nsec3hash.8*
255
256%attr(-,named,named) %dir %{_var}/named
257%attr(-,named,named) %dir %{_var}/run/named
258     
259
260%files libs
261%defattr(-,root,root)
262%{_libdir}/*.so.*
263
264%files utils
265%defattr(-,root,root)
266%{_bindir}/dig
267%{_bindir}/host
268%{_bindir}/nslookup
269%{_bindir}/nsupdate
270%{_mandir}/man1/host.1*
271%{_mandir}/man1/nsupdate.1*
272%{_mandir}/man1/dig.1*
273%{_mandir}/man5/resolver.5*
274%{_mandir}/man1/nslookup.1*
275%{_mandir}/man8/nslookup.8*
276
277
278%files devel
279%defattr(-,root,root)
280%{_libdir}/*.so
281# %{_libdir}/*.la
282%{_libdir}/*.a
283%{_includedir}/*
284%{_mandir}/man3/*
285%{_mandir}/man1/isc-config.sh.1*
286%{_bindir}/isc-config.sh
287
288%changelog
289* Thu Feb 19 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P2-1vl6
290- new upstream release with secrity fix (CVE-2015-1349)
291- add BR: readline-devel
292
293* Sun Dec 21 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-2vl6
294- rebuilt
295
296* Wed Dec 10 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.6.P1-1vl6
297- new upstream release with secrity fix (CVE-2014-8500) 
298
299* Sun May 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.5-1vl6
300- 9.9.x for Vine6.x
301
302* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
303- 9.6.ESV.R10.P2-1
304- new upstream release with secrity fix (CVE-2014-0591)
305
306* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
307- new upstream release with secrity fix (CVE-2012-5166)
308
309* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
310- new upstream release with secrity fix (CVE-2012-4244)
311
312* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
313- new upstream release with secrity fix (CVE-2012-3817)
314
315* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
316- new upstream release with security fix (CVE-2012-1667)
317
318* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
319- new upstream release with security fix (CVE-2011-4313)
320
321* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
322- new upstream release with security fix (CVE-2011-2464)
323- use hoge(pre) tags instead of old hogepre tags
324
325* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
326- new upstream release with security fix (CVE-2011-1910)
327
328* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
329- new upstream release
330
331* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
332- rebuild with openssl-1.0.0c
333
334* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
335- rebuild package
336
337* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
338- change spec filename bind9-vl -> bind-vl
339
340* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
341- new upstream ESV release
342- add BR: libxml2-devel libcap-devel
343
344* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
345- add Conflicts bind-current
346
347* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
348- new upstream ESV release
349- add epoch 1 to upgrade from exist bind package
350
351* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
352- add man1/isc-config.sh.1 into devel file list
353
354* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
355- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
356
357* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
358- new upstream release with security fix (CVE-2009-4022)
359
360* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
361- new upstream release with security fix
362
363* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
364- new upstream release
365- clean up %%post/%%pre scriptlet
366  - create named user and group in %%pre
367  - don't remove named user/group in %%preun
368  - use rndc-confgen to create rndc.key
369
370* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
371- new upstream release
372- drop patch0 and patch14, merged in upstream
373
374* Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
375- new upstream release with security fix
376
377* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
378- new upstream release with security fix
379- new versioning policy
380
381* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
382- new upstream release with security fix
383
384* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
385- new upstream release
386- build with new openssl/toolchain
387
388* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
389- new upstream release with security fix
390
391* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
392- new upstream release
393
394* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
395- add Prereq sed
396
397* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
398- new upstream release for security fix (CVE-2006-4095,4096)
399
400* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
401- separate -libs package
402- remove old named.conf.5.gz
403  - newer version is contained in source
404
405* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
406- add bsdcompat patch (Patch4)
407- add fix_h_errno patch from FC
408  - h_errno not being accessed / set correctly in libbind
409
410* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
411- new upstream release
412
413* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
414- added PreReq to bind-utils (see: [VineSeed:09555])
415
416* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
417- new upstream release
418
419* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
420- fix /etc/init.d/named to use rndc
421
422* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
423- rebuild to remove unneeded dependancy
424
425* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
426- new upstream release
427
428* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
429- new upstream release
430
431* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
432- fix dependancies.
433
434* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
435- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
436- change package name to bind for VineSeed.
437- use more macros.
438
439* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
440- fixed some macros
441- add conflicts: to bind-* in bind9-devel and bind9-utils
442- add provides: bind = %%{version}
443
444* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
445- use %%configure macros
446
447* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
448- fixed inconsistent dependency
449
450* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
451- updated to 9.2.2rc1
452
453* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
454- updated to bind9(9.2.1), test packages ;)
455        -- based on Rawhide's bind-9.2.0-8
456        -- changed name bind9
457        -- added Conflicts: bind
458
459* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
460- release 8.3.1 includes security fixes
461
462* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
463- Upgraded to current stable release 8.3.0
464
465* Mon Oct  8 2001 <zn@mbf.nifty.com>
466- 8.2.5-0vl0: Upgraded to new upstream version.
467
468* Thu May 24 2001 <sagami@vinelinux.org>
469- 8.2.4-0vl1: eliminate CVS related files from %%doc
470
471* Thu May 17 2001 <sagami@vinelinux.org>
472- 8.2.4-0vl0
473
474* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
475- 8.2.3-1vl2
476- built on VineSeed
477
478* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
479- add doc/old
480- build for Vine 2.1
481
482* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
483- 8.2.3, fixes several security problems
484
485* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
486- static libraries may be used in shared objects. Build with -fPIC on ia64
487
488* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
489- 8.2.2-P7 (fixes Bug #20546)
490
491* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
492- condrestart fixes
493
494* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
495- change the init script to take condrestart, not cond-restart
496- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
497  the %pre and %post scripts
498
499* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
500- Don't prereq /etc/init.d
501
502* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
503- move initscript back
504
505* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
506- automatic rebuild
507
508* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
509- add "exit 0" for uninstall case
510
511* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
512- add prereq init.d and cleanup install section
513
514* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
515- fix the init script
516
517* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
518- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
519
520* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
521- Fix up the initscript (Bug #13033)
522- Fix build with current glibc (Bug #12755)
523- /etc/rc.d/init.d -> /etc/init.d
524- use %%{_mandir} rather than /usr/share/man
525
526* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
527- fix conflict with man-pages
528- remove compatibilty chkconfig links
529- initscript munging
530
531* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
532- modify logrotate setup to use PID file
533- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
534- actually bump the release this time
535
536* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
537- FHS compliance
538
539* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
540- clean up restart patch
541
542* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
543- provide /var/named (fix for bugs #9847, #10205)
544- preserve args when restarted via ndc(8) (bug #10227)
545- make resolv.conf(5) a link to resolver(5) (bug #10245)
546- fix SYSTYPE bug in all makefiles
547- move creation of named user from %%post into %%pre
548
549* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
550- Fix TTL (patch from ISC, Bug #9820)
551
552* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
553- fix typo in spec (it's %post, without a leading blank) introduced in -6
554- change SYSTYPE to linux
555
556* Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
557- pick a standard < 100 uid/gid for named
558
559* Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
560- Pass named a '-u named' parameter by default, and add/remove user.
561
562* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
563- fix host mx bug (Bug #9021)
564
565* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
566- rebuild to fix dependencies
567- man pages are compressed
568
569* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
570- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
571
572* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
573- Fix up location of named-bootconf.pl and make it executable
574  (Bug #8028)
575- bind-devel requires bind
576
577* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
578- update to 8.2.2-P5
579
580* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
581- update to 8.2.2-P3
582
583* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
584- add patch to stop a cache only server from complaining about lame servers
585  on every request.
586
587* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
588- use real stop and start in named.init for restart, not ndc restart, it has
589  problems when named has changed during a package update... (# 4890)
590
591* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
592- chkconfig --del in %preun, not %postun
593
594* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
595- initscript munging
596
597* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
598- fix installed chkconfig links to match init file
599
600* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
601- conflict with new (in man-1.24) man pages (#3876,#3877).
602
603* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
604- fix named.logrotate (wrong %SOURCE)
605
606* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
607- update to 8.2.1.
608- add named.logrotate (#3571).
609- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
610- vet file list.
611
612* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
613- don't run by default
614
615* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
616- nslookup fixes (#2463).
617- missing files (#3152).
618
619* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
620- nslookup patched:
621  to count numRecords properly
622  to fix subsequent calls to ls -d
623  to parse "view" and "finger" commands properly
624  the view hack updated for bind-8 (using sed)
625
626* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
627- add ISC patch
628- add quick hack to make host not crash
629- add more docs
630
631* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
632- add probing information in the init file to keep linuxconf happy
633- dont strip libbind
634
635* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
636- auto rebuild in the new build environment (release 3)
637
638* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
639- removed 'done' output at named shutdown.
640
641* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
642- version 8.2
643
644* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
645- patch to use the __FDS_BITS macro
646- build for glibc 2.1
647
648* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
649- change named.restart to /usr/sbin/ndc restart
650
651* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
652- install man pages correctly.
653- change K10named to K45named.
654
655* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
656- don't start if /etc/named.conf doesn't exist.
657
658* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
659- autmagically create /etc/named.conf from /etc/named.boot in %post
660- remove echo in %post
661
662* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
663- merge in 5.1 mods
664
665* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
666- Several essential modifications to build and install correctly.
667- Modified 'ndc' to avoid deprecated use of '-'
668
669* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
670- Used buildroot
671- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
672  on Redhat 5.0 instead of <nlist.h>
673
Note: See TracBrowser for help on using the repository browser.