source: projects/specs/branches/6/b/bind/bind-vl.spec @ 8179

Revision 8179, 20.1 KB checked in by iwamoto, 10 years ago (diff)

bind: new upstream ESV release with security fix

Line 
1%define _localstatedir /var
2
3%define pversion 9.6.ESV.R10.P2
4%define sversion 9.6-ESV-R10-P2
5%define bind_epoch 1
6
7%define bind_uid  25
8%define bind_gid  25
9
10Summary: A DNS (Domain Name System) server.
11Summary(ja): DNS (Domain Name System) サーバ
12Name: bind
13Version: %{pversion}
14Release: 1%{?_dist_release}
15License: distributable
16Group: System Environment/Daemons
17Source: ftp://ftp.isc.org/isc/bind9/%{version}/%{name}-%{sversion}.tar.gz
18Source1: bind-manpages.tar.bz2
19Source2: named.sysconfig
20Source3: named.init
21Source4: named.logrotate
22Source5: keygen.c
23Url: http://www.isc.org/bind.html
24Patch1: bind-9.3.3rc2-rndckey.patch
25Buildroot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: openssl-devel glibc-devel libtool
27BuildRequires: libxml2-devel libcap-devel
28Requires(pre): chkconfig, sh-utils, textutils, fileutils, shadow-utils, perl, sed
29Requires(pre): bind-utils = %{bind_epoch}:%{version}-%{release}
30Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
31Conflicts: bind9 <= 9.2.1-0vl5, bind-current
32Obsoletes: bind9 <= 9.2.1-0vl5
33epoch: %{bind_epoch}
34
35Vendor: Project Vine
36Distribution: Vine Linux
37
38%description
39BIND (Berkeley Internet Name Domain) is an implementation of the DNS
40(Domain Name System) protocols. BIND includes a DNS server (named),
41which resolves host names to IP addresses, and a resolver library
42(routines for applications to use when interfacing with DNS).  A DNS
43server allows clients to name resources or objects and share the
44information with other network machines.  The named DNS server can be
45used on workstations as a caching name server, but is generally only
46needed on one machine for an entire network.  Note that the
47configuration files for making BIND act as a simple caching nameserver
48are included in the caching-nameserver package. 
49
50Install the bind package if you need a DNS server for your network.  If
51you want bind to act a caching name server, you will also need to install
52the caching-nameserver package.
53
54
55%package libs
56Summary: Libraries used by various DNS packages
57Group: System Environment/Libraries
58Conflicts: bind-current-libs
59
60%description libs
61Contains libraries used by both the bind server package as well as the utils packages.
62
63
64%package utils
65Summary: Utilities for querying DNS name servers.
66Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
67Group: Applications/System
68Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
69Conflicts: bind9-utils <= 9.2.1-0vl5, bind-current-utils
70Obsoletes: bind9-utils <= 9.2.1-0vl5
71
72
73%description utils
74Bind-utils contains a collection of utilities for querying DNS (Domain
75Name Service) name servers to find out information about Internet hosts.
76These tools will provide you with the IP addresses for given host names,
77as well as other information about registered domains and network
78addresses.
79
80You should install bind-utils if you need to get information from DNS name
81servers.
82
83
84%package devel
85Summary: Include files and libraries needed for bind DNS development.
86Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
87Group: Development/Libraries
88Requires: bind = %{bind_epoch}:%{version}-%{release}
89Requires: bind-libs = %{bind_epoch}:%{version}-%{release}
90Conflicts: bind9-devel <= 9.2.1-0vl5, bind-current-devel
91Obsoletes: bind9-devel <= 9.2.1-0vl5
92
93
94%description devel
95The bind-devel package contains all the include files and the
96library required for DNS (Domain Name Service) development for
97BIND versions 9.x.x.
98
99You should install bind-devel if you want to develop bind DNS
100applications. If you install bind-devel, you'll also need to install
101bind.
102#'
103
104%prep
105%setup -n bind-%{sversion} -q
106%patch1 -p1 -b .key
107
108%build
109libtoolize --copy --force
110aclocal
111autoconf
112%configure --with-libtool --with-openssl=/usr --enable-threads
113make %{?_smp_mflags}
114
115%install
116rm -rf $RPM_BUILD_ROOT
117mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{rc.d/init.d,logrotate.d}
118mkdir -p ${RPM_BUILD_ROOT}/usr/{bin,lib,sbin,include}
119mkdir -p ${RPM_BUILD_ROOT}/var/named
120mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/{man1,man5,man8}
121mkdir -p ${RPM_BUILD_ROOT}/var/run/named
122
123make DESTDIR=$RPM_BUILD_ROOT install
124install -c -m 640 bin/rndc/rndc.conf $RPM_BUILD_ROOT/etc
125install -c -m 755 contrib/named-bootconf/named-bootconf.sh $RPM_BUILD_ROOT/usr/sbin/named-bootconf
126install -c -m 755 %SOURCE3 $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/named
127install -c -m 644 %SOURCE4 $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/named
128touch $RPM_BUILD_ROOT%{_sysconfdir}/rndc.key
129gcc $RPM_OPT_FLAGS -o $RPM_BUILD_ROOT/usr/sbin/dns-keygen %{SOURCE5}
130cd $RPM_BUILD_ROOT%{_mandir}
131tar xjf %{SOURCE1}
132# newer version is contained in source
133rm -f man5/named.conf.5.gz
134mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
135cp %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/named
136
137
138%pre
139if [ "$1" -eq 1 ]; then
140  /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
141  /usr/sbin/useradd  -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
142fi;
143:;
144
145%post
146/sbin/ldconfig
147/sbin/chkconfig --add named
148if [ "$1" -eq 1 ]; then
149  if [ ! -e /etc/rndc.key ]; then
150    /usr/sbin/rndc-confgen -a > /dev/null 2>&1
151  fi
152  [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
153  # rndc.key has to have correct perms and ownership, CVE-2007-6283
154  [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
155  [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
156
157  # Check DNSSEC settings if this is a fresh install
158  if [ -r /etc/sysconfig/dnssec ]; then
159    . /etc/sysconfig/dnssec
160    [ -x /usr/sbin/dnssec-configure ] && \
161      dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
162        /dev/null 2>&1
163  fi;
164fi
165:;
166
167%preun
168if [ "$1" -eq 0 ]; then
169   /sbin/service named stop >/dev/null 2>&1 || :
170   /sbin/chkconfig --del named ||:
171fi
172exit 0
173
174
175%postun
176if [ "$1" -ge 1 ]; then
177        %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
178fi
179/sbin/ldconfig
180
181%triggerpostun -- bind < 8.2.2_P5-15
182/sbin/chkconfig --add named
183/sbin/ldconfig
184
185%clean
186rm -rf ${RPM_BUILD_ROOT} ${RPM_BUILD_DIR}/%{name}-%{version}
187
188
189%post libs -p /sbin/ldconfig
190
191%postun libs -p /sbin/ldconfig
192
193
194%files
195%defattr(-,root,root)
196%doc CHANGES README
197%doc doc/arm doc/draft doc/rfc doc/misc
198%config(noreplace) %{_sysconfdir}/logrotate.d/named
199%config %{_sysconfdir}/rc.d/init.d/named
200%config(noreplace) %{_sysconfdir}/sysconfig/named
201%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
202%config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
203
204%{_sbindir}/dnssec*
205%{_sbindir}/lwresd
206%{_sbindir}/named
207%{_sbindir}/named-bootconf
208%{_sbindir}/named-check*
209%{_sbindir}/named-compilezone
210%{_sbindir}/rndc*
211%{_sbindir}/dns-keygen
212
213#%{_libdir}/libbind9.so.*
214#%{_libdir}/libisccc.so.*
215#%{_libdir}/libisccfg.so.*
216
217%{_mandir}/man5/resolv.conf.5*
218%{_mandir}/man5/named.conf.5*
219%{_mandir}/man5/rndc.conf.5*
220%{_mandir}/man8/rndc.8*
221%{_mandir}/man8/named.8*
222%{_mandir}/man8/lwresd.8*
223%{_mandir}/man8/dnssec*.8*
224%{_mandir}/man8/named-checkconf.8*
225%{_mandir}/man8/named-checkzone.8*
226%{_mandir}/man8/named-compilezone.8*
227%{_mandir}/man8/rndc-confgen.8*
228
229%attr(-,named,named) %dir %{_var}/named
230%attr(-,named,named) %dir %{_var}/run/named
231     
232
233%files libs
234%defattr(-,root,root)
235%{_libdir}/*.so.*
236
237%files utils
238%defattr(-,root,root)
239%{_bindir}/dig
240%{_bindir}/host
241%{_bindir}/nslookup
242%{_bindir}/nsupdate
243#%{_libdir}/libdns.so.*
244#%{_libdir}/libisc.so.*
245#%{_libdir}/liblwres.so.*
246%{_mandir}/man1/host.1*
247%{_mandir}/man1/nsupdate.1*
248%{_mandir}/man1/dig.1*
249%{_mandir}/man5/resolver.5*
250%{_mandir}/man1/nslookup.1*
251%{_mandir}/man8/nslookup.8*
252
253
254%files devel
255%defattr(-,root,root)
256%{_libdir}/*.so
257%{_libdir}/*.la
258%{_libdir}/*.a
259%{_includedir}/*
260%{_mandir}/man3/*
261%{_mandir}/man1/isc-config.sh.1*
262%{_bindir}/isc-config.sh
263
264%changelog
265* Tue Jan 14 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
266- 9.6.ESV.R10.P2-1
267- new upstream release with secrity fix (CVE-2014-0591)
268
269* Wed Oct 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R8-1
270- new upstream release with secrity fix (CVE-2012-5166)
271
272* Thu Sep 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R7.P3-1
273- new upstream release with secrity fix (CVE-2012-4244)
274
275* Wed Jul 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.ESV.R7.P2-1
276- new upstream release with secrity fix (CVE-2012-3817)
277
278* Tue Jun  5 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R7.P1-1
279- new upstream release with security fix (CVE-2012-1667)
280
281* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R5.P1-1
282- new upstream release with security fix (CVE-2011-4313)
283
284* Wed Jul  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P3-1
285- new upstream release with security fix (CVE-2011-2464)
286- use hoge(pre) tags instead of old hogepre tags
287
288* Sat May 28 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R4.P1-1
289- new upstream release with security fix (CVE-2011-1910)
290
291* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.6.ESV.R4-1
292- new upstream release
293
294* Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-4
295- rebuild with openssl-1.0.0c
296
297* Fri Jan 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.6.ESV.R2-3
298- rebuild package
299
300* Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-2
301- change spec filename bind9-vl -> bind-vl
302
303* Thu Oct  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R2-1
304- new upstream ESV release
305- add BR: libxml2-devel libcap-devel
306
307* Wed Aug 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-2
308- add Conflicts bind-current
309
310* Tue Aug 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.ESV.R1-1
311- new upstream ESV release
312- add epoch 1 to upgrade from exist bind package
313
314* Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
315- add man1/isc-config.sh.1 into devel file list
316
317* Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
318- new upstream release with security fix (CVE-2009-4022, 2010-0097) 
319
320* Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
321- new upstream release with security fix (CVE-2009-4022)
322
323* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
324- new upstream release with security fix
325
326* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
327- new upstream release
328- clean up %%post/%%pre scriptlet
329  - create named user and group in %%pre
330  - don't remove named user/group in %%preun
331  - use rndc-confgen to create rndc.key
332
333* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
334- new upstream release
335- drop patch0 and patch14, merged in upstream
336
337* Sat Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
338- new upstream release with security fix
339
340* Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
341- new upstream release with security fix
342- new versioning policy
343
344* Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
345- new upstream release with security fix
346
347* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
348- new upstream release
349- build with new openssl/toolchain
350
351* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
352- new upstream release with security fix
353
354* Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
355- new upstream release
356
357* Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
358- add Prereq sed
359
360* Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
361- new upstream release for security fix (CVE-2006-4095,4096)
362
363* Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
364- separate -libs package
365- remove old named.conf.5.gz
366  - newer version is contained in source
367
368* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
369- add bsdcompat patch (Patch4)
370- add fix_h_errno patch from FC
371  - h_errno not being accessed / set correctly in libbind
372
373* Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
374- new upstream release
375
376* Sun Nov  7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
377- added PreReq to bind-utils (see: [VineSeed:09555])
378
379* Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
380- new upstream release
381
382* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
383- fix /etc/init.d/named to use rndc
384
385* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
386- rebuild to remove unneeded dependancy
387
388* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
389- new upstream release
390
391* Tue Mar  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
392- new upstream release
393
394* Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
395- fix dependancies.
396
397* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
398- add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
399- change package name to bind for VineSeed.
400- use more macros.
401
402* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
403- fixed some macros
404- add conflicts: to bind-* in bind9-devel and bind9-utils
405- add provides: bind = %%{version}
406
407* Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
408- use %%configure macros
409
410* Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
411- fixed inconsistent dependency
412
413* Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
414- updated to 9.2.2rc1
415
416* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
417- updated to bind9(9.2.1), test packages ;)
418        -- based on Rawhide's bind-9.2.0-8
419        -- changed name bind9
420        -- added Conflicts: bind
421
422* Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
423- release 8.3.1 includes security fixes
424
425* Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
426- Upgraded to current stable release 8.3.0
427
428* Mon Oct  8 2001 <zn@mbf.nifty.com>
429- 8.2.5-0vl0: Upgraded to new upstream version.
430
431* Thu May 24 2001 <sagami@vinelinux.org>
432- 8.2.4-0vl1: eliminate CVS related files from %%doc
433
434* Thu May 17 2001 <sagami@vinelinux.org>
435- 8.2.4-0vl0
436
437* Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
438- 8.2.3-1vl2
439- built on VineSeed
440
441* Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
442- add doc/old
443- build for Vine 2.1
444
445* Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
446- 8.2.3, fixes several security problems
447
448* Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
449- static libraries may be used in shared objects. Build with -fPIC on ia64
450
451* Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
452- 8.2.2-P7 (fixes Bug #20546)
453
454* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
455- condrestart fixes
456
457* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
458- change the init script to take condrestart, not cond-restart
459- add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
460  the %pre and %post scripts
461
462* Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
463- Don't prereq /etc/init.d
464
465* Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
466- move initscript back
467
468* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
469- automatic rebuild
470
471* Sun Jul  9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
472- add "exit 0" for uninstall case
473
474* Fri Jul  7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
475- add prereq init.d and cleanup install section
476
477* Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
478- fix the init script
479
480* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
481- make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
482
483* Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
484- Fix up the initscript (Bug #13033)
485- Fix build with current glibc (Bug #12755)
486- /etc/rc.d/init.d -> /etc/init.d
487- use %%{_mandir} rather than /usr/share/man
488
489* Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
490- fix conflict with man-pages
491- remove compatibilty chkconfig links
492- initscript munging
493
494* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
495- modify logrotate setup to use PID file
496- temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
497- actually bump the release this time
498
499* Sun Jun  4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
500- FHS compliance
501
502* Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
503- clean up restart patch
504
505* Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
506- provide /var/named (fix for bugs #9847, #10205)
507- preserve args when restarted via ndc(8) (bug #10227)
508- make resolv.conf(5) a link to resolver(5) (bug #10245)
509- fix SYSTYPE bug in all makefiles
510- move creation of named user from %%post into %%pre
511
512* Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
513- Fix TTL (patch from ISC, Bug #9820)
514
515* Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
516- fix typo in spec (it's %post, without a leading blank) introduced in -6
517- change SYSTYPE to linux
518
519* Sat Feb 11 2000 Bill Nottingham <notting@redhat.com>
520- pick a standard < 100 uid/gid for named
521
522* Thu Feb 04 2000 Elliot Lee <sopwith@redhat.com>
523- Pass named a '-u named' parameter by default, and add/remove user.
524
525* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
526- fix host mx bug (Bug #9021)
527
528* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
529- rebuild to fix dependencies
530- man pages are compressed
531
532* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
533- It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
534
535* Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
536- Fix up location of named-bootconf.pl and make it executable
537  (Bug #8028)
538- bind-devel requires bind
539
540* Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
541- update to 8.2.2-P5
542
543* Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
544- update to 8.2.2-P3
545
546* Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
547- add patch to stop a cache only server from complaining about lame servers
548  on every request.
549
550* Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
551- use real stop and start in named.init for restart, not ndc restart, it has
552  problems when named has changed during a package update... (# 4890)
553
554* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
555- chkconfig --del in %preun, not %postun
556
557* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
558- initscript munging
559
560* Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
561- fix installed chkconfig links to match init file
562
563* Sat Jul  3 1999 Jeff Johnson <jbj@redhat.com>
564- conflict with new (in man-1.24) man pages (#3876,#3877).
565
566* Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
567- fix named.logrotate (wrong %SOURCE)
568
569* Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
570- update to 8.2.1.
571- add named.logrotate (#3571).
572- hack around egcs-1.1.2 -m486 bug (#3413, #3485).
573- vet file list.
574
575* Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
576- don't run by default
577
578* Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
579- nslookup fixes (#2463).
580- missing files (#3152).
581
582* Sat May  1 1999 Stepan Kasal <kasal@math.cas.cz>
583- nslookup patched:
584  to count numRecords properly
585  to fix subsequent calls to ls -d
586  to parse "view" and "finger" commands properly
587  the view hack updated for bind-8 (using sed)
588
589* Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
590- add ISC patch
591- add quick hack to make host not crash
592- add more docs
593
594* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
595- add probing information in the init file to keep linuxconf happy
596- dont strip libbind
597
598* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
599- auto rebuild in the new build environment (release 3)
600
601* Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
602- removed 'done' output at named shutdown.
603
604* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
605- version 8.2
606
607* Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
608- patch to use the __FDS_BITS macro
609- build for glibc 2.1
610
611* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
612- change named.restart to /usr/sbin/ndc restart
613
614* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
615- install man pages correctly.
616- change K10named to K45named.
617
618* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
619- don't start if /etc/named.conf doesn't exist.
620
621* Sat Aug  8 1998 Jeff Johnson <jbj@redhat.com>
622- autmagically create /etc/named.conf from /etc/named.boot in %post
623- remove echo in %post
624
625* Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
626- merge in 5.1 mods
627
628* Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
629- Several essential modifications to build and install correctly.
630- Modified 'ndc' to avoid deprecated use of '-'
631
632* Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
633- Used buildroot
634- patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
635  on Redhat 5.0 instead of <nlist.h>
636
Note: See TracBrowser for help on using the repository browser.