source: projects/specs/branches/6/a/automake/automake-vl.spec @ 3553

Revision 3553, 7.0 KB checked in by daisuke, 13 years ago (diff)

automake: rebuild for Vine6

Line 
1%define api_version 1.11
2
3Summary: A GNU tool for automatically creating Makefiles.
4Summary(ja): Makefile を自動生成するための GNU ツール
5Name: automake
6Version: %{api_version}.1
7Release: 2%{?_dist_release}
8License: GPL
9Group: Development/Tools
10Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.bz2
11URL: http://sources.redhat.com/automake
12Requires: perl, autoconf >= 2.58
13Buildrequires: autoconf >= 2.58
14Prereq: install-info
15BuildArchitectures: noarch
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: daisuke
21
22# run "make check" by default
23%{?_without_check: %define _without_check 1}
24%{!?_without_check: %define _without_check 0}
25
26%description
27Automake is an experimental Makefile generator. Automake was inspired
28by the 4.4BSD make and include files, but aims to be portable and to
29conform to the GNU standards for Makefile variables and targets.
30
31You should install Automake if you are developing software and would
32like to use its ability to automatically generate GNU standard
33Makefiles. If you install Automake, you will also need to install
34GNU's Autoconf package.
35
36
37%prep
38%setup -q -n automake-%{version}
39
40
41%build
42./configure --prefix=%{_prefix}
43%{__make} %{?_smp_mflags}
44%if ! %{_without_check}
45  %{__make} check
46%endif
47
48
49%install
50rm -rf ${RPM_BUILD_ROOT}
51%makeinstall
52
53# create this dir empty so we can own it
54mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/aclocal
55rm -f $RPM_BUILD_ROOT%{_infodir}/dir
56
57
58%clean
59rm -rf ${RPM_BUILD_ROOT}
60
61
62%post
63/sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir
64
65
66%preun
67if [ $1 = 0 ]; then
68    /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir
69fi
70
71
72%files
73%defattr(-,root,root)
74%doc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO
75%{_bindir}/*
76%{_infodir}/*.info*
77%{_datadir}/automake-%{api_version}
78%{_datadir}/aclocal-%{api_version}
79%dir %{_datadir}/aclocal
80
81
82%changelog
83* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-2
84- rebuild for Vine 6
85
86* Sat Jan 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.1-1
87- new upstream release
88
89* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.10.1-2
90- spec in utf-8
91
92* Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-1
93- new upstream release
94
95* Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.6-0vl1
96- new upstream release
97
98* Thu Jun  3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.5-0vl1
99- new upstream release
100
101* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-0vl1
102- new upstream release
103
104* Thu Apr 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.3-0vl1
105- new upstream release
106
107* Wed Feb 25 2004 Tomoya TAKA <taka@vinelinux.org> 1.8.2-0vl3
108- rebuild
109
110* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8.2-1vl2
111- rebuild
112
113* Thu Feb 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.2-0vl1
114- new upstream release
115
116* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.8-1vl1
117- based on 1.8-1 from Rawhide and built for Vine Linux
118
119* Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.9-0vl1
120- new upstream release
121
122* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-0vl1
123- new upstream release
124
125* Mon Jun 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.5-1vl1
126- based on 1.7.5-1 from Rawhide and built for Vine Linux
127
128* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.7.3-1vl1
129- based on 1.7.3-1 from Rawhide and built for Vine Linux
130
131* Sun Dec 08 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.3-1vl2
132- based on 1.6.3-1 from Rawhide and built for Vine Linux
133
134* Mon Jul 29 2002 Jens Petersen <petersen@redhat.com> 1.6.3-1
135- bug fix release 1.6.3
136
137* Thu Jul 11 2002 Jens Petersen <petersen@redhat.com> 1.6.2-2
138- add buildrequires autoconf 2.52 or greater (reported by Edward Avis)
139
140* Wed Jun 19 2002 Jens Petersen <petersen@redhat.com> 1.6.2-1
141- 1.6.2 (bug fix release)
142- do "make check" after building
143
144* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.6.1-2
145- automated rebuild
146
147* Tue Apr 23 2002 Jens Petersen <petersen@redhat.com> 1.6.1-1
148- 1.6.1
149
150* Tue Mar 12 2002 Jens Petersen <petersen@redhat.com> 1.6-1
151- new package based on automake15
152- 1.6
153
154* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-8
155- better aclocal versioning
156
157* Wed Jan 23 2002 Jens Petersen <petersen@redhat.com> 1.5-7
158- don't version datadir/automake
159
160* Tue Jan 15 2002 Jens Petersen <petersen@redhat.com> 1.5-6
161- version suffix programs and data directories
162- own symlinks to programs and /usr/share/aclocal
163
164* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.5-5
165- automated rebuild
166
167* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-4
168- Completely back out the fix for #56624 for now, it causes more problems
169  than it fixes in either form.
170
171* Wed Jan  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-3
172- Don't use AS_DIRNAME, it doesn't work.
173
174* Tue Jan  7 2002 Jens Petersen <petersen@redhat.com> 1.5-2
175- Patch depout.m4 to handle makefiles passed to make with "-f" (#56624)
176
177* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.5-1
178- Update to 1.5 - much better to coexist with autoconf 2.52...
179- Fix specfile
180- No patches
181
182* Fri Aug 24 2001 Jens Petersen <petersen@redhat.com> - 1.4p5-2
183- dont raise error when there is source in a subdirectory (bug #35156).
184  This was preventing automake from working in binutuls/gas
185  [patch from HJ Lu <hjl@gnu.org>]
186- format long lines of output properly with backslash + newlines as in 1.4
187  (bug #35259) [patch from HJ Lu <hjl@gnu.org>]
188
189* Sat Jul 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
190- 1.4-p5, fixes #48788
191
192* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
193- add the patch from #20559
194- really update to 1.4-p4
195
196* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
197- update to 1.4-p4
198
199* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
200- Version 1.4-p1 to work with libtool-1.4
201
202* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
203- automatic rebuild
204
205* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
206- FHS packaging.
207
208* Fri Feb 04 2000 Nalin Dahyabhai <nalin@redhat.com>
209- fix bug #8870
210
211* Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
212- revert to pristine automake-1.4.
213
214* Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
215- arm netwinder patch
216
217* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
218- Injected new description and group.
219
220* Mon Feb  8 1999 Jeff Johnson <jbj@redhat.com>
221- add patches from CVS for 6.0beta1
222
223* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
224- update to 1.4.
225
226* Mon Nov 23 1998 Jeff Johnson <jbj@redhat.com>
227- update to 1.3b.
228- add URL.
229
230* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
231- translations modified for de, fr, tr
232
233* Tue Apr 07 1998 Erik Troan <ewt@redhat.com>
234- updated to 1.3
235
236* Tue Oct 28 1997 Cristian Gafton <gafton@redhat.com>
237- added BuildRoot; added aclocal files
238
239* Fri Oct 24 1997 Erik Troan <ewt@redhat.com>
240- made it a noarch package
241
242* Thu Oct 16 1997 Michael Fulbright <msf@redhat.com>
243- Fixed some tag lines to conform to 5.0 guidelines.
244
245* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
246- updated to 1.2
247
248* Wed Mar 5 1997 msf@redhat.com <Michael Fulbright>
249- first version (1.0)
Note: See TracBrowser for help on using the repository browser.