source: projects/specs/branches/6/a/audacious-plugins/audacious-plugins-vl.spec @ 5648

Revision 5648, 14.6 KB checked in by Takemikaduchi, 12 years ago (diff)

arpscan, aslookup, audacity, black-box, bookview, bumprace, gimp-help, js: new upstream release
libsrtp, gstreamer-filters: new package
others: rebuild

Line 
1# Now, these features provide self-build-audacious-plugins-extra package
2# to enable features, rpmbuild with '--with feature'
3#define with_aac        %{?_with_aac:1}%{!?_with_aac:0}
4#define with_wma        %{?_with_wma:1}%{!?_with_wma:0}
5#define with_lame       %{?_with_lame:1}%{!?_with_lame:0}
6
7%define _audacious_ver          2.3-1%{?_dist_release}
8%define _gtk2_ver               2.8.0
9%define _glib2_ver              2.12.0
10# to build OSD plugin, pango >= 1.14.7, cairo >= 1.2.6 are required
11%define _pango_ver              1.14.7
12%define _esound_ver             0.2
13%define _libvorbis_ver          1.0
14%define _libogg_ver             1.0
15%define _libsndfile_ver         0.19
16%define _flac_ver               1.2.0
17%define _alsa_ver               1.0
18%define _libxml2_ver            2.0.0
19%define _sdl_ver                1.2.5
20%define _libmtp_ver             0.3.5
21
22#define extraver alpha5
23
24%define plugindir %{_libdir}/audacious
25
26Summary:        Audacious Media Player plugins
27Summary(ja):    Audacious メディアプレイヤー プラグイン集
28Name:           audacious-plugins
29Version:        2.3
30Release:        3%{?_dist_release}
31# LGPLv2+: adplug, bio2jack, rocklight
32# MIT: crystalizer, dockalbumart
33# BSD: lastfm
34License:        GPLv2 and GPLv2+ and LGPLv2+ and MIT and BSD
35Group:          Applications/Multimedia
36URL:            http://audacious-media-player.org/
37Source:         http://distfiles.atheme.org/audacious-plugins-%{version}%{?extraver:-%extraver}.tgz
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40BuildRequires:  audacious-devel >= %{_audacious_ver}
41BuildRequires:  glib2-devel >= %{_glib2_ver}
42BuildRequires:  gtk2-devel >= %{_gtk2_ver}
43BuildRequires:  pango-devel >= %{_pango_ver}
44BuildRequires:  dbus-devel >= 0.80
45BuildRequires:  dbus-glib-devel >= 0.60
46BuildRequires:  libmowgli-devel >= 0.4.0
47BuildRequires:  esound-devel >= %{_esound_ver}
48BuildRequires:  pulseaudio-libs-devel >= 0.9.9
49BuildRequires:  libshout-devel >= 2.0.0
50BuildRequires:  lirc
51BuildRequires:  libogg-devel >= %{_libogg_ver}
52BuildRequires:  libvorbis-devel >= %{_libvorbis_ver}
53BuildRequires:  flac-devel >= %{_flac_ver}
54BuildRequires:  libsndfile-devel >= %{_libsndfile_ver}
55BuildRequires:  jack-audio-connection-kit-devel
56BuildRequires:  alsa-lib-devel >= %{_alsa_ver}
57BuildRequires:  libcdio-devel >= 0.70
58BuildRequires:  libcddb-devel >= 1.2.1
59BuildRequires:  neon-devel >= 0.26
60BuildRequires:  libmtp-devel >= %{_libmtp_ver}
61# bluetooth plugin has been broken by the output plugin on-demand work
62#BuildRequires:  bluez-libs-devel
63BuildRequires:  libxml2-devel >= %{_libxml2_ver}
64BuildRequires:  libprojectm-devel
65BuildRequires:  SDL-devel >= %{_sdl_ver}
66BuildRequires:  gtkglext-devel
67BuildRequires:  libsamplerate-devel
68BuildRequires:  mesa-libGLU-devel
69BuildRequires:  libSM-devel
70BuildRequires:  libXmu-devel
71BuildRequires:  libXt-devel
72BuildRequires:  wavpack-devel
73
74Requires:       audacious >= %{_audacious_ver}
75Requires:       glib2 >= %{_glib2_ver}, gtk2 >= %{_gtk2_ver}
76Requires:       pango >= %{_pango_ver}
77Requires:       libvorbis >= %{_libvorbis_ver}
78Requires:       libogg >= %{_libogg_ver}
79Requires:       libsndfile >= %{_libsndfile_ver}
80Requires:       alsa-lib >= %{_alsa_ver}
81Requires:       libxml2 >= %{_libxml2_ver}
82Requires(post):   /sbin/update-alternatives
83Requires(postun): /sbin/update-alternatives
84
85Obsoletes:      audacious < 1.2.0
86Obsoletes:      beepmp, beepmp-alsa
87
88Vendor:         Project Vine
89Distribution:   Vine Linux
90
91%description
92Audacious is a media player that currently uses a skinned user interface
93based on Winamp 2.x skins.
94
95This package provides essential plugins for audio input, audio output and
96visualization.
97
98
99%package -n audacious-jack
100Summary: Audacious output plugin for JACK sound service
101Group: Applications/Multimedia
102Requires: audacious >= %{_audacious_ver}
103
104%description -n audacious-jack
105This package provides an Audacious output plugin that uses the
106JACK sound service.
107
108
109%package -n audacious-flac
110Summary:        Audacious plugin to play FLAC files
111Summary(ja):    FLAC ファイルを再生するための Audacious プラグイン
112Group:          Applications/Multimedia
113Requires:       audacious >= %{_audacious_ver}
114Requires:       flac >= %{_flac_ver}
115Obsoletes:      beepmp-flac
116
117%description -n audacious-flac
118This package contains a input plugin that enables playback of FLAC files
119in Audacious.
120
121%description -l ja -n audacious-flac
122このパッケージには、Audacious で FLAC ファイル (*.flac/fla) を再生するため
123の入力プラグインが含まれています。
124
125
126%package -n audacious-esd
127Summary:        Audacious plugin to output audio via EsounD
128Summary(ja):    Audacious EsounD オーディオ出力プラグイン
129Group:          Applications/Multimedia
130Requires:       audacious >= %{_audacious_ver}
131Requires:       esound >= %{_esound_ver}
132
133%description -n audacious-esd
134This package contains an audio output plugin via EsounD for Audacious.
135
136%description -l ja -n audacious-esd
137このパッケージには、Audacious で EsounD を用いて音声を出力するための
138プラグインが含まれています。
139
140
141%package -n audacious-visualization
142Summary:        Audacious visualization plugins
143Summary(ja):    Audacious 視覚化プラグイン
144Group:          Applications/Multimedia
145Requires:       audacious >= %{_audacious_ver}
146Requires:       SDL >= %{_sdl_ver}
147Requires:       libprojectm
148Obsoletes:      audacious-paranormal
149
150%description -n audacious-visualization
151This package contains extra visualization plugin for Audacious.
152
153%description -l ja -n audacious-visualization
154このパッケージには、Audacious で再生した音声を視覚化する追加のプラグインが
155含まれています。
156
157%prep
158%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
159
160%build
161%configure \
162        --enable-ipv6           \
163        --enable-chardet        \
164        --disable-aac           \
165        --disable-ffaudio       \
166        --disable-filewriter_mp3 \
167        --disable-mp3
168
169%__make %{_smp_mflags} VERBOSE=1
170
171%install
172%__rm -rf %{buildroot}
173%__make DESTDIR=%{buildroot} install
174
175# rename for alternatives
176pushd $RPM_BUILD_ROOT%{plugindir}/Output/
177mkdir filewriter
178mv filewriter.so filewriter/plus.so
179popd
180
181%find_lang %{name}
182
183%clean
184%__rm -rf %{buildroot}
185
186%post
187/sbin/update-alternatives --install \
188    %{plugindir}/Output/filewriter.so \
189    filewriter.so \
190    %{plugindir}/Output/filewriter/plus.so 10
191
192%postun
193if [ $1 = 0 ]; then
194  /sbin/update-alternatives --remove filewriter.so %{plugindir}/Output/filewriter/plus.so
195  /sbin/update-alternatives --auto filewriter.so
196fi
197
198%posttrans
199# fix broken symlink if it's there
200if [ ! -f %{plugindir}/Output/filewriter.so ] ; then
201  /sbin/update-alternatives --auto filewriter.so
202fi
203
204
205%files -f %{name}.lang
206%defattr(-,root,root,-)
207%doc AUTHORS COPYING
208
209# container plugins
210%{plugindir}/Container/m3u.so
211%{plugindir}/Container/pls.so
212%{plugindir}/Container/xspf.so
213
214# effect plugins
215%{plugindir}/Effect/compressor.so
216%{plugindir}/Effect/crystalizer.so
217%{plugindir}/Effect/echo.so
218%{plugindir}/Effect/ladspa.so
219%{plugindir}/Effect/resample.so
220%{plugindir}/Effect/sndstretch.so
221%{plugindir}/Effect/stereo.so
222%{plugindir}/Effect/voice_removal.so
223
224# general plugins
225%{plugindir}/General/alarm.so
226%{plugindir}/General/aosd.so
227#{plugindir}/General/bluetooth.so
228%{plugindir}/General/cd-menu-items.so
229%{plugindir}/General/evdev-plug.so
230%{plugindir}/General/gnomeshortcuts.so
231%{plugindir}/General/gtkui.so
232%{plugindir}/General/hotkey.so
233%{plugindir}/General/lirc.so
234%{plugindir}/General/mtp_up.so
235%{plugindir}/General/skins.so
236%{plugindir}/General/song_change.so
237%{plugindir}/General/statusicon.so
238%{plugindir}/General/streambrowser.so
239%{plugindir}/General/vfstrace.so
240
241# input plugins
242#{plugindir}/Input/alac.so
243%{plugindir}/Input/amidi-plug.so
244%{plugindir}/Input/amidi-plug/ap-alsa.so
245%{plugindir}/Input/cdaudio-ng.so
246%{plugindir}/Input/console.so
247#{plugindir}/Input/cuesheet_ng.so
248#{plugindir}/Input/demac.so
249#{plugindir}/Input/madplug.so
250%{plugindir}/Input/metronom.so
251%{plugindir}/Input/modplug.so
252%exclude %{plugindir}/Input/psf2.so
253%{plugindir}/Input/sndfile.so
254%{plugindir}/Input/tonegen.so
255%{plugindir}/Input/vorbis.so
256%{plugindir}/Input/vtx.so
257%{plugindir}/Input/wavpack.so
258%exclude %{plugindir}/Input/xsf.so
259
260# output plugins
261%{plugindir}/Output/alsa.so
262%{plugindir}/Output/OSS.so
263%{plugindir}/Output/crossfade.so
264#{plugindir}/Output/filewriter.so
265%{plugindir}/Output/filewriter/plus.so
266%{plugindir}/Output/icecast.so
267%{plugindir}/Output/null.so
268%{plugindir}/Output/pulse_audio.so
269
270# transport plugins
271%{plugindir}/Transport/gio.so
272%{plugindir}/Transport/neon.so
273%{plugindir}/Transport/unix-io.so
274
275# visualization plugins
276%{plugindir}/Visualization/blur_scope.so
277%{plugindir}/Visualization/spectrum.so
278
279%dir %{_datadir}/audacious
280%{_datadir}/audacious/images/bookmarks.png
281%{_datadir}/audacious/images/shoutcast.png
282%{_datadir}/audacious/images/streambrowser-*.png
283%{_datadir}/audacious/images/xiph.png
284
285# skins
286%{_datadir}/audacious/Skins/*
287
288
289%files -n audacious-jack
290%defattr(-,root,root,-)
291%{plugindir}/Output/jackout.so
292
293%files -n audacious-flac
294%defattr(-,root,root,-)
295%{plugindir}/Input/flacng.so
296
297%files -n audacious-esd
298%defattr(-,root,root,-)
299%{plugindir}/Output/ESD.so
300
301%files -n audacious-visualization
302%defattr(-,root,root,-)
303%{plugindir}/Visualization/paranormal.so
304%{plugindir}/Visualization/rocklight.so
305%{plugindir}/Visualization/projectm-1.0.so
306%{_datadir}/audacious/paranormal
307
308%changelog
309* Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.3-3
310- rebuild with Vine6 environment
311- add BuildRequires: libSM-devel, libXmu-devel, libXt-devel, wavpack-devel
312
313* Sat Jun  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-2
314- rebuilt with libprojectm-2.0.1
315- added BR: libshout-devel
316- renamed filewriter.so for alternatives (audacious-lame)
317
318* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-1
319- new upstream release
320- remove BR: arts-devel
321- added BR: libcdio-devel, libcddb-devel
322
323* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
324- new upstream release
325- added --disable-mp3 options
326
327* Tue Apr 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-4
328- add BuildRequires: libmtp-devel >= 0.3.5
329- add Patch10 to fix mtp.c for API changes on libmtp >= 0.3.0
330
331* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-3
332- rebuilt with libmowgli-0.7.0
333
334* Sat Mar 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.1-2
335- add BuildRequires: libsamplerate-devel and mesa-libGLU-devel
336- add BuildRequires: neon-devel, lirc and pulseaudio-libs-devel
337
338* Sat Dec  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
339- new upstream release
340
341* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.5-1vl5
342- applied new versioning policy, spec in utf-8
343
344* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.5-0vl2
345- add Obsoletes: beepmp, beepmp-alsa
346- add Obsoletes: beepmp-flac to audacious-flac package
347- add Obsoletes: audioscrobbler-beepmp to audacious-scrobbler package
348
349* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-0vl1
350- new upstream release
351- rebuilt with flac-1.2.0
352
353* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.4-0vl1
354- new upstream release
355- build with new environment/toolchain
356
357* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
358- new upstream release
359
360* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
361- new upstream release
362- update ja.po (source1)
363- update %%_audacious_ver
364- overwrite POTFILES.in (source3)
365  - 1.3.0 contains old version of POTFILES.in
366- drop obsolete id3tag.h.patch (patch0)
367- drop BuildRequires: libglade2-devel, taglib-devel
368- add %%with_lame macro
369  - enable lame plugin if rpmbuild with '--with lame'
370
371* Thu Feb 22 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5.1
372- add BuildRequires: libmad-devel
373- add id3tag.h.patch (patch0)
374
375* Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
376- update to 1.3.0alpha5
377- update ja.po (source1)
378- update %%_audacious_ver
379- drop obsolete avoid-null-dereference.patch (patch0)
380- drop BuildRequires: libid3tag-devel
381  - NOTE: taglib is not used, but required in configure.ac
382- add plugin to core package
383  - libmadplug.so instead of libmpg123.so (Input)
384- move plugin to visualization package
385  - librocklight.so (Visualization)
386- add Requires: audacious instead of %%{name} to sub packages
387
388* Fri Feb 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
389- add avoid-null-dereference.patch (patch0) to avoid crash
390
391  r1316 | nenolod | 2007-02-08 03:35:13 +0900 (Thu, 08 Feb 2007) | 2 lines
392  - avoid NULL dereference. closes mandriva #28603.
393
394* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
395- update to 1.3.0alpha4
396- update ja.po (source1)
397- update %%_audacious_ver
398- update URLs
399- add BuildRequires: libprojectM-devel
400- add plugin to visualization package
401  - libprojectm.so (Visualization)
402
403* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
404- update to 1.3.0alpha3
405- update ja.po (source1)
406- add BuildRequires: libid3tag-devel
407- add plugins to core package
408  - libcurl.so, libevdev-plug.so, libstatusicon.so (General)
409- add new package: audacious-tta
410  - libtta.so (Input)
411
412* Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
413- update ja.po (source1)
414
415* Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
416- update to 1.3.0alpha2
417- update %%_audacious_ver
418- drop '--disable-gnome-vfs' option from %%configure (no longer supported)
419- add audacious-1.2.2's ja.po (source1)
420  to use some translations prior to plugin separation
421- add plugins to core package:
422  - libstdio.so (Container)
423  - libmetronom.so, libmodplug.so (Input)
424  - librocklight.so (Visualization)
425- rename paranormal package to visualization
426  - add Obsoletes: audacious-paranormal
427  - add plugin: librovascope.so
428- fix typo
429
430* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl2
431- separate paranormal package
432- add BuildRequires: SDL-devel
433
434* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl1
435- initial build based on audacious
436
437* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
438- new upstream release
439
440* Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
441- oops, really update ja.po (source2)
442
443* Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
444- new upstream release
445- make with 'VERBOSE=1'
446- drop obsolete POTFILES.in (source3)
447- make update-po before make
448  - 1.1.1 contains old version of audacious.pot...
449- update ja.po (source2)
450
451* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
452- overwrite POTFILES.in (source3)
453  - 1.1.0 contains old version of POTFILES.in
454- update ja.po (source2)
455
456* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
457- new upstream release
458- drop unneeded patch0 (was merged)
459- add '--enable-ipv6 --enable-chardet' to %%configure option
460- add BuildRequires: taglib-devel instead of id3lib-devel
461- update ja.po (source2)
462
463* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
464- add flac-filename-utf8.patch (patch0)
465      to convert filename on fileinfo box for FLAC files to UTF-8
466- add use-xfont.patch (patch1)
467      to disable 'Use Bitmap fonts if available' by default
468- add ja.po (source2)
469
470* Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
471- initial build
Note: See TracBrowser for help on using the repository browser.