source: projects/specs/branches/6/a/audacious-plugins/audacious-plugins-vl.spec @ 10622

Revision 10622, 14.9 KB checked in by tomop, 8 years ago (diff)

audacious-plugins-2.3-4

Line 
1# Now, these features provide self-build-audacious-plugins-extra package
2# to enable features, rpmbuild with '--with feature'
3#define with_aac        %{?_with_aac:1}%{!?_with_aac:0}
4#define with_wma        %{?_with_wma:1}%{!?_with_wma:0}
5#define with_lame       %{?_with_lame:1}%{!?_with_lame:0}
6
7%define _audacious_ver          2.3-1%{?_dist_release}
8%define _gtk2_ver               2.8.0
9%define _glib2_ver              2.12.0
10# to build OSD plugin, pango >= 1.14.7, cairo >= 1.2.6 are required
11%define _pango_ver              1.14.7
12%define _esound_ver             0.2
13%define _libvorbis_ver          1.0
14%define _libogg_ver             1.0
15%define _libsndfile_ver         0.19
16%define _flac_ver               1.2.0
17%define _alsa_ver               1.0
18%define _libxml2_ver            2.0.0
19%define _sdl_ver                1.2.5
20%define _libmtp_ver             0.3.5
21
22#define extraver alpha5
23
24%define plugindir %{_libdir}/audacious
25
26Summary:        Audacious Media Player plugins
27Summary(ja):    Audacious メディアプレイヤー プラグイン集
28Name:           audacious-plugins
29Version:        2.3
30Release:        4%{?_dist_release}
31# LGPLv2+: adplug, bio2jack, rocklight
32# MIT: crystalizer, dockalbumart
33# BSD: lastfm
34License:        GPLv2 and GPLv2+ and LGPLv2+ and MIT and BSD
35Group:          Applications/Multimedia
36URL:            http://audacious-media-player.org/
37Source:         http://distfiles.atheme.org/audacious-plugins-%{version}%{?extraver:-%extraver}.tgz
38Patch0:         audacious-plugins-2.3-invalid-var.patch
39Patch1:         audacious-plugins-2.3-gcc49.patch
40Patch2:         audacious-plugins-2.3-mkdir.patch
41
42BuildRoot:      %{_tmppath}/%{name}-%{version}-root
43BuildRequires:  audacious-devel >= %{_audacious_ver}
44BuildRequires:  glib2-devel >= %{_glib2_ver}
45BuildRequires:  gtk2-devel >= %{_gtk2_ver}
46BuildRequires:  pango-devel >= %{_pango_ver}
47BuildRequires:  dbus-devel >= 0.80
48BuildRequires:  dbus-glib-devel >= 0.60
49BuildRequires:  libmowgli-devel >= 0.4.0
50BuildRequires:  esound-devel >= %{_esound_ver}
51BuildRequires:  pulseaudio-libs-devel >= 0.9.9
52BuildRequires:  libshout-devel >= 2.0.0
53BuildRequires:  lirc
54BuildRequires:  libogg-devel >= %{_libogg_ver}
55BuildRequires:  libvorbis-devel >= %{_libvorbis_ver}
56BuildRequires:  flac-devel >= %{_flac_ver}
57BuildRequires:  libsndfile-devel >= %{_libsndfile_ver}
58BuildRequires:  jack-audio-connection-kit-devel
59BuildRequires:  alsa-lib-devel >= %{_alsa_ver}
60BuildRequires:  libcdio-devel >= 0.70
61BuildRequires:  libcddb-devel >= 1.2.1
62BuildRequires:  neon-devel >= 0.26
63BuildRequires:  libmtp-devel >= %{_libmtp_ver}
64# bluetooth plugin has been broken by the output plugin on-demand work
65#BuildRequires:  bluez-libs-devel
66BuildRequires:  libxml2-devel >= %{_libxml2_ver}
67BuildRequires:  libprojectm-devel
68BuildRequires:  SDL-devel >= %{_sdl_ver}
69BuildRequires:  gtkglext-devel
70BuildRequires:  libsamplerate-devel
71BuildRequires:  mesa-libGLU-devel
72BuildRequires:  libSM-devel
73BuildRequires:  libXmu-devel
74BuildRequires:  libXt-devel
75BuildRequires:  wavpack-devel
76
77Requires:       audacious >= %{_audacious_ver}
78Requires:       glib2 >= %{_glib2_ver}, gtk2 >= %{_gtk2_ver}
79Requires:       pango >= %{_pango_ver}
80Requires:       libvorbis >= %{_libvorbis_ver}
81Requires:       libogg >= %{_libogg_ver}
82Requires:       libsndfile >= %{_libsndfile_ver}
83Requires:       alsa-lib >= %{_alsa_ver}
84Requires:       libxml2 >= %{_libxml2_ver}
85Requires(post):   /sbin/update-alternatives
86Requires(postun): /sbin/update-alternatives
87
88Obsoletes:      audacious < 1.2.0
89Obsoletes:      beepmp, beepmp-alsa
90
91Vendor:         Project Vine
92Distribution:   Vine Linux
93
94%description
95Audacious is a media player that currently uses a skinned user interface
96based on Winamp 2.x skins.
97
98This package provides essential plugins for audio input, audio output and
99visualization.
100
101
102%package -n audacious-jack
103Summary: Audacious output plugin for JACK sound service
104Group: Applications/Multimedia
105Requires: audacious >= %{_audacious_ver}
106
107%description -n audacious-jack
108This package provides an Audacious output plugin that uses the
109JACK sound service.
110
111
112%package -n audacious-flac
113Summary:        Audacious plugin to play FLAC files
114Summary(ja):    FLAC ファイルを再生するための Audacious プラグイン
115Group:          Applications/Multimedia
116Requires:       audacious >= %{_audacious_ver}
117Requires:       flac >= %{_flac_ver}
118Obsoletes:      beepmp-flac
119
120%description -n audacious-flac
121This package contains a input plugin that enables playback of FLAC files
122in Audacious.
123
124%description -l ja -n audacious-flac
125このパッケージには、Audacious で FLAC ファイル (*.flac/fla) を再生するため
126の入力プラグインが含まれています。
127
128
129%package -n audacious-esd
130Summary:        Audacious plugin to output audio via EsounD
131Summary(ja):    Audacious EsounD オーディオ出力プラグイン
132Group:          Applications/Multimedia
133Requires:       audacious >= %{_audacious_ver}
134Requires:       esound >= %{_esound_ver}
135
136%description -n audacious-esd
137This package contains an audio output plugin via EsounD for Audacious.
138
139%description -l ja -n audacious-esd
140このパッケージには、Audacious で EsounD を用いて音声を出力するための
141プラグインが含まれています。
142
143
144%package -n audacious-visualization
145Summary:        Audacious visualization plugins
146Summary(ja):    Audacious 視覚化プラグイン
147Group:          Applications/Multimedia
148Requires:       audacious >= %{_audacious_ver}
149Requires:       SDL >= %{_sdl_ver}
150Requires:       libprojectm
151Obsoletes:      audacious-paranormal
152
153%description -n audacious-visualization
154This package contains extra visualization plugin for Audacious.
155
156%description -l ja -n audacious-visualization
157このパッケージには、Audacious で再生した音声を視覚化する追加のプラグインが
158含まれています。
159
160%prep
161%setup -q -n %{name}-%{version}%{?extraver:-%extraver}
162%patch0 -p1 -b .invalid-var
163%patch1 -p1 -b .gcc49
164%patch2 -p1 -b .mkdir
165
166%build
167export CXXFLAGS="%{optflags} -std=gnu++98"
168%configure \
169        --enable-ipv6           \
170        --enable-chardet        \
171        --disable-aac           \
172        --disable-ffaudio       \
173        --disable-filewriter_mp3 \
174        --disable-mp3
175
176%__make %{_smp_mflags} VERBOSE=1
177
178%install
179%__rm -rf %{buildroot}
180%__make DESTDIR=%{buildroot} install
181
182# rename for alternatives
183pushd $RPM_BUILD_ROOT%{plugindir}/Output/
184mkdir filewriter
185mv filewriter.so filewriter/plus.so
186popd
187
188%find_lang %{name}
189
190%clean
191%__rm -rf %{buildroot}
192
193%post
194/sbin/update-alternatives --install \
195    %{plugindir}/Output/filewriter.so \
196    filewriter.so \
197    %{plugindir}/Output/filewriter/plus.so 10
198
199%postun
200if [ $1 = 0 ]; then
201  /sbin/update-alternatives --remove filewriter.so %{plugindir}/Output/filewriter/plus.so
202  /sbin/update-alternatives --auto filewriter.so
203fi
204
205%posttrans
206# fix broken symlink if it's there
207if [ ! -f %{plugindir}/Output/filewriter.so ] ; then
208  /sbin/update-alternatives --auto filewriter.so
209fi
210
211
212%files -f %{name}.lang
213%defattr(-,root,root,-)
214%doc AUTHORS COPYING
215
216# container plugins
217%{plugindir}/Container/m3u.so
218%{plugindir}/Container/pls.so
219%{plugindir}/Container/xspf.so
220
221# effect plugins
222%{plugindir}/Effect/compressor.so
223%{plugindir}/Effect/crystalizer.so
224%{plugindir}/Effect/echo.so
225%{plugindir}/Effect/ladspa.so
226%{plugindir}/Effect/resample.so
227%{plugindir}/Effect/sndstretch.so
228%{plugindir}/Effect/stereo.so
229%{plugindir}/Effect/voice_removal.so
230
231# general plugins
232%{plugindir}/General/alarm.so
233%{plugindir}/General/aosd.so
234#{plugindir}/General/bluetooth.so
235%{plugindir}/General/cd-menu-items.so
236%{plugindir}/General/evdev-plug.so
237%{plugindir}/General/gnomeshortcuts.so
238%{plugindir}/General/gtkui.so
239%{plugindir}/General/hotkey.so
240%{plugindir}/General/lirc.so
241%{plugindir}/General/mtp_up.so
242%{plugindir}/General/skins.so
243%{plugindir}/General/song_change.so
244%{plugindir}/General/statusicon.so
245%{plugindir}/General/streambrowser.so
246%{plugindir}/General/vfstrace.so
247
248# input plugins
249#{plugindir}/Input/alac.so
250%{plugindir}/Input/amidi-plug.so
251%{plugindir}/Input/amidi-plug/ap-alsa.so
252%{plugindir}/Input/cdaudio-ng.so
253%{plugindir}/Input/console.so
254#{plugindir}/Input/cuesheet_ng.so
255#{plugindir}/Input/demac.so
256#{plugindir}/Input/madplug.so
257%{plugindir}/Input/metronom.so
258%{plugindir}/Input/modplug.so
259%exclude %{plugindir}/Input/psf2.so
260%{plugindir}/Input/sndfile.so
261%{plugindir}/Input/tonegen.so
262%{plugindir}/Input/vorbis.so
263%{plugindir}/Input/vtx.so
264%{plugindir}/Input/wavpack.so
265%exclude %{plugindir}/Input/xsf.so
266
267# output plugins
268%{plugindir}/Output/alsa.so
269%{plugindir}/Output/OSS.so
270%{plugindir}/Output/crossfade.so
271#{plugindir}/Output/filewriter.so
272%{plugindir}/Output/filewriter/plus.so
273%{plugindir}/Output/icecast.so
274%{plugindir}/Output/null.so
275%{plugindir}/Output/pulse_audio.so
276
277# transport plugins
278%{plugindir}/Transport/gio.so
279%{plugindir}/Transport/neon.so
280%{plugindir}/Transport/unix-io.so
281
282# visualization plugins
283%{plugindir}/Visualization/blur_scope.so
284%{plugindir}/Visualization/spectrum.so
285
286%dir %{_datadir}/audacious
287%{_datadir}/audacious/images/bookmarks.png
288%{_datadir}/audacious/images/shoutcast.png
289%{_datadir}/audacious/images/streambrowser-*.png
290%{_datadir}/audacious/images/xiph.png
291
292# skins
293%{_datadir}/audacious/Skins/*
294
295
296%files -n audacious-jack
297%defattr(-,root,root,-)
298%{plugindir}/Output/jackout.so
299
300%files -n audacious-flac
301%defattr(-,root,root,-)
302%{plugindir}/Input/flacng.so
303
304%files -n audacious-esd
305%defattr(-,root,root,-)
306%{plugindir}/Output/ESD.so
307
308%files -n audacious-visualization
309%defattr(-,root,root,-)
310%{plugindir}/Visualization/paranormal.so
311%{plugindir}/Visualization/rocklight.so
312%{plugindir}/Visualization/projectm-1.0.so
313%{_datadir}/audacious/paranormal
314
315%changelog
316* Fri Jul 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.3-4
317- built with libmtp-1.1.11.
318
319* Tue Feb 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.3-3
320- rebuild with Vine6 environment
321- add BuildRequires: libSM-devel, libXmu-devel, libXt-devel, wavpack-devel
322
323* Sat Jun  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-2
324- rebuilt with libprojectm-2.0.1
325- added BR: libshout-devel
326- renamed filewriter.so for alternatives (audacious-lame)
327
328* Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.3-1
329- new upstream release
330- remove BR: arts-devel
331- added BR: libcdio-devel, libcddb-devel
332
333* Sun Aug  9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1-1
334- new upstream release
335- added --disable-mp3 options
336
337* Tue Apr 28 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.5.1-4
338- add BuildRequires: libmtp-devel >= 0.3.5
339- add Patch10 to fix mtp.c for API changes on libmtp >= 0.3.0
340
341* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-3
342- rebuilt with libmowgli-0.7.0
343
344* Sat Mar 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.5.1-2
345- add BuildRequires: libsamplerate-devel and mesa-libGLU-devel
346- add BuildRequires: neon-devel, lirc and pulseaudio-libs-devel
347
348* Sat Dec  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.1-1vl5
349- new upstream release
350
351* Sun Sep 14 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.5-1vl5
352- applied new versioning policy, spec in utf-8
353
354* Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.3.5-0vl2
355- add Obsoletes: beepmp, beepmp-alsa
356- add Obsoletes: beepmp-flac to audacious-flac package
357- add Obsoletes: audioscrobbler-beepmp to audacious-scrobbler package
358
359* Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.5-0vl1
360- new upstream release
361- rebuilt with flac-1.2.0
362
363* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.4-0vl1
364- new upstream release
365- build with new environment/toolchain
366
367* Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
368- new upstream release
369
370* Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
371- new upstream release
372- update ja.po (source1)
373- update %%_audacious_ver
374- overwrite POTFILES.in (source3)
375  - 1.3.0 contains old version of POTFILES.in
376- drop obsolete id3tag.h.patch (patch0)
377- drop BuildRequires: libglade2-devel, taglib-devel
378- add %%with_lame macro
379  - enable lame plugin if rpmbuild with '--with lame'
380
381* Thu Feb 22 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5.1
382- add BuildRequires: libmad-devel
383- add id3tag.h.patch (patch0)
384
385* Wed Feb 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha5
386- update to 1.3.0alpha5
387- update ja.po (source1)
388- update %%_audacious_ver
389- drop obsolete avoid-null-dereference.patch (patch0)
390- drop BuildRequires: libid3tag-devel
391  - NOTE: taglib is not used, but required in configure.ac
392- add plugin to core package
393  - libmadplug.so instead of libmpg123.so (Input)
394- move plugin to visualization package
395  - librocklight.so (Visualization)
396- add Requires: audacious instead of %%{name} to sub packages
397
398* Fri Feb 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4.1
399- add avoid-null-dereference.patch (patch0) to avoid crash
400
401  r1316 | nenolod | 2007-02-08 03:35:13 +0900 (Thu, 08 Feb 2007) | 2 lines
402  - avoid NULL dereference. closes mandriva #28603.
403
404* Thu Feb 08 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha4
405- update to 1.3.0alpha4
406- update ja.po (source1)
407- update %%_audacious_ver
408- update URLs
409- add BuildRequires: libprojectM-devel
410- add plugin to visualization package
411  - libprojectm.so (Visualization)
412
413* Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha3
414- update to 1.3.0alpha3
415- update ja.po (source1)
416- add BuildRequires: libid3tag-devel
417- add plugins to core package
418  - libcurl.so, libevdev-plug.so, libstatusicon.so (General)
419- add new package: audacious-tta
420  - libtta.so (Input)
421
422* Sun Jan 21 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2.1
423- update ja.po (source1)
424
425* Sat Jan 13 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl0.0alpha2
426- update to 1.3.0alpha2
427- update %%_audacious_ver
428- drop '--disable-gnome-vfs' option from %%configure (no longer supported)
429- add audacious-1.2.2's ja.po (source1)
430  to use some translations prior to plugin separation
431- add plugins to core package:
432  - libstdio.so (Container)
433  - libmetronom.so, libmodplug.so (Input)
434  - librocklight.so (Visualization)
435- rename paranormal package to visualization
436  - add Obsoletes: audacious-paranormal
437  - add plugin: librovascope.so
438- fix typo
439
440* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl2
441- separate paranormal package
442- add BuildRequires: SDL-devel
443
444* Thu Nov 30 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.5-0vl1
445- initial build based on audacious
446
447* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
448- new upstream release
449
450* Tue Aug 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
451- oops, really update ja.po (source2)
452
453* Mon Jul 31 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
454- new upstream release
455- make with 'VERBOSE=1'
456- drop obsolete POTFILES.in (source3)
457- make update-po before make
458  - 1.1.1 contains old version of audacious.pot...
459- update ja.po (source2)
460
461* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
462- overwrite POTFILES.in (source3)
463  - 1.1.0 contains old version of POTFILES.in
464- update ja.po (source2)
465
466* Sat Jul 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
467- new upstream release
468- drop unneeded patch0 (was merged)
469- add '--enable-ipv6 --enable-chardet' to %%configure option
470- add BuildRequires: taglib-devel instead of id3lib-devel
471- update ja.po (source2)
472
473* Sun Jun 04 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl2
474- add flac-filename-utf8.patch (patch0)
475      to convert filename on fileinfo box for FLAC files to UTF-8
476- add use-xfont.patch (patch1)
477      to disable 'Use Bitmap fonts if available' by default
478- add ja.po (source2)
479
480* Sat Jun 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
481- initial build
Note: See TracBrowser for help on using the repository browser.