source: projects/specs/branches/6/a/apr/apr-vl.spec @ 1872

Revision 1872, 13.1 KB checked in by inagaki, 14 years ago (diff)

update: apr, libarchive
built with rpm-4.8.1: apr, hal

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.4.2
10Release: 1%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: http://apr.apache.org/
15
16Source0: %{name}-%{version}.tar.bz2
17Source1: apr-wrapper.h
18Patch2: apr-0.9.7-deepbind.patch
19Patch3: apr-1.2.2-locktimeout.patch
20Patch4: apr-1.2.2-libdir.patch
21Patch5: apr-1.3.3-pkgconf.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: autoconf, libtool, python, doxygen
25BuildRequires: libuuid-devel
26Conflicts: subversion < 0.20.1-2
27Obsoletes: apache2-apr
28
29%description
30The mission of the Apache Portable Runtime (APR) is to provide a
31free library of C data structures and routines, forming a system
32portability layer to as many operating systems as possible,
33including Unices, MS Win32, BeOS and OS/2.
34
35%package devel
36Summary: APR library development kit
37Summary(ja): APR ライブラリ開発キット
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40Conflicts: subversion-devel < 0.20.1-2
41Obsoletes: apache2-apr-devel
42
43%description devel
44This package provides the support files which can be used to
45build applications using the APR library.  The mission of the
46Apache Portable Runtime (APR) is to provide a free library of
47C data structures and routines.
48
49%prep
50%setup -q
51%patch2 -p1 -b .deepbind
52%patch3 -p1 -b .locktimeout
53%patch4 -p1 -b .libdir
54%patch5 -p1 -b .pkgconf
55
56%build
57# regenerate configure script etc.
58./buildconf
59
60# Forcibly prevent detection of shm_open (which then picks up but
61# does not use -lrt).
62export ac_cv_search_shm_open=no
63
64%configure \
65        --includedir=%{_includedir}/apr-%{aprver} \
66        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
67        --with-devrandom=/dev/urandom \
68        --disable-static \
69        CC=gcc CXX=g++
70make %{?_smp_mflags} && make dox
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT
75
76# Move docs to more convenient location
77rm -rf html
78mkdir -p html
79cp -pr docs/dox/html/* html/
80# mv docs/dox/html html
81
82# Trim exported dependecies
83sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
84      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
85sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
86      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
87
88%ifarch %{multilib_arches}
89# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
90# packages:
91mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
92   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
93install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
94%endif
95
96# Unpackaged files:
97rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
98rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
99
100%check
101# Fail if LFS support isn't present in a 32-bit build, since this
102# breaks ABI and the soname doesn't change: see #254241
103if grep 'define SIZEOF_VOIDP 4' include/apr.h \
104   && ! grep off64_t include/apr.h; then
105  cat config.log
106  : LFS support not present in 32-bit build
107  exit 1
108fi
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114
115%postun -p /sbin/ldconfig
116
117%files
118%defattr(-,root,root,-)
119%doc CHANGES LICENSE NOTICE
120%{_libdir}/libapr-%{aprver}.so.*
121
122%files devel
123%defattr(-,root,root,-)
124%doc docs/APRDesign.html docs/canonical_filenames.html
125%doc docs/incomplete_types docs/non_apr_programs
126%doc --parents html
127%{_bindir}/apr-%{aprver}-config
128#{_libdir}/libapr-%{aprver}.a
129%{_libdir}/libapr-%{aprver}.so
130%{_libdir}/pkgconfig/*.pc
131%dir %{_libdir}/apr-%{aprver}
132%dir %{_libdir}/apr-%{aprver}/build
133%{_libdir}/apr-%{aprver}/build/*
134%dir %{_includedir}/apr-%{aprver}
135%{_includedir}/apr-%{aprver}/*.h
136
137%changelog
138* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
139- new upstream release
140- built with rpm-4.8.1
141- removed static libraries from devel package
142
143* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
144- rebuilt with new toolchain
145
146* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
147- new upstream release
148
149* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
150- new upstream release with security fix (CVE-2009-2412)
151
152* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
153- new upstream release
154
155* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
156- new upstream release
157- updated Patch5
158
159* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
160- new upstream release
161- removed Patch1 and 6
162
163* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
164- removed *.la files from devel package
165
166* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
167- new upstream release
168- added Patch2 and 6 from Fedora
169  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
170  - add fix for use of %%pI with psprintf
171  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
172  - use RTLD_DEEPBIND in apr_dso_open by default
173
174* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
175- new upstream release
176
177* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
178- new upstream release
179
180* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
181- remove Requires: gcc = %%(gcc -dumpversion)
182
183* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
184- rebuilt with new toolchain
185
186* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
187- new upstream release
188
189* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
190- initial build for Vine Linux based on FC package
191
192* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
193- fix another multilib conflict (#192659)
194
195* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
196- BR e2fsprogs-devel for libuuid
197
198* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
199- use multilib parallel-installation wrapper hack for apr.h
200
201* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
202- fix installbuilddir in apr-1-config
203
204* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
205- update to 1.2.7
206- use pkg-config in apr-1-config to make it libdir-agnostic
207
208* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
209- update to 1.2.6
210
211* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
212- bump again for double-long bug on ppc(64)
213
214* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
215- rebuilt for new gcc4.1 snapshot and glibc changes
216
217* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
218- fix namespace pollution (r354824, r355464)
219
220* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
221- fix build with recent glibc (#176911)
222
223* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
224- rebuilt again
225
226* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
227- rebuilt
228
229* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
230- rebuild for new gcc
231
232* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
233- add apr_file_seek() fixes from upstream (r326593, r326597)
234
235* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
236- apr-1-config: strip more exports (#175124)
237
238* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
239- avoid linking against -lrt
240- don't print -L${libdir} in --libs output
241- don't export -lcrypt/-luuid in .la file
242
243* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
244- update to 1.2.2
245
246* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
247- use RTLD_DEEPBIND in apr_dso_open by default
248
249* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
250- update to 0.9.7
251
252* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
253- rebuild for new gcc
254
255* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
256- don't override CFLAGS at build time
257- allow setting TCP_NODELAY and TCP_CORK concurrently
258- use _exit() not exit() in child if exec*() fails (upstream #30913)
259
260* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
261- add from 0.9.x branch:
262 * fix for apr_{uid,gid}_* error handling (r239592)
263 * fix for apr_file_ write flushing (r267192)
264- add backport for use of readdir64_r (r265032, r265681, r265684)
265
266* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
267- rebuild
268
269* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
270- fix apr_procattr_child_*_set error handling
271
272* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
273- have apr-devel depend on specific version of gcc
274- add NOTICE to docdir
275
276* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
277- update to 0.9.6
278
279* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
280- don't disable sendfile on s390 (IBM LTC, #146891)
281
282* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
283- really fix apr-config --srcdir
284
285* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
286- fix apr-config --srcdir again
287
288* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
289- update to 0.9.5
290
291* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
292- rebuild
293
294* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
295- have -devel require apr of same V-R
296
297* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
298- backport fixes from HEAD:
299 * correct implementation of nested mutexes
300 * support for POSIX semaphores on LP64 platforms
301
302* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
303- rebuild for another attempt at using sem_open
304
305* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
306- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
307
308* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
309- rebuild
310
311* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
312- rebuild now /dev/shm is mounted
313
314* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
315- add fix for cleanup structure reuse (part of upstream #23567)
316
317* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
318- rebuilt
319
320* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
321- add support for setuid/setgid/sticky bits (Andr辿 Malo)
322- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
323
324* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
325- enable posixsem and process-shared pthread mutex support, but
326  ensure that sysvsem remains the default mechanism
327
328* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
329- entirely remove 2Gb file size limit from apr_file_copy();
330  fixes "svnadmin hotcopy" on repos with >2Gb strings table
331- work around getnameinfo bugs with v4-mapped addresses
332- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
333
334* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
335- use APR_LARGEFILE in apr_file_{copy,append}
336
337* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
338- add APR_LARGEFILE flag
339
340* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
341- fix configure check for mmap of /dev/zero
342- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
343
344* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
345- rebuilt
346
347* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
348- undocument apr_dir_read() ordering constraint and fix tests
349
350* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
351- rebuilt without -Wall -Werror
352
353* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
354- rebuilt
355
356* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
357- define apr_off_t as int/long/... to prevent it changing
358  with _FILE_OFFSET_BITS on 32-bit platforms
359
360* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
361- add apr_temp_dir_get fixes from HEAD
362
363* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
364- ensure that libapr is linked against libpthread
365- don't link libapr against -lnsl
366
367* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
368- -devel package no longer requires libtool
369
370* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
371- disable tests on x86_64 (#97611)
372
373* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
374- update to 0.9.4, enable tests
375- ensure that libresolv is not used
376
377* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
378- use /dev/urandom (#103049)
379
380* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
381- add back CC=gcc, CXX=g++
382
383* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
384- rebuild
385
386* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
387- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
388
389* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
390- support --cc and --cpp arguments in apr-config
391
392* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
393- force libtool to use CC=gcc, CXX=g++
394
395* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
396- fix libtool location in apr_rules.mk
397
398* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
399- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
400- include a working libtool script rather than relying on
401 /usr/bin/libtool (#97695)
402
403* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
404- don't use /usr/bin/libtool
405
406* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
407- rebuilt
408
409* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
410- add fix for psprintf memory corruption (CAN-2003-0245)
411- remove executable bit from apr_poll.h
412
413* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
414- link libapr against libpthread
415- make apr-devel conflict with old subversion-devel
416- fix License
417
418* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
419- run ldconfig in post/postun
420
421* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
422- patch test suite to not care if IPv6 is disabled
423
424* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
425- initial build
Note: See TracBrowser for help on using the repository browser.