source: projects/specs/branches/6/a/apache2/apache2-vl.spec @ 8902

Revision 8902, 26.3 KB checked in by iwamoto, 10 years ago (diff)

apache2: add security fix patches

Line 
1%define contentdir /var/www
2%define suexec_caller apache
3%define mmn 20051115
4%define pkgname apache2
5
6Summary: Apache HTTP Server
7Name: %{pkgname}
8Version: 2.2.27
9Release: 2%{_dist_release}
10URL: http://httpd.apache.org/
11
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: daisuke
15
16Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
17Source1: index.html.ja
18Source3: apache2.logrotate
19Source4: apache2.init
20Source5: README.confd
21Source6: vine.png
22Source10: httpd.conf
23Source11: apache-ssl.conf
24Source12: migration.html
25Source13: migration.css
26Source14: mod_ssl-Makefile.crt
27Source15: mod_ssl-Makefile.crl
28# add vine entry to config.layout
29Source100: vine-config.layout
30# man files
31Source101: apache2.8
32Source102: apache2ctl.8
33#Source103: config_vars.mk
34# build/scripts patches
35Patch1: httpd-2.1.10-apctl.patch
36Patch2: httpd-2.2.3-apxs.patch
37Patch3: httpd-2.0.45-deplibs.patch
38Patch4: httpd-2.1.10-disablemods.patch
39# features/functional changes
40Patch21: httpd-2.0.40-xfsz.patch
41# Patch22: httpd-2.1.10-pod.patch
42Patch22: httpd-2.2.23-pod.patch
43Patch23: httpd-2.0.45-export.patch
44Patch24: httpd-2.0.48-corelimit.patch
45# Bug fixes
46Patch54: httpd-2.2.0-authnoprov.patch
47Patch60: httpd-2.2.3-sslusername.patch
48
49# Security fixes
50Patch100: CVE-2014-0118_mod_deflate-DoS.patch
51Patch110: CVE-2014-0226_scoreboard.patch
52Patch120: CVE-2014-0231_mod_cgid-DoS.patch
53
54License: Apache Software License
55Group: System Environment/Daemons
56BuildRoot: %{_tmppath}/%{name}-%{version}-root
57BuildRequires: db4-devel, expat-devel
58BuildRequires: findutils, perl, openldap-devel, zlib-devel
59BuildRequires: apr-devel, apr-util-devel
60BuildRequires: pcre-devel, sqlite3-devel
61Requires: mailcap, gawk, file, findutils, apr, apr-util
62Requires(pre): chkconfig, mktemp, fileutils
63Requires(pre): sh-utils, textutils, shadow-utils
64Requires(post): alternatives
65Provides: webserver
66Provides: httpd = %{version}
67Provides: httpd-mmn = %{mmn}
68Obsoletes: apache2-apr, apache2-apr-devel
69
70%description
71Apache is a powerful, full-featured, efficient, and freely-available
72Web server. Apache is also the most popular Web server on the
73Internet.
74
75%package devel
76Group: Development/Libraries
77Summary: Development tools for the Apache HTTP server.
78Requires: libtool, httpd = %{version}
79Requires: apr-devel, apr-util-devel
80
81%description devel
82The httpd-devel package contains the APXS binary and other files
83that you need to build Dynamic Shared Objects (DSOs) for Apache.
84
85If you are installing the Apache HTTP server and you want to be
86able to compile or develop additional modules for Apache, you need
87to install this package.
88
89%package manual
90Group: Applications/Documentation
91Summary: Documentation for the Apache HTTP server.
92
93%description manual
94The httpd-manual package contains the complete manual and
95reference guide for the Apache HTTP server. The information can
96also be found at http://httpd.apache.org/docs/.
97
98%package -n mod_ssl-apache2
99Group: System Environment/Daemons
100Summary: SSL/TLS module for the Apache HTTP server
101Epoch: 1
102BuildRequires: openssl-devel
103Requires(pre): openssl, dev, /bin/cat
104Requires: httpd, make, httpd-mmn = %{mmn}
105
106%description -n mod_ssl-apache2
107The mod_ssl module provides strong cryptography for the Apache Web
108server via the Secure Sockets Layer (SSL) and Transport Layer
109Security (TLS) protocols.
110
111%prep
112%setup -q -n httpd-%{version}
113
114%patch1 -p1 -b .apctl
115%patch2 -p1 -b .apxs
116#patch3 -p1 -b .deplibs
117%patch4 -p1 -b .disablemods
118
119%patch21 -p0 -b .xfsz
120%patch22 -p1 -b .pod
121%patch23 -p1 -b .export
122%patch24 -p1 -b .corelimit
123
124%patch54 -p1 -b .authnoprov
125%patch60 -p1 -b .sslusername
126
127# security fixes
128%patch100 -p1 -b .CVE-2014-0118
129%patch110 -p1 -b .CVE-2014-0226
130%patch120 -p1 -b .CVE-2014-0231
131
132# copy across the migration guide and sed it's location into apachectl
133cp $RPM_SOURCE_DIR/migration.{html,css} .
134%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
135        support/apachectl.in
136
137
138# add Vine configure's option to config.layout
139sed -e "s|${prefix}/lib|${prefix}/%{_lib}|" \
140  < $RPM_SOURCE_DIR/vine-config.layout >> config.layout
141
142# regenerate configure scripts
143./buildconf
144
145%build
146# remove bundled apr, apr-util, pcre
147rm -rf srclib/{apr,apr-util,pcre}
148
149#CFLAGS="$RPM_OPT_FLAGS -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
150#AP_LIBS="-lssl -lcrypto"
151#export CFLAGS AP_LIBS
152CFLAGS="$RPM_OPT_FLAGS"
153SH_LDFLAGS="-Wl,-z,relro"
154export CFLAGS SH_LDFLAGS
155
156%define mpms worker prefork
157%define prefer_mpm prefork
158
159AP_CONFOPTS="\
160        --prefix=%{_sysconfdir}/apache2 \
161        --exec-prefix=%{_prefix} \
162        --bindir=%{_bindir} \
163        --sbindir=%{_sbindir} \
164        --mandir=%{_mandir} \
165        --libdir=%{_libdir} \
166        --sysconfdir=%{_sysconfdir}/apache2/conf \
167        --includedir=%{_includedir}/apache2 \
168        --libexecdir=%{_libdir}/apache2/modules \
169        --datadir=%{contentdir} \
170        --with-installbuilddir=%{_libdir}/apache2/build \
171        --enable-layout=Vine \
172        --with-program-name=apache2 \
173        --with-ldap \
174        --enable-ldap --enable-authnz-ldap \
175        --enable-mods-shared=all \
176        --enable-cache=shared \
177        --enable-cgi=shared \
178        --enable-cgid=shared \
179        --enable-rewrite=shared \
180        --enable-disk-cache=shared \
181        --enable-file-cache=shared \
182        --enable-mem-cache=shared \
183        --enable-authn-anon --enable-authn-alias \
184        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
185        --enable-suexec --with-suexec \
186        --with-suexec-caller=%{suexec_caller} \
187        --with-suexec-docroot=%{contentdir} \
188        --with-suexec-logfile=%{_localstatedir}/log/apache2/suexec.log \
189        --with-suexec-bin=%{_libdir}/%{pkgname}/suexec \
190        --with-suexec-uidmin=500 --with-suexec-gidmin=500 \
191        --with-pcre \
192        --enable-ssl --with-ssl \
193        --enable-deflate \
194        --enable-proxy --enable-proxy-connect \
195        --enable-proxy-http --enable-proxy-ftp"
196#all  mpm build
197for mpm in %{mpms}; do
198   mkdir mpm-$mpm;
199   cd mpm-$mpm;
200   ../configure $AP_CONFOPTS --with-mpm=$mpm --srcdir=../ ;
201   make %{?_smp_mflags} ;
202#   mv apache2 apache2.$mpm ;
203   cd ../
204done
205
206%install
207rm -rf $RPM_BUILD_ROOT
208
209# install mpms binary
210pushd mpm-prefork
211  make DESTDIR=$RPM_BUILD_ROOT install
212  rm -f $RPM_BUILD_ROOT/%{_sbindir}/apache2
213popd
214
215for mpm in %{mpms}; do
216    install -m755 mpm-$mpm/apache2 $RPM_BUILD_ROOT/%{_sbindir}/apache2.$mpm
217done
218
219# install conf file/directory
220mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d
221install -m 644 $RPM_SOURCE_DIR/README.confd \
222   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/README
223install -m 644 $RPM_SOURCE_DIR/apache-ssl.conf \
224   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf.d/ssl.conf
225
226rm $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/*.conf
227install -m 644 $RPM_SOURCE_DIR/httpd.conf \
228   $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/httpd.conf
229
230# mod_ssl bits
231for suffix in crl crt csr key prm; do
232   mkdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${suffix}
233done
234
235# Makefiles for certificate management
236for ext in crt crl; do
237  install -m 644 $RPM_SOURCE_DIR/mod_ssl-Makefile.${ext} \
238        $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/ssl.${ext}/Makefile.${ext}
239done
240ln -s ../../../usr/share/ssl/certs/Makefile $RPM_BUILD_ROOT/etc/apache2/conf
241
242# for holding mod_dav lock database
243mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/dav
244
245# create a prototype session cache
246mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl
247touch $RPM_BUILD_ROOT%{_localstatedir}/cache/mod_ssl/scache.{dir,pag,sem}
248
249# move utilities to /usr/bin
250mv $RPM_BUILD_ROOT%{_sbindir}/{ab,htdbm,logresolve,htpasswd,htdigest} \
251   $RPM_BUILD_ROOT%{_bindir}
252
253# Make the MMN accessible to module packages
254echo %{mmn} > $RPM_BUILD_ROOT%{_includedir}/apache2/.mmn
255
256# docroot
257# mkdir $RPM_BUILD_ROOT%{contentdir}/html
258install -m 644 $RPM_SOURCE_DIR/index.html.ja \
259        $RPM_BUILD_ROOT%{contentdir}/error/noindex.html
260rm -r $RPM_BUILD_ROOT%{contentdir}/manual/style
261
262install -m 644 $RPM_SOURCE_DIR/vine.png \
263        $RPM_BUILD_ROOT%{contentdir}/icons
264
265# logs
266# rmdir $RPM_BUILD_ROOT%{_sysconfdir}/apache2/logs
267mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/apache2
268
269ln -sf %{_sysconfdir}/%{pkgname}/conf/httpd.conf $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/conf/apache2.conf
270
271
272# symlinks for /etc/apache2
273ln -s ../..%{_localstatedir}/log/apache2 $RPM_BUILD_ROOT/etc/apache2/logs
274ln -s ../..%{_localstatedir}/run $RPM_BUILD_ROOT/etc/apache2/run
275ln -s ../..%{_libdir}/apache2/modules $RPM_BUILD_ROOT/etc/apache2/modules
276ln -s ../..%{_libdir}/apache2/build $RPM_BUILD_ROOT/etc/apache2/build
277
278# install SYSV init stuff
279mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
280install -m755 $RPM_SOURCE_DIR/apache2.init \
281        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
282%{__perl} -pi -e "s:\@docdir\@:%{_docdir}/%{name}-%{version}:g" \
283        $RPM_BUILD_ROOT/etc/rc.d/init.d/apache2
284
285# install log rotation stuff
286mkdir -p $RPM_BUILD_ROOT/etc/logrotate.d
287install -m644 $RPM_SOURCE_DIR/apache2.logrotate \
288        $RPM_BUILD_ROOT/etc/logrotate.d/apache2
289
290mv $RPM_BUILD_ROOT/%{_sbindir}/apachectl $RPM_BUILD_ROOT/%{_sbindir}/apache2ctl
291
292# fix man page paths
293sed -e "s|/usr/local/apache2/conf/httpd.conf|/etc/apache2/conf/httpd.conf|" \
294    -e "s|/usr/local/apache2/conf/mime.types|/etc/mime.types|" \
295    -e "s|/usr/local/apache2/conf/magic|/etc/apache2/conf/magic|" \
296    -e "s|/usr/local/apache2/logs/error_log|/var/log/apache2/error_log|" \
297    -e "s|/usr/local/apache2/logs/access_log|/var/log/apache2/access_log|" \
298    -e "s|/usr/local/apache2/logs/httpd.pid|/var/run/apache2.pid|" \
299    -e "s|/usr/local/apache2|/etc/httpd|" < $RPM_SOURCE_DIR/apache2.8 \
300  > $RPM_BUILD_ROOT%{_mandir}/man8/apache2.8
301
302install -m644 $RPM_SOURCE_DIR/apache2ctl.8 \
303        $RPM_BUILD_ROOT%{_mandir}/man8/apache2ctl.8
304
305# change command name to avoid conflict with apache1 pacjage
306%define cflcmd /usr/bin/htdigest /usr/bin/htpasswd /usr/sbin/rotatelogs
307
308for i in %{cflcmd}; do \
309  echo $i
310  mv $RPM_BUILD_ROOT$i $RPM_BUILD_ROOT$i"2";
311done;
312
313mv $RPM_BUILD_ROOT/%{_sbindir}/apxs $RPM_BUILD_ROOT/%{_bindir}/apxs
314
315%define cflman usr/share/man/man1/dbmmanage.1 usr/share/man/man1/htdigest.1 usr/share/man/man1/htpasswd.1 usr/share/man/man8/rotatelogs.8 usr/share/man/man8/suexec.8 usr/share/man/man8/apxs.8 usr/share/man/man8/httpd.8
316
317(cd $RPM_BUILD_ROOT;
318for i in %{cflman}; do \
319    echo $i | sed -e "s|\.1|2\.1|" -e "s|\.8|2\.8|" |    xargs mv $i ;
320   
321done;
322)
323
324#cp $RPM_SOURCE_DIR/config_vars.mk $RPM_BUILD_ROOT/%{_sysconfdir}/%{pkgname}/build/.
325mv $RPM_BUILD_ROOT/%{_sbindir}/suexec $RPM_BUILD_ROOT/%{_libdir}/%{pkgname}/suexec
326
327
328rm -f $RPM_BUILD_ROOT%{_mandir}/man1/ab*
329rm -f $RPM_BUILD_ROOT%{_mandir}/man1/logresolve*
330# conflict with apache 1, so removed...
331rm -f $RPM_BUILD_ROOT%{_mandir}/man8/ab*
332rm -f $RPM_BUILD_ROOT%{_mandir}/man8/logresolve*
333
334# remove unpackaged files
335rm -f $RPM_BUILD_ROOT%{_sysconfdir}/apache2/conf/mime.types \
336      $RPM_BUILD_ROOT%{_libdir}/*.la \
337      $RPM_BUILD_ROOT%{_libdir}/*.exp \
338      $RPM_BUILD_ROOT%{_libdir}/apache2/modules/*.exp \
339      $RPM_BUILD_ROOT%{_libdir}/apache2/build/config.nice \
340      $RPM_BUILD_ROOT%{_sbindir}/{apache2,checkgid,dbmmanage,envvars*} \
341      $RPM_BUILD_ROOT%{contentdir}/html/* \
342      $RPM_BUILD_ROOT%{contentdir}/cgi-bin/*
343
344%pre
345# Add the "apache" user
346/usr/sbin/useradd -c "Apache" -u 48 \
347        -s /sbin/nologin -r -d %{contentdir} apache 2> /dev/null || :
348
349%triggerpostun -- apache < 2.0
350/sbin/chkconfig --add apache2
351
352
353%post
354# Register the httpd service
355for mpm in %{mpms}; do
356  /sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.$mpm 20;
357done
358/sbin/update-alternatives --install %{_sbindir}/apache2 apache2 %{_sbindir}/apache2.%{prefer_mpm} 30
359/sbin/chkconfig --add apache2
360
361%preun
362if [ $1 = 0 ]; then
363        /sbin/service apache2 stop > /dev/null 2>&1
364        /sbin/chkconfig --del apache2
365        for mpm in %{mpms}; do
366          /sbin/update-alternatives --remove apache2 %{_sbindir}/apache2.$mpm;
367        done 
368fi
369
370%postun
371if [ "$1" -ge 1 ]; then
372        /sbin/service apache2 condrestart
373fi
374/sbin/ldconfig
375
376%post -n mod_ssl-apache2
377/sbin/ldconfig ### is this needed?
378umask 077
379
380if [ ! -f %{_sysconfdir}/apache2/conf/ssl.key/server.key ] ; then
381%{_bindir}/openssl genrsa -rand /proc/apm:/proc/cpuinfo:/proc/dma:/proc/filesystems:/proc/interrupts:/proc/ioports:/proc/pci:/proc/rtc:/proc/uptime 1024 > %{_sysconfdir}/apache2/conf/ssl.key/server.key 2> /dev/null
382fi
383
384FQDN=`hostname`
385if [ "x${FQDN}" = "x" ]; then
386   FQDN=localhost.localdomain
387fi
388
389if [ ! -f %{_sysconfdir}/apache2/conf/ssl.crt/server.crt ] ; then
390cat << EOF | %{_bindir}/openssl req -new -key %{_sysconfdir}/apache2/conf/ssl.key/server.key -x509 -days 365 -out %{_sysconfdir}/apache2/conf/ssl.crt/server.crt 2>/dev/null
391--
392SomeState
393SomeCity
394SomeOrganization
395SomeOrganizationalUnit
396${FQDN}
397root@${FQDN}
398EOF
399fi
400
401%clean
402rm -rf $RPM_BUILD_ROOT
403
404%files
405%defattr(-,root,root)
406
407%doc ABOUT_APACHE README CHANGES LAYOUT LICENSE
408%doc migration.html migration.css
409
410%dir %{_sysconfdir}/apache2
411%{_sysconfdir}/apache2/modules
412%{_sysconfdir}/apache2/logs
413%{_sysconfdir}/apache2/run
414%dir %{_sysconfdir}/apache2/conf
415%config(noreplace) %{_sysconfdir}/apache2/conf/*.conf
416%config(noreplace) %{_sysconfdir}/apache2/conf/magic
417
418%config %{_sysconfdir}/logrotate.d/apache2
419%config %{_sysconfdir}/rc.d/init.d/apache2
420
421%dir %{_sysconfdir}/apache2/conf.d
422%{_sysconfdir}/apache2/conf.d/README
423
424%dir %{_sysconfdir}/apache2/conf/extra
425%config %{_sysconfdir}/apache2/conf/extra/*
426
427%dir %{_sysconfdir}/apache2/conf/original
428%{_sysconfdir}/apache2/conf/original/*
429
430%{_bindir}/ab
431%{_bindir}/ht*
432%{_bindir}/logresolve
433%{_sbindir}/ht*
434%{_sbindir}/apache2.*
435%{_sbindir}/apache2ctl
436%{_sbindir}/rotatelogs2
437%attr(4510,root,%{suexec_caller}) %{_libdir}/%{pkgname}/suexec
438
439%dir %{_libdir}/apache2
440%dir %{_libdir}/apache2/modules
441# everything but mod_ssl.so:
442%{_libdir}/apache2/modules/mod_[a-r]*.so
443%{_libdir}/apache2/modules/mod_s[petu]*.so
444%{_libdir}/apache2/modules/mod_[t-z]*.so
445
446%dir %{contentdir}
447%dir %{contentdir}/cgi-bin
448%dir %{contentdir}/html
449%dir %{contentdir}/icons
450%dir %{contentdir}/error
451%dir %{contentdir}/error/include
452%{contentdir}/icons/*
453%{contentdir}/error/README
454%{contentdir}/error/noindex.html
455%config(noreplace) %{contentdir}/error/*.var
456%config(noreplace) %{contentdir}/error/include/*.html
457
458%attr(0700,root,root) %dir %{_localstatedir}/log/apache2
459
460%attr(0700,apache,apache) %dir %{_localstatedir}/lib/dav
461
462%{_mandir}/man1/*
463
464%{_mandir}/man8/*
465
466%files manual
467%defattr(-,root,root)
468%{contentdir}/manual
469
470%files -n mod_ssl-apache2
471%defattr(-,root,root)
472%{_libdir}/apache2/modules/mod_ssl.so
473%config(noreplace) %{_sysconfdir}/apache2/conf.d/ssl.conf
474%attr(0700,root,root) %dir %{_sysconfdir}/apache2/conf/ssl.*
475%config %{_sysconfdir}/apache2/conf/Makefile
476%config %{_sysconfdir}/apache2/conf/ssl.*/*
477%attr(0700,apache,root) %dir %{_localstatedir}/cache/mod_ssl
478%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.dir
479%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.pag
480%attr(0600,apache,root) %ghost %{_localstatedir}/cache/mod_ssl/scache.sem
481
482%files devel
483%defattr(-,root,root)
484%{_includedir}/apache2
485%{_sysconfdir}/apache2/build
486%{_bindir}/apxs
487%{_mandir}/man?/apxs*
488%{_libdir}/apache2/build/*.mk
489%{_libdir}/apache2/build/*.sh
490
491%changelog
492* Wed Aug 13 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-2
493- add Patch100 for fix CVE-2014-0118 (mod_deflate)
494- add Patch110 for fix CVE-2014-0226 (mod_status)
495- add Patch120 for fix CVE-2014-0231 (mod_cgid)
496  these patches are from debian wheezy, thanks
497
498* Fri Mar 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.27-1
499- new upstream release with security fix (CVE-2013-6438, 2014-0098)
500
501* Fri Jan 24 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.26-1
502- new upstream release
503
504* Sat Sep 28 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.25-1
505- new upstream release with security fix (CVE-2013-1862,1896)
506- drop patch100 (is included in new release)
507
508* Fri May 17 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-2
509- add patch100 for fix CVE-2013-1862 (mod_rewrite)
510
511* Wed Feb 27 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.24-1
512- new upstream release with security fix (CVE-2012-3499, 4558)
513
514* Sun Sep 16 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.23-1
515- new upstream release with security fix (CVE-2012-3502,CVE-2012-2687)
516- update patch22 to fit new release
517- update man filename convert list
518
519* Wed Mar 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.22-1
520- update to 2.2.22
521  - CVE-2012-0021 (mod_log_config)
522  - CVE-2012-0031
523  - CVE-2012-0053
524- remove upstreamed patches
525
526* Fri Dec  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-5
527- add patch120 for fix CVE-2011-4317 (mod_rewrite/mod_proxy)
528
529* Fri Nov 18 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-4
530- add patch110 for fix CVE-2011-3607-4415 (ModSetEnvIf)
531
532* Wed Oct 12 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-3
533- add patch70 for fix byterange filter
534
535* Tue Oct 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-2
536- add Patch100 for fix CVE-2011-3368 (mod_proxy)
537
538* Wed Sep 14 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.21-1
539- new upstream release with security fix (CVE-2011-3348)
540- regression fixes of CVE-2011-3192 byterange fix in 2.2.20
541
542* Tue Sep  6 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-3
543- update Patch101 (Thanks to debian team)
544
545* Sat Sep  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-2
546- add Patch101 for fix CVE-2011-3192 regression
547
548* Thu Sep  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.20-1
549- new upstream release with security fix (CVE-2011-3192)
550- drop patch100 (is included in new release)
551
552* Thu Aug 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.19-2
553- add patch100 for fix CVE-2011-3192 (Range Header DoS)
554
555* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.19-1
556- update to 2.2.19
557
558* Sat Apr 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-9
559- remove old Obsoletes/Conflicts
560
561* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-8
562- rebuild with openssl-1.0.0c
563
564* Sat Aug 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.14-7
565- add  patch120 for fix CVE-2010-1452 (mod_dav/mod_cache) from mdk2010
566
567* Wed Aug 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-6
568- add R(post): alternatives
569
570* Sat Mar 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-5
571- add patch110 for fix CVE-2010-0434 from mdk 2010
572
573* Sun Mar  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.2.14-4
574- add patch100 for fix CVE-2010-0408 (mod_proxy_ajp)
575
576* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.14-3
577- rebuilt with rpm-4.8.0-3 (on ppc)
578
579* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-2
580- rebuild with db4-4.8.0
581
582* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.14-1
583- new upstream release with security fix
584  (CVE-2009-2699, CVE-2009-3095, CVE-2009-3094)
585- fix ssl.conf (2.2.13-1 includes wrong file)
586
587* Sun Aug 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.13-1
588- new upstream release
589
590* Wed Jul 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.12-1
591- new upstream release
592  (including security fix for CVE-2009-1890, CVE-2009-1191,
593   CVE-2009-1195, CVE-2009-1955, CVE-2009-1956, CVE-2009-0023)
594
595* Fri Jan 09 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-2
596- rebuilt with openldap-2.4.11
597
598* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-1
599- new upstream release
600
601* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-1
602- new upstream release (including security fix for CVE-2008-2939)
603
604* Fri Jun 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-1
605- new upstream release (including security fix for CVE-2008-2364, CVE-2007-6420)
606- built with db4-4.6.21, apr 1.3.0
607
608* Sun Apr 27 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.2.8-1
609- add Patch60 (to fix bug#31418).
610
611* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.8-0vl2
612- rebuild with expat-2.0.1
613
614* Tue Jan 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
615- new upstream release
616
617* Sat Nov  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-0vl2
618- added postun script from VinePlus/4.0 package
619  * Tue Sep 11 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.2.3-0vl3.2
620  - add postun script to restart daemon with message
621
622* Sun Jul 01 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl8
623- updated Patch2: httpd-2.2.3-apxs.patch
624
625* Sun Jun 24 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl7
626- modified libdir in config.layout for lib64 architecture
627
628* Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl6
629- rebuilt with openssl-0.9.8e
630
631* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl5
632- rebuilt with new toolchain and db4-4.3.x
633
634* Tue Feb  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl4
635- added BuildRequires: pcre-devel, sqlite3-devel <BTS:VineLinux:474>
636
637* Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.3-0vl3
638- change manual Group to Applications/Documentation. <BTS:VineLinux:163>
639
640* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl2
641- rebuilt with openldap-2.3.27-0vl1
642
643* Sat Jul 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
644- new upstream release including security fix (CVE-2006-3747)
645
646* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
647- new upstream release
648  - update to 2.2.2
649- remove apr/apr-devel subpackage,
650  use external apr/apr-util instead of internal one.
651
652* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.58-0vl1
653- new upstream release
654- use apache2.prefork as default.
655
656* Thu Mar 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl3
657- rebuild to use new _localstatedir (rpm-4.4.2-0vl11)
658- remove unpackaged files in %%install section
659
660* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl2
661- fix logrotate configuration (use apache2.pid instead of httpd.pid)
662  (BTS:10)
663- use Epoch instead of Serial
664
665* Sat Oct 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.55-0vl1
666- new upstream release
667- drop obsolete security patches which is merged in upstream
668
669* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.54-0vl1
670- new upstream release
671
672* Sun Sep 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl2
673- added Patch122 to 125 for secutiry fix
674  (CAN-2004-{1268,2088,2700,2728})
675- fix %install section
676
677* Sun Apr 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.53-0vl1
678- new upstream release
679
680* Sat Nov 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.52-0vl1
681- new upstream release
682
683* Sun Oct 24 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.50-0vl4
684- rebuilt with db4-4.2.52
685
686* Sat Sep  4 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 2.0.50-0vl3
687- separate apr, apr-devel packages
688- add BuildPreReq: zlib-devel
689
690* Sun Jul 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.50-0vl2
691- fix %%files to include instdso.sh
692  thanks to jax <jax AT morejams DOT no-ip DOT com>
693- add %%{?_smp_mflags} to make option.
694
695* Sun Jul  4 2004 IWAI, Masaharu <iwai@alib.jp> 2.0.50-0vl1
696- new upstream version
697
698* Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.48-0vl1
699- new upstream version
700
701* Mon Sep 15 2003 IWAI, Masaharu <iwai@alib.jp> 2.0.47-0vl1
702- new upstream version
703- update apxs patch (Patch101)
704- fix dependency:
705    - change file name to package name in Requires and {Build,}Prereq
706- add BuildPrereq: openldap-devel
707- update %%files section
708- rename httpd.8 manpage
709
710* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.45-0vl1
711- new upstream version
712- used vine-config.layout in srclib
713
714* Tue May 12 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.44-0vl9
715- rebuild
716
717* Sun Apr  6 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl8
718- change pkg name from mod_ssl to mod_ssl-apache2
719- remove "apache-manual" entry from Obsoletes:
720
721* Thu Apr  3 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl7
722- remove "mod_dav" and "apache-devel" from Obsoletes:
723- enable MPMS(worker %mpms )
724
725* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl6
726- add correct config_vars.mk
727
728* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl5
729- apply apxs's patch ( from Debian)
730
731* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl4
732- add apr-config,apu-config to devel's %file
733
734* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl3
735- change apxs path ( /usr/sbin -> /usr/bin
736- add symlink under /etc/apache2/conf
737  (logs, run), httpd.conf -> apache2.conf
738- fixed apache2 initscript.
739
740* Sat Mar 29 2003 Kazuhisa TAKEI <takei@vinelinux.org> 2.0.44-0vl2
741- build Vine Linux
742- new upstream version
743- sharing with apache1
744
745* Wed Sep  4 2002 Nalin Dahyabhai <nalin@redhat.com> 2.0.40-8
746- link httpd with libssl to avoid library loading/unloading weirdness
747
748* Tue Sep  3 2002 Joe Orton <jorton@redhat.com> 2.0.40-7
749- add LoadModule lines for proxy modules in httpd.conf (#73349)
750- fix permissions of conf/ssl.*/ directories; add Makefiles for
751  certificate management (#73352)
752
753* Mon Sep  2 2002 Joe Orton <jorton@redhat.com> 2.0.40-6
754- provide "httpd-mmn" to manage module ABI compatibility
755
756* Sun Sep  1 2002 Joe Orton <jorton@redhat.com> 2.0.40-5
757- fix SSL session cache (#69699)
758- revert addition of LDAP support to apr-util
759
760* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-4
761- set SIGXFSZ disposition to "ignored" (#69520)
762- make dummy connections to the first listener in config (#72692)
763
764* Mon Aug 26 2002 Joe Orton <jorton@redhat.com> 2.0.40-3
765- allow "apachectl configtest" on a 1.3 httpd.conf
766- add mod_deflate
767- enable LDAP support in apr-util
768- don't package everything in /var/www/error as config(noreplace)
769
770* Wed Aug 21 2002 Bill Nottingham <notting@redhat.com> 2.0.40-2
771- add trigger (#68657)
772
773* Mon Aug 12 2002 Joe Orton <jorton@redhat.com> 2.0.40-1
774- update to 2.0.40
775
776* Wed Jul 24 2002 Joe Orton <jorton@redhat.com> 2.0.36-8
777- improve comment on use of UserDir in default config (#66886)
778
779* Wed Jul 10 2002 Joe Orton <jorton@redhat.com> 2.0.36-7
780- use /sbin/nologin as shell for apache user (#68371)
781- add patch from CVS to fix possible infinite loop when processing
782  internal redirects
783
784* Wed Jun 26 2002 Gary Benson <gbenson@redhat.com> 2.0.36-6
785- modify init script to detect 1.3.x httpd.conf's and direct users
786  to the migration guide
787
788* Tue Jun 25 2002 Gary Benson <gbenson@redhat.com> 2.0.36-5
789- patch apachectl to detect 1.3.x httpd.conf's and direct users
790  to the migration guide
791- ship the migration guide
792
793* Fri Jun 21 2002 Joe Orton <jorton@redhat.com>
794- move /etc/httpd2 back to /etc/httpd
795- add noindex.html page and poweredby logo; tweak default config
796  to load noindex.html if no default "/" page is present.
797- add patch to prevent mutex errors on graceful restart
798
799* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 2.0.36-4
800- automated rebuild
801
802* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-3
803- add patch to fix SSL mutex handling
804
805* Wed Jun 12 2002 Joe Orton <jorton@redhat.com> 2.0.36-2
806- improved config directory patch
807
808* Mon May 20 2002 Joe Orton <jorton@redhat.com>
809- initial build; based heavily on apache.spec and mod_ssl.spec
810- fixes: #65214, #58490, #57376, #61265, #65518, #58177, #57245
811
Note: See TracBrowser for help on using the repository browser.